Update to MySQL 8.0.18
This commit is contained in:
parent
1b305ccda0
commit
9be4f7f6c4
@ -1,6 +1,8 @@
|
|||||||
--- mysql-8.0.4-rc/mysql-test/include/mtr_warnings.sql~ 2018-01-18 16:52:52.000000000 +0100
|
diff --git a/mysql-test/include/mtr_warnings.sql b/mysql-test/include/mtr_warnings.sql
|
||||||
+++ mysql-8.0.4-rc/mysql-test/include/mtr_warnings.sql 2018-03-08 20:14:48.537507245 +0100
|
index c62deb3d..3ae57613 100644
|
||||||
@@ -311,6 +311,11 @@
|
--- a/mysql-test/include/mtr_warnings.sql
|
||||||
|
+++ b/mysql-test/include/mtr_warnings.sql
|
||||||
|
@@ -265,6 +265,11 @@ INSERT INTO global_suppressions VALUES
|
||||||
*/
|
*/
|
||||||
("The SSL library function CRYPTO_set_mem_functions failed"),
|
("The SSL library function CRYPTO_set_mem_functions failed"),
|
||||||
|
|
||||||
@ -9,6 +11,6 @@
|
|||||||
+ */
|
+ */
|
||||||
+ ("The CYCLE timer is not available. WAIT events in the performance_schema will not be timed."),
|
+ ("The CYCLE timer is not available. WAIT events in the performance_schema will not be timed."),
|
||||||
+
|
+
|
||||||
("THE_LAST_SUPPRESSION")||
|
("THE_LAST_SUPPRESSION");
|
||||||
|
|
||||||
|
|
||||||
|
@ -4,10 +4,10 @@ Software Collections. Removing these hard-coded paths should fix it.
|
|||||||
Upstream report: https://mariadb.atlassian.net/browse/MDEV-6485
|
Upstream report: https://mariadb.atlassian.net/browse/MDEV-6485
|
||||||
|
|
||||||
diff --git a/cmake/install_layout.cmake b/cmake/install_layout.cmake
|
diff --git a/cmake/install_layout.cmake b/cmake/install_layout.cmake
|
||||||
index 17ea6443..1d38e3eb 100644
|
index 94d9ecf5..69058c22 100644
|
||||||
--- a/cmake/install_layout.cmake
|
--- a/cmake/install_layout.cmake
|
||||||
+++ b/cmake/install_layout.cmake
|
+++ b/cmake/install_layout.cmake
|
||||||
@@ -115,7 +115,7 @@ IF(UNIX)
|
@@ -109,7 +109,7 @@ IF(UNIX)
|
||||||
" Choose between ${VALID_INSTALL_LAYOUTS}" )
|
" Choose between ${VALID_INSTALL_LAYOUTS}" )
|
||||||
ENDIF()
|
ENDIF()
|
||||||
|
|
||||||
@ -16,16 +16,16 @@ index 17ea6443..1d38e3eb 100644
|
|||||||
CACHE PATH "config directory (for my.cnf)")
|
CACHE PATH "config directory (for my.cnf)")
|
||||||
MARK_AS_ADVANCED(SYSCONFDIR)
|
MARK_AS_ADVANCED(SYSCONFDIR)
|
||||||
ENDIF()
|
ENDIF()
|
||||||
@@ -319,6 +319,7 @@ SET(INSTALL_SECURE_FILE_PRIVDIR_TARGZ ${secure_file_priv_path})
|
@@ -271,6 +271,7 @@ SET(INSTALL_SECURE_FILE_PRIVDIR_TARGZ ${secure_file_priv_path})
|
||||||
#
|
#
|
||||||
SET(INSTALL_BINDIR_RPM "bin")
|
SET(INSTALL_BINDIR_RPM "bin")
|
||||||
SET(INSTALL_SBINDIR_RPM "sbin")
|
SET(INSTALL_SBINDIR_RPM "sbin")
|
||||||
+SET(INSTALL_SYSCONFDIR_RPM "/etc")
|
+SET(INSTALL_SYSCONFDIR_RPM "/etc")
|
||||||
#
|
#
|
||||||
IF(CMAKE_SYSTEM_PROCESSOR MATCHES "x86_64")
|
IF(CMAKE_SYSTEM_PROCESSOR IN_LIST KNOWN_64BIT_ARCHITECTURES)
|
||||||
SET(INSTALL_LIBDIR_RPM "lib64")
|
SET(INSTALL_LIBDIR_RPM "lib64/mysql")
|
||||||
diff --git a/mysys/my_default.cc b/mysys/my_default.cc
|
diff --git a/mysys/my_default.cc b/mysys/my_default.cc
|
||||||
index d7f5016e..f8fe5d90 100644
|
index a8f6132a..3b448ef3 100644
|
||||||
--- a/mysys/my_default.cc
|
--- a/mysys/my_default.cc
|
||||||
+++ b/mysys/my_default.cc
|
+++ b/mysys/my_default.cc
|
||||||
@@ -1565,12 +1565,12 @@ static const char **init_default_directories(MEM_ROOT *alloc) {
|
@@ -1565,12 +1565,12 @@ static const char **init_default_directories(MEM_ROOT *alloc) {
|
||||||
@ -45,10 +45,10 @@ index d7f5016e..f8fe5d90 100644
|
|||||||
|
|
||||||
#endif
|
#endif
|
||||||
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
|
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
|
||||||
index bed32565..ca08ee7c 100644
|
index c64bfb52..1b2a76cf 100644
|
||||||
--- a/scripts/CMakeLists.txt
|
--- a/scripts/CMakeLists.txt
|
||||||
+++ b/scripts/CMakeLists.txt
|
+++ b/scripts/CMakeLists.txt
|
||||||
@@ -324,9 +324,9 @@ IF(UNIX)
|
@@ -288,9 +288,9 @@ IF(UNIX)
|
||||||
ENDIF(UNIX)
|
ENDIF(UNIX)
|
||||||
|
|
||||||
SET(prefix "${CMAKE_INSTALL_PREFIX}")
|
SET(prefix "${CMAKE_INSTALL_PREFIX}")
|
||||||
|
@ -4,12 +4,13 @@ secure-execution mode in http://man7.org/linux/man-pages/man8/ld.so.8.html).
|
|||||||
|
|
||||||
Related: #1628814
|
Related: #1628814
|
||||||
|
|
||||||
diff -up mysql-8.0.12/sql/CMakeLists.txt.patchrpath mysql-8.0.12/sql/CMakeLists.txt
|
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
|
||||||
--- mysql-8.0.12/sql/CMakeLists.txt.patchrpath 2018-09-14 13:59:02.884021458 +0200
|
index 3f179a7a..209b3eb2 100644
|
||||||
+++ mysql-8.0.12/sql/CMakeLists.txt 2018-09-14 14:01:10.897983621 +0200
|
--- a/sql/CMakeLists.txt
|
||||||
@@ -711,6 +711,8 @@ ENDIF()
|
+++ b/sql/CMakeLists.txt
|
||||||
MYSQL_ADD_EXECUTABLE(mysqld
|
@@ -918,6 +918,8 @@ IF(UNIX_INSTALL_RPATH_ORIGIN_PRIV_LIBDIR)
|
||||||
${MYSQLD_SOURCE} DESTINATION ${INSTALL_SBINDIR} COMPONENT Server)
|
ADD_INSTALL_RPATH_FOR_PROTOBUF(mysqld)
|
||||||
|
ENDIF()
|
||||||
|
|
||||||
+SET_TARGET_PROPERTIES(mysqld PROPERTIES INSTALL_RPATH "${RPATH_LIBDIR}")
|
+SET_TARGET_PROPERTIES(mysqld PROPERTIES INSTALL_RPATH "${RPATH_LIBDIR}")
|
||||||
+
|
+
|
||||||
|
@ -1,7 +1,8 @@
|
|||||||
diff -rup mysql-5.7.8.orig/scripts/CMakeLists.txt mysql-5.7.8/scripts/CMakeLists.txt
|
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
|
||||||
--- mysql-5.7.8.orig/scripts/CMakeLists.txt 2015-07-20 14:25:08.000000000 +0200
|
index c64bfb52..4da9e699 100644
|
||||||
+++ mysql-5.7.8/scripts/CMakeLists.txt 2015-09-24 10:47:01.733914088 +0200
|
--- a/scripts/CMakeLists.txt
|
||||||
@@ -483,6 +483,32 @@ ELSE()
|
+++ b/scripts/CMakeLists.txt
|
||||||
|
@@ -523,6 +523,32 @@ ELSE()
|
||||||
PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
|
PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
|
||||||
)
|
)
|
||||||
ENDIF()
|
ENDIF()
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt
|
diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt
|
||||||
index 1eb22c37..e200d4eb 100644
|
index f77bd022..a3a3bd9f 100644
|
||||||
--- a/mysql-test/CMakeLists.txt
|
--- a/mysql-test/CMakeLists.txt
|
||||||
+++ b/mysql-test/CMakeLists.txt
|
+++ b/mysql-test/CMakeLists.txt
|
||||||
@@ -56,6 +56,9 @@ INSTALL(
|
@@ -57,6 +57,9 @@ IF(INSTALL_MYSQLTESTDIR)
|
||||||
ENDIF()
|
ENDIF()
|
||||||
|
|
||||||
|
|
||||||
@ -13,10 +13,10 @@ index 1eb22c37..e200d4eb 100644
|
|||||||
# Enable running mtr from build directory
|
# Enable running mtr from build directory
|
||||||
FIND_PROGRAM(PERL_EXECUTABLE perl
|
FIND_PROGRAM(PERL_EXECUTABLE perl
|
||||||
diff --git a/mysql-test/mysql-test-run.pl b/mysql-test/mysql-test-run.pl
|
diff --git a/mysql-test/mysql-test-run.pl b/mysql-test/mysql-test-run.pl
|
||||||
index 05a504da..9cdc2cda 100755
|
index b82611fd..7fc5987e 100755
|
||||||
--- a/mysql-test/mysql-test-run.pl
|
--- a/mysql-test/mysql-test-run.pl
|
||||||
+++ b/mysql-test/mysql-test-run.pl
|
+++ b/mysql-test/mysql-test-run.pl
|
||||||
@@ -1626,7 +1626,7 @@ sub command_line_setup {
|
@@ -1656,7 +1656,7 @@ sub command_line_setup {
|
||||||
my $path_share = $path_language;
|
my $path_share = $path_language;
|
||||||
|
|
||||||
@share_locations =
|
@share_locations =
|
||||||
|
@ -66,8 +66,8 @@
|
|||||||
%global sameevr %{?epoch:%{epoch}:}%{version}-%{release}
|
%global sameevr %{?epoch:%{epoch}:}%{version}-%{release}
|
||||||
|
|
||||||
Name: community-mysql
|
Name: community-mysql
|
||||||
Version: 8.0.17
|
Version: 8.0.18
|
||||||
Release: 2%{?with_debug:.debug}%{?dist}
|
Release: 1%{?with_debug:.debug}%{?dist}
|
||||||
Summary: MySQL client programs and shared libraries
|
Summary: MySQL client programs and shared libraries
|
||||||
URL: http://www.mysql.com
|
URL: http://www.mysql.com
|
||||||
|
|
||||||
@ -798,6 +798,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 14 2019 Lars Tangvald <lars.tangvald@oracle.com> - 8.0.18-1
|
||||||
|
- Update to MySQL 8.0.18
|
||||||
|
|
||||||
* Mon Aug 19 2019 Michal Schorm <mschorm@redhat.com> - 8.0.17-2
|
* Mon Aug 19 2019 Michal Schorm <mschorm@redhat.com> - 8.0.17-2
|
||||||
- Use RELRO hardening on all binaries
|
- Use RELRO hardening on all binaries
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user