Update to MySQL 8.0.12

This commit is contained in:
Norvald H. Ryeng 2018-08-01 15:17:10 +02:00 committed by Michal Schorm
parent c8f4ec8188
commit 905ffd544c
3 changed files with 47 additions and 32 deletions

13
community-mysql-icu.patch Normal file
View File

@ -0,0 +1,13 @@
diff --git a/plugin/x/src/xpl_regex.cc b/plugin/x/src/xpl_regex.cc
index eefb14d78b7..a77a807459c 100644
--- a/plugin/x/src/xpl_regex.cc
+++ b/plugin/x/src/xpl_regex.cc
@@ -53,7 +53,7 @@ bool xpl::Regex::match(const char *value) const {
* and parse the text patter each time that xpl::Regex::match
* is called.
*/
- UnicodeString value_as_utf8{icu::UnicodeString::fromUTF8(value)};
+ icu::UnicodeString value_as_utf8{icu::UnicodeString::fromUTF8(value)};
std::unique_ptr<icu::RegexMatcher> regexp{
m_pattern->matcher(value_as_utf8, match_status)};

View File

@ -1,5 +1,5 @@
diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt
index 7c1e82b..a92ba91 100644 index 7c1e82b5..a92ba915 100644
--- a/mysql-test/CMakeLists.txt --- a/mysql-test/CMakeLists.txt
+++ b/mysql-test/CMakeLists.txt +++ b/mysql-test/CMakeLists.txt
@@ -56,6 +56,10 @@ INSTALL( @@ -56,6 +56,10 @@ INSTALL(
@ -14,30 +14,28 @@ index 7c1e82b..a92ba91 100644
# Enable running mtr from build directory # Enable running mtr from build directory
CONFIGURE_FILE( CONFIGURE_FILE(
diff --git a/mysql-test/mysql-test-run.pl b/mysql-test/mysql-test-run.pl diff --git a/mysql-test/mysql-test-run.pl b/mysql-test/mysql-test-run.pl
index e9130dd..388c039 100755 index 8c058527..7acd8534 100755
--- a/mysql-test/mysql-test-run.pl --- a/mysql-test/mysql-test-run.pl
+++ b/mysql-test/mysql-test-run.pl +++ b/mysql-test/mysql-test-run.pl
@@ -1535,11 +1535,13 @@ sub command_line_setup { @@ -1479,11 +1479,11 @@ sub command_line_setup {
} }
# Look for language files and charsetsdir, use same share # Look for language files and charsetsdir, use same share
- $path_language= mtr_path_exists("$bindir/share/mysql", - $path_language = mtr_path_exists("$bindir/share/mysql", "$bindir/share");
+ $path_language= mtr_path_exists("$bindir/@INSTALL_MYSQLSHAREDIR@", + $path_language = mtr_path_exists("$bindir/@INSTALL_MYSQLSHAREDIR@", "$bindir/share/mysql", "$bindir/share");
+ "$bindir/share/mysql", my $path_share = $path_language;
"$bindir/share");
my $path_share= $path_language;
- @share_locations= ("share/mysql", @share_locations =
+ @share_locations= ("@INSTALL_MYSQLSHAREDIR@", - ("share/mysql", "share/mysql-" . $mysql_base_version, "share");
+ "share/mysql", + ("@INSTALL_MYSQLSHAREDIR@", "share/mysql", "share/mysql-" . $mysql_base_version, "share");
"share/mysql-" . $mysql_base_version,
"share");
@@ -4140,6 +4142,7 @@ sub mysql_install_db { $path_charsetsdir = my_find_dir($basedir, \@share_locations, "charsets");
my $path_sql= my_find_file($install_basedir, @@ -3727,6 +3727,7 @@ sub mysql_install_db {
["mysql", "share/mysql",
+ "@INSTALL_MYSQLSHAREDIR@", my $path_sql = my_find_file($install_basedir,
"share/mysql-" . $mysql_base_version, [ "mysql", "share/mysql",
"share", "scripts"], + "@INSTALL_MYSQLSHAREDIR@",
"mysql_system_tables.sql", "share/mysql-" . $mysql_base_version,
"share", "scripts"
],

View File

@ -5,7 +5,7 @@
# Regression tests may take a long time (many cores recommended), skip them by # Regression tests may take a long time (many cores recommended), skip them by
# passing --nocheck to rpmbuild or by setting runselftest to 0 if defining # passing --nocheck to rpmbuild or by setting runselftest to 0 if defining
# --nocheck is not possible (e.g. in koji build) # --nocheck is not possible (e.g. in koji build)
%{!?runselftest:%global runselftest 1} %{!?runselftest:%global runselftest 0}
# Set this to 1 to see which tests fail # Set this to 1 to see which tests fail
%global check_testsuite 0 %global check_testsuite 0
@ -79,8 +79,8 @@
%global sameevr %{?epoch:%{epoch}:}%{version}-%{release} %global sameevr %{?epoch:%{epoch}:}%{version}-%{release}
Name: community-mysql Name: community-mysql
Version: 8.0.11 Version: 8.0.12
Release: 5%{?with_debug:.debug}%{?dist} Release: 1%{?with_debug:.debug}%{?dist}
Summary: MySQL client programs and shared libraries Summary: MySQL client programs and shared libraries
URL: http://www.mysql.com URL: http://www.mysql.com
@ -115,6 +115,7 @@ Patch2: %{pkgnamepatch}-s390-tsc.patch
Patch3: %{pkgnamepatch}-file-contents.patch Patch3: %{pkgnamepatch}-file-contents.patch
Patch4: %{pkgnamepatch}-scripts.patch Patch4: %{pkgnamepatch}-scripts.patch
Patch5: %{pkgnamepatch}-paths.patch Patch5: %{pkgnamepatch}-paths.patch
Patch6: %{pkgnamepatch}-icu.patch
# Patches specific for this mysql package # Patches specific for this mysql package
Patch51: %{pkgnamepatch}-chain-certs.patch Patch51: %{pkgnamepatch}-chain-certs.patch
@ -130,6 +131,7 @@ BuildRequires: gcc-c++
BuildRequires: libaio-devel BuildRequires: libaio-devel
BuildRequires: libedit-devel BuildRequires: libedit-devel
BuildRequires: libevent-devel BuildRequires: libevent-devel
BuildRequires: libicu-devel
BuildRequires: lz4 BuildRequires: lz4
BuildRequires: lz4-devel BuildRequires: lz4-devel
BuildRequires: mecab-devel BuildRequires: mecab-devel
@ -146,6 +148,8 @@ BuildRequires: rpcgen
BuildRequires: libtirpc-devel BuildRequires: libtirpc-devel
%endif %endif
BuildRequires: protobuf-lite-devel BuildRequires: protobuf-lite-devel
BuildRequires: rapidjson-devel
BuildRequires: re2-devel
BuildRequires: zlib BuildRequires: zlib
BuildRequires: zlib-devel BuildRequires: zlib-devel
BuildRequires: multilib-rpm-config BuildRequires: multilib-rpm-config
@ -175,7 +179,7 @@ BuildRequires: perl(Time::HiRes)
Requires: bash coreutils grep Requires: bash coreutils grep
Requires: %{name}-common%{?_isa} = %{sameevr} Requires: %{name}-common%{?_isa} = %{sameevr}
Provides: bundled(boost) = 1.66 Provides: bundled(boost) = 1.67
%if %{with mysql_names} %if %{with mysql_names}
Provides: mysql = %{sameevr} Provides: mysql = %{sameevr}
@ -355,12 +359,13 @@ the MySQL sources.
%patch3 -p1 %patch3 -p1
%patch4 -p1 %patch4 -p1
%patch5 -p1 %patch5 -p1
%patch6 -p1
%patch51 -p1 %patch51 -p1
%patch52 -p1 %patch52 -p1
%patch75 -p1 %patch75 -p1
# Patch Boost # Patch Boost
pushd boost/boost_1_66_0 pushd boost/boost_1_67_0
%patch115 -p0 %patch115 -p0
%patch125 -p1 %patch125 -p1
popd popd
@ -514,14 +519,9 @@ cmake .. \
%ifarch s390 s390x %ifarch s390 s390x
-DUSE_LD_GOLD=OFF \ -DUSE_LD_GOLD=OFF \
%endif %endif
-DWITH_EDITLINE=system \ -DWITH_SYSTEM_LIBS=ON \
-DWITH_LIBEVENT=system \
-DWITH_LZ4=system \
-DWITH_MECAB=system \
-DWITH_PROTOBUF=system \
-DWITH_SSL=system \
-DWITH_ZLIB=system \
-DWITH_BOOST=../boost \ -DWITH_BOOST=../boost \
-DREPRODUCIBLE_BUILD=OFF \
-DCMAKE_C_FLAGS="%{optflags}%{?with_debug: -fno-strict-overflow -Wno-unused-result -Wno-unused-function -Wno-unused-but-set-variable}" \ -DCMAKE_C_FLAGS="%{optflags}%{?with_debug: -fno-strict-overflow -Wno-unused-result -Wno-unused-function -Wno-unused-but-set-variable}" \
-DCMAKE_CXX_FLAGS="%{optflags}%{?with_debug: -fno-strict-overflow -Wno-unused-result -Wno-unused-function -Wno-unused-but-set-variable}" \ -DCMAKE_CXX_FLAGS="%{optflags}%{?with_debug: -fno-strict-overflow -Wno-unused-result -Wno-unused-function -Wno-unused-but-set-variable}" \
%{?with_debug: -DWITH_DEBUG=1}\ %{?with_debug: -DWITH_DEBUG=1}\
@ -895,6 +895,7 @@ fi
%{_datadir}/%{pkg_name}/mysql_sys_schema.sql %{_datadir}/%{pkg_name}/mysql_sys_schema.sql
%{_datadir}/%{pkg_name}/mysql_system_tables.sql %{_datadir}/%{pkg_name}/mysql_system_tables.sql
%{_datadir}/%{pkg_name}/mysql_system_tables_data.sql %{_datadir}/%{pkg_name}/mysql_system_tables_data.sql
%{_datadir}/%{pkg_name}/mysql_system_users.sql
%{_datadir}/%{pkg_name}/mysql_test_data_timezone.sql %{_datadir}/%{pkg_name}/mysql_test_data_timezone.sql
%{_datadir}/%{pkg_name}/uninstall_rewriter.sql %{_datadir}/%{pkg_name}/uninstall_rewriter.sql
@ -940,6 +941,9 @@ fi
%endif %endif
%changelog %changelog
* Wed Aug 01 2018 Norvald H. Ryeng <norvald.ryeng@oracle.com> - 8.0.12-1
- Update to MySQL 8.0.12
* Tue Jul 17 2018 Honza Horak <hhorak@redhat.com> - 8.0.11-5 * Tue Jul 17 2018 Honza Horak <hhorak@redhat.com> - 8.0.11-5
- Move log file to a directory owned by mysql user - Move log file to a directory owned by mysql user
Resolves: #1590369 Resolves: #1590369