Expand paths in perl scripts in mysql-test

Conflicts:
	community-mysql.spec
This commit is contained in:
Honza Horak 2015-02-23 13:16:31 +01:00
parent 7e9daefea9
commit 90502f12b1
2 changed files with 22 additions and 5 deletions

View File

@ -6,7 +6,7 @@ diff -up mysql-5.5.31/mysql-test/lib/My/ConfigFactory.pm.p22 mysql-5.5.31/mysql-
-my @share_locations= ("share/mysql", "sql/share", "share");
+my @share_locations= ("share/community-mysql", "sql/share", "share");
+my @share_locations= ("@INSTALL_MYSQLSHAREDIR@", "sql/share", "share");
sub get_basedir {
@ -18,12 +18,12 @@ diff -up mysql-5.5.31/mysql-test/mysql-test-run.pl.p22 mysql-5.5.31/mysql-test/m
# Look for language files and charsetsdir, use same share
- $path_language= mtr_path_exists("$bindir/share/mysql",
+ $path_language= mtr_path_exists("$bindir/share/community-mysql",
+ $path_language= mtr_path_exists("$bindir/@INSTALL_MYSQLSHAREDIR@",
"$bindir/sql/share",
"$bindir/share");
my $path_share= $path_language;
- $path_charsetsdir = mtr_path_exists("$basedir/share/mysql/charsets",
+ $path_charsetsdir = mtr_path_exists("$basedir/share/community-mysql/charsets",
+ $path_charsetsdir = mtr_path_exists("$basedir/@INSTALL_MYSQLSHAREDIR@/charsets",
"$basedir/sql/share/charsets",
"$basedir/share/charsets");
@ -32,7 +32,21 @@ diff -up mysql-5.5.31/mysql-test/mysql-test-run.pl.p22 mysql-5.5.31/mysql-test/m
my $path_sql= my_find_file($install_basedir,
- ["mysql", "sql/share", "share/mysql",
+ ["mysql", "sql/share", "share/community-mysql",
+ ["mysql", "sql/share", "@INSTALL_MYSQLSHAREDIR@",
"share", "scripts"],
"mysql_system_tables.sql",
NOT_REQUIRED);
diff -up mysql-5.6.23/mysql-test/CMakeLists.txt.sharedir mysql-5.6.23/mysql-test/CMakeLists.txt
--- mysql-5.6.23/mysql-test/CMakeLists.txt.sharedir 2015-01-19 14:48:31.000000000 +0100
+++ mysql-5.6.23/mysql-test/CMakeLists.txt 2015-02-23 13:11:58.358488693 +0100
@@ -33,6 +33,10 @@ ENDIF()
+# Expand some paths in the perl scripts correctly
+CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/lib/My/ConfigFactory.pm ${CMAKE_CURRENT_SOURCE_DIR}/lib/My/ConfigFactory.pm @ONLY)
+CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/mysql-test-run.pl ${CMAKE_CURRENT_SOURCE_DIR}/mysql-test-run.pl @ONLY)
+
IF(NOT ${CMAKE_SOURCE_DIR} STREQUAL ${CMAKE_BINARY_DIR})
# Enable running mtr from build directory
CONFIGURE_FILE(

View File

@ -74,7 +74,7 @@
Name: community-mysql
Version: 5.6.23
Release: 1%{?with_debug:.debug}%{?dist}
Release: 3%{?with_debug:.debug}%{?dist}
Summary: MySQL client programs and shared libraries
Group: Applications/Databases
URL: http://www.mysql.com
@ -937,6 +937,9 @@ fi
%endif
%changelog
* Mon Feb 23 2015 Honza Horak <hhorak@redhat.com> - 5.6.23-3
- Expand paths in perl scripts in mysql-test
* Thu Jan 29 2015 Bjorn Munch <bjorn.munch@oracle.com> - 5.6.23-1
- Update to MySQL 5.6.23, for various fixes described at
https://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-23.html