Update to MySQL 8.0.14

This commit is contained in:
Lars Tangvald 2019-01-23 10:29:27 +01:00 committed by Michal Schorm
parent 421f344096
commit 64898829e9
2 changed files with 24 additions and 8 deletions

View File

@ -0,0 +1,15 @@
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index 8cc64089f5a..2ee48177b85 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -113,10 +113,6 @@ TARGET_LINK_LIBRARIES(mysql_secure_installation mysqlclient)
MYSQL_ADD_EXECUTABLE(mysql_ssl_rsa_setup mysql_ssl_rsa_setup.cc path.cc logger.cc)
TARGET_LINK_LIBRARIES(mysql_ssl_rsa_setup mysys mysys_ssl)
-# Bug in /usr/lib/gcc-snapshot/lib/libstdc++.so ??
-IF(CMAKE_CXX_COMPILER_VERSION VERSION_EQUAL "9.0.0")
- TARGET_LINK_LIBRARIES(mysql_ssl_rsa_setup -static-libstdc++)
-ENDIF()
# "WIN32" also covers 64 bit. "echo" is used in some files below "mysql-test/".
IF(WIN32)

View File

@ -82,8 +82,8 @@
%global sameevr %{?epoch:%{epoch}:}%{version}-%{release} %global sameevr %{?epoch:%{epoch}:}%{version}-%{release}
Name: community-mysql Name: community-mysql
Version: 8.0.13 Version: 8.0.14
Release: 3%{?with_debug:.debug}%{?dist} Release: 1%{?with_debug:.debug}%{?dist}
Summary: MySQL client programs and shared libraries Summary: MySQL client programs and shared libraries
URL: http://www.mysql.com URL: http://www.mysql.com
@ -123,6 +123,7 @@ Patch5: %{pkgnamepatch}-paths.patch
Patch51: %{pkgnamepatch}-chain-certs.patch Patch51: %{pkgnamepatch}-chain-certs.patch
Patch52: %{pkgnamepatch}-sharedir.patch Patch52: %{pkgnamepatch}-sharedir.patch
Patch53: %{pkgnamepatch}-router.patch Patch53: %{pkgnamepatch}-router.patch
Patch54: %{pkgnamepatch}-gcc9.patch
Patch75: %{pkgnamepatch}-arm32-timer.patch Patch75: %{pkgnamepatch}-arm32-timer.patch
# Patches taken from boost 1.59 # Patches taken from boost 1.59
@ -183,7 +184,7 @@ BuildRequires: perl(Time::HiRes)
Requires: bash coreutils grep Requires: bash coreutils grep
Requires: %{name}-common%{?_isa} = %{sameevr} Requires: %{name}-common%{?_isa} = %{sameevr}
Provides: bundled(boost) = 1.67 Provides: bundled(boost) = 1.68
%if %{with mysql_names} %if %{with mysql_names}
Provides: mysql = %{sameevr} Provides: mysql = %{sameevr}
@ -377,10 +378,11 @@ the MySQL sources.
%patch51 -p1 %patch51 -p1
%patch52 -p1 %patch52 -p1
%patch53 -p1 %patch53 -p1
%patch54 -p1
%patch75 -p1 %patch75 -p1
# Patch Boost # Patch Boost
pushd boost/boost_1_67_0 pushd boost/boost_1_??_0
%patch115 -p0 %patch115 -p0
%patch125 -p1 %patch125 -p1
popd popd
@ -858,8 +860,6 @@ fi
%{_bindir}/mysqldumpslow %{_bindir}/mysqldumpslow
%{_bindir}/innochecksum %{_bindir}/innochecksum
%{_bindir}/perror %{_bindir}/perror
%{_bindir}/resolve_stack_dump
%{_bindir}/resolveip
%config(noreplace) %{_sysconfdir}/my.cnf.d/%{pkg_name}-server.cnf %config(noreplace) %{_sysconfdir}/my.cnf.d/%{pkg_name}-server.cnf
@ -896,8 +896,6 @@ fi
%{_mandir}/man1/mysqlman.1* %{_mandir}/man1/mysqlman.1*
%{_mandir}/man1/innochecksum.1* %{_mandir}/man1/innochecksum.1*
%{_mandir}/man1/perror.1* %{_mandir}/man1/perror.1*
%{_mandir}/man1/resolve_stack_dump.1*
%{_mandir}/man1/resolveip.1*
%{_mandir}/man1/lz4_decompress.1* %{_mandir}/man1/lz4_decompress.1*
%{_mandir}/man1/zlib_decompress.1* %{_mandir}/man1/zlib_decompress.1*
%{_mandir}/man8/mysqld.8* %{_mandir}/man8/mysqld.8*
@ -947,6 +945,9 @@ fi
%endif %endif
%changelog %changelog
* Mon Jan 21 2019 Lars Tangvald <lars.tangvald@oracle.com> - 8.0.14-1
- Update to MySQL 8.0.14
* Wed Jan 16 2019 Michal Schorm <mschorm@redhat.com> - 8.0.13-3 * Wed Jan 16 2019 Michal Schorm <mschorm@redhat.com> - 8.0.13-3
- Tweak handling of the mysql-selinux requirement - Tweak handling of the mysql-selinux requirement