Add configuration file for server

This commit is contained in:
Honza Horak 2015-01-12 16:34:36 +01:00
parent 891c072e02
commit 1eadb03b89
3 changed files with 27 additions and 3 deletions

View File

@ -1,7 +1,7 @@
diff -rup mysql-5.6.19-orig/scripts/CMakeLists.txt mysql-5.6.19/scripts/CMakeLists.txt diff -rup mysql-5.6.19-orig/scripts/CMakeLists.txt mysql-5.6.19/scripts/CMakeLists.txt
--- mysql-5.6.19-orig/scripts/CMakeLists.txt 2014-07-22 10:07:12.053410263 +0200 --- mysql-5.6.19-orig/scripts/CMakeLists.txt 2014-07-22 10:07:12.053410263 +0200
+++ mysql-5.6.19/scripts/CMakeLists.txt 2014-07-22 10:10:44.102502369 +0200 +++ mysql-5.6.19/scripts/CMakeLists.txt 2014-07-22 10:10:44.102502369 +0200
@@ -381,6 +381,32 @@ ELSE() @@ -381,6 +381,33 @@ ELSE()
ENDIF() ENDIF()
INSTALL_SCRIPT(${CMAKE_CURRENT_BINARY_DIR}/${file} COMPONENT ${${file}_COMPONENT}) INSTALL_SCRIPT(${CMAKE_CURRENT_BINARY_DIR}/${file} COMPONENT ${${file}_COMPONENT})
ENDFOREACH() ENDFOREACH()
@ -18,6 +18,7 @@ diff -rup mysql-5.6.19-orig/scripts/CMakeLists.txt mysql-5.6.19/scripts/CMakeLis
+ mysql_config_multilib + mysql_config_multilib
+ mysql.init + mysql.init
+ my.cnf + my.cnf
+ server.cnf
+ ) + )
+ FOREACH(file ${SYSTEMD_SCRIPTS}) + FOREACH(file ${SYSTEMD_SCRIPTS})
+ IF(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${file}.sh) + IF(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${file}.sh)

View File

@ -65,7 +65,7 @@
Name: %{pkgname} Name: %{pkgname}
Version: 5.6.22 Version: 5.6.22
Release: 1%{?with_debug:.debug}%{?dist} Release: 2%{?with_debug:.debug}%{?dist}
Summary: MySQL client programs and shared libraries Summary: MySQL client programs and shared libraries
Group: Applications/Databases Group: Applications/Databases
URL: http://www.mysql.com URL: http://www.mysql.com
@ -90,6 +90,8 @@ Source16: mysql-check-upgrade.sh
Source19: mysql.init.in Source19: mysql.init.in
# To track rpmlint warnings # To track rpmlint warnings
Source30: mysql-5.6.10-rpmlintrc Source30: mysql-5.6.10-rpmlintrc
# Configuration for server
Source31: server.cnf.in
# Comments for these patches are in the patch files # Comments for these patches are in the patch files
# Patches common for more mysql-like packages # Patches common for more mysql-like packages
@ -424,7 +426,7 @@ add_test 'main.upgrade : unknown'
popd popd
cp %{SOURCE2} %{SOURCE3} %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} \ cp %{SOURCE2} %{SOURCE3} %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} \
%{SOURCE14} %{SOURCE15} %{SOURCE16} %{SOURCE19} scripts %{SOURCE14} %{SOURCE15} %{SOURCE16} %{SOURCE19} %{SOURCE31} scripts
%build %build
# fail quickly and obviously if user tries to build as root # fail quickly and obviously if user tries to build as root
@ -543,6 +545,7 @@ install -p -m 755 scripts/mysql-wait-ready %{buildroot}%{_libexecdir}/mysql-wait
install -p -m 755 scripts/mysql-check-socket %{buildroot}%{_libexecdir}/mysql-check-socket install -p -m 755 scripts/mysql-check-socket %{buildroot}%{_libexecdir}/mysql-check-socket
install -p -m 755 scripts/mysql-check-upgrade %{buildroot}%{_libexecdir}/mysql-check-upgrade install -p -m 755 scripts/mysql-check-upgrade %{buildroot}%{_libexecdir}/mysql-check-upgrade
install -p -m 644 scripts/mysql-scripts-common %{buildroot}%{_libexecdir}/mysql-scripts-common install -p -m 644 scripts/mysql-scripts-common %{buildroot}%{_libexecdir}/mysql-scripts-common
install -D -p -m 0644 scripts/server.cnf %{buildroot}%{_sysconfdir}/my.cnf.d/server.cnf
# mysql-test includes one executable that doesn't belong under /usr/share, # mysql-test includes one executable that doesn't belong under /usr/share,
# so move it and provide a symlink # so move it and provide a symlink
@ -829,6 +832,8 @@ fi
%{_bindir}/resolve_stack_dump %{_bindir}/resolve_stack_dump
%{_bindir}/resolveip %{_bindir}/resolveip
%config(noreplace) %{_sysconfdir}/my.cnf.d/server.cnf
%{_libexecdir}/mysqld %{_libexecdir}/mysqld
%{_libdir}/mysql/INFO_SRC %{_libdir}/mysql/INFO_SRC
@ -926,6 +931,9 @@ fi
%endif %endif
%changelog %changelog
* Mon Jan 12 2015 Honza Horak <hhorak@redhat.com> - 5.6.22-2
- Add configuration file for server
* Wed Dec 3 2014 Jakub Dorňák <jdornak@redhat.com> - 5.6.22-1 * Wed Dec 3 2014 Jakub Dorňák <jdornak@redhat.com> - 5.6.22-1
- Update to MySQL 5.6.22 - Update to MySQL 5.6.22

15
server.cnf.in Normal file
View File

@ -0,0 +1,15 @@
#
# These groups are read by MySQL server.
# Use it for options that only the server (but not clients) should see
#
# See the examples of server my.cnf files in /usr/share/mysql/
#
# this is read by the standalone daemon and embedded servers
[server]
# this is only for the mysqld standalone daemon
[mysqld]
log-error=@LOG_LOCATION@
pid-file=@PID_FILE_DIR@/@DAEMON_NAME@.pid