import mvapich2-2.3.5-1.el8
This commit is contained in:
parent
3123f2b408
commit
15a9cd7613
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/mvapich2-2.3.3.tar.gz
|
||||
SOURCES/mvapich2-2.3.5.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
c53074dd0836a250e7fd5a76bf1cc1ba9320f841 SOURCES/mvapich2-2.3.3.tar.gz
|
||||
4158180718b1703afa76bcea3819eb86b5b355d1 SOURCES/mvapich2-2.3.5.tar.gz
|
||||
|
@ -1,40 +0,0 @@
|
||||
From 3ba35a3261e2222326b3d81f273d3e8261cad942 Mon Sep 17 00:00:00 2001
|
||||
From: Honggang Li <honli@redhat.com>
|
||||
Date: Thu, 2 Apr 2020 18:29:43 +0800
|
||||
Subject: [PATCH] Fix Processing Unit calculation for non-NUMA machine
|
||||
|
||||
For hwloc without commit ba7d4976d38f, function
|
||||
|
||||
hwloc_get_nbobjs_by_type(topology, HWLOC_OBJ_NUMANODE)
|
||||
|
||||
return zero instead of one when no NUMA node exists.
|
||||
|
||||
This patch fixes a floating point exception issue for non-NUMA
|
||||
machine.
|
||||
|
||||
Signed-off-by: Honggang Li <honli@redhat.com>
|
||||
---
|
||||
src/mpid/ch3/channels/common/src/affinity/hwloc_bind.c | 7 ++++++-
|
||||
1 file changed, 6 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/mpid/ch3/channels/common/src/affinity/hwloc_bind.c b/src/mpid/ch3/channels/common/src/affinity/hwloc_bind.c
|
||||
index 7afb9f74248d..f1a1f1fefb97 100644
|
||||
--- a/src/mpid/ch3/channels/common/src/affinity/hwloc_bind.c
|
||||
+++ b/src/mpid/ch3/channels/common/src/affinity/hwloc_bind.c
|
||||
@@ -2748,7 +2748,12 @@ static int mv2_generate_implicit_cpu_mapping (int local_procs, int num_app_threa
|
||||
|
||||
num_physical_cores_per_socket = num_physical_cores / num_sockets;
|
||||
num_pu_per_socket = num_pu / num_sockets;
|
||||
- num_pu_per_numanode = num_pu / num_numanodes;
|
||||
+
|
||||
+ /* non-NUMA */
|
||||
+ if (num_numanodes == 0)
|
||||
+ num_pu_per_numanode = num_pu;
|
||||
+ else
|
||||
+ num_pu_per_numanode = num_pu / num_numanodes;
|
||||
|
||||
topodepth = hwloc_get_type_depth (topology, HWLOC_OBJ_CORE);
|
||||
obj = hwloc_get_obj_by_depth (topology, topodepth, 0); /* check on core 0*/
|
||||
--
|
||||
2.25.2
|
||||
|
@ -1,30 +1,37 @@
|
||||
From c152d5a633876ff01ae69bd69d25c9ec08d0bbcb Mon Sep 17 00:00:00 2001
|
||||
From: Michal Schmidt <mschmidt@redhat.com>
|
||||
Date: Fri, 3 Nov 2017 11:49:50 +0100
|
||||
From 88e61b66e821f0f4bda5fed002065093146b352c Mon Sep 17 00:00:00 2001
|
||||
From: Honggang Li <honli@redhat.com>
|
||||
Date: Tue, 1 Dec 2020 12:41:55 +0800
|
||||
Subject: [PATCH 1/2] mvapich23: unbundle contrib/hwloc
|
||||
|
||||
Signed-off-by: Honggang Li <honli@redhat.com>
|
||||
---
|
||||
Makefile.in | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
Makefile.in | 12 ++++++------
|
||||
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index 0d9ec512f5..ff3af667a4 100644
|
||||
index 140d9d8ecd6c..6bbf5f857bad 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -3029,10 +3029,10 @@ bin_PROGRAMS = $(am__EXEEXT_1) src/env/mpichversion$(EXEEXT) \
|
||||
@BUILD_F77_BINDING_TRUE@@BUILD_PROFILING_LIB_TRUE@am__append_175 = -DMPICH_MPI_FROM_PMPI -DUSE_ONLY_MPI_NAMES
|
||||
@BUILD_F77_BINDING_TRUE@@BUILD_FC_BINDING_TRUE@am__append_176 = $(mpi_fc_sources)
|
||||
@BUILD_CXX_BINDING_TRUE@am__append_177 = lib/lib@MPICXXLIBNAME@.la
|
||||
-@BUILD_OSU_MVAPICH_TRUE@am__append_178 = contrib/hwloc
|
||||
+@BUILD_OSU_MVAPICH_TRUE@am__append_178 =
|
||||
@BUILD_OSU_MVAPICH_TRUE@am__append_179 = src/env/mpiname src/util/mv2_ckpt_rebuild osu_benchmarks
|
||||
-@BUILD_OSU_MVAPICH_TRUE@am__append_180 = -Icontrib/hwloc/include/ -I$(top_srcdir)/contrib/hwloc/include
|
||||
-@BUILD_OSU_MVAPICH_TRUE@am__append_181 = contrib/hwloc/src/libhwloc_embedded.la
|
||||
+@BUILD_OSU_MVAPICH_TRUE@am__append_180 =
|
||||
+@BUILD_OSU_MVAPICH_TRUE@am__append_181 = -lhwloc
|
||||
@BUILD_COVERAGE_TRUE@am__append_182 = coverage-clean
|
||||
@@ -3049,13 +3049,13 @@ bin_PROGRAMS = $(am__EXEEXT_1) src/env/mpichversion$(EXEEXT) \
|
||||
@BUILD_F77_BINDING_TRUE@@BUILD_PROFILING_LIB_TRUE@am__append_183 = -DMPICH_MPI_FROM_PMPI -DUSE_ONLY_MPI_NAMES
|
||||
@BUILD_F77_BINDING_TRUE@@BUILD_FC_BINDING_TRUE@am__append_184 = $(mpi_fc_sources)
|
||||
@BUILD_CXX_BINDING_TRUE@am__append_185 = lib/lib@MPICXXLIBNAME@.la
|
||||
-@BUILD_HWLOC_v1_TRUE@@BUILD_OSU_MVAPICH_TRUE@am__append_186 = contrib/hwloc_v1
|
||||
-@BUILD_HWLOC_v1_FALSE@@BUILD_OSU_MVAPICH_TRUE@am__append_187 = contrib/hwloc_v2
|
||||
+@BUILD_HWLOC_v1_TRUE@@BUILD_OSU_MVAPICH_TRUE@am__append_186 =
|
||||
+@BUILD_HWLOC_v1_FALSE@@BUILD_OSU_MVAPICH_TRUE@am__append_187 =
|
||||
@BUILD_OSU_MVAPICH_TRUE@am__append_188 = src/env/mpiname src/util/mv2_ckpt_rebuild osu_benchmarks
|
||||
-@BUILD_HWLOC_v1_TRUE@@BUILD_OSU_MVAPICH_TRUE@am__append_189 = -Icontrib/hwloc_v1/include/ -I$(top_srcdir)/contrib/hwloc_v1/include
|
||||
-@BUILD_HWLOC_v1_TRUE@@BUILD_OSU_MVAPICH_TRUE@am__append_190 = contrib/hwloc_v1/src/libhwloc_embedded.la
|
||||
-@BUILD_HWLOC_v1_FALSE@@BUILD_OSU_MVAPICH_TRUE@am__append_191 = -Icontrib/hwloc_v2/include/ -I$(top_srcdir)/contrib/hwloc_v2/include
|
||||
-@BUILD_HWLOC_v1_FALSE@@BUILD_OSU_MVAPICH_TRUE@am__append_192 = contrib/hwloc_v2/hwloc/libhwloc_embedded.la
|
||||
+@BUILD_HWLOC_v1_TRUE@@BUILD_OSU_MVAPICH_TRUE@am__append_189 =
|
||||
+@BUILD_HWLOC_v1_TRUE@@BUILD_OSU_MVAPICH_TRUE@am__append_190 = -lhwloc
|
||||
+@BUILD_HWLOC_v1_FALSE@@BUILD_OSU_MVAPICH_TRUE@am__append_191 =
|
||||
+@BUILD_HWLOC_v1_FALSE@@BUILD_OSU_MVAPICH_TRUE@am__append_192 = -lhwloc
|
||||
@BUILD_COVERAGE_TRUE@am__append_193 = coverage-clean
|
||||
subdir = .
|
||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
||||
--
|
||||
2.13.6
|
||||
2.25.4
|
||||
|
||||
|
@ -1,25 +1,26 @@
|
||||
From 3aad06949ee9edbb6376092c6891efa9a37b8f51 Mon Sep 17 00:00:00 2001
|
||||
From: Michal Schmidt <mschmidt@redhat.com>
|
||||
Date: Fri, 3 Nov 2017 11:51:33 +0100
|
||||
From 03bc868ca5580f2266d93b2805c79ce97b117767 Mon Sep 17 00:00:00 2001
|
||||
From: Honggang Li <honli@redhat.com>
|
||||
Date: Tue, 1 Dec 2020 12:44:12 +0800
|
||||
Subject: [PATCH 2/2] mvapich23: unbundle osu_benchmarks
|
||||
|
||||
Signed-off-by: Honggang Li <honli@redhat.com>
|
||||
---
|
||||
Makefile.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index ff3af667a4..21e2754b56 100644
|
||||
index 6bbf5f857bad..500df0988a2f 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -3030,7 +3030,7 @@ bin_PROGRAMS = $(am__EXEEXT_1) src/env/mpichversion$(EXEEXT) \
|
||||
@BUILD_F77_BINDING_TRUE@@BUILD_FC_BINDING_TRUE@am__append_176 = $(mpi_fc_sources)
|
||||
@BUILD_CXX_BINDING_TRUE@am__append_177 = lib/lib@MPICXXLIBNAME@.la
|
||||
@BUILD_OSU_MVAPICH_TRUE@am__append_178 =
|
||||
-@BUILD_OSU_MVAPICH_TRUE@am__append_179 = src/env/mpiname src/util/mv2_ckpt_rebuild osu_benchmarks
|
||||
+@BUILD_OSU_MVAPICH_TRUE@am__append_179 = src/env/mpiname src/util/mv2_ckpt_rebuild
|
||||
@BUILD_OSU_MVAPICH_TRUE@am__append_180 =
|
||||
@BUILD_OSU_MVAPICH_TRUE@am__append_181 = -lhwloc
|
||||
@BUILD_COVERAGE_TRUE@am__append_182 = coverage-clean
|
||||
@@ -3051,7 +3051,7 @@ bin_PROGRAMS = $(am__EXEEXT_1) src/env/mpichversion$(EXEEXT) \
|
||||
@BUILD_CXX_BINDING_TRUE@am__append_185 = lib/lib@MPICXXLIBNAME@.la
|
||||
@BUILD_HWLOC_v1_TRUE@@BUILD_OSU_MVAPICH_TRUE@am__append_186 =
|
||||
@BUILD_HWLOC_v1_FALSE@@BUILD_OSU_MVAPICH_TRUE@am__append_187 =
|
||||
-@BUILD_OSU_MVAPICH_TRUE@am__append_188 = src/env/mpiname src/util/mv2_ckpt_rebuild osu_benchmarks
|
||||
+@BUILD_OSU_MVAPICH_TRUE@am__append_188 = src/env/mpiname src/util/mv2_ckpt_rebuild
|
||||
@BUILD_HWLOC_v1_TRUE@@BUILD_OSU_MVAPICH_TRUE@am__append_189 =
|
||||
@BUILD_HWLOC_v1_TRUE@@BUILD_OSU_MVAPICH_TRUE@am__append_190 = -lhwloc
|
||||
@BUILD_HWLOC_v1_FALSE@@BUILD_OSU_MVAPICH_TRUE@am__append_191 =
|
||||
--
|
||||
2.13.6
|
||||
2.25.4
|
||||
|
||||
|
@ -1,35 +1,7 @@
|
||||
# We only compile with gcc, but other people may want other compilers.
|
||||
# Set the compiler here.
|
||||
%define opt_cc gcc
|
||||
# Optional CFLAGS to use with the specific compiler...gcc doesn't need any,
|
||||
# so uncomment and define to use
|
||||
#define opt_cflags
|
||||
%define opt_cxx g++
|
||||
#define opt_cxxflags
|
||||
%define opt_f77 gfortran
|
||||
#define opt_fflags
|
||||
%define opt_fc gfortran
|
||||
#define opt_fcflags
|
||||
|
||||
%{!?python3_sitearch: %global python3_sitearch %(%{__python3} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||
|
||||
%define opt_cflags -O3 -fno-strict-aliasing
|
||||
%define opt_cxxflags -O3
|
||||
%ifarch i386
|
||||
%define opt_cflags -m32 -O3 -fno-strict-aliasing
|
||||
%define opt_cxxflags -m32 -O3
|
||||
%define opt_fflags -m32
|
||||
%define opt_fcflags -m32
|
||||
%endif
|
||||
%ifarch x86_64
|
||||
%define opt_cflags -m64 -O3 -fno-strict-aliasing
|
||||
%define opt_cxxflags -m64 -O3
|
||||
%define opt_fflags -m64
|
||||
%define opt_fcflags -m64
|
||||
%endif
|
||||
|
||||
Name: mvapich2
|
||||
Version: 2.3.3
|
||||
Version: 2.3.5
|
||||
Release: 1%{?dist}
|
||||
Summary: OSU MVAPICH2 MPI package
|
||||
Group: Development/Libraries
|
||||
@ -53,7 +25,6 @@ Source2: mvapich2.macros.in
|
||||
# the configure scripts and Makefiles accordingly.
|
||||
Patch1: 0001-mvapich23-unbundle-contrib-hwloc.patch
|
||||
Patch2: 0002-mvapich23-unbundle-osu_benchmarks.patch
|
||||
Patch3: 0001-Fix-Processing-Unit-calculation-for-non-NUMA-machine.patch
|
||||
|
||||
BuildRequires: gcc-gfortran
|
||||
BuildRequires: libibumad-devel, libibverbs-devel >= 1.1.3, librdmacm-devel
|
||||
@ -123,7 +94,6 @@ Contains development headers and libraries for %{name}-psm2.
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
# bundled hwloc, knem kernel module
|
||||
rm -r contrib/
|
||||
# limic kernel module
|
||||
@ -175,16 +145,8 @@ cd psm2
|
||||
--enable-cxx \
|
||||
--disable-silent-rules \
|
||||
--disable-wrapper-rpath \
|
||||
--with-hwloc-prefix=system \
|
||||
--with-device=ch3:psm \
|
||||
--with-ftb=no \
|
||||
--with-blcr=no \
|
||||
--with-fuse=no \
|
||||
CC=%{opt_cc} CFLAGS="%{?opt_cflags} %{build_cflags} $XFLAGS" \
|
||||
CXX=%{opt_cxx} CXXFLAGS="%{?opt_cxxflags} %{build_cflags} $XFLAGS" \
|
||||
FC=%{opt_fc} FCFLAGS="%{?opt_fcflags} %{build_cflags} $XFLAGS" \
|
||||
F77=%{opt_f77} FFLAGS="%{?opt_fflags} %{build_cflags} $XFLAGS" \
|
||||
LDFLAGS="%{build_ldflags}"
|
||||
--with-hwloc=v2 \
|
||||
--with-device=ch3:psm
|
||||
|
||||
# Remove rpath, part 2
|
||||
find . -name libtool -exec \
|
||||
@ -220,15 +182,7 @@ cd default
|
||||
--enable-cxx \
|
||||
--disable-silent-rules \
|
||||
--disable-wrapper-rpath \
|
||||
--with-hwloc-prefix=system \
|
||||
--with-ftb=no \
|
||||
--with-blcr=no \
|
||||
--with-fuse=no \
|
||||
CC=%{opt_cc} CFLAGS="%{?opt_cflags} %{build_cflags} $XFLAGS" \
|
||||
CXX=%{opt_cxx} CXXFLAGS="%{?opt_cxxflags} %{build_cflags} $XFLAGS" \
|
||||
FC=%{opt_fc} FCFLAGS="%{?opt_fcflags} %{build_cflags} $XFLAGS" \
|
||||
F77=%{opt_f77} FFLAGS="%{?opt_fflags} %{build_cflags} $XFLAGS" \
|
||||
LDFLAGS="%{build_ldflags}"
|
||||
--with-hwloc=v2
|
||||
|
||||
# Remove rpath, part 2
|
||||
find . -name libtool -exec \
|
||||
@ -392,6 +346,15 @@ cd ..
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Dec 01 2020 Honggang Li <honli@redhat.com> - 2.3.5-1
|
||||
- Update to upstream stable point release v2.3.5
|
||||
- Resolves: rhbz#1904914
|
||||
|
||||
* Wed Oct 14 2020 Honggang Li <honli@redhat.com> - 2.3.4-1
|
||||
- Update to upstream stable point release v2.3.4
|
||||
- Build against hwloc-2.2.0
|
||||
- Resolves: rhbz#1850084
|
||||
|
||||
* Wed Apr 15 2020 Honggang Li <honli@redhat.com> - 2.3.3-1
|
||||
- Update to upstream stable point release v2.3.3
|
||||
- Fix floating point exception for non-NUMA machine
|
||||
|
Loading…
Reference in New Issue
Block a user