69 lines
2.0 KiB
Diff
69 lines
2.0 KiB
Diff
From abfc64268d4135663fb46c5f3529cd5f082a5c20 Mon Sep 17 00:00:00 2001
|
|
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
|
Date: Sun, 20 Oct 2019 12:04:31 +0200
|
|
Subject: [PATCH] EGL: Include EGL/eglmesaext.h
|
|
|
|
The eglext.h shipped by libglvnd does not include the Mesa extensions,
|
|
unlike the header shipped in Mesa.
|
|
|
|
Fixes https://gitlab.gnome.org/GNOME/mutter/issues/876
|
|
---
|
|
cogl/cogl/meson.build | 2 +-
|
|
src/backends/meta-egl-ext.h | 1 +
|
|
src/backends/meta-egl.c | 1 +
|
|
src/backends/meta-egl.h | 1 +
|
|
4 files changed, 4 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/cogl/cogl/meson.build b/cogl/cogl/meson.build
|
|
index cb940420a..8032669e4 100644
|
|
--- a/cogl/cogl/meson.build
|
|
+++ b/cogl/cogl/meson.build
|
|
@@ -48,7 +48,7 @@ cogl_gl_header_h = configure_file(
|
|
built_headers += [cogl_gl_header_h]
|
|
|
|
if have_egl
|
|
- cogl_egl_includes_string = '#include <EGL/egl.h>\n#include <EGL/eglext.h>'
|
|
+ cogl_egl_includes_string = '#include <EGL/egl.h>\n#include <EGL/eglext.h>\n#include <EGL/eglmesaext.h>'
|
|
else
|
|
cogl_egl_includes_string = ''
|
|
endif
|
|
diff --git a/src/backends/meta-egl-ext.h b/src/backends/meta-egl-ext.h
|
|
index 8705e7d5b..db0b74f76 100644
|
|
--- a/src/backends/meta-egl-ext.h
|
|
+++ b/src/backends/meta-egl-ext.h
|
|
@@ -29,6 +29,7 @@
|
|
|
|
#include <EGL/egl.h>
|
|
#include <EGL/eglext.h>
|
|
+#include <EGL/eglmesaext.h>
|
|
|
|
/*
|
|
* This is a little different to the tests shipped with EGL implementations,
|
|
diff --git a/src/backends/meta-egl.c b/src/backends/meta-egl.c
|
|
index 8b953449a..a28eef4ca 100644
|
|
--- a/src/backends/meta-egl.c
|
|
+++ b/src/backends/meta-egl.c
|
|
@@ -26,6 +26,7 @@
|
|
|
|
#include <EGL/egl.h>
|
|
#include <EGL/eglext.h>
|
|
+#include <EGL/eglmesaext.h>
|
|
#include <gio/gio.h>
|
|
#include <glib.h>
|
|
#include <glib-object.h>
|
|
diff --git a/src/backends/meta-egl.h b/src/backends/meta-egl.h
|
|
index ff37f124f..81b53b32d 100644
|
|
--- a/src/backends/meta-egl.h
|
|
+++ b/src/backends/meta-egl.h
|
|
@@ -27,6 +27,7 @@
|
|
|
|
#include <EGL/egl.h>
|
|
#include <EGL/eglext.h>
|
|
+#include <EGL/eglmesaext.h>
|
|
#include <glib-object.h>
|
|
|
|
#define META_EGL_ERROR meta_egl_error_quark ()
|
|
--
|
|
2.23.0
|
|
|