parent
1b483df165
commit
fc6842463b
@ -0,0 +1,29 @@
|
|||||||
|
From 9179d4a4b1708a769d09d0d31d9af5d82240492c Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
|
||||||
|
Date: Tue, 5 Oct 2021 15:17:17 +0200
|
||||||
|
Subject: [PATCH] kms/impl-device/atomic: Add virtio_gpu to deny list
|
||||||
|
|
||||||
|
virtio_gpu is used in virtual machine environments, meaning they need
|
||||||
|
accurate cursor hotspots, which currently needs non-atomic mode setting.
|
||||||
|
|
||||||
|
Related: https://bugzilla.redhat.com/show_bug.cgi?id=2009304
|
||||||
|
Part-of: <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/2040>
|
||||||
|
---
|
||||||
|
src/backends/native/meta-kms-impl-device-atomic.c | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/src/backends/native/meta-kms-impl-device-atomic.c b/src/backends/native/meta-kms-impl-device-atomic.c
|
||||||
|
index 674a24902b..e1adf20b3c 100644
|
||||||
|
--- a/src/backends/native/meta-kms-impl-device-atomic.c
|
||||||
|
+++ b/src/backends/native/meta-kms-impl-device-atomic.c
|
||||||
|
@@ -1150,6 +1150,7 @@ is_atomic_allowed (const char *driver_name)
|
||||||
|
"vboxvideo",
|
||||||
|
"nvidia-drm",
|
||||||
|
"tegra",
|
||||||
|
+ "virtio_gpu",
|
||||||
|
NULL,
|
||||||
|
};
|
||||||
|
|
||||||
|
--
|
||||||
|
2.32.0
|
||||||
|
|
11
mutter.spec
11
mutter.spec
@ -10,7 +10,7 @@
|
|||||||
|
|
||||||
Name: mutter
|
Name: mutter
|
||||||
Version: 41.0
|
Version: 41.0
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Window and compositing manager based on Clutter
|
Summary: Window and compositing manager based on Clutter
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
@ -26,6 +26,12 @@ Patch1: 0001-Revert-build-Do-not-provide-built-sources-as-libmutt.patch
|
|||||||
# Workaround for RHBZ#1936991 (blocks atomic KMS on "tegra" driver)
|
# Workaround for RHBZ#1936991 (blocks atomic KMS on "tegra" driver)
|
||||||
Patch2: 0001-Test-deny-atomic-KMS-for-tegra-RHBZ-1936991.patch
|
Patch2: 0001-Test-deny-atomic-KMS-for-tegra-RHBZ-1936991.patch
|
||||||
|
|
||||||
|
# Block atomic mode setting on virtio to fix cursor offset
|
||||||
|
# manually re-diffed on top of "tegra" patch above
|
||||||
|
# https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/2040
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=2009304
|
||||||
|
Patch3: 0001-kms-impl-device-atomic-Add-virtio_gpu-to-deny-list.patch
|
||||||
|
|
||||||
BuildRequires: pango-devel
|
BuildRequires: pango-devel
|
||||||
BuildRequires: startup-notification-devel
|
BuildRequires: startup-notification-devel
|
||||||
BuildRequires: gnome-desktop3-devel
|
BuildRequires: gnome-desktop3-devel
|
||||||
@ -174,6 +180,9 @@ desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
|
|||||||
%{_datadir}/mutter-%{mutter_api_version}/tests
|
%{_datadir}/mutter-%{mutter_api_version}/tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 05 2021 Adam Williamson <awilliam@redhat.com> - 41.0-3
|
||||||
|
- Backport MR #2040 to fix cursor offset in VMs (#2009304)
|
||||||
|
|
||||||
* Mon Sep 20 2021 Kalev Lember <klember@redhat.com> - 41.0-2
|
* Mon Sep 20 2021 Kalev Lember <klember@redhat.com> - 41.0-2
|
||||||
- Add missing mesa-libEGL-devel dep to mutter-devel (#2002441)
|
- Add missing mesa-libEGL-devel dep to mutter-devel (#2002441)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user