- Update to 2.27.3, remove mutter-metawindow.patch
This commit is contained in:
parent
83dddcd33a
commit
deaa3dd08f
@ -1 +1,3 @@
|
||||
mutter-2.27.1.tar.bz2
|
||||
mutter-2.27.2.tar.bz2
|
||||
mutter-2.27.3.tar.bz2
|
||||
|
@ -1,44 +0,0 @@
|
||||
From f3e6913d579a2409de1eb7933a664f1c2b51380b Mon Sep 17 00:00:00 2001
|
||||
From: Tomas Frydrych <tf@linux.intel.com>
|
||||
Date: Thu, 06 Aug 2009 17:11:11 +0000
|
||||
Subject: Added meta_window_is_modal()
|
||||
|
||||
Queries whether the window is in a modal state, as per the _NET_WM_STATE
|
||||
protocol.
|
||||
---
|
||||
diff --git a/src/core/window.c b/src/core/window.c
|
||||
index 974c650..d77a553 100644
|
||||
--- a/src/core/window.c
|
||||
+++ b/src/core/window.c
|
||||
@@ -8793,3 +8793,19 @@ meta_window_get_client_machine (MetaWindow *window)
|
||||
return window->wm_client_machine;
|
||||
}
|
||||
|
||||
+/**
|
||||
+ * meta_window_is_modal:
|
||||
+ * @window: a #MetaWindow
|
||||
+ *
|
||||
+ * Queries whether the window is in a modal state as described by the
|
||||
+ * _NET_WM_STATE protocol.
|
||||
+ *
|
||||
+ * Return value: (transfer none): TRUE if the window is in modal state.
|
||||
+ */
|
||||
+gboolean
|
||||
+meta_window_is_modal (MetaWindow *window)
|
||||
+{
|
||||
+ g_return_val_if_fail (META_IS_WINDOW (window), FALSE);
|
||||
+
|
||||
+ return window->wm_state_modal;
|
||||
+}
|
||||
diff --git a/src/include/window.h b/src/include/window.h
|
||||
index f611da8..5295456 100644
|
||||
--- a/src/include/window.h
|
||||
+++ b/src/include/window.h
|
||||
@@ -116,4 +116,5 @@ void meta_window_delete (MetaWindow *window,
|
||||
guint32 timestamp);
|
||||
int meta_window_get_pid (MetaWindow *window);
|
||||
const char *meta_window_get_client_machine (MetaWindow *window);
|
||||
+gboolean meta_window_is_modal (MetaWindow *window);
|
||||
#endif
|
||||
--
|
||||
cgit v0.8.2
|
17
mutter.spec
17
mutter.spec
@ -1,13 +1,12 @@
|
||||
Name: mutter
|
||||
Version: 2.27.2
|
||||
Release: 2%{?dist}
|
||||
Version: 2.27.3
|
||||
Release: 1%{?dist}
|
||||
Summary: Window and compositing manager based on Clutter
|
||||
|
||||
Group: User Interface/Desktops
|
||||
License: GPLv2+
|
||||
URL: http://git.gnome.org/cgit/mutter
|
||||
Source0: ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.27/%{name}-%{version}.tar.bz2
|
||||
Patch0: mutter-metawindow.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: clutter-devel
|
||||
@ -31,13 +30,6 @@ BuildRequires: intltool
|
||||
BuildRequires: gnome-doc-utils
|
||||
BuildRequires: desktop-file-utils
|
||||
|
||||
# Add these due to the autoreconf for the clutter patches
|
||||
BuildRequires: intltool
|
||||
BuildRequires: gettext
|
||||
BuildRequires: libtool
|
||||
BuildRequires: automake
|
||||
BuildRequires: autoconf
|
||||
|
||||
Requires: control-center-filesystem
|
||||
Requires: startup-notification
|
||||
Requires: GConf2
|
||||
@ -69,10 +61,8 @@ utilities for testing Metacity/Mutter themes.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .metawindows
|
||||
|
||||
%build
|
||||
autoreconf
|
||||
%configure --with-clutter --disable-static
|
||||
|
||||
SHOULD_HAVE_DEFINED="HAVE_SM HAVE_XINERAMA HAVE_XFREE_XINERAMA HAVE_SHAPE HAVE_RANDR HAVE_STARTUP_NOTIFICATION HAVE_COMPOSITE_EXTENSION"
|
||||
@ -157,6 +147,9 @@ gconftool-2 --makefile-install-rule \
|
||||
%doc %{_mandir}/man1/mutter-window-demo.1.gz
|
||||
|
||||
%changelog
|
||||
* Fri Aug 28 2009 Owen Taylor <otaylor@redhat.com> - 2.27.3-1
|
||||
- Update to 2.27.3, remove mutter-metawindow.patch
|
||||
|
||||
* Fri Aug 21 2009 Peter Robinson <pbrobinson@gmail.com> 2.27.2-2
|
||||
- Add upstream patch needed by latest mutter-moblin
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user