Update to 3.31.2
This commit is contained in:
parent
3266acf63f
commit
d3a743c74f
1
.gitignore
vendored
1
.gitignore
vendored
@ -145,3 +145,4 @@ mutter-2.31.5.tar.bz2
|
||||
/mutter-3.29.92.tar.xz
|
||||
/mutter-3.30.0.tar.xz
|
||||
/mutter-3.30.1.tar.xz
|
||||
/mutter-3.31.2.tar.xz
|
||||
|
35
0001-window-actor-Special-case-shaped-Java-windows.patch
Normal file
35
0001-window-actor-Special-case-shaped-Java-windows.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From 172180057f37946461866e397d01b72c3e29c887 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Fri, 12 May 2017 13:40:31 +0200
|
||||
Subject: [PATCH] window-actor: Special-case shaped Java windows
|
||||
|
||||
OpenJDK wrongly assumes that shaping a window implies no shadows.
|
||||
They got lucky until commit b975676c changed the fallback case,
|
||||
but now their compliance tests are broken. Make them happy again
|
||||
by special-casing shaped Java windows.
|
||||
---
|
||||
src/compositor/meta-window-actor.c | 8 ++++++++
|
||||
1 file changed, 8 insertions(+)
|
||||
|
||||
diff --git a/src/compositor/meta-window-actor.c b/src/compositor/meta-window-actor.c
|
||||
index 219226b19..58a03b1fe 100644
|
||||
--- a/src/compositor/meta-window-actor.c
|
||||
+++ b/src/compositor/meta-window-actor.c
|
||||
@@ -858,6 +858,14 @@ meta_window_actor_has_shadow (MetaWindowActor *self)
|
||||
if (priv->window->has_custom_frame_extents)
|
||||
return FALSE;
|
||||
|
||||
+ /*
|
||||
+ * OpenJDK wrongly assumes that shaping a window implies no compositor
|
||||
+ * shadows; make its compliance tests happy to give it what it wants ...
|
||||
+ */
|
||||
+ if (g_strcmp0 (priv->window->res_name, "sun-awt-X11-XWindowPeer") == 0 &&
|
||||
+ priv->window->shape_region != NULL)
|
||||
+ return FALSE;
|
||||
+
|
||||
/*
|
||||
* Generate shadows for all other windows.
|
||||
*/
|
||||
--
|
||||
2.19.1
|
||||
|
29
mutter.spec
29
mutter.spec
@ -4,28 +4,25 @@
|
||||
%global json_glib_version 0.12.0
|
||||
%global libinput_version 1.4
|
||||
%global pipewire_version 0.2.2
|
||||
%global mutter_api_version 3
|
||||
|
||||
Name: mutter
|
||||
Version: 3.30.1
|
||||
Release: 5%{?dist}
|
||||
Version: 3.31.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Window and compositing manager based on Clutter
|
||||
|
||||
License: GPLv2+
|
||||
#VCS: git:git://git.gnome.org/mutter
|
||||
URL: http://www.gnome.org
|
||||
Source0: http://download.gnome.org/sources/%{name}/3.30/%{name}-%{version}.tar.xz
|
||||
Source0: http://download.gnome.org/sources/%{name}/3.31/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch0: startup-notification.patch
|
||||
|
||||
# Work-around for OpenJDK's compliance test
|
||||
Patch1: 0001-window-actor-Special-case-shaped-Java-windows.patch
|
||||
|
||||
# Fix disabled monitor when laptop lid is closed (rhbz#1638444)
|
||||
Patch1: 0001-monitor-manager-Don-t-use-switch-config-when-ensurin.patch
|
||||
|
||||
# Backport memory leak fixes (rhbz#1641254)
|
||||
Patch2: 0001-constraints-Make-current-placement-rule-stack-alloca.patch
|
||||
Patch3: 0002-shaped-texture-Clean-up-texture-regions.patch
|
||||
|
||||
# Backport work-around for hangul text input bug (rhbz#1632981)
|
||||
Patch4: 0001-wayland-Defer-text_input.done-on-an-idle.patch
|
||||
Patch2: 0001-monitor-manager-Don-t-use-switch-config-when-ensurin.patch
|
||||
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: pango-devel
|
||||
@ -59,6 +56,7 @@ BuildRequires: pam-devel
|
||||
BuildRequires: pipewire-devel >= %{pipewire_version}
|
||||
BuildRequires: systemd-devel
|
||||
BuildRequires: upower-devel
|
||||
BuildRequires: xorg-x11-server-Xorg
|
||||
BuildRequires: xkeyboard-config-devel
|
||||
BuildRequires: zenity
|
||||
BuildRequires: desktop-file-utils
|
||||
@ -132,7 +130,7 @@ autoreconf -f -i
|
||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi;
|
||||
%configure --disable-static --enable-compile-warnings=maximum --enable-remote-desktop --enable-installed-tests --with-libwacom --enable-egl-device)
|
||||
|
||||
SHOULD_HAVE_DEFINED="HAVE_SM HAVE_RANDR HAVE_STARTUP_NOTIFICATION"
|
||||
SHOULD_HAVE_DEFINED="HAVE_SM HAVE_STARTUP_NOTIFICATION"
|
||||
|
||||
for I in $SHOULD_HAVE_DEFINED; do
|
||||
if ! grep -q "define $I" config.h; then
|
||||
@ -168,7 +166,7 @@ desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
|
||||
%{_bindir}/mutter
|
||||
%{_datadir}/applications/*.desktop
|
||||
%{_libdir}/lib*.so.*
|
||||
%{_libdir}/mutter/
|
||||
%{_libdir}/mutter-%{mutter_api_version}/
|
||||
%{_libexecdir}/mutter-restart-helper
|
||||
%{_datadir}/GConf/gsettings/mutter-schemas.convert
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.mutter.gschema.xml
|
||||
@ -188,9 +186,12 @@ desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
|
||||
%{_datadir}/installed-tests/mutter
|
||||
%{_datadir}/installed-tests/mutter-clutter
|
||||
%{_datadir}/installed-tests/mutter-cogl
|
||||
%{_datadir}/mutter/tests
|
||||
%{_datadir}/mutter-%{mutter_api_version}/tests
|
||||
|
||||
%changelog
|
||||
* Wed Nov 14 2018 Florian Müllner <fmuellner@redhat.com> - 3.31.2-1
|
||||
- Update to 3.31.2
|
||||
|
||||
* Mon Oct 22 2018 Jonas Ådahl <jadahl@redhat.com> - 3.30.1-5
|
||||
- Backport work-around for hangul text input bug (rhbz#1632981)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mutter-3.30.1.tar.xz) = e9ec72b04e33c8b0ad4c7b575253e1bcac4563d885acc347c7348837d13e188368b99d8f19d9496b901039eaa52d9e3a3eb06ae4c1858ba17ea3811e99999d0d
|
||||
SHA512 (mutter-3.31.2.tar.xz) = 3acd15ecd5d6c667c1dc54505ec73f7a6a57c974151dc7e3483a644d22246ef1bc0df5c10f662578d17ed5f26cb51878931ce420b7cd923f3b14d468d44b99d5
|
||||
|
Loading…
Reference in New Issue
Block a user