Fix meson goo to install polkit rules in right place

This commit is contained in:
Ray Strode 2023-09-29 23:53:01 -04:00
parent cde2442e8a
commit c47a34687d
3 changed files with 17 additions and 14 deletions

View File

@ -1,4 +1,4 @@
From 574f2cf39e37ac6ecdb6d9b8b38626b4d6502822 Mon Sep 17 00:00:00 2001
From e416c06afacc05b3365103436b6cf5893be57b7b Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Mon, 25 Sep 2023 22:22:08 +0200
Subject: [PATCH 1/3] util: Add way to print backtraces
@ -14,7 +14,7 @@ current process and the kernel (if possible).
A future commit will use this new function.
---
meson.build | 8 ++++
meson.build | 11 +++++
meson_options.txt | 6 +++
src/50-mutter.rules | 9 ++++
src/core/util-private.h | 2 +
@ -22,16 +22,16 @@ A future commit will use this new function.
src/meson.build | 27 +++++++++++
src/mutter-backtrace | 17 +++++++
src/org.gnome.mutter.backtrace.policy.in | 17 +++++++
8 files changed, 143 insertions(+)
8 files changed, 146 insertions(+)
create mode 100644 src/50-mutter.rules
create mode 100755 src/mutter-backtrace
create mode 100644 src/org.gnome.mutter.backtrace.policy.in
diff --git a/meson.build b/meson.build
index d08401b3c..5482dfb9e 100644
index d08401b3c..15e3643c1 100644
--- a/meson.build
+++ b/meson.build
@@ -270,60 +270,67 @@ if have_wayland or have_native_backend
@@ -270,60 +270,70 @@ if have_wayland or have_native_backend
libdrm_dep = dependency('libdrm')
endif
@ -66,7 +66,10 @@ index d08401b3c..5482dfb9e 100644
+if have_polkit
+ polkit_dep = dependency('polkit-gobject-1')
+ polkit_policy_dir = polkit_dep.get_variable('policydir')
+ polkit_action_dir = polkit_dep.get_variable('actiondir')
+
+ # polkit currently has no way to get rulesdir so derive it from actiondir
+ # https://gitlab.freedesktop.org/polkit/polkit/-/merge_requests/195
+ polkit_rules_dir = join_paths(polkit_policy_dir, '..', 'rules.d')
+endif
+
have_startup_notification = get_option('startup_notification')
@ -99,7 +102,7 @@ index d08401b3c..5482dfb9e 100644
gidocgen_dep = dependency('gi-docgen', version: '>= 2021.1',
fallback: ['gi-docgen', 'dummy_dep'])
endif
@@ -671,50 +678,51 @@ if have_documentation
@@ -671,50 +681,51 @@ if have_documentation
subdir('doc/reference')
endif
@ -582,7 +585,7 @@ index 05a0dea39..dc547713c 100644
clutter_get_debug_flags (debug_flags, draw_flags, pick_flags);
}
diff --git a/src/meson.build b/src/meson.build
index ca2ef166c..4aabb6a14 100644
index ca2ef166c..ea3614936 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -1197,60 +1197,87 @@ libmutter = shared_library(libmutter_name,
@ -638,7 +641,7 @@ index ca2ef166c..4aabb6a14 100644
+
+ install_data(
+ '50-mutter.rules',
+ install_dir : polkit_action_dir,
+ install_dir : polkit_rules_dir,
+ install_mode : 'rw-r--r--'
+ )
+endif

View File

@ -1,4 +1,4 @@
From 2c78762dfe3dc05febe6be6408e4018be048159e Mon Sep 17 00:00:00 2001
From 555d200c63051228062367316859e255abf6ab00 Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Fri, 29 Sep 2023 10:53:50 -0400
Subject: [PATCH 2/3] clutter: Add ms2ns helper

View File

@ -1,4 +1,4 @@
From c49ff787cefa5917e8c6601624db414930b9b1d6 Mon Sep 17 00:00:00 2001
From 637d2cfab9421fbcd87fef72f6ce7347b7722c13 Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Mon, 25 Sep 2023 22:29:17 +0200
Subject: [PATCH 3/3] native: Stop using real-time thread if it stalls
@ -452,7 +452,7 @@ index 000000000..439966ef2
+}
diff --git a/src/backends/native/meta-thread-watcher.h b/src/backends/native/meta-thread-watcher.h
new file mode 100644
index 000000000..21e48de2d
index 000000000..fa6a1e4c8
--- /dev/null
+++ b/src/backends/native/meta-thread-watcher.h
@@ -0,0 +1,36 @@
@ -481,7 +481,7 @@ index 000000000..21e48de2d
+G_DECLARE_FINAL_TYPE (MetaThreadWatcher, meta_thread_watcher,
+ META, THREAD_WATCHER, GObject)
+
+MetaThreadWatcher * meta_thread_watcher_new (void);
+MetaThreadWatcher *meta_thread_watcher_new (void);
+void meta_thread_watcher_attach (MetaThreadWatcher *self,
+ GMainContext *context);
+void meta_thread_watcher_detach (MetaThreadWatcher *self);
@ -1002,7 +1002,7 @@ index 08d01144d..a4188ee56 100644
MetaThreadCallbackData *callback_data = l->data;
diff --git a/src/meson.build b/src/meson.build
index 4aabb6a14..427cef4d0 100644
index ea3614936..297aa8302 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -828,61 +828,62 @@ if have_native_backend