Update to 40.rc
This commit is contained in:
parent
d0dbd22662
commit
bacd61617d
1
.gitignore
vendored
1
.gitignore
vendored
@ -182,3 +182,4 @@ mutter-2.31.5.tar.bz2
|
|||||||
/mutter-40.alpha.1.1.tar.xz
|
/mutter-40.alpha.1.1.tar.xz
|
||||||
/mutter-40.alpha.1.1-214-ga9d9aee6c.tar.xz
|
/mutter-40.alpha.1.1-214-ga9d9aee6c.tar.xz
|
||||||
/mutter-40.beta.tar.xz
|
/mutter-40.beta.tar.xz
|
||||||
|
/mutter-40.rc.tar.xz
|
||||||
|
@ -1,49 +0,0 @@
|
|||||||
From 19cdbd50dca4ea08d18ffad22a96efc3e4e372d3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Benjamin Berg <bberg@redhat.com>
|
|
||||||
Date: Thu, 11 Mar 2021 18:52:48 +0100
|
|
||||||
Subject: [PATCH] main: Force Xwayland startup if not on systemd
|
|
||||||
|
|
||||||
In non-systemd managed session we are unable to start services on
|
|
||||||
demand. Instead, gnome-session will start everything at login time,
|
|
||||||
including any X11 related service (i.e. gsd-xsettings).
|
|
||||||
|
|
||||||
However, in order to start gsd-xsettings, Xwayland needs to be started
|
|
||||||
already. Otherwise it will connect to GNOME_SETUP_DISPLAY and login will
|
|
||||||
hang at that point.
|
|
||||||
|
|
||||||
Fix this by detecting whether mutter is running in a systemd unit. If it
|
|
||||||
is, we assume that we are systemd managed and the machinery to start the
|
|
||||||
services works fine. If not, we assume that the session management may
|
|
||||||
unconditionally try to start X11 related services and Xwayland must be
|
|
||||||
started in order to not block this.
|
|
||||||
---
|
|
||||||
src/core/main.c | 9 ++++++++-
|
|
||||||
1 file changed, 8 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/core/main.c b/src/core/main.c
|
|
||||||
index 6b26990c6..c189eceb5 100644
|
|
||||||
--- a/src/core/main.c
|
|
||||||
+++ b/src/core/main.c
|
|
||||||
@@ -1014,11 +1014,18 @@ meta_get_x11_display_policy (void)
|
|
||||||
#ifdef HAVE_WAYLAND
|
|
||||||
if (meta_is_wayland_compositor ())
|
|
||||||
{
|
|
||||||
+#ifdef HAVE_XWAYLAND_INITFD
|
|
||||||
+ g_autofree char *unit = NULL;
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
if (opt_no_x11)
|
|
||||||
return META_DISPLAY_POLICY_DISABLED;
|
|
||||||
|
|
||||||
#ifdef HAVE_XWAYLAND_INITFD
|
|
||||||
- return META_DISPLAY_POLICY_ON_DEMAND;
|
|
||||||
+ if (sd_pid_get_user_unit (0, &unit) < 0)
|
|
||||||
+ return META_DISPLAY_POLICY_MANDATORY;
|
|
||||||
+ else
|
|
||||||
+ return META_DISPLAY_POLICY_ON_DEMAND;
|
|
||||||
#endif
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
--
|
|
||||||
2.29.2
|
|
||||||
|
|
14
mutter.spec
14
mutter.spec
@ -7,14 +7,14 @@
|
|||||||
%global mutter_api_version 8
|
%global mutter_api_version 8
|
||||||
|
|
||||||
Name: mutter
|
Name: mutter
|
||||||
Version: 40.0~beta
|
Version: 40.0~rc
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Window and compositing manager based on Clutter
|
Summary: Window and compositing manager based on Clutter
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
#VCS: git:git://git.gnome.org/mutter
|
#VCS: git:git://git.gnome.org/mutter
|
||||||
URL: http://www.gnome.org
|
URL: http://www.gnome.org
|
||||||
Source0: http://download.gnome.org/sources/%{name}/40/%{name}-40.beta.tar.xz
|
Source0: http://download.gnome.org/sources/%{name}/40/%{name}-40.rc.tar.xz
|
||||||
|
|
||||||
# Work-around for OpenJDK's compliance test
|
# Work-around for OpenJDK's compliance test
|
||||||
Patch0: 0001-window-actor-Special-case-shaped-Java-windows.patch
|
Patch0: 0001-window-actor-Special-case-shaped-Java-windows.patch
|
||||||
@ -25,9 +25,6 @@ Patch1: 0001-Revert-build-Do-not-provide-built-sources-as-libmutt.patch
|
|||||||
# Workaround for RHBZ#1936991 (blocks atomic KMS on "tegra" driver)
|
# Workaround for RHBZ#1936991 (blocks atomic KMS on "tegra" driver)
|
||||||
Patch2: 0001-Test-deny-atomic-KMS-for-tegra-RHBZ-1936991.patch
|
Patch2: 0001-Test-deny-atomic-KMS-for-tegra-RHBZ-1936991.patch
|
||||||
|
|
||||||
# Pull in Xwayland autostart fix for non-systemd startup
|
|
||||||
Patch3: 0001-main-Force-Xwayland-startup-if-not-on-systemd.patch
|
|
||||||
|
|
||||||
BuildRequires: chrpath
|
BuildRequires: chrpath
|
||||||
BuildRequires: pango-devel
|
BuildRequires: pango-devel
|
||||||
BuildRequires: startup-notification-devel
|
BuildRequires: startup-notification-devel
|
||||||
@ -135,7 +132,7 @@ The %{name}-tests package contains tests that can be used to verify
|
|||||||
the functionality of the installed %{name} package.
|
the functionality of the installed %{name} package.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -S git -n %{name}-40.beta
|
%autosetup -S git -n %{name}-40.rc
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%meson -Degl_device=true -Dwayland_eglstream=true
|
%meson -Degl_device=true -Dwayland_eglstream=true
|
||||||
@ -177,6 +174,9 @@ desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
|
|||||||
%{_datadir}/mutter-%{mutter_api_version}/tests
|
%{_datadir}/mutter-%{mutter_api_version}/tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 15 2021 Florian Müllner <fmuellner@redhat.com> - 40.0~rc-1
|
||||||
|
- Update to 40.rc
|
||||||
|
|
||||||
* Fri Mar 12 2021 Benjamin Berg <bberg@redhat.com> - 40.0~beta-3
|
* Fri Mar 12 2021 Benjamin Berg <bberg@redhat.com> - 40.0~beta-3
|
||||||
- Pull in Xwayland autostart fix for non-systemd startup
|
- Pull in Xwayland autostart fix for non-systemd startup
|
||||||
Resolves: #1924908
|
Resolves: #1924908
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mutter-40.beta.tar.xz) = 2e676bd670bb3f7ad20281b8070627f9943aeb10edefc674602567344c5d34fc61e111dbb0cdd6cc96f6850052e601156b99369e9419dfc24566693fa3843bcd
|
SHA512 (mutter-40.rc.tar.xz) = 450c38c32531a636b1a4186e06e6c1d0a348147f3de9ad1d10cc87b43e549140e50dc7e9ffc8428a86f7509c98a64ed19cbe9a782a5e49823a3a490790d347e3
|
||||||
|
Loading…
Reference in New Issue
Block a user