parent
dc08d1f31b
commit
af53624392
1
.gitignore
vendored
1
.gitignore
vendored
@ -184,3 +184,4 @@ mutter-2.31.5.tar.bz2
|
|||||||
/mutter-40.beta.tar.xz
|
/mutter-40.beta.tar.xz
|
||||||
/mutter-40.rc.tar.xz
|
/mutter-40.rc.tar.xz
|
||||||
/mutter-40.0.tar.xz
|
/mutter-40.0.tar.xz
|
||||||
|
/mutter-40.2.1.tar.xz
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From f1f55d341939f916aa533a28cbaabb10e9d8566c Mon Sep 17 00:00:00 2001
|
From a8746403352be96bae7dfd73ac31fe0253f884b8 Mon Sep 17 00:00:00 2001
|
||||||
From: Adam Williamson <awilliam@redhat.com>
|
From: Adam Williamson <awilliam@redhat.com>
|
||||||
Date: Tue, 9 Mar 2021 17:21:59 -0800
|
Date: Tue, 9 Mar 2021 17:21:59 -0800
|
||||||
Subject: [PATCH] Test: deny atomic KMS for "tegra" (RHBZ #1936991)
|
Subject: [PATCH] Test: deny atomic KMS for "tegra" (RHBZ #1936991)
|
||||||
@ -10,13 +10,13 @@ Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
|||||||
2 files changed, 2 insertions(+)
|
2 files changed, 2 insertions(+)
|
||||||
|
|
||||||
diff --git a/data/61-mutter.rules b/data/61-mutter.rules
|
diff --git a/data/61-mutter.rules b/data/61-mutter.rules
|
||||||
index bfe63a8e9..ea7740833 100644
|
index edc03e6c1..d8e3c5f00 100644
|
||||||
--- a/data/61-mutter.rules
|
--- a/data/61-mutter.rules
|
||||||
+++ b/data/61-mutter.rules
|
+++ b/data/61-mutter.rules
|
||||||
@@ -2,3 +2,4 @@ DRIVERS=="i915", SUBSYSTEM=="drm", TAG+="mutter-device-disable-kms-modifiers"
|
@@ -3,3 +3,4 @@ DRIVERS=="nouveau", SUBSYSTEM=="drm", TAG+="mutter-device-disable-kms-modifiers"
|
||||||
DRIVERS=="nouveau", SUBSYSTEM=="drm", TAG+="mutter-device-disable-kms-modifiers"
|
|
||||||
DRIVERS=="amdgpu", SUBSYSTEM=="drm", TAG+="mutter-device-disable-kms-modifiers"
|
DRIVERS=="amdgpu", SUBSYSTEM=="drm", TAG+="mutter-device-disable-kms-modifiers"
|
||||||
DRIVER=="vkms", SUBSYSTEM=="platform", TAG+="mutter-device-ignore"
|
DRIVERS=="radeon", SUBSYSTEM=="drm", TAG+="mutter-device-disable-kms-modifiers"
|
||||||
|
ENV{ID_PATH}=="platform-vkms", TAG+="mutter-device-ignore"
|
||||||
+DRIVER=="tegra", SUBSYSTEM=="platform", TAG+="mutter-device-disable-atomic-kms"
|
+DRIVER=="tegra", SUBSYSTEM=="platform", TAG+="mutter-device-disable-atomic-kms"
|
||||||
diff --git a/src/backends/native/meta-kms-device.c b/src/backends/native/meta-kms-device.c
|
diff --git a/src/backends/native/meta-kms-device.c b/src/backends/native/meta-kms-device.c
|
||||||
index c388096d5..ef65cf82b 100644
|
index c388096d5..ef65cf82b 100644
|
||||||
@ -31,5 +31,5 @@ index c388096d5..ef65cf82b 100644
|
|||||||
};
|
};
|
||||||
|
|
||||||
--
|
--
|
||||||
2.31.1
|
2.28.0
|
||||||
|
|
||||||
|
@ -1,34 +0,0 @@
|
|||||||
From 47d16c100d481393f1be511b661b12ba4e81a5b2 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
|
||||||
Date: Wed, 2 Jun 2021 16:24:25 +0200
|
|
||||||
Subject: [PATCH] clutter/actor: Don't emit focus signals during destruction
|
|
||||||
|
|
||||||
We rightfully unset the stage focus when the focus actor is destroyed,
|
|
||||||
which in turns results in the ClutterActor::-key-focus-out signal being
|
|
||||||
emitted on an actor that is no longer fully valid.
|
|
||||||
|
|
||||||
Avoid that emission, so consumers don't have to deal with half-disposed
|
|
||||||
actors in their handler.
|
|
||||||
|
|
||||||
https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/4324
|
|
||||||
---
|
|
||||||
clutter/clutter/clutter-actor.c | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/clutter/clutter/clutter-actor.c b/clutter/clutter/clutter-actor.c
|
|
||||||
index ce0c5ed32..989e479a8 100644
|
|
||||||
--- a/clutter/clutter/clutter-actor.c
|
|
||||||
+++ b/clutter/clutter/clutter-actor.c
|
|
||||||
@@ -14584,6 +14584,9 @@ _clutter_actor_set_has_key_focus (ClutterActor *self,
|
|
||||||
{
|
|
||||||
priv->has_key_focus = has_key_focus;
|
|
||||||
|
|
||||||
+ if (CLUTTER_ACTOR_IN_DESTRUCTION (self))
|
|
||||||
+ return;
|
|
||||||
+
|
|
||||||
if (has_key_focus)
|
|
||||||
g_signal_emit (self, actor_signals[KEY_FOCUS_IN], 0);
|
|
||||||
else
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
25
mutter.spec
25
mutter.spec
@ -9,8 +9,8 @@
|
|||||||
%global tarball_version %%(echo %{version} | tr '~' '.')
|
%global tarball_version %%(echo %{version} | tr '~' '.')
|
||||||
|
|
||||||
Name: mutter
|
Name: mutter
|
||||||
Version: 40.1
|
Version: 40.2.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Window and compositing manager based on Clutter
|
Summary: Window and compositing manager based on Clutter
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
@ -26,30 +26,27 @@ Patch1: 0001-Revert-build-Do-not-provide-built-sources-as-libmutt.patch
|
|||||||
# Workaround for RHBZ#1936991 (blocks atomic KMS on "tegra" driver)
|
# Workaround for RHBZ#1936991 (blocks atomic KMS on "tegra" driver)
|
||||||
Patch2: 0001-Test-deny-atomic-KMS-for-tegra-RHBZ-1936991.patch
|
Patch2: 0001-Test-deny-atomic-KMS-for-tegra-RHBZ-1936991.patch
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1964386
|
|
||||||
Patch3: 0001-clutter-actor-Don-t-emit-focus-signals-during-destru.patch
|
|
||||||
|
|
||||||
# Allow Xwayland grabs by default, on a selected set of X11 apps (rhbz#1500399)
|
# Allow Xwayland grabs by default, on a selected set of X11 apps (rhbz#1500399)
|
||||||
Patch4: 0001-wayland-Allow-Xwayland-grabs-on-selected-apps.patch
|
Patch3: 0001-wayland-Allow-Xwayland-grabs-on-selected-apps.patch
|
||||||
|
|
||||||
# X11 window management work arounds
|
# X11 window management work arounds
|
||||||
Patch5: 0001-constraints-Enforce-X11-size-limits.patch
|
Patch4: 0001-constraints-Enforce-X11-size-limits.patch
|
||||||
|
|
||||||
# X11/VM monitor configuration patches (rhbz#1265511, rhbz#1618632,
|
# X11/VM monitor configuration patches (rhbz#1265511, rhbz#1618632,
|
||||||
# rhbz#1497303, rhbz#1690506, rhbz#1776530, rhbz#1365717, rhbz#1690170)
|
# rhbz#1497303, rhbz#1690506, rhbz#1776530, rhbz#1365717, rhbz#1690170)
|
||||||
Patch6: x11-monitor-configuration-patches.patch
|
Patch5: x11-monitor-configuration-patches.patch
|
||||||
|
|
||||||
# Sloppy focus fix (rhbz#1358535)
|
# Sloppy focus fix (rhbz#1358535)
|
||||||
Patch7: 0001-events-Don-t-move-sloppy-focus-while-buttons-are-pre.patch
|
Patch6: 0001-events-Don-t-move-sloppy-focus-while-buttons-are-pre.patch
|
||||||
|
|
||||||
# Legacy X11 configuration support (synaptics/plain)
|
# Legacy X11 configuration support (synaptics/plain)
|
||||||
Patch8: legacy-x11-input-configuration.patch
|
Patch7: legacy-x11-input-configuration.patch
|
||||||
|
|
||||||
# GLX Stereo (nvidia)
|
# GLX Stereo (nvidia)
|
||||||
Patch9: glx-stereo-support.patch
|
Patch8: glx-stereo-support.patch
|
||||||
|
|
||||||
# Work around vncserver not setting the right XDG_SESSION_TYPE
|
# Work around vncserver not setting the right XDG_SESSION_TYPE
|
||||||
Patch10: 0001-main-be-more-aggressive-in-assuming-X11-backend.patch
|
Patch9: 0001-main-be-more-aggressive-in-assuming-X11-backend.patch
|
||||||
|
|
||||||
BuildRequires: chrpath
|
BuildRequires: chrpath
|
||||||
BuildRequires: pango-devel
|
BuildRequires: pango-devel
|
||||||
@ -193,6 +190,10 @@ desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
|
|||||||
%{_datadir}/mutter-%{mutter_api_version}/tests
|
%{_datadir}/mutter-%{mutter_api_version}/tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 14 2021 Florian Müllner <fmuellner@redhat.com> - 40.2.1-1
|
||||||
|
- Update to 40.2.1
|
||||||
|
Resolves: #1971437
|
||||||
|
|
||||||
* Thu Jun 03 2021 Jonas Ådahl <jadahl@redhat.com> - 40.1-3
|
* Thu Jun 03 2021 Jonas Ådahl <jadahl@redhat.com> - 40.1-3
|
||||||
- Forward port downstream patches from RHEL8
|
- Forward port downstream patches from RHEL8
|
||||||
Resolves: #1965949
|
Resolves: #1965949
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mutter-40.1.tar.xz) = c2b6603e1d55492916f742f9cb8e15588cb30e78c37de987404ac40d3befa65e417184305ad87fdffc41052a094790f9e324a1ea7482e5de4f0439dceefed118
|
SHA512 (mutter-40.2.1.tar.xz) = f9b50b10f6a4ee8ba3d8d721734d25184675c2af1f14cb8da8cac6a6a60397c36bf39e87db06ac0ed8a0f3cbf78859e57fa965ac0d2593ed9c6aa9692d90d5b2
|
||||||
|
Loading…
Reference in New Issue
Block a user