Update to 3.13.2
This commit is contained in:
parent
ed4226070c
commit
a1980c1080
1
.gitignore
vendored
1
.gitignore
vendored
@ -71,3 +71,4 @@ mutter-2.31.5.tar.bz2
|
||||
/mutter-3.12.0.tar.xz
|
||||
/mutter-3.12.1.tar.xz
|
||||
/mutter-3.13.1.tar.xz
|
||||
/mutter-3.13.2.tar.xz
|
||||
|
@ -1,31 +0,0 @@
|
||||
From bc8799d7d7f240887086a16e8a400e049ea64df0 Mon Sep 17 00:00:00 2001
|
||||
From: "Jasper St. Pierre" <jstpierre@mecheye.net>
|
||||
Date: Mon, 5 May 2014 19:06:47 -0400
|
||||
Subject: [PATCH] constraints: Complete fix for size hints constrainment
|
||||
|
||||
---
|
||||
src/core/constraints.c | 8 ++++++++
|
||||
1 file changed, 8 insertions(+)
|
||||
|
||||
diff --git a/src/core/constraints.c b/src/core/constraints.c
|
||||
index df9c219..bfc7090 100644
|
||||
--- a/src/core/constraints.c
|
||||
+++ b/src/core/constraints.c
|
||||
@@ -950,6 +950,14 @@ constrain_size_increments (MetaWindow *window,
|
||||
if (new_height < window->size_hints.min_height)
|
||||
new_height += ((window->size_hints.min_height - new_height)/hi + 1)*hi;
|
||||
|
||||
+ {
|
||||
+ client_rect.width = new_width;
|
||||
+ client_rect.height = new_height;
|
||||
+ meta_window_client_rect_to_frame_rect (window, &client_rect, &client_rect);
|
||||
+ new_width = client_rect.width;
|
||||
+ new_height = client_rect.height;
|
||||
+ }
|
||||
+
|
||||
/* Figure out what original rect to pass to meta_rectangle_resize_with_gravity
|
||||
* See bug 448183
|
||||
*/
|
||||
--
|
||||
1.9.0
|
||||
|
@ -1,55 +0,0 @@
|
||||
From f4ef4b79f95db7b4e3071489a30cbc8f710ab4ce Mon Sep 17 00:00:00 2001
|
||||
From: "Jasper St. Pierre" <jstpierre@mecheye.net>
|
||||
Date: Mon, 5 May 2014 13:09:41 -0400
|
||||
Subject: [PATCH] constraints: Size increments need to be applied to the client
|
||||
rect
|
||||
|
||||
Not the frame rect.
|
||||
---
|
||||
src/core/constraints.c | 11 +++++++----
|
||||
1 file changed, 7 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/core/constraints.c b/src/core/constraints.c
|
||||
index e4e019b..df9c219 100644
|
||||
--- a/src/core/constraints.c
|
||||
+++ b/src/core/constraints.c
|
||||
@@ -905,6 +905,7 @@ constrain_size_increments (MetaWindow *window,
|
||||
int new_width, new_height;
|
||||
gboolean constraint_already_satisfied;
|
||||
MetaRectangle *start_rect;
|
||||
+ MetaRectangle client_rect;
|
||||
|
||||
if (priority > PRIORITY_SIZE_HINTS_INCREMENTS)
|
||||
return TRUE;
|
||||
@@ -915,13 +916,15 @@ constrain_size_increments (MetaWindow *window,
|
||||
info->action_type == ACTION_MOVE)
|
||||
return TRUE;
|
||||
|
||||
+ meta_window_frame_rect_to_client_rect (window, &info->current, &client_rect);
|
||||
+
|
||||
/* Determine whether constraint is already satisfied; exit if it is */
|
||||
bh = window->size_hints.base_height;
|
||||
hi = window->size_hints.height_inc;
|
||||
bw = window->size_hints.base_width;
|
||||
wi = window->size_hints.width_inc;
|
||||
- extra_height = (info->current.height - bh) % hi;
|
||||
- extra_width = (info->current.width - bw) % wi;
|
||||
+ extra_height = (client_rect.height - bh) % hi;
|
||||
+ extra_width = (client_rect.width - bw) % wi;
|
||||
/* ignore size increments for maximized windows */
|
||||
if (window->maximized_horizontally)
|
||||
extra_width *= 0;
|
||||
@@ -935,8 +938,8 @@ constrain_size_increments (MetaWindow *window,
|
||||
return constraint_already_satisfied;
|
||||
|
||||
/*** Enforce constraint ***/
|
||||
- new_width = info->current.width - extra_width;
|
||||
- new_height = info->current.height - extra_height;
|
||||
+ new_width = client_rect.width - extra_width;
|
||||
+ new_height = client_rect.height - extra_height;
|
||||
|
||||
/* Adjusting down instead of up (as done in the above two lines) may
|
||||
* violate minimum size constraints; fix the adjustment if this
|
||||
--
|
||||
1.9.0
|
||||
|
@ -1,59 +0,0 @@
|
||||
From 845fdda22c1e7595d72b710796ed61490b02cbbd Mon Sep 17 00:00:00 2001
|
||||
From: "Jasper St. Pierre" <jstpierre@mecheye.net>
|
||||
Date: Sat, 3 May 2014 12:49:41 -0400
|
||||
Subject: [PATCH] keybindings: Make sure not to call meta_change_keygrab under
|
||||
Wayland
|
||||
|
||||
---
|
||||
src/core/keybindings.c | 14 +++++++++-----
|
||||
1 file changed, 9 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/core/keybindings.c b/src/core/keybindings.c
|
||||
index bf9be99..b0a6bbd 100644
|
||||
--- a/src/core/keybindings.c
|
||||
+++ b/src/core/keybindings.c
|
||||
@@ -1259,6 +1259,7 @@ guint
|
||||
meta_display_grab_accelerator (MetaDisplay *display,
|
||||
const char *accelerator)
|
||||
{
|
||||
+ MetaBackend *backend = meta_get_backend ();
|
||||
MetaKeyBinding *binding;
|
||||
MetaKeyGrab *grab;
|
||||
guint keysym = 0;
|
||||
@@ -1284,7 +1285,8 @@ meta_display_grab_accelerator (MetaDisplay *display,
|
||||
if (display_get_keybinding (display, keycode, mask))
|
||||
return META_KEYBINDING_ACTION_NONE;
|
||||
|
||||
- meta_change_keygrab (display, display->screen->xroot, TRUE, keysym, keycode, mask);
|
||||
+ if (META_IS_BACKEND_X11 (backend))
|
||||
+ meta_change_keygrab (display, display->screen->xroot, TRUE, keysym, keycode, mask);
|
||||
|
||||
grab = g_new0 (MetaKeyGrab, 1);
|
||||
grab->action = next_dynamic_keybinding_action ();
|
||||
@@ -1314,6 +1316,7 @@ gboolean
|
||||
meta_display_ungrab_accelerator (MetaDisplay *display,
|
||||
guint action)
|
||||
{
|
||||
+ MetaBackend *backend = meta_get_backend ();
|
||||
MetaKeyBinding *binding;
|
||||
MetaKeyGrab *grab;
|
||||
char *key;
|
||||
@@ -1335,10 +1338,11 @@ meta_display_ungrab_accelerator (MetaDisplay *display,
|
||||
{
|
||||
guint32 index_key;
|
||||
|
||||
- meta_change_keygrab (display, display->screen->xroot, FALSE,
|
||||
- binding->keysym,
|
||||
- binding->keycode,
|
||||
- binding->mask);
|
||||
+ if (META_IS_BACKEND_X11 (backend))
|
||||
+ meta_change_keygrab (display, display->screen->xroot, FALSE,
|
||||
+ binding->keysym,
|
||||
+ binding->keycode,
|
||||
+ binding->mask);
|
||||
|
||||
index_key = key_binding_key (binding->keycode, binding->mask);
|
||||
g_hash_table_remove (display->key_bindings_index, GINT_TO_POINTER (index_key));
|
||||
--
|
||||
1.9.0
|
||||
|
19
mutter.spec
19
mutter.spec
@ -1,6 +1,6 @@
|
||||
Name: mutter
|
||||
Version: 3.13.1
|
||||
Release: 5%{?dist}
|
||||
Version: 3.13.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Window and compositing manager based on Clutter
|
||||
|
||||
Group: User Interface/Desktops
|
||||
@ -9,13 +9,7 @@ License: GPLv2+
|
||||
URL: http://www.gnome.org
|
||||
Source0: http://download.gnome.org/sources/%{name}/3.13/%{name}-%{version}.tar.xz
|
||||
|
||||
# Backported upstream fix for a Wayland session crash
|
||||
Patch0: 0001-keybindings-Make-sure-not-to-call-meta_change_keygra.patch
|
||||
# Fix shrinking terminals
|
||||
Patch1: 0001-constraints-Size-increments-need-to-be-applied-to-th.patch
|
||||
Patch2: 0001-constraints-Complete-fix-for-size-hints-constrainmen.patch
|
||||
|
||||
BuildRequires: clutter-devel >= 1.15.90
|
||||
BuildRequires: clutter-devel >= 1.19.2
|
||||
BuildRequires: pango-devel
|
||||
BuildRequires: startup-notification-devel
|
||||
BuildRequires: gnome-desktop3-devel
|
||||
@ -74,9 +68,6 @@ utilities for testing Metacity/Mutter themes.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi;
|
||||
@ -123,7 +114,6 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
%doc COPYING NEWS doc/theme-format.txt
|
||||
%doc %{_mandir}/man1/mutter.1.gz
|
||||
%{_bindir}/mutter
|
||||
%attr(4755,root,root) %{_bindir}/mutter-launch
|
||||
%{_datadir}/applications/*.desktop
|
||||
%{_libdir}/lib*.so.*
|
||||
%{_libdir}/mutter/
|
||||
@ -141,6 +131,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
%exclude %{_datadir}/gtk-doc
|
||||
|
||||
%changelog
|
||||
* Tue May 27 2014 Florian Müllner <fmuellner@redhat.com> - 3.13.2-1
|
||||
- Update to 3.13.2, drop upstreamed patches
|
||||
|
||||
* Thu May 8 2014 Matthias Clasen <mclasen@redhat.com> - 3.13.1-5
|
||||
- Fix shrinking terminals
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user