Update to 3.29.4
This commit is contained in:
parent
644c26ec24
commit
97fcafd352
1
.gitignore
vendored
1
.gitignore
vendored
@ -139,3 +139,4 @@ mutter-2.31.5.tar.bz2
|
||||
/mutter-3.28.1.tar.xz
|
||||
/mutter-3.29.1.tar.xz
|
||||
/mutter-3.29.2.tar.xz
|
||||
/mutter-3.29.4.tar.xz
|
||||
|
@ -1,71 +0,0 @@
|
||||
From 473bf38753221dc0002fae309d2f3f217e96c5f5 Mon Sep 17 00:00:00 2001
|
||||
From: Olivier Fourdan <ofourdan@redhat.com>
|
||||
Date: Tue, 22 May 2018 11:23:13 +0200
|
||||
Subject: [PATCH] frames: Allow for unknown mouse buttons
|
||||
|
||||
Commit 47131b1d ("frames: Handle touch events") introduced an assert to
|
||||
make sure that all mouse button actions are handled in mutter.
|
||||
|
||||
However, mice can have a more than 5 buttons, so simply ignore the
|
||||
"other" actions instead of aborting.
|
||||
|
||||
Fixes: https://gitlab.gnome.org/GNOME/mutter/issues/160
|
||||
---
|
||||
src/ui/frames.c | 15 +++++++++++----
|
||||
1 file changed, 11 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/ui/frames.c b/src/ui/frames.c
|
||||
index 850f2850a..6d7b999be 100644
|
||||
--- a/src/ui/frames.c
|
||||
+++ b/src/ui/frames.c
|
||||
@@ -75,7 +75,8 @@ enum {
|
||||
META_ACTION_CLICK,
|
||||
META_ACTION_RIGHT_CLICK,
|
||||
META_ACTION_MIDDLE_CLICK,
|
||||
- META_ACTION_DOUBLE_CLICK
|
||||
+ META_ACTION_DOUBLE_CLICK,
|
||||
+ META_ACTION_IGNORE
|
||||
};
|
||||
|
||||
static GObject *
|
||||
@@ -974,6 +975,10 @@ get_action (const ClutterEvent *event)
|
||||
return META_ACTION_RIGHT_CLICK;
|
||||
case CLUTTER_BUTTON_MIDDLE:
|
||||
return META_ACTION_MIDDLE_CLICK;
|
||||
+ default:
|
||||
+ meta_verbose ("No action triggered for button %u %s\n",
|
||||
+ event->button.button,
|
||||
+ (event->type == CLUTTER_BUTTON_PRESS) ? "press" : "release");
|
||||
}
|
||||
}
|
||||
else if (event->type == CLUTTER_TOUCH_BEGIN ||
|
||||
@@ -983,7 +988,7 @@ get_action (const ClutterEvent *event)
|
||||
return META_ACTION_CLICK;
|
||||
}
|
||||
|
||||
- g_assert_not_reached ();
|
||||
+ return META_ACTION_IGNORE;
|
||||
}
|
||||
|
||||
static uint32_t
|
||||
@@ -1115,13 +1120,15 @@ handle_press_event (MetaUIFrame *frame,
|
||||
g_assert (event->type == CLUTTER_BUTTON_PRESS ||
|
||||
event->type == CLUTTER_TOUCH_BEGIN);
|
||||
|
||||
+ action = get_action (event);
|
||||
+ if (action == META_ACTION_IGNORE)
|
||||
+ return FALSE;
|
||||
+
|
||||
display = GDK_DISPLAY_XDISPLAY (gdk_display_get_default ());
|
||||
|
||||
evtime = clutter_event_get_time (event);
|
||||
clutter_event_get_coords (event, &x, &y);
|
||||
control = get_control (frame, x, y);
|
||||
- action = get_action (event);
|
||||
-
|
||||
/* don't do the rest of this if on client area */
|
||||
if (control == META_FRAME_CONTROL_CLIENT_AREA)
|
||||
return FALSE; /* not on the frame, just passed through from client */
|
||||
--
|
||||
2.17.0
|
||||
|
11
mutter.spec
11
mutter.spec
@ -6,8 +6,8 @@
|
||||
%global pipewire_version 0.1.4
|
||||
|
||||
Name: mutter
|
||||
Version: 3.29.2
|
||||
Release: 3%{?dist}
|
||||
Version: 3.29.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Window and compositing manager based on Clutter
|
||||
|
||||
License: GPLv2+
|
||||
@ -16,10 +16,6 @@ URL: http://www.gnome.org
|
||||
Source0: http://download.gnome.org/sources/%{name}/3.29/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch0: startup-notification.patch
|
||||
# https://gitlab.gnome.org/GNOME/mutter/issues/160
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1585360
|
||||
# https://gitlab.gnome.org/GNOME/mutter/commit/473bf38753221dc0002fae309d2f3f217e96c5f5
|
||||
Patch1: 0001-frames-Allow-for-unknown-mouse-buttons.patch
|
||||
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: pango-devel
|
||||
@ -184,6 +180,9 @@ desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
|
||||
%{_datadir}/mutter/tests
|
||||
|
||||
%changelog
|
||||
* Wed Jul 18 2018 Florian Müllner <fmuellner@redhat.com> - 3.29.4-1
|
||||
- Update to 3.29.4
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.29.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mutter-3.29.2.tar.xz) = 9b542ec72cf6381b36318ef8785bf052b5e3b6f32d12f066b751b197e9ad6d10edcabe50244b16c7d843fb0b05566cded37d0506d2c19592841125a2bfd9f867
|
||||
SHA512 (mutter-3.29.4.tar.xz) = 1fb3f8340956368d9c60757dd5681d78dd75aa97c0ecf6139256bcbf46912bc84f9d76584d558e004757ecea163c4ed0cfc301df01420758c5d6634a5263a68d
|
||||
|
Loading…
Reference in New Issue
Block a user