Update to 3.30.1
This commit is contained in:
parent
371cda4940
commit
818439c2ae
1
.gitignore
vendored
1
.gitignore
vendored
@ -144,3 +144,4 @@ mutter-2.31.5.tar.bz2
|
||||
/mutter-3.29.91.tar.xz
|
||||
/mutter-3.29.92.tar.xz
|
||||
/mutter-3.30.0.tar.xz
|
||||
/mutter-3.30.1.tar.xz
|
||||
|
@ -1,43 +0,0 @@
|
||||
From 68ec9ac017157def9b7c25dd8141dc0e93d9f918 Mon Sep 17 00:00:00 2001
|
||||
From: Olivier Fourdan <ofourdan@redhat.com>
|
||||
Date: Tue, 25 Sep 2018 13:50:09 +0200
|
||||
Subject: [PATCH] wayland: No xdg-output events without a logical monitor
|
||||
|
||||
To avoid a known race condition in the wl_output protocol documented in
|
||||
https://phabricator.freedesktop.org/T7722, mutter delays the `wl_output`
|
||||
destruction but nullify the `logical_monitor` associated with the
|
||||
`wl_output` and the binding routine `bind_output()` makes sure not to
|
||||
send wl_output events if the `logical_monitor` is `NULL` (see commit
|
||||
1923db97).
|
||||
|
||||
The binding routine for `xdg_output` however does not check for such a
|
||||
condition, hence if the output configuration changes while a client is
|
||||
binding to xdg-output (typically Xwayland at startup), mutter would
|
||||
crash while trying to access the `logical_monitor` which was nullified
|
||||
by the change in configuration.
|
||||
|
||||
Just like `bind_output()` does for wl_output, do not send xdg-output
|
||||
events if there is no `logical_monitor` yet.
|
||||
|
||||
Closes: https://gitlab.gnome.org/GNOME/mutter/issues/194
|
||||
---
|
||||
src/wayland/meta-wayland-outputs.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/src/wayland/meta-wayland-outputs.c b/src/wayland/meta-wayland-outputs.c
|
||||
index 544ce341d..bd0a3b1ff 100644
|
||||
--- a/src/wayland/meta-wayland-outputs.c
|
||||
+++ b/src/wayland/meta-wayland-outputs.c
|
||||
@@ -591,6 +591,9 @@ meta_xdg_output_manager_get_xdg_output (struct wl_client *client,
|
||||
wayland_output->xdg_output_resources =
|
||||
g_list_prepend (wayland_output->xdg_output_resources, xdg_output_resource);
|
||||
|
||||
+ if (!wayland_output->logical_monitor)
|
||||
+ return;
|
||||
+
|
||||
send_xdg_output_events (xdg_output_resource,
|
||||
wayland_output,
|
||||
wayland_output->logical_monitor,
|
||||
--
|
||||
2.19.0
|
||||
|
10
mutter.spec
10
mutter.spec
@ -6,8 +6,8 @@
|
||||
%global pipewire_version 0.2.2
|
||||
|
||||
Name: mutter
|
||||
Version: 3.30.0
|
||||
Release: 3%{?dist}
|
||||
Version: 3.30.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Window and compositing manager based on Clutter
|
||||
|
||||
License: GPLv2+
|
||||
@ -16,9 +16,6 @@ URL: http://www.gnome.org
|
||||
Source0: http://download.gnome.org/sources/%{name}/3.30/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch0: startup-notification.patch
|
||||
# Backport of https://gitlab.gnome.org/GNOME/mutter/commit/68ec9ac017157def9b7c25dd8141dc0e93d9f918
|
||||
# Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1630943
|
||||
Patch1: 0001-wayland-No-xdg-output-events-without-a-logical-monit.patch
|
||||
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: pango-devel
|
||||
@ -184,6 +181,9 @@ desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
|
||||
%{_datadir}/mutter/tests
|
||||
|
||||
%changelog
|
||||
* Mon Oct 08 2018 Florian Müllner <fmuellner@redhat.com> - 3.30.1-1
|
||||
- Update to 3.30.1
|
||||
|
||||
* Wed Oct 03 2018 Adam Williamson <awilliam@redhat.com> - 3.30.0-3
|
||||
- Backport fix for #1630943 from upstream master
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mutter-3.30.0.tar.xz) = 2c8ff7d4d6ddec1365e778490a5bb6acb7c84df66dadcd1e321b9cce9a65737e6b9510a6aaf6792883ad3a46ef6defb60df3bb9a735847c3878ee43692e973fa
|
||||
SHA512 (mutter-3.30.1.tar.xz) = e9ec72b04e33c8b0ad4c7b575253e1bcac4563d885acc347c7348837d13e188368b99d8f19d9496b901039eaa52d9e3a3eb06ae4c1858ba17ea3811e99999d0d
|
||||
|
Loading…
Reference in New Issue
Block a user