Update to 3.13.91
This commit is contained in:
parent
3b22485755
commit
6fe6bae6a6
1
.gitignore
vendored
1
.gitignore
vendored
@ -75,3 +75,4 @@ mutter-2.31.5.tar.bz2
|
||||
/mutter-3.13.3.tar.xz
|
||||
/mutter-3.13.4.tar.xz
|
||||
/mutter-3.13.90.tar.xz
|
||||
/mutter-3.13.91.tar.xz
|
||||
|
@ -1,43 +0,0 @@
|
||||
From d15bce3e4aff06e4a70f156f41eec73f4089cd16 Mon Sep 17 00:00:00 2001
|
||||
From: Adel Gadllah <adel.gadllah@gmail.com>
|
||||
Date: Tue, 26 Aug 2014 18:22:33 +0200
|
||||
Subject: [PATCH] meta-surface-actor: Fix is_argb32 for unredirected windows
|
||||
|
||||
meta_surface_actor_is_argb32 assumes that lack of stex means that a window is
|
||||
ARGB32. When we unredirect a window we detach the texture so we end up without
|
||||
a texture. Given that should_unredirect returns FALSE when a window is argb32,
|
||||
we know that this window is indeed not ARGB32.
|
||||
|
||||
Returing TRUE in that case causes us to flip between redirected and
|
||||
unredirected on every paint.
|
||||
|
||||
So fix that by returning FALSE in that case.
|
||||
---
|
||||
src/compositor/meta-surface-actor.c | 10 ++++++++--
|
||||
1 file changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/compositor/meta-surface-actor.c b/src/compositor/meta-surface-actor.c
|
||||
index e7e3a02..bb85478 100644
|
||||
--- a/src/compositor/meta-surface-actor.c
|
||||
+++ b/src/compositor/meta-surface-actor.c
|
||||
@@ -280,9 +280,15 @@ meta_surface_actor_is_argb32 (MetaSurfaceActor *self)
|
||||
CoglTexture *texture = meta_shaped_texture_get_texture (stex);
|
||||
|
||||
/* If we don't have a texture, like during initialization, assume
|
||||
- * that we're ARGB32. */
|
||||
+ * that we're ARGB32.
|
||||
+ *
|
||||
+ * If we are unredirected and we have no texture assume that we are
|
||||
+ * not ARGB32 otherwise we wouldn't be unredirected in the first
|
||||
+ * place. This prevents us from continually redirecting and
|
||||
+ * unredirecting on every paint.
|
||||
+ */
|
||||
if (!texture)
|
||||
- return TRUE;
|
||||
+ return !meta_surface_actor_is_unredirected (self);
|
||||
|
||||
switch (cogl_texture_get_components (texture))
|
||||
{
|
||||
--
|
||||
1.9.3
|
||||
|
@ -1,60 +0,0 @@
|
||||
From 8f757c7b8062edc45e7d2c78508ed50969aa0be7 Mon Sep 17 00:00:00 2001
|
||||
From: "Jasper St. Pierre" <jstpierre@mecheye.net>
|
||||
Date: Mon, 25 Aug 2014 08:57:13 -0400
|
||||
Subject: [PATCH 1/2] workspace: Smarten assert in light of O-R windows
|
||||
|
||||
O-R windows appear in workspace->windows, which aren't relocatable,
|
||||
so we can't simply check if the workspace is empty after relocating
|
||||
all normal windows, since those windows remain.
|
||||
|
||||
Make sure that the only windows we have are those that are
|
||||
on_all_workspaces.
|
||||
---
|
||||
src/core/workspace.c | 17 +++++++++++++++--
|
||||
1 file changed, 15 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/core/workspace.c b/src/core/workspace.c
|
||||
index af84eed..d55593c 100644
|
||||
--- a/src/core/workspace.c
|
||||
+++ b/src/core/workspace.c
|
||||
@@ -241,6 +241,19 @@ workspace_free_builtin_struts (MetaWorkspace *workspace)
|
||||
workspace->builtin_struts = NULL;
|
||||
}
|
||||
|
||||
+/* Ensure that the workspace is empty by making sure that
|
||||
+ * all of our windows are on-all-workspaces. */
|
||||
+static void
|
||||
+assert_workspace_empty (MetaWorkspace *workspace)
|
||||
+{
|
||||
+ GList *l;
|
||||
+ for (l = workspace->windows; l != NULL; l = l->next)
|
||||
+ {
|
||||
+ MetaWindow *window = l->data;
|
||||
+ g_assert (window->on_all_workspaces);
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
void
|
||||
meta_workspace_remove (MetaWorkspace *workspace)
|
||||
{
|
||||
@@ -249,7 +262,7 @@ meta_workspace_remove (MetaWorkspace *workspace)
|
||||
|
||||
g_return_if_fail (workspace != workspace->screen->active_workspace);
|
||||
|
||||
- g_assert (workspace->windows == NULL);
|
||||
+ assert_workspace_empty (workspace);
|
||||
|
||||
screen = workspace->screen;
|
||||
|
||||
@@ -349,7 +362,7 @@ meta_workspace_relocate_windows (MetaWorkspace *workspace,
|
||||
|
||||
g_list_free (copy);
|
||||
|
||||
- g_assert (workspace->windows == NULL);
|
||||
+ assert_workspace_empty (workspace);
|
||||
}
|
||||
|
||||
void
|
||||
--
|
||||
2.1.0
|
||||
|
12
mutter.spec
12
mutter.spec
@ -1,8 +1,8 @@
|
||||
%global clutter_version 1.19.6-3
|
||||
|
||||
Name: mutter
|
||||
Version: 3.13.90
|
||||
Release: 4%{?dist}
|
||||
Version: 3.13.91
|
||||
Release: 1%{?dist}
|
||||
Summary: Window and compositing manager based on Clutter
|
||||
|
||||
Group: User Interface/Desktops
|
||||
@ -10,9 +10,6 @@ License: GPLv2+
|
||||
#VCS: git:git://git.gnome.org/mutter
|
||||
URL: http://www.gnome.org
|
||||
Source0: http://download.gnome.org/sources/%{name}/3.13/%{name}-%{version}.tar.xz
|
||||
# rhbz1103221 From upstream git, drop when rebasing
|
||||
Patch1: 0001-workspace-Smarten-assert-in-light-of-O-R-windows.patch
|
||||
Patch2: 0001-meta-surface-actor-Fix-is_argb32-for-unredirected-wi.patch
|
||||
|
||||
|
||||
BuildRequires: clutter-devel >= %{clutter_version}
|
||||
@ -79,8 +76,6 @@ utilities for testing Metacity/Mutter themes.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi;
|
||||
@ -145,6 +140,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
%exclude %{_datadir}/gtk-doc
|
||||
|
||||
%changelog
|
||||
* Wed Sep 03 2014 Florian Müllner <fmuellner@redhat.com> - 3.31.91-1
|
||||
- Update to 3.13.91, drop downstream patches
|
||||
|
||||
* Tue Aug 26 2014 Adel Gadllah <adel.gadllah@gmail.com> - 3.13.90-4
|
||||
- Apply fix for RH #1133166
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user