Update to 3.13.3
This commit is contained in:
parent
362fd3e07b
commit
69a9976084
1
.gitignore
vendored
1
.gitignore
vendored
@ -72,3 +72,4 @@ mutter-2.31.5.tar.bz2
|
||||
/mutter-3.12.1.tar.xz
|
||||
/mutter-3.13.1.tar.xz
|
||||
/mutter-3.13.2.tar.xz
|
||||
/mutter-3.13.3.tar.xz
|
||||
|
@ -1,42 +0,0 @@
|
||||
From 3f6c6f1dd93744e98add7bc3656c13e204b51435 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Fri, 6 Jun 2014 14:53:33 +0200
|
||||
Subject: [PATCH] constraints: Translate frame to client rect for legacy
|
||||
fullscreen check
|
||||
|
||||
Stupid apps fullscreen themselves by resizing the client window to
|
||||
monitor size. A monitor-sized frame rect on the other hand is perfectly
|
||||
normal on monitors without struts - stop force-fullscreening those
|
||||
and catch the real baddies instead.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=730681
|
||||
---
|
||||
src/core/constraints.c | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/src/core/constraints.c b/src/core/constraints.c
|
||||
index 250de41..f9b5668 100644
|
||||
--- a/src/core/constraints.c
|
||||
+++ b/src/core/constraints.c
|
||||
@@ -411,6 +411,9 @@ setup_constraint_info (ConstraintInfo *info,
|
||||
* if there are no struts making the workarea smaller than
|
||||
* the monitor.
|
||||
*/
|
||||
+
|
||||
+ meta_window_frame_rect_to_client_rect (window, new, new);
|
||||
+
|
||||
if (meta_prefs_get_force_fullscreen() &&
|
||||
window->client_type != META_WINDOW_CLIENT_TYPE_WAYLAND &&
|
||||
!window->hide_titlebar_when_maximized &&
|
||||
@@ -429,6 +432,8 @@ setup_constraint_info (ConstraintInfo *info,
|
||||
meta_window_make_fullscreen_internal (window);
|
||||
}
|
||||
|
||||
+ meta_window_client_rect_to_frame_rect (window, new, new);
|
||||
+
|
||||
/* Log all this information for debugging */
|
||||
meta_topic (META_DEBUG_GEOMETRY,
|
||||
"Setting up constraint info:\n"
|
||||
--
|
||||
2.0.0
|
||||
|
10
mutter.spec
10
mutter.spec
@ -1,6 +1,6 @@
|
||||
Name: mutter
|
||||
Version: 3.13.2
|
||||
Release: 3%{?dist}
|
||||
Version: 3.13.3
|
||||
Release: 1%{?dist}
|
||||
Summary: Window and compositing manager based on Clutter
|
||||
|
||||
Group: User Interface/Desktops
|
||||
@ -9,8 +9,6 @@ License: GPLv2+
|
||||
URL: http://www.gnome.org
|
||||
Source0: http://download.gnome.org/sources/%{name}/3.13/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch1: 0001-constraints-Translate-frame-to-client-rect-for-legac.patch
|
||||
|
||||
BuildRequires: clutter-devel >= 1.19.2
|
||||
BuildRequires: pango-devel
|
||||
BuildRequires: startup-notification-devel
|
||||
@ -70,7 +68,6 @@ utilities for testing Metacity/Mutter themes.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .fix-legacy-fullscreen-check
|
||||
|
||||
%build
|
||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi;
|
||||
@ -134,6 +131,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
%exclude %{_datadir}/gtk-doc
|
||||
|
||||
%changelog
|
||||
* Wed Jun 25 2014 Florian Müllner <fmuellner@redhat.com> - 3.13.3-1
|
||||
- Update to 3.13.1
|
||||
|
||||
* Wed Jun 11 2014 Florian Müllner <fmuellner@redhat.com> - 3.13.2-2
|
||||
- Backport fix for legacy fullscreen check
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user