Update to 3.15.90
This commit is contained in:
parent
90b5961696
commit
4e5f58db61
1
.gitignore
vendored
1
.gitignore
vendored
@ -83,3 +83,4 @@ mutter-2.31.5.tar.bz2
|
||||
/mutter-3.15.2.tar.xz
|
||||
/mutter-3.15.3.tar.xz
|
||||
/mutter-3.15.4.tar.xz
|
||||
/mutter-3.15.90.tar.xz
|
||||
|
@ -1,76 +0,0 @@
|
||||
From ad90b7dd2f0eec6c9966e83742e7bfddcea19f76 Mon Sep 17 00:00:00 2001
|
||||
From: Rui Matos <tiagomatos@gmail.com>
|
||||
Date: Fri, 23 Jan 2015 17:32:21 +0100
|
||||
Subject: [PATCH 1/6] monitor-manager: Initialize MetaOutput even when we can't
|
||||
get the EDID
|
||||
|
||||
Otherwise we'll crash later when building a MetaConfiguration.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=743412
|
||||
---
|
||||
src/backends/meta-monitor-manager.c | 4 ++++
|
||||
src/backends/native/meta-monitor-manager-kms.c | 7 ++-----
|
||||
src/backends/x11/meta-monitor-manager-xrandr.c | 7 ++-----
|
||||
3 files changed, 8 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/src/backends/meta-monitor-manager.c b/src/backends/meta-monitor-manager.c
|
||||
index 3f11716..352a182 100644
|
||||
--- a/src/backends/meta-monitor-manager.c
|
||||
+++ b/src/backends/meta-monitor-manager.c
|
||||
@@ -1230,6 +1230,9 @@ meta_output_parse_edid (MetaOutput *meta_output,
|
||||
MonitorInfo *parsed_edid;
|
||||
gsize len;
|
||||
|
||||
+ if (!edid)
|
||||
+ goto out;
|
||||
+
|
||||
parsed_edid = decode_edid (g_bytes_get_data (edid, &len));
|
||||
|
||||
if (parsed_edid)
|
||||
@@ -1247,6 +1250,7 @@ meta_output_parse_edid (MetaOutput *meta_output,
|
||||
g_free (parsed_edid);
|
||||
}
|
||||
|
||||
+ out:
|
||||
if (!meta_output->vendor)
|
||||
{
|
||||
meta_output->vendor = g_strdup ("unknown");
|
||||
diff --git a/src/backends/native/meta-monitor-manager-kms.c b/src/backends/native/meta-monitor-manager-kms.c
|
||||
index 13709f1..9efba75 100644
|
||||
--- a/src/backends/native/meta-monitor-manager-kms.c
|
||||
+++ b/src/backends/native/meta-monitor-manager-kms.c
|
||||
@@ -512,11 +512,8 @@ meta_monitor_manager_kms_read_current (MetaMonitorManager *manager)
|
||||
find_properties (manager_kms, output_kms);
|
||||
|
||||
edid = read_output_edid (manager_kms, meta_output);
|
||||
- if (edid)
|
||||
- {
|
||||
- meta_output_parse_edid (meta_output, edid);
|
||||
- g_bytes_unref (edid);
|
||||
- }
|
||||
+ meta_output_parse_edid (meta_output, edid);
|
||||
+ g_bytes_unref (edid);
|
||||
|
||||
/* MetaConnectorType matches DRM's connector types */
|
||||
meta_output->connector_type = (MetaConnectorType) connector->connector_type;
|
||||
diff --git a/src/backends/x11/meta-monitor-manager-xrandr.c b/src/backends/x11/meta-monitor-manager-xrandr.c
|
||||
index 03b4152..d950592 100644
|
||||
--- a/src/backends/x11/meta-monitor-manager-xrandr.c
|
||||
+++ b/src/backends/x11/meta-monitor-manager-xrandr.c
|
||||
@@ -693,11 +693,8 @@ meta_monitor_manager_xrandr_read_current (MetaMonitorManager *manager)
|
||||
meta_output->name = g_strdup (output->name);
|
||||
|
||||
edid = read_output_edid (manager_xrandr, meta_output->winsys_id);
|
||||
- if (edid)
|
||||
- {
|
||||
- meta_output_parse_edid (meta_output, edid);
|
||||
- g_bytes_unref (edid);
|
||||
- }
|
||||
+ meta_output_parse_edid (meta_output, edid);
|
||||
+ g_bytes_unref (edid);
|
||||
|
||||
meta_output->width_mm = output->mm_width;
|
||||
meta_output->height_mm = output->mm_height;
|
||||
--
|
||||
2.2.2
|
||||
|
@ -1,75 +0,0 @@
|
||||
From 1b1eda59a46665cc61ec66e1ab8cc2aaed006215 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Fri, 19 Dec 2014 13:51:54 +0100
|
||||
Subject: [PATCH 1/2] Revert "wayland: Upgrade to v2 of data-device"
|
||||
|
||||
This reverts commit b832bc7424d7d14a9a43334476e7dd17122f22f0.
|
||||
---
|
||||
src/wayland/meta-wayland-data-device.c | 7 -------
|
||||
src/wayland/meta-wayland-versions.h | 2 +-
|
||||
2 files changed, 1 insertion(+), 8 deletions(-)
|
||||
|
||||
diff --git a/src/wayland/meta-wayland-data-device.c b/src/wayland/meta-wayland-data-device.c
|
||||
index 36675a5..a726cd2 100644
|
||||
--- a/src/wayland/meta-wayland-data-device.c
|
||||
+++ b/src/wayland/meta-wayland-data-device.c
|
||||
@@ -547,16 +547,9 @@ data_device_set_selection (struct wl_client *client,
|
||||
meta_wayland_data_device_set_selection (data_device, source, serial);
|
||||
}
|
||||
|
||||
-static void
|
||||
-data_device_release(struct wl_client *client, struct wl_resource *resource)
|
||||
-{
|
||||
- wl_resource_destroy(resource);
|
||||
-}
|
||||
-
|
||||
static const struct wl_data_device_interface data_device_interface = {
|
||||
data_device_start_drag,
|
||||
data_device_set_selection,
|
||||
- data_device_release,
|
||||
};
|
||||
|
||||
static void
|
||||
diff --git a/src/wayland/meta-wayland-versions.h b/src/wayland/meta-wayland-versions.h
|
||||
index 3944956..e6ba794 100644
|
||||
--- a/src/wayland/meta-wayland-versions.h
|
||||
+++ b/src/wayland/meta-wayland-versions.h
|
||||
@@ -36,7 +36,7 @@
|
||||
|
||||
/* Global/master objects (version exported by wl_registry and negotiated through bind) */
|
||||
#define META_WL_COMPOSITOR_VERSION 3
|
||||
-#define META_WL_DATA_DEVICE_MANAGER_VERSION 2
|
||||
+#define META_WL_DATA_DEVICE_MANAGER_VERSION 1
|
||||
#define META_XDG_SHELL_VERSION 1
|
||||
#define META_WL_SHELL_VERSION 1
|
||||
#define META_WL_SEAT_VERSION 4
|
||||
--
|
||||
2.1.0
|
||||
|
||||
|
||||
From e3b247435f809d91e58169c8dec61109d68a5d0f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Fri, 19 Dec 2014 13:52:16 +0100
|
||||
Subject: [PATCH 2/2] Revert "build: Require wayland-server >= 1.6.90"
|
||||
|
||||
This reverts commit e73f5cc8ab97050ae140a478310f92955bd76212.
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index a3724d9..65dc031 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -215,7 +215,7 @@ AS_IF([test "$have_native_backend" = "yes"], [
|
||||
])
|
||||
AM_CONDITIONAL([HAVE_NATIVE_BACKEND],[test "$have_native_backend" = "yes"])
|
||||
|
||||
-MUTTER_WAYLAND_MODULES="clutter-wayland-1.0 clutter-wayland-compositor-1.0 wayland-server >= 1.6.90"
|
||||
+MUTTER_WAYLAND_MODULES="clutter-wayland-1.0 clutter-wayland-compositor-1.0 wayland-server >= 1.5.90"
|
||||
|
||||
AC_ARG_ENABLE(wayland,
|
||||
AS_HELP_STRING([--disable-wayland], [disable mutter on wayland support]),,
|
||||
--
|
||||
2.1.0
|
||||
|
13
mutter.spec
13
mutter.spec
@ -1,8 +1,8 @@
|
||||
%global clutter_version 1.19.6-3
|
||||
|
||||
Name: mutter
|
||||
Version: 3.15.4
|
||||
Release: 2%{?dist}
|
||||
Version: 3.15.90
|
||||
Release: 1%{?dist}
|
||||
Summary: Window and compositing manager based on Clutter
|
||||
|
||||
Group: User Interface/Desktops
|
||||
@ -11,10 +11,6 @@ License: GPLv2+
|
||||
URL: http://www.gnome.org
|
||||
Source0: http://download.gnome.org/sources/%{name}/3.15/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch0: dont-depend-on-unreleased-wayland.patch
|
||||
# Backport ad90b7dd to fix BGO #743412 / RHBZ #1185811
|
||||
Patch1: 0001-monitor-manager-Initialize-MetaOutput-even-when-we-c.patch
|
||||
|
||||
BuildRequires: clutter-devel >= %{clutter_version}
|
||||
BuildRequires: pango-devel
|
||||
BuildRequires: startup-notification-devel
|
||||
@ -96,8 +92,6 @@ the functionality of the installed %{name} package.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .dont-depend-on-unreleased-wayland
|
||||
%patch1 -p1 -b .metaoutput-initialize
|
||||
|
||||
%build
|
||||
autoreconf -f -i
|
||||
@ -168,6 +162,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
%{_datadir}/mutter/tests
|
||||
|
||||
%changelog
|
||||
* Fri Feb 20 2015 Florian Müllner <fmuellner@redhat.com> - 3.15.90-1
|
||||
- Update to 3.15.90
|
||||
|
||||
* Mon Feb 02 2015 Adam Williamson <awilliam@redhat.com> - 3.15.4-2
|
||||
- backport ad90b7dd to fix BGO #743412 / RHBZ #1185811
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user