Update to 3.18.0
This commit is contained in:
parent
3edaab2dd1
commit
4aabf56bfc
1
.gitignore
vendored
1
.gitignore
vendored
@ -96,3 +96,4 @@ mutter-2.31.5.tar.bz2
|
||||
/mutter-3.17.90.tar.xz
|
||||
/mutter-3.17.91.tar.xz
|
||||
/mutter-3.17.92.tar.xz
|
||||
/mutter-3.18.0.tar.xz
|
||||
|
@ -1,27 +0,0 @@
|
||||
From dc780d2c4450385a2fba4df34be62e0bfc838c72 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
|
||||
Date: Wed, 16 Sep 2015 17:38:10 +0200
|
||||
Subject: [PATCH] launcher: Don't pass variable as format string
|
||||
|
||||
We know the variable only contains one or another string literal,
|
||||
but keep compilers happy as well.
|
||||
---
|
||||
src/backends/native/meta-launcher.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/backends/native/meta-launcher.c b/src/backends/native/meta-launcher.c
|
||||
index 5ceeda7..6fc4505 100644
|
||||
--- a/src/backends/native/meta-launcher.c
|
||||
+++ b/src/backends/native/meta-launcher.c
|
||||
@@ -63,7 +63,7 @@ report_error_and_die (const char *prefix,
|
||||
if (error)
|
||||
g_error ("%s: %s", prefix, error->message);
|
||||
else
|
||||
- g_error (prefix);
|
||||
+ g_error ("%s", prefix);
|
||||
|
||||
/* the error is not freed, but it is ok as g_error aborts the process */
|
||||
}
|
||||
--
|
||||
2.5.0
|
||||
|
10
mutter.spec
10
mutter.spec
@ -2,7 +2,7 @@
|
||||
%global gsettings_desktop_schemas_version 3.15.92
|
||||
|
||||
Name: mutter
|
||||
Version: 3.17.92
|
||||
Version: 3.18.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Window and compositing manager based on Clutter
|
||||
|
||||
@ -10,9 +10,7 @@ Group: User Interface/Desktops
|
||||
License: GPLv2+
|
||||
#VCS: git:git://git.gnome.org/mutter
|
||||
URL: http://www.gnome.org
|
||||
Source0: http://download.gnome.org/sources/%{name}/3.17/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch1: 0001-launcher-Don-t-pass-variable-as-format-string.patch
|
||||
Source0: http://download.gnome.org/sources/%{name}/3.18/%{name}-%{version}.tar.xz
|
||||
|
||||
BuildRequires: clutter-devel >= %{clutter_version}
|
||||
BuildRequires: pango-devel
|
||||
@ -96,7 +94,6 @@ the functionality of the installed %{name} package.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b fix-compiler-warning
|
||||
|
||||
%build
|
||||
autoreconf -f -i
|
||||
@ -167,6 +164,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
%{_datadir}/mutter/tests
|
||||
|
||||
%changelog
|
||||
* Mon Sep 21 2015 Florian Müllner <fmuellner@redhat.com> - 3.18.0-1
|
||||
- Update to 3.18.0
|
||||
|
||||
* Wed Sep 16 2015 Florian Müllner <fmuellner@redhat.com> - 3.17.92-1
|
||||
- Update to 3.17.92
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user