Update to 3.14.1
This commit is contained in:
parent
c529da39ea
commit
455aae9423
1
.gitignore
vendored
1
.gitignore
vendored
@ -78,3 +78,4 @@ mutter-2.31.5.tar.bz2
|
||||
/mutter-3.13.91.tar.xz
|
||||
/mutter-3.13.92.tar.xz
|
||||
/mutter-3.14.0.tar.xz
|
||||
/mutter-3.14.1.tar.xz
|
||||
|
@ -1,44 +0,0 @@
|
||||
From d3111a9f07d3741501fb3a85cf3716c2cb362b27 Mon Sep 17 00:00:00 2001
|
||||
From: "Owen W. Taylor" <otaylor@fishsoup.net>
|
||||
Date: Wed, 24 Sep 2014 16:16:27 -0400
|
||||
Subject: [PATCH 01/27] Fix stacking of the guard window
|
||||
|
||||
With the change to how hidden windows are stacked, the position
|
||||
of the guard window with respect to the hidden windows got flipped
|
||||
and the guard window was at the bottom of everything; fix it to
|
||||
be on top of the hidden windows.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=737233
|
||||
---
|
||||
src/core/stack.c | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/core/stack.c b/src/core/stack.c
|
||||
index 15ea826..037e878 100644
|
||||
--- a/src/core/stack.c
|
||||
+++ b/src/core/stack.c
|
||||
@@ -1056,10 +1056,6 @@ stack_sync_to_xserver (MetaStack *stack)
|
||||
all_root_children_stacked = g_array_new (FALSE, FALSE, sizeof (guint64));
|
||||
x11_hidden_stack_ids = g_array_new (FALSE, FALSE, sizeof (guint64));
|
||||
|
||||
- /* The screen guard window sits above all hidden windows and acts as
|
||||
- * a barrier to input reaching these windows. */
|
||||
- g_array_append_val (x11_hidden_stack_ids, stack->screen->guard_window);
|
||||
-
|
||||
meta_topic (META_DEBUG_STACK, "Top to bottom: ");
|
||||
meta_push_no_msg_prefix ();
|
||||
|
||||
@@ -1107,6 +1103,10 @@ stack_sync_to_xserver (MetaStack *stack)
|
||||
meta_topic (META_DEBUG_STACK, "\n");
|
||||
meta_pop_no_msg_prefix ();
|
||||
|
||||
+ /* The screen guard window sits above all hidden windows and acts as
|
||||
+ * a barrier to input reaching these windows. */
|
||||
+ g_array_append_val (x11_hidden_stack_ids, stack->screen->guard_window);
|
||||
+
|
||||
/* Sync to server */
|
||||
|
||||
meta_topic (META_DEBUG_STACK, "Restacking %u windows\n",
|
||||
--
|
||||
2.1.0
|
||||
|
14
mutter.spec
14
mutter.spec
@ -1,8 +1,8 @@
|
||||
%global clutter_version 1.19.6-3
|
||||
|
||||
Name: mutter
|
||||
Version: 3.14.0
|
||||
Release: 3%{?dist}
|
||||
Version: 3.14.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Window and compositing manager based on Clutter
|
||||
|
||||
Group: User Interface/Desktops
|
||||
@ -11,10 +11,6 @@ License: GPLv2+
|
||||
URL: http://www.gnome.org
|
||||
Source0: http://download.gnome.org/sources/%{name}/3.14/%{name}-%{version}.tar.xz
|
||||
|
||||
# Backport fix for BGO #737233 / RHBZ #1145952
|
||||
# Will be fixed in 3.14.1, drop at that point - adamw 2014/10
|
||||
Patch0: 0001-Fix-stacking-of-the-guard-window.patch
|
||||
|
||||
BuildRequires: clutter-devel >= %{clutter_version}
|
||||
BuildRequires: pango-devel
|
||||
BuildRequires: startup-notification-devel
|
||||
@ -48,7 +44,7 @@ Obsoletes: mutter-wayland-devel < 3.13.0
|
||||
|
||||
# Make sure yum updates gnome-shell as well; otherwise we might end up with
|
||||
# broken gnome-shell installations due to mutter ABI changes.
|
||||
Conflicts: gnome-shell < 3.14.0
|
||||
Conflicts: gnome-shell < 3.14.1
|
||||
|
||||
Requires: clutter%{?_isa} >= %{clutter_version}
|
||||
Requires: control-center-filesystem
|
||||
@ -79,7 +75,6 @@ utilities for testing Metacity/Mutter themes.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .stacking
|
||||
|
||||
%build
|
||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi;
|
||||
@ -144,6 +139,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
%exclude %{_datadir}/gtk-doc
|
||||
|
||||
%changelog
|
||||
* Tue Oct 14 2014 Florian Müllner <fmuellner@redhat.com> - 3.14.1-1
|
||||
- Update to 3.14.1
|
||||
|
||||
* Fri Oct 03 2014 Adam Williamson <awilliam@redhat.com> - 3.14.0-3
|
||||
- backport fix for BGO #737233 / RHBZ #1145952 (desktop right click broken)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user