Update to 42.alpha
This commit is contained in:
parent
92e4457ef8
commit
17a871bfa3
1
.gitignore
vendored
1
.gitignore
vendored
@ -191,3 +191,4 @@ mutter-2.31.5.tar.bz2
|
||||
/mutter-41.beta.tar.xz
|
||||
/mutter-41.rc.tar.xz
|
||||
/mutter-41.0.tar.xz
|
||||
/mutter-42.alpha.tar.xz
|
||||
|
@ -1,35 +0,0 @@
|
||||
From 02d4c01bb9b1b458dcbe10e7be8d2c14df7622da Mon Sep 17 00:00:00 2001
|
||||
From: Adam Williamson <awilliam@redhat.com>
|
||||
Date: Tue, 9 Mar 2021 17:21:59 -0800
|
||||
Subject: [PATCH] Test: deny atomic KMS for "tegra" (RHBZ #1936991)
|
||||
|
||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
||||
---
|
||||
data/61-mutter.rules | 1 +
|
||||
src/backends/native/meta-kms-impl-device-atomic.c | 1 +
|
||||
2 files changed, 2 insertions(+)
|
||||
|
||||
diff --git a/data/61-mutter.rules b/data/61-mutter.rules
|
||||
index edc03e6c1..d8e3c5f00 100644
|
||||
--- a/data/61-mutter.rules
|
||||
+++ b/data/61-mutter.rules
|
||||
@@ -3,3 +3,4 @@ DRIVERS=="nouveau", SUBSYSTEM=="drm", TAG+="mutter-device-disable-kms-modifiers"
|
||||
DRIVERS=="amdgpu", SUBSYSTEM=="drm", TAG+="mutter-device-disable-kms-modifiers"
|
||||
DRIVERS=="radeon", SUBSYSTEM=="drm", TAG+="mutter-device-disable-kms-modifiers"
|
||||
ENV{ID_PATH}=="platform-vkms", TAG+="mutter-device-ignore"
|
||||
+DRIVER=="tegra", SUBSYSTEM=="platform", TAG+="mutter-device-disable-atomic-kms"
|
||||
diff --git a/src/backends/native/meta-kms-impl-device-atomic.c b/src/backends/native/meta-kms-impl-device-atomic.c
|
||||
index 8e41207ee..20b2f8153 100644
|
||||
--- a/src/backends/native/meta-kms-impl-device-atomic.c
|
||||
+++ b/src/backends/native/meta-kms-impl-device-atomic.c
|
||||
@@ -1122,6 +1122,7 @@ is_atomic_allowed (const char *driver_name)
|
||||
"vmwgfx",
|
||||
"vboxvideo",
|
||||
"nvidia-drm",
|
||||
+ "tegra",
|
||||
NULL,
|
||||
};
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,45 +0,0 @@
|
||||
From 3b6f9111c7da3fee82d3ffd19c444155f84d86ea Mon Sep 17 00:00:00 2001
|
||||
From: Carlos Garnacho <carlosg@gnome.org>
|
||||
Date: Tue, 19 Oct 2021 16:53:13 +0200
|
||||
Subject: [PATCH] clutter: Only reset preedit text if set
|
||||
|
||||
On ClutterInputFocus::reset, avoid to unset the preedit text if
|
||||
none was set earlier. This seems to trick GTK clients into focusing
|
||||
the cursor position again, even when we are moving away from it.
|
||||
|
||||
Fixes: https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/4647
|
||||
Part-of: <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/2059>
|
||||
---
|
||||
clutter/clutter/clutter-input-focus.c | 14 ++++++++------
|
||||
1 file changed, 8 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/clutter/clutter/clutter-input-focus.c b/clutter/clutter/clutter-input-focus.c
|
||||
index c22e3a32c0..117bab72ce 100644
|
||||
--- a/clutter/clutter/clutter-input-focus.c
|
||||
+++ b/clutter/clutter/clutter-input-focus.c
|
||||
@@ -103,14 +103,16 @@ clutter_input_focus_reset (ClutterInputFocus *focus)
|
||||
|
||||
priv = clutter_input_focus_get_instance_private (focus);
|
||||
|
||||
- if (priv->preedit &&
|
||||
- priv->mode == CLUTTER_PREEDIT_RESET_COMMIT)
|
||||
- clutter_input_focus_commit (focus, priv->preedit);
|
||||
+ if (priv->preedit)
|
||||
+ {
|
||||
+ if (priv->mode == CLUTTER_PREEDIT_RESET_COMMIT)
|
||||
+ clutter_input_focus_commit (focus, priv->preedit);
|
||||
|
||||
- clutter_input_focus_set_preedit_text (focus, NULL, 0);
|
||||
- g_clear_pointer (&priv->preedit, g_free);
|
||||
- priv->mode = CLUTTER_PREEDIT_RESET_CLEAR;
|
||||
+ clutter_input_focus_set_preedit_text (focus, NULL, 0);
|
||||
+ g_clear_pointer (&priv->preedit, g_free);
|
||||
+ }
|
||||
|
||||
+ priv->mode = CLUTTER_PREEDIT_RESET_CLEAR;
|
||||
clutter_input_method_reset (priv->im);
|
||||
}
|
||||
|
||||
--
|
||||
2.33.0
|
||||
|
@ -1,29 +0,0 @@
|
||||
From 9179d4a4b1708a769d09d0d31d9af5d82240492c Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
|
||||
Date: Tue, 5 Oct 2021 15:17:17 +0200
|
||||
Subject: [PATCH] kms/impl-device/atomic: Add virtio_gpu to deny list
|
||||
|
||||
virtio_gpu is used in virtual machine environments, meaning they need
|
||||
accurate cursor hotspots, which currently needs non-atomic mode setting.
|
||||
|
||||
Related: https://bugzilla.redhat.com/show_bug.cgi?id=2009304
|
||||
Part-of: <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/2040>
|
||||
---
|
||||
src/backends/native/meta-kms-impl-device-atomic.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/backends/native/meta-kms-impl-device-atomic.c b/src/backends/native/meta-kms-impl-device-atomic.c
|
||||
index 674a24902b..e1adf20b3c 100644
|
||||
--- a/src/backends/native/meta-kms-impl-device-atomic.c
|
||||
+++ b/src/backends/native/meta-kms-impl-device-atomic.c
|
||||
@@ -1150,6 +1150,7 @@ is_atomic_allowed (const char *driver_name)
|
||||
"vboxvideo",
|
||||
"nvidia-drm",
|
||||
"tegra",
|
||||
+ "virtio_gpu",
|
||||
NULL,
|
||||
};
|
||||
|
||||
--
|
||||
2.32.0
|
||||
|
41
mutter.spec
41
mutter.spec
@ -4,18 +4,18 @@
|
||||
%global json_glib_version 0.12.0
|
||||
%global libinput_version 1.4
|
||||
%global pipewire_version 0.3.0
|
||||
%global mutter_api_version 9
|
||||
%global mutter_api_version 10
|
||||
|
||||
%global tarball_version %%(echo %{version} | tr '~' '.')
|
||||
|
||||
Name: mutter
|
||||
Version: 41.0
|
||||
Release: 5%{?dist}
|
||||
Version: 42~alpha
|
||||
Release: 1%{?dist}
|
||||
Summary: Window and compositing manager based on Clutter
|
||||
|
||||
License: GPLv2+
|
||||
URL: http://www.gnome.org
|
||||
Source0: http://download.gnome.org/sources/%{name}/41/%{name}-%{tarball_version}.tar.xz
|
||||
Source0: http://download.gnome.org/sources/%{name}/42/%{name}-%{tarball_version}.tar.xz
|
||||
|
||||
# Work-around for OpenJDK's compliance test
|
||||
Patch0: 0001-window-actor-Special-case-shaped-Java-windows.patch
|
||||
@ -23,27 +23,9 @@ Patch0: 0001-window-actor-Special-case-shaped-Java-windows.patch
|
||||
# To make s390x build pass
|
||||
Patch1: 0001-Revert-build-Do-not-provide-built-sources-as-libmutt.patch
|
||||
|
||||
# Workaround for RHBZ#1936991 (blocks atomic KMS on "tegra" driver)
|
||||
Patch2: 0001-Test-deny-atomic-KMS-for-tegra-RHBZ-1936991.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1936991
|
||||
Patch2: mutter-42.alpha-disable-tegra.patch
|
||||
|
||||
# Block atomic mode setting on virtio to fix cursor offset
|
||||
# manually re-diffed on top of "tegra" patch above
|
||||
# https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/2040
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2009304
|
||||
Patch3: 0001-kms-impl-device-atomic-Add-virtio_gpu-to-deny-list.patch
|
||||
|
||||
# Only reset preedit text if set
|
||||
# Fixes cursor jumping around like a demented bunny in text editors
|
||||
# https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/4647
|
||||
# https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/2059
|
||||
Patch4: 0001-clutter-Only-reset-preedit-text-if-set.patch
|
||||
|
||||
BuildRequires: pango-devel
|
||||
BuildRequires: startup-notification-devel
|
||||
BuildRequires: gnome-desktop3-devel
|
||||
BuildRequires: glib2-devel >= %{glib_version}
|
||||
BuildRequires: gtk3-devel >= %{gtk3_version}
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: gobject-introspection-devel >= 1.41.0
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libwacom-devel
|
||||
@ -84,14 +66,16 @@ BuildRequires: libcanberra-devel
|
||||
BuildRequires: gsettings-desktop-schemas-devel >= %{gsettings_desktop_schemas_version}
|
||||
BuildRequires: gnome-settings-daemon-devel
|
||||
BuildRequires: meson
|
||||
BuildRequires: pkgconfig(gbm)
|
||||
BuildRequires: pkgconfig(gnome-desktop-3.0)
|
||||
BuildRequires: pkgconfig(gudev-1.0)
|
||||
BuildRequires: pkgconfig(libdrm)
|
||||
BuildRequires: pkgconfig(gbm)
|
||||
BuildRequires: pkgconfig(wayland-server)
|
||||
BuildRequires: pkgconfig(libstartup-notification-1.0)
|
||||
BuildRequires: pkgconfig(wayland-eglstream)
|
||||
BuildRequires: pkgconfig(wayland-protocols)
|
||||
BuildRequires: pkgconfig(wayland-server)
|
||||
|
||||
BuildRequires: json-glib-devel >= %{json_glib_version}
|
||||
BuildRequires: libgudev1-devel
|
||||
BuildRequires: libinput-devel >= %{libinput_version}
|
||||
BuildRequires: pkgconfig(xwayland)
|
||||
|
||||
@ -186,6 +170,9 @@ desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
|
||||
%{_datadir}/mutter-%{mutter_api_version}/tests
|
||||
|
||||
%changelog
|
||||
* Fri Jan 14 2022 David King <amigadave@amigadave.com> - 42~alpha-1
|
||||
- Update to 42~alpha
|
||||
|
||||
* Mon Dec 13 2021 Peter Hutterer <peter.hutterer@redhat.com> - 41.0-5
|
||||
- Rebuild for libwacom soname bump
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mutter-41.0.tar.xz) = ad1b19cc05d434610657ab1d4f8d060dbd4584feba410da0c18fc9232082d6abee8d5c3c3243b12a47019779da3fe3f13b172b992d85de552cef696952cf65a3
|
||||
SHA512 (mutter-42.alpha.tar.xz) = 577ab2671358985fd32988c38a4571c971926352fd06175803e9500bae488eecca33ec8ca81574b74d0646d1c8d047f3175402eedc0eac8de0b65c6a66b3870c
|
||||
|
Loading…
Reference in New Issue
Block a user