Update to 3.23.1
This commit is contained in:
parent
7d014dec44
commit
08a004c1f1
1
.gitignore
vendored
1
.gitignore
vendored
@ -116,3 +116,4 @@ mutter-2.31.5.tar.bz2
|
|||||||
/mutter-3.21.92.tar.xz
|
/mutter-3.21.92.tar.xz
|
||||||
/mutter-3.22.0.tar.xz
|
/mutter-3.22.0.tar.xz
|
||||||
/mutter-3.22.1.tar.xz
|
/mutter-3.22.1.tar.xz
|
||||||
|
/mutter-3.23.1.tar.xz
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From 5ec5e294226ef8ef47af1b56b4c0c349aea7d607 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rui Matos <tiagomatos@gmail.com>
|
|
||||||
Date: Wed, 21 Sep 2016 15:06:08 +0200
|
|
||||||
Subject: [PATCH] clutter/stage: Fix framebuffer capture origin offset (again)
|
|
||||||
|
|
||||||
Commit 5fbb4793017b1891f0de4720a9793e8cfc1c8483 was wrong too. What we
|
|
||||||
really want to do here is getting view relative coordinates given the
|
|
||||||
view's and the rectangle's global coordinates so we need to subtract
|
|
||||||
the view's origin from the rectangle's.
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=771502
|
|
||||||
---
|
|
||||||
clutter/clutter/clutter-stage.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/clutter/clutter/clutter-stage.c b/clutter/clutter/clutter-stage.c
|
|
||||||
index 1d2c0bc..21968b9 100644
|
|
||||||
--- a/clutter/clutter/clutter-stage.c
|
|
||||||
+++ b/clutter/clutter/clutter-stage.c
|
|
||||||
@@ -4712,8 +4712,8 @@ capture_view (ClutterStage *stage,
|
|
||||||
clutter_stage_view_get_layout (view, &view_layout);
|
|
||||||
|
|
||||||
cogl_framebuffer_read_pixels_into_bitmap (framebuffer,
|
|
||||||
- view_layout.x + rect->x,
|
|
||||||
- view_layout.y + rect->y,
|
|
||||||
+ rect->x - view_layout.x,
|
|
||||||
+ rect->y - view_layout.y,
|
|
||||||
COGL_READ_PIXELS_COLOR_BUFFER,
|
|
||||||
bitmap);
|
|
||||||
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
12
mutter.spec
12
mutter.spec
@ -4,19 +4,17 @@
|
|||||||
%global libinput_version 1.4
|
%global libinput_version 1.4
|
||||||
|
|
||||||
Name: mutter
|
Name: mutter
|
||||||
Version: 3.22.1
|
Version: 3.23.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Window and compositing manager based on Clutter
|
Summary: Window and compositing manager based on Clutter
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
#VCS: git:git://git.gnome.org/mutter
|
#VCS: git:git://git.gnome.org/mutter
|
||||||
URL: http://www.gnome.org
|
URL: http://www.gnome.org
|
||||||
Source0: http://download.gnome.org/sources/%{name}/3.22/%{name}-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/%{name}/3.23/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=772422
|
# https://bugzilla.gnome.org/show_bug.cgi?id=772422
|
||||||
Patch0: 0001-Use-eglGetPlatformDisplay.patch
|
Patch0: 0001-Use-eglGetPlatformDisplay.patch
|
||||||
# Backported from upstream
|
|
||||||
Patch1: 0001-clutter-stage-Fix-framebuffer-capture-origin-offset-.patch
|
|
||||||
|
|
||||||
BuildRequires: chrpath
|
BuildRequires: chrpath
|
||||||
BuildRequires: pango-devel
|
BuildRequires: pango-devel
|
||||||
@ -109,7 +107,6 @@ the functionality of the installed %{name} package.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf -f -i
|
autoreconf -f -i
|
||||||
@ -184,6 +181,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
|||||||
%{_datadir}/mutter/tests
|
%{_datadir}/mutter/tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Oct 30 2016 Florian Müllner <fmuellner@redhat.com> - 3.23.1-1
|
||||||
|
- Update to 3.23.1
|
||||||
|
|
||||||
* Tue Oct 18 2016 Kalev Lember <klember@redhat.com> - 3.22.1-3
|
* Tue Oct 18 2016 Kalev Lember <klember@redhat.com> - 3.22.1-3
|
||||||
- Backport a fix to make gnome-screenshot --area work
|
- Backport a fix to make gnome-screenshot --area work
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user