Update to 3.27.1

This commit is contained in:
Florian Müllner 2017-10-17 18:08:53 +02:00
parent be7688cdb9
commit 0339df666b
4 changed files with 8 additions and 73 deletions

1
.gitignore vendored
View File

@ -132,3 +132,4 @@ mutter-2.31.5.tar.bz2
/mutter-3.25.92.tar.xz
/mutter-3.26.0.tar.xz
/mutter-3.26.1.tar.xz
/mutter-3.27.1.tar.xz

View File

@ -1,67 +0,0 @@
From 18c41aefc982864225ea993a0d0213e22e07e62e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Thu, 5 Oct 2017 21:38:25 +0200
Subject: [PATCH 1/2] build: Fetch pipewire micro version
Pipewire doesn't export its version defines, so the API checks added
in commit f0c6c4eb1fa2b21e38 effectively disable screencasting, whoops.
Breaking changes like this should disappear once the library stabilizes,
so simply define the version ourselves instead of writing a "proper"
test with AC_COMPILE_IFELSE() ...
https://bugzilla.gnome.org/show_bug.cgi?id=788572
---
configure.ac | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/configure.ac b/configure.ac
index 89c15e23b..a5870e6ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -245,6 +245,10 @@ AC_ARG_ENABLE(remote-desktop,
)
AS_IF([test "$enable_remote_desktop" = "yes"], [
MUTTER_PC_MODULES="$MUTTER_PC_MODULES libpipewire-0.1 >= 0.1.4"
+ PKG_CHECK_EXISTS([libpipewire-0.1], [
+ pw_micro=`$PKG_CONFIG --modversion libpipewire-0.1 | cut -d. -f3`
+ AC_DEFINE_UNQUOTED([PIPEWIRE_VERSION_MICRO],[$pw_micro], [Pipewire micro version used])
+ ])
AC_DEFINE([HAVE_REMOTE_DESKTOP],[1], [Defined if screen cast and remote desktop support is enabled])
])
AM_CONDITIONAL([HAVE_REMOTE_DESKTOP],[test "$enable_remote_desktop" = "yes"])
--
2.14.2
From 8185373bd4d23b7090dab6e4507ecad153f07099 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
Date: Thu, 5 Oct 2017 14:16:35 -0400
Subject: [PATCH 2/2] screen-cast-stream-src: Only clean up pipewire
remote/core if they exist
They can could fail to create, so lets deal better with that
possibility.
https://bugzilla.gnome.org/show_bug.cgi?id=788569
---
src/backends/meta-screen-cast-stream-src.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/backends/meta-screen-cast-stream-src.c b/src/backends/meta-screen-cast-stream-src.c
index e6d99d592..0343ea458 100644
--- a/src/backends/meta-screen-cast-stream-src.c
+++ b/src/backends/meta-screen-cast-stream-src.c
@@ -593,8 +593,8 @@ meta_screen_cast_stream_src_finalize (GObject *object)
meta_screen_cast_stream_src_disable (src);
g_clear_pointer (&priv->pipewire_stream, (GDestroyNotify) pw_stream_destroy);
- pw_remote_destroy (priv->pipewire_remote);
- pw_core_destroy (priv->pipewire_core);
+ g_clear_pointer (&priv->pipewire_remote, (GDestroyNotify) pw_remote_destroy);
+ g_clear_pointer (&priv->pipewire_core, (GDestroyNotify) pw_core_destroy);
g_source_destroy (&priv->pipewire_source->base);
G_OBJECT_CLASS (meta_screen_cast_stream_src_parent_class)->finalize (object);
--
2.14.2

View File

@ -6,19 +6,17 @@
%global pipewire_version 0.1.4
Name: mutter
Version: 3.26.1
Release: 2%{?dist}
Version: 3.27.1
Release: 1%{?dist}
Summary: Window and compositing manager based on Clutter
License: GPLv2+
#VCS: git:git://git.gnome.org/mutter
URL: http://www.gnome.org
Source0: http://download.gnome.org/sources/%{name}/3.26/%{name}-%{version}.tar.xz
Source0: http://download.gnome.org/sources/%{name}/3.27/%{name}-%{version}.tar.xz
Patch0: startup-notification.patch
Patch1: fix-screencasts.patch
BuildRequires: chrpath
BuildRequires: pango-devel
BuildRequires: startup-notification-devel
@ -189,6 +187,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
%{_datadir}/mutter/tests
%changelog
* Tue Oct 17 2017 Florian Müllner <fmuellner@redhat.com> - 3.27.1-1
- Update to 3.27.1
* Fri Oct 06 2017 Florian Müllner <fmuellner@redhat.com> - 3.26.1-2
- Fix screencasts

View File

@ -1 +1 @@
SHA512 (mutter-3.26.1.tar.xz) = e638864fddcebcd922637a7a5a17f19815dc9b77bf72568374a81ad1e327c0fb644f546428848aacb39c99b04eba9f651f441b16e21ad880ab1593ee3ba912f4
SHA512 (mutter-3.27.1.tar.xz) = ba7c00bd52c829e745248799b221abc586a674448e29bdfa11865811207b73d21ed38781caa5e27eaa7b611df76e24164e35e5aeec24bd28e4765377d6f69e45