- fix md5 on big-endian systems

This commit is contained in:
Miroslav Lichvar 2007-09-17 12:20:52 +00:00
parent 8b6071858f
commit f40a1571c9
2 changed files with 22 additions and 1 deletions

View File

@ -1144,3 +1144,21 @@ diff -r 4ade2517703a -r 9cfb5ac98e26 imap/auth_cram.c
+ md5_process_bytes (response, MD5_DIGEST_LEN, &ctx);
+ md5_finish_ctx (&ctx, response);
}
# HG changeset patch
# User Emanuele Giaquinta
# Date 1189794927 25200
# Node ID c699e5847630f6c9a2207d87d7f933a06b9d9e87
# Parent 154417d57b9da5e488108887b3061a5322de8dbd
The new MD5 code needs AC_C_BIGENDIAN on big-endian systems
diff -r 154417d57b9d -r c699e5847630 configure.ac
--- a/configure.ac Thu Sep 13 09:39:47 2007 -0700
+++ b/configure.ac Fri Sep 14 11:35:27 2007 -0700
@@ -39,6 +39,7 @@ AC_CHECK_TOOL(AR, ar, ar)
AC_C_INLINE
AC_C_CONST
+AC_C_BIGENDIAN
AC_SYS_LARGEFILE
AC_FUNC_FSEEKO

View File

@ -1,7 +1,7 @@
Summary: A text mode mail user agent
Name: mutt
Version: 1.5.16
Release: 3%{?dist}
Release: 4%{?dist}
Epoch: 5
# The entire source code is GPLv2+ except
# pgpewrap.c setenv.c sha1.c wcwidth.c which are Public Domain
@ -101,6 +101,9 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man5/muttrc.*
%changelog
* Mon Sep 17 2007 Miroslav Lichvar <mlichvar@redhat.com> 5:1.5.16-4
- fix md5 on big-endian systems
* Tue Aug 28 2007 Miroslav Lichvar <mlichvar@redhat.com> 5:1.5.16-3
- replace md5 implementation
- update license tag