Disable dotlock by patch instead of sed

Resolves: #1568597
This commit is contained in:
Matej Muzila 2018-04-18 17:44:28 +02:00
parent 47160096a5
commit f1628ed761
2 changed files with 29 additions and 3 deletions

View File

@ -0,0 +1,22 @@
diff -up mutt-1.9.5/configure.ac.nodotlock mutt-1.9.5/configure.ac
--- mutt-1.9.5/configure.ac.nodotlock 2018-04-18 17:30:32.856796564 +0200
+++ mutt-1.9.5/configure.ac 2018-04-18 17:33:07.047923724 +0200
@@ -524,9 +524,7 @@ int main (int argc, char **argv)
}]])],[mutt_cv_worldwrite=yes],[mutt_cv_worldwrite=no],[mutt_cv_worldwrite=no])])
mutt_cv_setgid=no
- if test $mutt_cv_worldwrite = yes; then
- AC_DEFINE(USE_DOTLOCK,1,[ Define to use dotlocking for mailboxes. ])
- else
+ if test $mutt_cv_worldwrite != yes; then
AC_CACHE_CHECK(if $mutt_cv_mailpath is group writable, mutt_cv_groupwrite, [AC_RUN_IFELSE([AC_LANG_SOURCE([[#include <sys/types.h>
#include <sys/stat.h>
@@ -542,7 +540,6 @@ int main (int argc, char **argv)
}]])],[mutt_cv_groupwrite=yes],[mutt_cv_groupwrite=no],[mutt_cv_groupwrite=no])])
if test $mutt_cv_groupwrite = yes; then
- AC_DEFINE(USE_DOTLOCK,1,[ Define to use dotlocking for mailboxes. ])
AC_DEFINE(USE_SETGID,1,[ Define if mutt should run setgid "mail". ])
mutt_cv_setgid=yes
fi

View File

@ -20,7 +20,7 @@
Summary: A text mode mail user agent
Name: mutt
Version: 1.9.5
Release: 3%{?dist}
Release: 4%{?dist}
Epoch: 5
# The entire source code is GPLv2+ except
# pgpewrap.c setenv.c sha1.c wcwidth.c which are Public Domain
@ -38,6 +38,7 @@ Patch8: mutt-1.5.23-system_certs.patch
Patch9: mutt-1.9.0-ssl_ciphers.patch
Patch10: mutt-1.9.4-lynx_no_backscapes.patch
Patch11: mutt-1.9.5-add_libidn2_support.patch
Patch12: mutt-1.9.5-nodotlock.patch
Url: http://www.mutt.org
Requires: mailcap, urlview
BuildRequires: ncurses-devel, gettext, automake
@ -84,6 +85,7 @@ sed -i -r 's|install-exec-hook|my-useless-label|' Makefile.am
%patch10 -p1 -b .lynx_no_backscapes
%patch11 -p1 -b .add_libidn2_support
%patch12 -p1 -b .nodotlock
autoreconf --install
%patch1 -p1 -b .muttrc
@ -93,8 +95,6 @@ autoreconf --install
%patch9 -p1 -b .ssl_ciphers
sed -i -r 's/`$GPGME_CONFIG --libs`/"\0 -lgpg-error"/' configure
# disable mutt_dotlock program - remove support from mutt binary
sed -i -r 's|^(.*USE_DOTLOCK.*)$|//\1|' configure
install -p -m644 %{SOURCE1} mutt_ldap_query
@ -207,6 +207,10 @@ ln -sf ./muttrc.5 %{buildroot}%{_mandir}/man5/muttrc.local.5
%changelog
* Thu Apr 19 2018 Matej Mužila <mmuzila@redhat.com> - 5:1.9.5-4
- Disable dotlock by patch instead of sed
- Resolves: #1568597
* Wed Apr 18 2018 Matej Mužila <mmuzila@redhat.com> - 5:1.9.5-3
- Apply patches of autoreconf related configuration files before running
autoreconf