Update to 1.7.0 and enable the sidebar
This commit is contained in:
parent
6ed884c893
commit
e67474fe80
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@ mutt-1.5.23.tar.gz
|
||||
/mutt-1.6.0.tar.gz
|
||||
/mutt-1.6.1.tar.gz
|
||||
/mutt-1.6.2.tar.gz
|
||||
/mutt-1.7.0.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -ur mutt-1.6.0-orig/imap/imap.c mutt-1.6.0/imap/imap.c
|
||||
--- mutt-1.6.0-orig/imap/imap.c 2016-04-02 19:12:22.000000000 +0100
|
||||
+++ mutt-1.6.0/imap/imap.c 2016-04-18 14:08:01.016584276 +0100
|
||||
@@ -1125,7 +1125,7 @@
|
||||
if (!idata->ctx)
|
||||
return -1;
|
||||
|
||||
- if (!mutt_bit_isset (idata->ctx->rights, right))
|
||||
+ if (!idata->ctx || !mutt_bit_isset (idata->ctx->rights, right))
|
||||
return 0;
|
||||
|
||||
if (right == M_ACL_WRITE && !imap_has_flag (idata->flags, name))
|
12
mutt-1.7.0-syncdebug.patch
Normal file
12
mutt-1.7.0-syncdebug.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ur mutt-1.7.0-orig/imap/imap.c mutt-1.7.0/imap/imap.c
|
||||
--- mutt-1.7.0-orig/imap/imap.c 2016-08-20 11:06:26.266272415 +0100
|
||||
+++ mutt-1.7.0/imap/imap.c 2016-08-20 11:07:42.874509429 +0100
|
||||
@@ -1143,7 +1143,7 @@
|
||||
if (!idata->ctx)
|
||||
return -1;
|
||||
|
||||
- if (!mutt_bit_isset (idata->ctx->rights, right))
|
||||
+ if (!idata->ctx || !mutt_bit_isset (idata->ctx->rights, right))
|
||||
return 0;
|
||||
|
||||
if (right == MUTT_ACL_WRITE && !imap_has_flag (idata->flags, name))
|
12
mutt.spec
12
mutt.spec
@ -17,7 +17,7 @@
|
||||
|
||||
Summary: A text mode mail user agent
|
||||
Name: mutt
|
||||
Version: 1.6.2
|
||||
Version: 1.7.0
|
||||
Release: 1%{?dist}
|
||||
Epoch: 5
|
||||
# The entire source code is GPLv2+ except
|
||||
@ -30,7 +30,7 @@ Source1: mutt_ldap_query
|
||||
Patch1: mutt-1.5.18-muttrc.patch
|
||||
Patch2: mutt-1.5.21-cabundle.patch
|
||||
# https://dev.mutt.org/trac/ticket/3569
|
||||
Patch3: mutt-1.6.0-syncdebug.patch
|
||||
Patch3: mutt-1.7.0-syncdebug.patch
|
||||
# FIXME make it to upstream
|
||||
Patch8: mutt-1.5.23-system_certs.patch
|
||||
Patch9: mutt-1.5.23-ssl_ciphers.patch
|
||||
@ -129,6 +129,7 @@ rm -f mutt_ssl.c
|
||||
\
|
||||
%{!?with_idn: --without-idn} \
|
||||
%{?with_gpgme: --enable-gpgme} \
|
||||
--enable-sidebar \
|
||||
--with-docdir=%{_pkgdocdir}
|
||||
|
||||
make %{?_smp_mflags}
|
||||
@ -192,13 +193,16 @@ ln -sf ./muttrc.5 $RPM_BUILD_ROOT%{_mandir}/man5/muttrc.local.5
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Aug 20 2016 Fabio Alessandro Locati <fale@redhat.com> - 5:1.7.0-1
|
||||
- Upgrade to 1.7.0
|
||||
|
||||
* Thu Jul 07 2016 Jon Ciesla <limburgher@gmail.com> - 5:1.6.2-1
|
||||
- Upgrade to 1.6.2
|
||||
|
||||
* Mon May 02 2016 Fabio Alessandro Locati <fabio@locati.cc> - 5:1.6.1-1
|
||||
* Mon May 02 2016 Fabio Alessandro Locati <fale@redhat.com> - 5:1.6.1-1
|
||||
- Upgrade to 1.6.1
|
||||
|
||||
* Mon Apr 18 2016 Fabio Alessandro Locati <fabio@locati.cc> - 5:1.6.0-1
|
||||
* Mon Apr 18 2016 Fabio Alessandro Locati <fale@redhat.com> - 5:1.6.0-1
|
||||
- Upgrade to 1.6.0
|
||||
- Drop patch domainname since it should not be needed any more
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user