Fix C99 compatibility issue
Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
This commit is contained in:
parent
dd9a544e07
commit
e3bef1eb91
24
mutt-configure-c99.patch
Normal file
24
mutt-configure-c99.patch
Normal file
@ -0,0 +1,24 @@
|
||||
The standard iconv function uses char ** even for its input
|
||||
argument. With a const char ** argument, ICONV_NONTRANS is incorrectly
|
||||
set to 1 if the compiler produces an error for such incompatible
|
||||
pointer types.
|
||||
|
||||
Submitted upstream: <https://gitlab.com/muttmua/mutt/-/merge_requests/175>
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 9fe461df2a5af3a8..443da363081343c5 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1322,10 +1322,10 @@ AC_CACHE_CHECK([whether iconv is non-transcribing], mutt_cv_iconv_nontrans,
|
||||
int main()
|
||||
{
|
||||
iconv_t cd;
|
||||
- const char *ib;
|
||||
+ char *ib;
|
||||
char *ob;
|
||||
size_t ibl, obl;
|
||||
- const char *s = "\304\211";
|
||||
+ char *s = (char *) "\304\211";
|
||||
changequote(, )dnl
|
||||
char t[3];
|
||||
changequote([, ])dnl
|
@ -20,7 +20,7 @@
|
||||
Summary: A text mode mail user agent
|
||||
Name: mutt
|
||||
Version: 2.2.12
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Epoch: 5
|
||||
# The entire source code is GPLv2+ except
|
||||
# pgpewrap.c setenv.c sha1.c wcwidth.c which are Public Domain
|
||||
@ -38,6 +38,7 @@ Patch9: mutt-1.9.0-ssl_ciphers.patch
|
||||
Patch10: mutt-1.9.4-lynx_no_backscapes.patch
|
||||
Patch12: mutt-1.9.5-nodotlock.patch
|
||||
Patch13: mutt-1.12.1-optusegpgagent.patch
|
||||
Patch14: mutt-configure-c99.patch
|
||||
|
||||
Url: http://www.mutt.org
|
||||
Requires: mailcap, urlview
|
||||
@ -86,6 +87,7 @@ for selecting groups of messages.
|
||||
|
||||
%patch10 -p1 -b .lynx_no_backscapes
|
||||
%patch12 -p1 -b .nodotlock
|
||||
%patch14 -p1
|
||||
|
||||
autoreconf --install
|
||||
%patch1 -p1 -b .muttrc
|
||||
@ -218,6 +220,9 @@ ln -sf ./muttrc.5 %{buildroot}%{_mandir}/man5/muttrc.local.5
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Dec 7 2023 Florian Weimer <fweimer@redhat.com> - 5:2.2.12-2
|
||||
- Fix C99 compatibility issue
|
||||
|
||||
* Mon Nov 13 2023 Matej Mužila <mmuzila@redhat.com> - 5:2.2.12-1
|
||||
- Upgrade to 2.2.12
|
||||
- Resolves: #2232712
|
||||
|
Loading…
Reference in New Issue
Block a user