- update to 1.5.19
- switch hcache backend to tokyocabinet - drop intr patch
This commit is contained in:
parent
1c3adaf10b
commit
77df92ba60
@ -1 +1 @@
|
||||
mutt-1.5.18.tar.gz
|
||||
mutt-1.5.19.tar.gz
|
||||
|
@ -1,16 +0,0 @@
|
||||
Patch by Robert Scheck <robert@fedoraproject.org> for mutt <= 1.5.18, which
|
||||
adds the ability to link mutt against db <= 4.7 rather the original <= 4.6.
|
||||
This patch was sent upstream and hopefully should be included into the next
|
||||
release of mutt.
|
||||
|
||||
--- mutt-1.5.18/configure 2008-07-12 20:34:15.000000000 +0200
|
||||
+++ mutt-1.5.18/configure.db47 2008-07-12 20:39:52.000000000 +0200
|
||||
@@ -17397,7 +17397,7 @@
|
||||
bdbpfx="$bdbpfx $d/$v"
|
||||
done
|
||||
done
|
||||
- BDB_VERSIONS="db-4 db4 db-4.6 db4.6 db46 db-4.5 db4.5 db45 db-4.4 db4.4 db44 db-4.3 db4.3 db43 db-4.2 db4.2 db42 db-4.1 db4.1 db41 db ''"
|
||||
+ BDB_VERSIONS="db-4 db4 db-4.7 db4.7 db-4.6 db4.6 db46 db-4.5 db4.5 db45 db-4.4 db4.4 db44 db-4.3 db4.3 db43 db-4.2 db4.2 db42 db-4.1 db4.1 db41 db ''"
|
||||
{ $as_echo "$as_me:$LINENO: checking for BerkeleyDB > 4.0" >&5
|
||||
$as_echo_n "checking for BerkeleyDB > 4.0... " >&6; }
|
||||
for d in $bdbpfx; do
|
@ -1,20 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Rocco Rutte <pdmef@gmx.net>
|
||||
# Date 1211437223 25200
|
||||
# Branch HEAD
|
||||
# Node ID bba92e40144004664f0ff20dddc82d253f5a656d
|
||||
# Parent 51c494a2e735c8f6a8338b26d932b54c5d8a9a7d
|
||||
Guard idata->mailbox read in imap_mailbox_state. Closes #3057.
|
||||
|
||||
diff -r 51c494a2e735 -r bba92e401440 imap/browse.c
|
||||
--- a/imap/browse.c Wed May 21 22:59:22 2008 -0700
|
||||
+++ b/imap/browse.c Wed May 21 23:20:23 2008 -0700
|
||||
@@ -228,7 +228,7 @@ int imap_mailbox_state (const char* path
|
||||
return -1;
|
||||
}
|
||||
|
||||
- if (!imap_mxcmp(mx.mbox, idata->mailbox))
|
||||
+ if (idata->ctx && !imap_mxcmp(mx.mbox, idata->mailbox))
|
||||
{
|
||||
state->new = idata->ctx->new;
|
||||
state->messages = idata->ctx->msgcount;
|
@ -1,58 +0,0 @@
|
||||
diff -up mutt-1.5.18/mutt_socket.c.intr mutt-1.5.18/mutt_socket.c
|
||||
--- mutt-1.5.18/mutt_socket.c.intr 2008-01-28 03:20:23.000000000 +0100
|
||||
+++ mutt-1.5.18/mutt_socket.c 2008-05-22 16:49:04.000000000 +0200
|
||||
@@ -75,10 +75,12 @@ int mutt_socket_close (CONNECTION* conn)
|
||||
{
|
||||
int rc = -1;
|
||||
|
||||
+ mutt_allow_interrupt (1);
|
||||
if (conn->fd < 0)
|
||||
dprint (1, (debugfile, "mutt_socket_close: Attempt to close closed connection.\n"));
|
||||
else
|
||||
rc = conn->conn_close (conn);
|
||||
+ mutt_allow_interrupt (0);
|
||||
|
||||
conn->fd = -1;
|
||||
conn->ssf = 0;
|
||||
@@ -96,7 +98,9 @@ int mutt_socket_read (CONNECTION* conn,
|
||||
return -1;
|
||||
}
|
||||
|
||||
+ mutt_allow_interrupt (1);
|
||||
rc = conn->conn_read (conn, buf, len);
|
||||
+ mutt_allow_interrupt (0);
|
||||
/* EOF */
|
||||
if (rc == 0)
|
||||
{
|
||||
@@ -123,14 +127,17 @@ int mutt_socket_write_d (CONNECTION *con
|
||||
|
||||
if (len < 0)
|
||||
len = mutt_strlen (buf);
|
||||
+ mutt_allow_interrupt (1);
|
||||
if ((rc = conn->conn_write (conn, buf, len)) < 0)
|
||||
{
|
||||
+ mutt_allow_interrupt (0);
|
||||
dprint (1, (debugfile,
|
||||
"mutt_socket_write: error writing, closing socket\n"));
|
||||
mutt_socket_close (conn);
|
||||
|
||||
return -1;
|
||||
}
|
||||
+ mutt_allow_interrupt (0);
|
||||
|
||||
if (rc < len)
|
||||
{
|
||||
@@ -161,9 +168,11 @@ int mutt_socket_readchar (CONNECTION *co
|
||||
{
|
||||
if (conn->bufpos >= conn->available)
|
||||
{
|
||||
- if (conn->fd >= 0)
|
||||
+ if (conn->fd >= 0) {
|
||||
+ mutt_allow_interrupt (1);
|
||||
conn->available = conn->conn_read (conn, conn->inbuf, sizeof (conn->inbuf));
|
||||
- else
|
||||
+ mutt_allow_interrupt (0);
|
||||
+ } else
|
||||
{
|
||||
dprint (1, (debugfile, "mutt_socket_readchar: attempt to read from closed connection.\n"));
|
||||
return -1;
|
12
mutt-1.5.19-db47.patch
Normal file
12
mutt-1.5.19-db47.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up mutt-1.5.19/configure.db47 mutt-1.5.19/configure
|
||||
--- mutt-1.5.19/configure.db47 2009-01-06 17:03:22.000000000 +0100
|
||||
+++ mutt-1.5.19/configure 2009-01-06 17:05:19.000000000 +0100
|
||||
@@ -16074,7 +16074,7 @@ echo "$as_me: error: GDBM could not be u
|
||||
bdbpfx="$bdbpfx $d/$v"
|
||||
done
|
||||
done
|
||||
- BDB_VERSIONS="db-4 db4 db-4.6 db4.6 db46 db-4.5 db4.5 db45 db-4.4 db4.4 db44 db-4.3 db4.3 db43 db-4.2 db4.2 db42 db-4.1 db4.1 db41 db ''"
|
||||
+ BDB_VERSIONS="db-4 db4 db-4.7 db4.7 db-4.6 db4.6 db46 db-4.5 db4.5 db45 db-4.4 db4.4 db44 db-4.3 db4.3 db43 db-4.2 db4.2 db42 db-4.1 db4.1 db41 db ''"
|
||||
{ echo "$as_me:$LINENO: checking for BerkeleyDB > 4.0" >&5
|
||||
echo $ECHO_N "checking for BerkeleyDB > 4.0... $ECHO_C" >&6; }
|
||||
for d in $bdbpfx; do
|
20
mutt.spec
20
mutt.spec
@ -7,15 +7,16 @@
|
||||
%bcond_without sasl
|
||||
%bcond_without idn
|
||||
%bcond_without hcache
|
||||
%bcond_without bdb
|
||||
%bcond_without tokyocabinet
|
||||
%bcond_with bdb
|
||||
%bcond_with qdbm
|
||||
%bcond_with gdbm
|
||||
%bcond_with gpgme
|
||||
|
||||
Summary: A text mode mail user agent
|
||||
Name: mutt
|
||||
Version: 1.5.18
|
||||
Release: 4%{?dist}
|
||||
Version: 1.5.19
|
||||
Release: 1%{?dist}
|
||||
Epoch: 5
|
||||
# The entire source code is GPLv2+ except
|
||||
# pgpewrap.c setenv.c sha1.c wcwidth.c which are Public Domain
|
||||
@ -26,9 +27,7 @@ Source1: mutt_ldap_query
|
||||
Patch2: mutt-1.5.13-nodotlock.patch
|
||||
Patch3: mutt-1.5.18-muttrc.patch
|
||||
Patch4: mutt-1.5.18-manual.patch
|
||||
Patch5: mutt-1.5.18-intr.patch
|
||||
Patch6: mutt-1.5.18-imap.patch
|
||||
Patch7: mutt-1.5.18-db47.patch
|
||||
Patch7: mutt-1.5.19-db47.patch
|
||||
Url: http://www.mutt.org/
|
||||
Requires: mailcap urlview
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -39,6 +38,7 @@ BuildRequires: gettext
|
||||
BuildRequires: docbook-style-xsl libxslt lynx
|
||||
|
||||
%if %{with hcache}
|
||||
%{?with_tokyocabinet:BuildRequires: tokyocabinet-devel}
|
||||
%{?with_bdb:BuildRequires: db4-devel}
|
||||
%{?with_qdbm:BuildRequires: qdbm-devel}
|
||||
%{?with_gdbm:BuildRequires: gdbm-devel}
|
||||
@ -66,8 +66,6 @@ for selecting groups of messages.
|
||||
%patch2 -p1 -b .nodl
|
||||
%patch3 -p1 -b .muttrc
|
||||
%patch4 -p1 -b .manual
|
||||
%patch5 -p1 -b .intr
|
||||
%patch6 -p1 -b .imap
|
||||
%patch7 -p1 -b .db47
|
||||
|
||||
install -p -m644 %{SOURCE1} mutt_ldap_query
|
||||
@ -80,6 +78,7 @@ install -p -m644 %{SOURCE1} mutt_ldap_query
|
||||
%{?with_smtp: --enable-smtp} \
|
||||
%if %{with hcache}
|
||||
--enable-hcache \
|
||||
%{!?with_tokyocabinet: --without-tokyocabinet} \
|
||||
%{!?with_gdbm: --without-gdbm} \
|
||||
%{!?with_qdbm: --without-qdbm} \
|
||||
%endif
|
||||
@ -143,6 +142,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man5/muttrc.*
|
||||
|
||||
%changelog
|
||||
* Wed Jan 07 2009 Miroslav Lichvar <mlichvar@redhat.com> 5:1.5.19-1
|
||||
- update to 1.5.19
|
||||
- switch hcache backend to tokyocabinet
|
||||
- drop intr patch
|
||||
|
||||
* Mon Jul 28 2008 Miroslav Lichvar <mlichvar@redhat.com> 5:1.5.18-4
|
||||
- rebuild with db4.7 (Robert Scheck) (#455144)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user