Disable post-install mutt_dotlock checking by patch, not by sed.
This commit is contained in:
parent
756a7c9dd6
commit
67fde24e87
@ -1,7 +1,7 @@
|
||||
diff -up mutt-1.9.5/configure.ac.nodotlock mutt-1.9.5/configure.ac
|
||||
--- mutt-1.9.5/configure.ac.nodotlock 2018-04-18 17:30:32.856796564 +0200
|
||||
+++ mutt-1.9.5/configure.ac 2018-04-18 17:33:07.047923724 +0200
|
||||
@@ -524,9 +524,7 @@ int main (int argc, char **argv)
|
||||
diff -up mutt-1.10.0/configure.ac.nodotlock mutt-1.10.0/configure.ac
|
||||
--- mutt-1.10.0/configure.ac.nodotlock 2018-05-14 23:51:53.000000000 +0200
|
||||
+++ mutt-1.10.0/configure.ac 2018-05-23 15:09:21.186613968 +0200
|
||||
@@ -528,9 +528,7 @@ int main (int argc, char **argv)
|
||||
}]])],[mutt_cv_worldwrite=yes],[mutt_cv_worldwrite=no],[mutt_cv_worldwrite=no])])
|
||||
|
||||
mutt_cv_setgid=no
|
||||
@ -12,7 +12,7 @@ diff -up mutt-1.9.5/configure.ac.nodotlock mutt-1.9.5/configure.ac
|
||||
|
||||
AC_CACHE_CHECK(if $mutt_cv_mailpath is group writable, mutt_cv_groupwrite, [AC_RUN_IFELSE([AC_LANG_SOURCE([[#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
@@ -542,7 +540,6 @@ int main (int argc, char **argv)
|
||||
@@ -546,7 +544,6 @@ int main (int argc, char **argv)
|
||||
}]])],[mutt_cv_groupwrite=yes],[mutt_cv_groupwrite=no],[mutt_cv_groupwrite=no])])
|
||||
|
||||
if test $mutt_cv_groupwrite = yes; then
|
||||
@ -20,3 +20,24 @@ diff -up mutt-1.9.5/configure.ac.nodotlock mutt-1.9.5/configure.ac
|
||||
AC_DEFINE(USE_SETGID,1,[ Define if mutt should run setgid "mail". ])
|
||||
mutt_cv_setgid=yes
|
||||
fi
|
||||
diff -up mutt-1.10.0/Makefile.am.nodotlock mutt-1.10.0/Makefile.am
|
||||
--- mutt-1.10.0/Makefile.am.nodotlock 2018-05-23 15:11:05.477977659 +0200
|
||||
+++ mutt-1.10.0/Makefile.am 2018-05-23 15:11:20.252170843 +0200
|
||||
@@ -154,17 +154,6 @@ hcversion.h: $(srcdir)/mutt.h $(srcdir)/
|
||||
patchlist.c: $(srcdir)/PATCHES $(srcdir)/patchlist.sh
|
||||
$(srcdir)/patchlist.sh < $(srcdir)/PATCHES > patchlist.c
|
||||
|
||||
-install-exec-hook:
|
||||
- if test -f $(DESTDIR)$(bindir)/mutt.dotlock && test -f $(DESTDIR)$(bindir)/mutt_dotlock ; then \
|
||||
- rm -f $(DESTDIR)$(bindir)/mutt.dotlock ; \
|
||||
- ln -sf $(DESTDIR)$(bindir)/mutt_dotlock $(DESTDIR)$(bindir)/mutt.dotlock ; \
|
||||
- fi
|
||||
- if test -f $(DESTDIR)$(bindir)/mutt_dotlock && test x$(DOTLOCK_GROUP) != x ; then \
|
||||
- chgrp $(DOTLOCK_GROUP) $(DESTDIR)$(bindir)/mutt_dotlock && \
|
||||
- chmod $(DOTLOCK_PERMISSION) $(DESTDIR)$(bindir)/mutt_dotlock || \
|
||||
- { echo "Can't fix mutt_dotlock's permissions! This is required to lock mailboxes in the mail spool directory." >&2 ; exit 1 ; } \
|
||||
- fi
|
||||
-
|
||||
install-data-local:
|
||||
$(MKDIR_P) $(DESTDIR)$(sysconfdir)
|
||||
$(INSTALL) -m 644 $(srcdir)/mime.types $(DESTDIR)$(sysconfdir)/mime.types.dist
|
||||
|
@ -20,7 +20,7 @@
|
||||
Summary: A text mode mail user agent
|
||||
Name: mutt
|
||||
Version: 1.10.0
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Epoch: 5
|
||||
# The entire source code is GPLv2+ except
|
||||
# pgpewrap.c setenv.c sha1.c wcwidth.c which are Public Domain
|
||||
@ -78,8 +78,6 @@ for selecting groups of messages.
|
||||
%prep
|
||||
# unpack; cd
|
||||
%setup -q
|
||||
# disable mutt_dotlock program - disable post-install mutt_dotlock checking
|
||||
sed -i -r 's|install-exec-hook|my-useless-label|' Makefile.am
|
||||
# do not run ./prepare -V, because it also runs ./configure
|
||||
|
||||
%patch10 -p1 -b .lynx_no_backscapes
|
||||
@ -205,6 +203,9 @@ ln -sf ./muttrc.5 %{buildroot}%{_mandir}/man5/muttrc.local.5
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu May 24 2018 Matej Mužila <mmuzila@redhat.com> - 5:1.10.0-2
|
||||
- Disable post-install mutt_dotlock checking by patch, not by sed.
|
||||
|
||||
* Tue May 22 2018 Matej Mužila <mmuzila@redhat.com> - 5:1.10.0-1
|
||||
- Upgrade to 1.10.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user