parent
b375bb5a14
commit
586febde65
1
.gitignore
vendored
1
.gitignore
vendored
@ -26,3 +26,4 @@ mutt-1.5.23.tar.gz
|
||||
/mutt-1.12.0.tar.gz
|
||||
/mutt-1.12.1.tar.gz
|
||||
/mutt-1.12.2.tar.gz
|
||||
/mutt-1.13.0.tar.gz
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -ur mutt-1.8.0.orig/doc/Muttrc.head mutt-1.8.0/doc/Muttrc.head
|
||||
--- mutt-1.8.0.orig/doc/Muttrc.head 2017-02-25 15:28:22.120997474 +0000
|
||||
+++ mutt-1.8.0/doc/Muttrc.head 2017-02-25 15:30:10.643079681 +0000
|
||||
@@ -24,12 +24,16 @@
|
||||
@@ -24,13 +24,17 @@
|
||||
|
||||
# Show documentation when pressing F1
|
||||
macro generic,pager <F1> "<shell-escape> less @docdir@/manual.txt<Enter>" "show Mutt documentation"
|
||||
@ -9,8 +9,9 @@ diff -ur mutt-1.8.0.orig/doc/Muttrc.head mutt-1.8.0/doc/Muttrc.head
|
||||
+macro generic,pager <F2> "<shell-escape> less @docdir@/manual.txt<Enter>" "show Mutt documentation"
|
||||
|
||||
# show the incoming mailboxes list (just like "mutt -y") and back when pressing "y"
|
||||
macro index y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
|
||||
macro pager y "<exit><change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
|
||||
# note: these macros have been subsumed by the <browse-mailboxes> function.
|
||||
# macro index y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
|
||||
# macro pager y "<exit><change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
|
||||
bind browser y exit
|
||||
|
||||
+bind editor <delete> delete-char
|
||||
|
@ -5,8 +5,8 @@ diff -up mutt-1.12.1/init.h.optusegpgagent mutt-1.12.1/init.h
|
||||
** not used.
|
||||
** (PGP only)
|
||||
*/
|
||||
- { "pgp_use_gpg_agent", DT_BOOL, R_NONE, OPTUSEGPGAGENT, 1},
|
||||
+ { "pgp_use_gpg_agent", DT_BOOL, R_NONE, OPTUSEGPGAGENT, 0},
|
||||
- { "pgp_use_gpg_agent", DT_BOOL, R_NONE, {.l=OPTUSEGPGAGENT}, {.l=1} },
|
||||
+ { "pgp_use_gpg_agent", DT_BOOL, R_NONE, {.l=OPTUSEGPGAGENT}, {.l=0} },
|
||||
/*
|
||||
** .pp
|
||||
** If \fIset\fP, mutt expects a \fCgpg-agent(1)\fP process will handle
|
||||
|
@ -5,8 +5,8 @@ diff -rup mutt-17a4f92e4a95-orig/init.h mutt-17a4f92e4a95-new/init.h
|
||||
*/
|
||||
#if defined(USE_SSL)
|
||||
#ifdef USE_SSL_GNUTLS
|
||||
- { "ssl_ca_certificates_file", DT_PATH, R_NONE, UL &SslCACertFile, 0 },
|
||||
+ { "ssl_ca_certificates_file", DT_PATH, R_NONE, UL &SslCACertFile, "/etc/ssl/certs/ca-bundle.crt" },
|
||||
- { "ssl_ca_certificates_file", DT_PATH, R_NONE, {.p=&SslCACertFile}, {.p=0} },
|
||||
+ { "ssl_ca_certificates_file", DT_PATH, R_NONE, {.p=&SslCACertFile}, {.p="/etc/ssl/certs/ca-bundle.crt"} },
|
||||
/*
|
||||
** .pp
|
||||
** This variable specifies a file containing trusted CA certificates.
|
||||
|
@ -5,8 +5,8 @@ diff -ur mutt-1.8.0.orig/contrib/Makefile.am mutt-1.8.0/contrib/Makefile.am
|
||||
sample.mailcap sample.muttrc sample.muttrc-sidebar sample.muttrc-tlr \
|
||||
sample.muttrc-compress sample.muttrc-starter \
|
||||
sample.vimrc-sidebar colors.default colors.linux smime.rc \
|
||||
- ca-bundle.crt smime_keys_test.pl mutt_xtitle
|
||||
+ smime_keys_test.pl mutt_xtitle
|
||||
- ca-bundle.crt smime_keys_test.pl mutt_xtitle markdown2html
|
||||
+ smime_keys_test.pl mutt_xtitle markdown2html
|
||||
|
||||
EXTRA_DIST = language.txt language50.txt \
|
||||
patch.slang-1.2.2.keypad.1 \
|
||||
|
@ -5,8 +5,8 @@ diff -ur mutt-1.9.0.orig/init.h mutt-1.9.0/init.h
|
||||
*/
|
||||
# endif /* defined HAVE_SSL_PARTIAL_CHAIN */
|
||||
# endif /* defined USE_SSL_OPENSSL */
|
||||
- { "ssl_ciphers", DT_STR, R_NONE, UL &SslCiphers, UL 0 },
|
||||
+ { "ssl_ciphers", DT_STR, R_NONE, UL &SslCiphers, UL "@SYSTEM" },
|
||||
- { "ssl_ciphers", DT_STR, R_NONE, {.p=&SslCiphers}, {.p=0} },
|
||||
+ { "ssl_ciphers", DT_STR, R_NONE, {.p=&SslCiphers}, {.p="@SYSTEM"} },
|
||||
/*
|
||||
** .pp
|
||||
** Contains a colon-seperated list of ciphers to use when using SSL.
|
||||
@ -15,18 +15,18 @@ diff -ur mutt-1.9.0.orig/mutt_ssl_gnutls.c mutt-1.9.0/mutt_ssl_gnutls.c
|
||||
+++ mutt-1.9.0/mutt_ssl_gnutls.c 2017-09-04 16:51:16.081679141 +0200
|
||||
@@ -286,6 +286,8 @@
|
||||
else
|
||||
safe_strcat (priority, priority_size, "NORMAL");
|
||||
mutt_buffer_strcpy (priority, "NORMAL");
|
||||
|
||||
+if (SslCiphers && strcmp(SslCiphers, "@SYSTEM"))
|
||||
+{
|
||||
if (! option(OPTTLSV1_2))
|
||||
if (!option(OPTTLSV1_3))
|
||||
{
|
||||
nproto--;
|
||||
@@ -313,6 +315,7 @@
|
||||
FREE (&priority);
|
||||
return -1;
|
||||
mutt_error (_("All available protocols for TLS/SSL connection disabled"));
|
||||
goto cleanup;
|
||||
}
|
||||
+}
|
||||
|
||||
if ((err = gnutls_priority_set_direct (data->state, priority, NULL)) < 0)
|
||||
if ((err = gnutls_priority_set_direct (data->state, mutt_b2s (priority), NULL)) < 0)
|
||||
{
|
||||
|
@ -19,7 +19,7 @@
|
||||
|
||||
Summary: A text mode mail user agent
|
||||
Name: mutt
|
||||
Version: 1.12.2
|
||||
Version: 1.13.0
|
||||
Release: 1%{?dist}
|
||||
Epoch: 5
|
||||
# The entire source code is GPLv2+ except
|
||||
@ -211,6 +211,10 @@ ln -sf ./muttrc.5 %{buildroot}%{_mandir}/man5/muttrc.local.5
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Dec 02 2019 Matej Mužila <mmuzila@redhat.com> - 5:1.13.0-1
|
||||
- Upgrade to 1.13.0
|
||||
- Resolves: #1754211
|
||||
|
||||
* Tue Sep 24 2019 Matej Mužila <mmuzila@redhat.com> - 5:1.12.2-1
|
||||
- Upgrade to 1.12.2
|
||||
- Resolves: #1754211
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mutt-1.12.2.tar.gz) = a824a056edef0c320b7633a39ab2421646442132190c2b2bf788ac39aaf7a0143d12847eb27290913d8ae793810bb6353803977610045b36235579001a1096bd
|
||||
SHA512 (mutt-1.13.0.tar.gz) = 76dc0a0cce4293851fb4caa0018538f112bac0f02a1faa2a8ec62bbf078b130d2907709423b3eda5217d24886e58a1e7a184a094701c9bdb989e93b9dac123fa
|
||||
|
Loading…
Reference in New Issue
Block a user