- update to 1.5.18
This commit is contained in:
parent
c9d9f8cab0
commit
4c99360ace
@ -1 +1 @@
|
||||
mutt-1.5.17.tar.gz
|
||||
mutt-1.5.18.tar.gz
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff -up mutt-1.5.17/send.c.batchsend mutt-1.5.17/send.c
|
||||
--- mutt-1.5.17/send.c.batchsend 2007-07-26 21:43:39.000000000 +0200
|
||||
+++ mutt-1.5.17/send.c 2007-11-23 12:26:28.000000000 +0100
|
||||
@@ -1212,7 +1212,8 @@ ci_send_message (int flags, /* send mod
|
||||
if (!msg->env->from && option (OPTUSEFROM) && !(flags & (SENDPOSTPONED|SENDRESEND)))
|
||||
{
|
||||
msg->env->from = mutt_default_from ();
|
||||
- killfrom = 1; /* $use_from will be re-checked after send-hooks */
|
||||
+ if (!(flags & SENDBATCH))
|
||||
+ killfrom = 1; /* $use_from will be re-checked after send-hooks */
|
||||
}
|
||||
|
||||
if (flags & SENDBATCH)
|
@ -1,42 +0,0 @@
|
||||
diff -r e3bc99a4a6bd -r c10d4343a17f mutt_ssl_gnutls.c
|
||||
--- a/mutt_ssl_gnutls.c Tue Mar 11 17:20:48 2008 -0700
|
||||
+++ b/mutt_ssl_gnutls.c Thu Apr 03 17:08:13 2008 +0200
|
||||
@@ -112,6 +112,7 @@ static int tls_socket_write (CONNECTION*
|
||||
{
|
||||
tlssockdata *data = conn->sockdata;
|
||||
int ret;
|
||||
+ size_t sent = 0;
|
||||
|
||||
if (!data)
|
||||
{
|
||||
@@ -120,14 +121,23 @@ static int tls_socket_write (CONNECTION*
|
||||
return -1;
|
||||
}
|
||||
|
||||
- ret = gnutls_record_send (data->state, buf, len);
|
||||
- if (ret < 0 && gnutls_error_is_fatal(ret) == 1)
|
||||
+ do
|
||||
{
|
||||
- mutt_error ("tls_socket_write (%s)", gnutls_strerror (ret));
|
||||
- mutt_sleep (4);
|
||||
- return -1;
|
||||
- }
|
||||
- return ret;
|
||||
+ ret = gnutls_record_send (data->state, buf + sent, len - sent);
|
||||
+ if (ret < 0)
|
||||
+ {
|
||||
+ if (gnutls_error_is_fatal(ret) == 1)
|
||||
+ {
|
||||
+ mutt_error ("tls_socket_write (%s)", gnutls_strerror (ret));
|
||||
+ mutt_sleep (4);
|
||||
+ return -1;
|
||||
+ }
|
||||
+ return ret;
|
||||
+ }
|
||||
+ sent += ret;
|
||||
+ } while (sent < len);
|
||||
+
|
||||
+ return sent;
|
||||
}
|
||||
|
||||
static int tls_socket_open (CONNECTION* conn)
|
@ -1,20 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Rocco Rutte <pdmef@gmx.net>
|
||||
# Date 1194084739 -3600
|
||||
# Branch HEAD
|
||||
# Node ID 0c054faeb28595ef4a252c38319fa1f1f376b68e
|
||||
# Parent cc5de08f46129c447901f7f79e571105eb0d81c1
|
||||
Check Maildir for not being NULL when expanding '='-paths. Closes #2977.
|
||||
|
||||
diff -r cc5de08f4612 -r 0c054faeb285 muttlib.c
|
||||
--- a/muttlib.c Fri Nov 02 16:55:55 2007 -0700
|
||||
+++ b/muttlib.c Sat Nov 03 11:12:19 2007 +0100
|
||||
@@ -397,7 +397,7 @@ char *_mutt_expand_path (char *s, size_t
|
||||
strfcpy (p, NONULL (Maildir), sizeof (p));
|
||||
else
|
||||
#endif
|
||||
- if (Maildir[strlen (Maildir) - 1] == '/')
|
||||
+ if (Maildir && *Maildir && Maildir[strlen (Maildir) - 1] == '/')
|
||||
strfcpy (p, NONULL (Maildir), sizeof (p));
|
||||
else
|
||||
snprintf (p, sizeof (p), "%s/", NONULL (Maildir));
|
@ -1,113 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Rocco Rutte <pdmef@gmx.net>
|
||||
# Date 1194196465 -3600
|
||||
# Branch HEAD
|
||||
# Node ID 6248b3c04f61fcbd447bed96030cb7a4887b69b6
|
||||
# Parent 2157b46eb93823e5c38136fe49c9b16c1475f27b
|
||||
Prevent mailto parsing buffer overflow by ignoring too long header.
|
||||
If they're longer than our buffer, we can't turn it into a header to
|
||||
be parsed by mutt_parse_rfc822_line() anyway, so we bail out in this
|
||||
case. Also make main() catchup mailto parsing errors. Closes #2980.
|
||||
|
||||
diff -r 2157b46eb938 -r 6248b3c04f61 main.c
|
||||
--- a/main.c Sun Nov 04 17:02:56 2007 +0100
|
||||
+++ b/main.c Sun Nov 04 18:14:25 2007 +0100
|
||||
@@ -829,7 +829,15 @@ int main (int argc, char **argv)
|
||||
for (i = optind; i < argc; i++)
|
||||
{
|
||||
if (url_check_scheme (argv[i]) == U_MAILTO)
|
||||
- url_parse_mailto (msg->env, &bodytext, argv[i]);
|
||||
+ {
|
||||
+ if (url_parse_mailto (msg->env, &bodytext, argv[i]) < 0)
|
||||
+ {
|
||||
+ if (!option (OPTNOCURSES))
|
||||
+ mutt_endwin (NULL);
|
||||
+ fputs (_("Failed to parse mailto: link\n"), stderr);
|
||||
+ exit (1);
|
||||
+ }
|
||||
+ }
|
||||
else
|
||||
msg->env->to = rfc822_parse_adrlist (msg->env->to, argv[i]);
|
||||
}
|
||||
diff -r 2157b46eb938 -r 6248b3c04f61 url.c
|
||||
--- a/url.c Sun Nov 04 17:02:56 2007 +0100
|
||||
+++ b/url.c Sun Nov 04 18:14:25 2007 +0100
|
||||
@@ -217,7 +217,7 @@ int url_parse_mailto (ENVELOPE *e, char
|
||||
char *tag, *value;
|
||||
char scratch[HUGE_STRING];
|
||||
|
||||
- int taglen;
|
||||
+ int taglen, rc = 0;
|
||||
|
||||
LIST *last = NULL;
|
||||
|
||||
@@ -250,19 +250,25 @@ int url_parse_mailto (ENVELOPE *e, char
|
||||
if (body)
|
||||
mutt_str_replace (body, value);
|
||||
}
|
||||
- else
|
||||
- {
|
||||
- taglen = strlen (tag);
|
||||
- /* mutt_parse_rfc822_line makes some assumptions */
|
||||
+ else if ((taglen = mutt_strlen (tag)) <= sizeof (scratch) - 2)
|
||||
+ {
|
||||
+ /* only try to parse if we can format it as header for
|
||||
+ * mutt_parse_rfc822_line (tag fits in scratch) */
|
||||
snprintf (scratch, sizeof (scratch), "%s: %s", tag, value);
|
||||
scratch[taglen] = '\0';
|
||||
value = &scratch[taglen+1];
|
||||
SKIPWS (value);
|
||||
mutt_parse_rfc822_line (e, NULL, scratch, value, 1, 0, 0, &last);
|
||||
}
|
||||
- }
|
||||
-
|
||||
+ else
|
||||
+ {
|
||||
+ rc = -1;
|
||||
+ goto out;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+out:
|
||||
FREE (&tmp);
|
||||
- return 0;
|
||||
-}
|
||||
-
|
||||
+ return rc;
|
||||
+}
|
||||
+
|
||||
# HG changeset patch
|
||||
# User cypher@conuropsis.org
|
||||
# Date 1194197244 -3600
|
||||
# Branch HEAD
|
||||
# Node ID ab676b9f0c040644f27c1fb862a7d67171c553c7
|
||||
# Parent 6248b3c04f61fcbd447bed96030cb7a4887b69b6
|
||||
Use strtok_r() to parse mailto: links, not strtok().
|
||||
In case a headers needs to call mutt_parse_references() which uses
|
||||
strtok(), too, later headers will be silently discarded. Closes #2968.
|
||||
|
||||
diff -r 6248b3c04f61 -r ab676b9f0c04 url.c
|
||||
--- a/url.c Sun Nov 04 18:14:25 2007 +0100
|
||||
+++ b/url.c Sun Nov 04 18:27:24 2007 +0100
|
||||
@@ -211,7 +211,7 @@ int url_ciss_tostring (ciss_url_t* ciss,
|
||||
|
||||
int url_parse_mailto (ENVELOPE *e, char **body, const char *src)
|
||||
{
|
||||
- char *t;
|
||||
+ char *t, *p;
|
||||
char *tmp;
|
||||
char *headers;
|
||||
char *tag, *value;
|
||||
@@ -233,9 +233,9 @@ int url_parse_mailto (ENVELOPE *e, char
|
||||
url_pct_decode (tmp);
|
||||
e->to = rfc822_parse_adrlist (e->to, tmp);
|
||||
|
||||
- tag = headers ? strtok (headers, "&") : NULL;
|
||||
-
|
||||
- for (; tag; tag = strtok (NULL, "&"))
|
||||
+ tag = headers ? strtok_r (headers, "&", &p) : NULL;
|
||||
+
|
||||
+ for (; tag; tag = strtok_r (NULL, "&", &p))
|
||||
{
|
||||
if ((value = strchr (tag, '=')))
|
||||
*value++ = '\0';
|
@ -1,26 +0,0 @@
|
||||
diff -up mutt-1.5.17/doc/Makefile.in.manual mutt-1.5.17/doc/Makefile.in
|
||||
--- mutt-1.5.17/doc/Makefile.in.manual 2007-11-01 20:13:14.000000000 +0100
|
||||
+++ mutt-1.5.17/doc/Makefile.in 2007-11-02 13:00:53.000000000 +0100
|
||||
@@ -481,10 +481,9 @@ muttrc.man: ../makedoc$(EXEEXT) $(top_sr
|
||||
mutt.1: $(srcdir)/mutt.man
|
||||
$(EDIT) $(srcdir)/mutt.man > $@
|
||||
|
||||
-stamp-doc-xml: $(top_srcdir)/makedoc.c $(top_srcdir)/makedoc-defs.h $(top_srcdir)/init.h \
|
||||
+stamp-doc-xml: ../makedoc$(EXEEXT) $(top_srcdir)/makedoc-defs.h $(top_srcdir)/init.h \
|
||||
manual.xml.head $(top_srcdir)/functions.h $(top_srcdir)/OPS* manual.xml.tail \
|
||||
$(srcdir)/gen-map-doc $(top_srcdir)/VERSION $(top_srcdir)/ChangeLog
|
||||
- $(MAKE) ../makedoc$(EXEEXT) # we do not want to rebuild the documentation in tarball builds
|
||||
( date=`head -n 1 $(top_srcdir)/ChangeLog | LC_ALL=C cut -d ' ' -f 1` && \
|
||||
sed -e "s/@VERSION\@/`cat $(top_srcdir)/VERSION` ($$date)/" $(srcdir)/manual.xml.head && \
|
||||
$(MAKEDOC_CPP) $(top_srcdir)/init.h | ../makedoc -s && \
|
||||
diff -up mutt-1.5.17/init.h.manual mutt-1.5.17/init.h
|
||||
--- mutt-1.5.17/init.h.manual 2007-10-31 18:48:52.000000000 +0100
|
||||
+++ mutt-1.5.17/init.h 2007-11-02 13:00:53.000000000 +0100
|
||||
@@ -19,7 +19,6 @@
|
||||
|
||||
#ifdef _MAKEDOC
|
||||
# include "config.h"
|
||||
-# include "makedoc-defs.h"
|
||||
#else
|
||||
# include "sort.h"
|
||||
#endif
|
@ -1,20 +0,0 @@
|
||||
diff -up mutt-1.5.17/smime_keys.pl.smimekeys mutt-1.5.17/smime_keys.pl
|
||||
--- mutt-1.5.17/smime_keys.pl.smimekeys 2007-03-02 19:44:44.000000000 +0100
|
||||
+++ mutt-1.5.17/smime_keys.pl 2008-04-04 12:33:34.000000000 +0200
|
||||
@@ -20,6 +20,7 @@
|
||||
|
||||
use strict;
|
||||
use File::Copy;
|
||||
+use File::Glob ':glob';
|
||||
|
||||
umask 077;
|
||||
|
||||
@@ -225,7 +226,7 @@ You must set this in your mutt config fi
|
||||
EOF
|
||||
#'
|
||||
|
||||
- $answer =~ /\"(.*?)\"/ and return $1;
|
||||
+ $answer =~ /\"(.*?)\"/ and return bsd_glob($1, GLOB_TILDE | GLOB_NOCHECK);
|
||||
|
||||
$answer =~ /^Mutt (.*?) / and die<<EOF;
|
||||
This script requires mutt 1.5.0 or later. You are using mutt $1.
|
@ -1,93 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Rocco Rutte <pdmef@gmx.net>
|
||||
# Date 1194192176 -3600
|
||||
# Branch HEAD
|
||||
# Node ID 2157b46eb93823e5c38136fe49c9b16c1475f27b
|
||||
# Parent 1416714ec4d1013f5572e49e480df8b9de2bdee0
|
||||
Add 1.5.17 to UPDATING
|
||||
|
||||
diff -r 1416714ec4d1 -r 2157b46eb938 UPDATING
|
||||
--- a/UPDATING Sun Nov 04 17:01:12 2007 +0100
|
||||
+++ b/UPDATING Sun Nov 04 17:02:56 2007 +0100
|
||||
@@ -3,6 +3,8 @@ mutt. Please read this file carefully wh
|
||||
|
||||
The keys used are:
|
||||
!: modified feature, -: deleted feature, +: new feature
|
||||
+
|
||||
+1.5.17 (2007-11-01)
|
||||
|
||||
! --enable-exact-address works again
|
||||
+ next-unread-mailbox
|
||||
# HG changeset patch
|
||||
# User Rocco Rutte <pdmef@gmx.net>
|
||||
# Date 1194199833 -3600
|
||||
# Branch HEAD
|
||||
# Node ID 02e8b9c7bdc61250c9546de1abc0cb296953274c
|
||||
# Parent ab676b9f0c040644f27c1fb862a7d67171c553c7
|
||||
Fixup UPDATING for 1.5.16/1.5.17
|
||||
|
||||
diff -r ab676b9f0c04 -r 02e8b9c7bdc6 UPDATING
|
||||
--- a/UPDATING Sun Nov 04 18:27:24 2007 +0100
|
||||
+++ b/UPDATING Sun Nov 04 19:10:33 2007 +0100
|
||||
@@ -4,14 +4,18 @@ The keys used are:
|
||||
The keys used are:
|
||||
!: modified feature, -: deleted feature, +: new feature
|
||||
|
||||
-1.5.17 (2007-11-01)
|
||||
+1.5.17 (2007-11-01):
|
||||
|
||||
! --enable-exact-address works again
|
||||
+
|
||||
+1.5.16 (2007-06-09):
|
||||
+
|
||||
+ next-unread-mailbox
|
||||
+ $message_cache_clean (clean cache on sync)
|
||||
- + %P expando for $pager_format
|
||||
+ + $smtp_pass
|
||||
+ ! $header_cache_compress defaults to yes
|
||||
|
||||
-1.5.15 (2007-04-06)
|
||||
+1.5.15 (2007-04-06):
|
||||
|
||||
- $imap_home_namespace (useless clutter)
|
||||
+ $check_mbox_size (use size change instead of atime for new mail)
|
||||
# HG changeset patch
|
||||
# User Rocco Rutte <pdmef@gmx.net>
|
||||
# Date 1195640183 -3600
|
||||
# Branch HEAD
|
||||
# Node ID 849daa6be9f56dc0e3505b9c7e9d18d1116a53cd
|
||||
# Parent 96f931ae0b2298134f5c3c1ac283d5bd6d7b287f
|
||||
Remove raw utf-8 char in UPDATING to make it ascii again
|
||||
|
||||
diff -r 96f931ae0b22 -r 849daa6be9f5 UPDATING
|
||||
--- a/UPDATING Tue Nov 20 19:46:52 2007 +0100
|
||||
+++ b/UPDATING Wed Nov 21 11:16:23 2007 +0100
|
||||
@@ -28,7 +28,7 @@ 1.5.15 (2007-04-06):
|
||||
+ $save_history, $history_file (save history across sessions)
|
||||
+ $smtp_url (ESMTP relay support)
|
||||
+ $crypt_use_pka (use GPGME PKA signature verification)
|
||||
- ! format pipe support: format strings ending in | are filtered
|
||||
+ ! format pipe support: format strings ending in | are filtered
|
||||
|
||||
1.5.13 (2006-08-14):
|
||||
|
||||
# HG changeset patch
|
||||
# User Rocco Rutte <pdmef@gmx.net>
|
||||
# Date 1195660074 -3600
|
||||
# Branch HEAD
|
||||
# Node ID 309ab3a63d915dd50921ec23d4f73e7b87985527
|
||||
# Parent b8d811e5931eee623dfd5c040bade7ec9e1554a9
|
||||
Add UPDATING entry for $check_mbox_size
|
||||
|
||||
diff -r b8d811e5931e -r 309ab3a63d91 UPDATING
|
||||
--- a/UPDATING Wed Nov 21 14:46:43 2007 +0100
|
||||
+++ b/UPDATING Wed Nov 21 16:47:54 2007 +0100
|
||||
@@ -29,6 +29,8 @@ 1.5.15 (2007-04-06):
|
||||
+ $smtp_url (ESMTP relay support)
|
||||
+ $crypt_use_pka (use GPGME PKA signature verification)
|
||||
! format pipe support: format strings ending in | are filtered
|
||||
+ ! buffy size is configurable at runtime (no --enable-buffy-size
|
||||
+ configure option, new $check_mbox_size variable)
|
||||
|
||||
1.5.13 (2006-08-14):
|
||||
|
12
mutt-1.5.18-manual.patch
Normal file
12
mutt-1.5.18-manual.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up mutt-1.5.18/doc/Makefile.in.manual mutt-1.5.18/doc/Makefile.in
|
||||
diff -up mutt-1.5.18/init.h.manual mutt-1.5.18/init.h
|
||||
--- mutt-1.5.18/init.h.manual 2008-01-30 05:26:50.000000000 +0100
|
||||
+++ mutt-1.5.18/init.h 2008-05-19 11:05:02.000000000 +0200
|
||||
@@ -19,7 +19,6 @@
|
||||
|
||||
#ifdef _MAKEDOC
|
||||
# include "config.h"
|
||||
-# include "doc/makedoc-defs.h"
|
||||
#else
|
||||
# include "sort.h"
|
||||
#endif
|
@ -1,6 +1,7 @@
|
||||
--- mutt-1.5.16/Muttrc.head.muttrc 2007-06-06 18:02:56.000000000 +0200
|
||||
+++ mutt-1.5.16/Muttrc.head 2007-06-11 10:46:02.000000000 +0200
|
||||
@@ -19,11 +19,15 @@
|
||||
diff -up mutt-1.5.18/doc/Muttrc.head.muttrc mutt-1.5.18/doc/Muttrc.head
|
||||
--- mutt-1.5.18/doc/Muttrc.head.muttrc 2008-01-30 05:26:50.000000000 +0100
|
||||
+++ mutt-1.5.18/doc/Muttrc.head 2008-05-19 10:58:21.000000000 +0200
|
||||
@@ -19,11 +19,15 @@ macro index,pager,attach,compose \cb "\
|
||||
|
||||
# Show documentation when pressing F1
|
||||
macro generic,pager <F1> "<shell-escape> less @docdir@/manual.txt<Enter>" "show Mutt documentation"
|
||||
@ -16,3 +17,4 @@
|
||||
# If Mutt is unable to determine your site's domain name correctly, you can
|
||||
# set the default here.
|
||||
#
|
||||
diff -up mutt-1.5.18/contrib/sample.muttrc mutt-1.5.18/contrib/sample
|
24
mutt.spec
24
mutt.spec
@ -14,8 +14,8 @@
|
||||
|
||||
Summary: A text mode mail user agent
|
||||
Name: mutt
|
||||
Version: 1.5.17
|
||||
Release: 4%{?dist}
|
||||
Version: 1.5.18
|
||||
Release: 1%{?dist}
|
||||
Epoch: 5
|
||||
# The entire source code is GPLv2+ except
|
||||
# pgpewrap.c setenv.c sha1.c wcwidth.c which are Public Domain
|
||||
@ -24,14 +24,8 @@ Group: Applications/Internet
|
||||
Source: ftp://ftp.mutt.org/pub/mutt/devel/mutt-%{version}.tar.gz
|
||||
Source1: mutt_ldap_query
|
||||
Patch2: mutt-1.5.13-nodotlock.patch
|
||||
Patch3: mutt-1.5.16-muttrc.patch
|
||||
Patch4: mutt-1.5.17-manual.patch
|
||||
Patch5: mutt-1.5.17-maildirnull.patch
|
||||
Patch6: mutt-1.5.17-updating.patch
|
||||
Patch7: mutt-1.5.17-mailto.patch
|
||||
Patch8: mutt-1.5.17-batchsend.patch
|
||||
Patch9: mutt-1.5.17-gnutls.patch
|
||||
Patch10: mutt-1.5.17-smimekeys.patch
|
||||
Patch3: mutt-1.5.18-muttrc.patch
|
||||
Patch4: mutt-1.5.18-manual.patch
|
||||
Url: http://www.mutt.org/
|
||||
Requires: mailcap urlview
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -69,18 +63,11 @@ for selecting groups of messages.
|
||||
%patch2 -p1 -b .nodl
|
||||
%patch3 -p1 -b .muttrc
|
||||
%patch4 -p1 -b .manual
|
||||
%patch5 -p1 -b .maildirnull
|
||||
%patch6 -p1 -b .updating
|
||||
%patch7 -p1 -b .mailto
|
||||
%patch8 -p1 -b .batchsend
|
||||
%patch9 -p1 -b .gnutls
|
||||
%patch10 -p1 -b .smimekeys
|
||||
|
||||
install -p -m644 %{SOURCE1} mutt_ldap_query
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-inodesort \
|
||||
%{?with_debug: --enable-debug}\
|
||||
%{?with_pop: --enable-pop}\
|
||||
%{?with_imap: --enable-imap} \
|
||||
@ -150,6 +137,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man5/muttrc.*
|
||||
|
||||
%changelog
|
||||
* Mon May 19 2008 Miroslav Lichvar <mlichvar@redhat.com> 5:1.5.18-1
|
||||
- update to 1.5.18
|
||||
|
||||
* Fri Apr 04 2008 Miroslav Lichvar <mlichvar@redhat.com> 5:1.5.17-4
|
||||
- fix sending long commands when using gnutls (#438275)
|
||||
- glob tilde in smime_keys (#424311)
|
||||
|
Loading…
Reference in New Issue
Block a user