Update to 1.9.0
This commit is contained in:
parent
cb0c1571b1
commit
039dc0ab69
@ -1,74 +0,0 @@
|
|||||||
diff -rup mutt-17a4f92e4a95-orig/init.h mutt-17a4f92e4a95/init.h
|
|
||||||
--- mutt-17a4f92e4a95-orig/init.h 2015-07-30 11:09:54.536930119 +0200
|
|
||||||
+++ mutt-17a4f92e4a95/init.h 2015-07-30 11:11:17.383772131 +0200
|
|
||||||
@@ -3092,7 +3092,7 @@ struct option_t MuttVars[] = {
|
|
||||||
** URL. You should only unset this for particular known hosts, using
|
|
||||||
** the \fC$<account-hook>\fP function.
|
|
||||||
*/
|
|
||||||
- { "ssl_ciphers", DT_STR, R_NONE, UL &SslCiphers, UL 0 },
|
|
||||||
+ { "ssl_ciphers", DT_STR, R_NONE, UL &SslCiphers, UL "@SYSTEM" },
|
|
||||||
/*
|
|
||||||
** .pp
|
|
||||||
** Contains a colon-seperated list of ciphers to use when using SSL.
|
|
||||||
--- mutt-17a4f92e4a95/mutt_ssl_gnutls.c.ssl_ciphers 2015-08-20 13:19:24.990481900 +0200
|
|
||||||
+++ mutt-17a4f92e4a95/mutt_ssl_gnutls.c 2015-08-20 14:37:18.405928684 +0200
|
|
||||||
@@ -286,32 +286,35 @@
|
|
||||||
else
|
|
||||||
safe_strcat (priority, priority_size, "NORMAL");
|
|
||||||
|
|
||||||
- if (! option(OPTTLSV1_2))
|
|
||||||
+ if (SslCiphers && strcmp(SslCiphers, "@SYSTEM"))
|
|
||||||
{
|
|
||||||
- nproto--;
|
|
||||||
- safe_strcat (priority, priority_size, ":-VERS-TLS1.2");
|
|
||||||
- }
|
|
||||||
- if (! option(OPTTLSV1_1))
|
|
||||||
- {
|
|
||||||
- nproto--;
|
|
||||||
- safe_strcat (priority, priority_size, ":-VERS-TLS1.1");
|
|
||||||
- }
|
|
||||||
- if (! option(OPTTLSV1))
|
|
||||||
- {
|
|
||||||
- nproto--;
|
|
||||||
- safe_strcat (priority, priority_size, ":-VERS-TLS1.0");
|
|
||||||
- }
|
|
||||||
- if (! option(OPTSSLV3))
|
|
||||||
- {
|
|
||||||
- nproto--;
|
|
||||||
- safe_strcat (priority, priority_size, ":-VERS-SSL3.0");
|
|
||||||
- }
|
|
||||||
+ if (! option(OPTTLSV1_2))
|
|
||||||
+ {
|
|
||||||
+ nproto--;
|
|
||||||
+ safe_strcat (priority, priority_size, ":-VERS-TLS1.2");
|
|
||||||
+ }
|
|
||||||
+ if (! option(OPTTLSV1_1))
|
|
||||||
+ {
|
|
||||||
+ nproto--;
|
|
||||||
+ safe_strcat (priority, priority_size, ":-VERS-TLS1.1");
|
|
||||||
+ }
|
|
||||||
+ if (! option(OPTTLSV1))
|
|
||||||
+ {
|
|
||||||
+ nproto--;
|
|
||||||
+ safe_strcat (priority, priority_size, ":-VERS-TLS1.0");
|
|
||||||
+ }
|
|
||||||
+ if (! option(OPTSSLV3))
|
|
||||||
+ {
|
|
||||||
+ nproto--;
|
|
||||||
+ safe_strcat (priority, priority_size, ":-VERS-SSL3.0");
|
|
||||||
+ }
|
|
||||||
|
|
||||||
- if (nproto == 0)
|
|
||||||
- {
|
|
||||||
- mutt_error (_("All available protocols for TLS/SSL connection disabled"));
|
|
||||||
- FREE (&priority);
|
|
||||||
- return -1;
|
|
||||||
+ if (nproto == 0)
|
|
||||||
+ {
|
|
||||||
+ mutt_error (_("All available protocols for TLS/SSL connection disabled"));
|
|
||||||
+ FREE (&priority);
|
|
||||||
+ return -1;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
if ((err = gnutls_priority_set_direct (data->state, priority, NULL)) < 0)
|
|
32
mutt-1.9.0-ssl_ciphers.patch
Normal file
32
mutt-1.9.0-ssl_ciphers.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
diff -ur mutt-1.9.0.orig/init.h mutt-1.9.0/init.h
|
||||||
|
--- mutt-1.9.0.orig/init.h 2017-09-04 16:48:21.409528002 +0200
|
||||||
|
+++ mutt-1.9.0/init.h 2017-09-04 16:49:26.505093636 +0200
|
||||||
|
@@ -3510,7 +3510,7 @@
|
||||||
|
*/
|
||||||
|
# endif /* defined HAVE_SSL_PARTIAL_CHAIN */
|
||||||
|
# endif /* defined USE_SSL_OPENSSL */
|
||||||
|
- { "ssl_ciphers", DT_STR, R_NONE, UL &SslCiphers, UL 0 },
|
||||||
|
+ { "ssl_ciphers", DT_STR, R_NONE, UL &SslCiphers, UL "@SYSTEM" },
|
||||||
|
/*
|
||||||
|
** .pp
|
||||||
|
** Contains a colon-seperated list of ciphers to use when using SSL.
|
||||||
|
diff -ur mutt-1.9.0.orig/mutt_ssl_gnutls.c mutt-1.9.0/mutt_ssl_gnutls.c
|
||||||
|
--- mutt-1.9.0.orig/mutt_ssl_gnutls.c 2017-09-04 16:48:21.403528134 +0200
|
||||||
|
+++ mutt-1.9.0/mutt_ssl_gnutls.c 2017-09-04 16:51:16.081679141 +0200
|
||||||
|
@@ -286,6 +286,8 @@
|
||||||
|
else
|
||||||
|
safe_strcat (priority, priority_size, "NORMAL");
|
||||||
|
|
||||||
|
+if (SslCiphers && strcmp(SslCiphers, "@SYSTEM"))
|
||||||
|
+{
|
||||||
|
if (! option(OPTTLSV1_2))
|
||||||
|
{
|
||||||
|
nproto--;
|
||||||
|
@@ -313,6 +315,7 @@
|
||||||
|
FREE (&priority);
|
||||||
|
return -1;
|
||||||
|
}
|
||||||
|
+}
|
||||||
|
|
||||||
|
if ((err = gnutls_priority_set_direct (data->state, priority, NULL)) < 0)
|
||||||
|
{
|
10
mutt.spec
10
mutt.spec
@ -18,8 +18,8 @@
|
|||||||
|
|
||||||
Summary: A text mode mail user agent
|
Summary: A text mode mail user agent
|
||||||
Name: mutt
|
Name: mutt
|
||||||
Version: 1.8.3
|
Version: 1.9.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 5
|
Epoch: 5
|
||||||
# The entire source code is GPLv2+ except
|
# The entire source code is GPLv2+ except
|
||||||
# pgpewrap.c setenv.c sha1.c wcwidth.c which are Public Domain
|
# pgpewrap.c setenv.c sha1.c wcwidth.c which are Public Domain
|
||||||
@ -34,7 +34,7 @@ Patch2: mutt-1.8.0-cabundle.patch
|
|||||||
Patch3: mutt-1.7.0-syncdebug.patch
|
Patch3: mutt-1.7.0-syncdebug.patch
|
||||||
# FIXME make it to upstream
|
# FIXME make it to upstream
|
||||||
Patch8: mutt-1.5.23-system_certs.patch
|
Patch8: mutt-1.5.23-system_certs.patch
|
||||||
Patch9: mutt-1.5.23-ssl_ciphers.patch
|
Patch9: mutt-1.9.0-ssl_ciphers.patch
|
||||||
Url: http://www.mutt.org
|
Url: http://www.mutt.org
|
||||||
Requires: mailcap, urlview
|
Requires: mailcap, urlview
|
||||||
BuildRequires: ncurses-devel, gettext, automake
|
BuildRequires: ncurses-devel, gettext, automake
|
||||||
@ -196,6 +196,10 @@ ln -sf ./muttrc.5 %{buildroot}%{_mandir}/man5/muttrc.local.5
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 04 2017 Fabio Alessandro Locati <fale@fedoraproject.org> - 5:1.9.0-1
|
||||||
|
- Upgrade to 1.9.0
|
||||||
|
- Rebase mutt-1.5.23-ssl_ciphers.patch to mutt-1.9.0-ssl_ciphers.patch
|
||||||
|
|
||||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5:1.8.3-3
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5:1.8.3-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user