- update to 0.79
- patches merged - mtr-0.75-fd-flags.path - mtr075-rh516603.patch
This commit is contained in:
parent
92ebd991b7
commit
e20d5d7fe8
@ -1 +1 @@
|
|||||||
mtr-0.75.tar.gz
|
mtr-0.79.tar.gz
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
diff -up mtr-0.75/net.c.fd-flags mtr-0.75/net.c
|
|
||||||
--- mtr-0.75/net.c.fd-flags 2008-10-22 08:07:53.000000000 +0200
|
|
||||||
+++ mtr-0.75/net.c 2008-10-23 13:57:04.000000000 +0200
|
|
||||||
@@ -945,8 +945,9 @@ int net_preopen(void)
|
|
||||||
set_fd_flags(recvsock4);
|
|
||||||
#ifdef ENABLE_IPV6
|
|
||||||
recvsock6 = socket(AF_INET6, SOCK_RAW, IPPROTO_ICMPV6);
|
|
||||||
+ if (recvsock6 >= 0)
|
|
||||||
+ set_fd_flags(recvsock6);
|
|
||||||
#endif
|
|
||||||
- set_fd_flags(recvsock6);
|
|
||||||
|
|
||||||
return 0;
|
|
||||||
}
|
|
14
mtr.spec
14
mtr.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A network diagnostic tool
|
Summary: A network diagnostic tool
|
||||||
Name: mtr
|
Name: mtr
|
||||||
Version: 0.75
|
Version: 0.79
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
@ -10,8 +10,6 @@ Source: ftp://ftp.bitwizard.nl/mtr/%{name}-%{version}.tar.gz
|
|||||||
Source1: xmtr.consolehelper
|
Source1: xmtr.consolehelper
|
||||||
Source2: xmtr.pam
|
Source2: xmtr.pam
|
||||||
Source3: net-x%{name}.desktop
|
Source3: net-x%{name}.desktop
|
||||||
Patch0: mtr-0.75-fd-flags.path
|
|
||||||
Patch1: mtr075-rh516603.patch
|
|
||||||
BuildRequires: ncurses-devel gtk2-devel desktop-file-utils
|
BuildRequires: ncurses-devel gtk2-devel desktop-file-utils
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -34,8 +32,6 @@ diagnostic tool.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .fd-flags
|
|
||||||
%patch1 -p1 -b .rh516603
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --enable-gtk2
|
%configure --enable-gtk2
|
||||||
@ -86,6 +82,12 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/pixmaps/mtr_icon.xpm
|
%{_datadir}/pixmaps/mtr_icon.xpm
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 2:0.79-1
|
||||||
|
- update to 0.79
|
||||||
|
- patches merged
|
||||||
|
- mtr-0.75-fd-flags.path
|
||||||
|
- mtr075-rh516603.patch
|
||||||
|
|
||||||
* Mon Dec 07 2009 Adam Tkac <atkac redhat com> 2:0.75-6
|
* Mon Dec 07 2009 Adam Tkac <atkac redhat com> 2:0.75-6
|
||||||
- install mtr as SUID binary (#518828)
|
- install mtr as SUID binary (#518828)
|
||||||
- use fprintf instead of perror when getaddrinfo fails (#516603)
|
- use fprintf instead of perror when getaddrinfo fails (#516603)
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up mtr-0.75/mtr.c.rh516603 mtr-0.75/mtr.c
|
|
||||||
--- mtr-0.75/mtr.c.rh516603 2009-12-07 14:27:27.281726685 +0100
|
|
||||||
+++ mtr-0.75/mtr.c 2009-12-07 14:28:32.574226121 +0100
|
|
||||||
@@ -402,7 +402,7 @@ int main(int argc, char **argv)
|
|
||||||
hints.ai_socktype = SOCK_DGRAM;
|
|
||||||
error = getaddrinfo( Hostname, NULL, &hints, &res );
|
|
||||||
if ( error ) {
|
|
||||||
- perror( gai_strerror(error) );
|
|
||||||
+ fprintf(stderr, "%s\n", gai_strerror(error));
|
|
||||||
exit( EXIT_FAILURE );
|
|
||||||
}
|
|
||||||
/* Convert the first addrinfo into a hostent. */
|
|
Loading…
Reference in New Issue
Block a user