Updated to 0.73 Fixed mtr-0.69-CVE-2002-0497.patch Added build requirement
for GTK+
This commit is contained in:
parent
b8f20dc6d6
commit
81c7a7b03b
@ -1 +1 @@
|
||||
mtr-0.72.tar.gz
|
||||
mtr-0.73.tar.gz
|
||||
|
@ -203,21 +203,3 @@
|
||||
strlongip(ip));
|
||||
restell(tempstring);
|
||||
}
|
||||
--- mtr-0.69/split.c.CVE-2002-0497 2005-01-11 09:34:07.000000000 +0100
|
||||
+++ mtr-0.69/split.c 2005-02-09 18:13:58.000000000 +0100
|
||||
@@ -103,13 +103,13 @@
|
||||
name = dns_lookup(addr);
|
||||
if(name != NULL) {
|
||||
/* May be we should test name's length */
|
||||
- sprintf(newLine, "%s %d %d %d %d %d %d", name,
|
||||
+ snprintf(newLine, sizeof(newLine), "%s %d %d %d %d %d %d", name,
|
||||
net_loss(at),
|
||||
net_returned(at), net_xmit(at),
|
||||
net_best(at) /1000, net_avg(at)/1000,
|
||||
net_worst(at)/1000);
|
||||
} else {
|
||||
- sprintf(newLine, "%s %d %d %d %d %d %d",
|
||||
+ snprintf(newLine, sizeof(newLine), "%s %d %d %d %d %d %d",
|
||||
strlongip( addr ),
|
||||
net_loss(at),
|
||||
net_returned(at), net_xmit(at),
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- mtr-0.71/dns.c.mar 2006-07-03 07:53:28.000000000 +0200
|
||||
+++ mtr-0.71/dns.c 2006-07-03 07:52:26.000000000 +0200
|
||||
@@ -1357,7 +1357,7 @@
|
||||
#ifdef ENABLE_IPV6
|
||||
/* Returns an ip6.arpa character string. */
|
||||
void addr2ip6arpa( ip_t * ip, char * buf ) {
|
||||
- char * p = (char *) ip;
|
||||
+ unsigned char * p = (unsigned char *) ip;
|
||||
char * b = buf;
|
||||
int i;
|
||||
|
15
mtr.spec
15
mtr.spec
@ -1,7 +1,7 @@
|
||||
Summary: A network diagnostic tool
|
||||
Name: mtr
|
||||
Version: 0.72
|
||||
Release: 4%{?dist}
|
||||
Version: 0.73
|
||||
Release: 1%{?dist}
|
||||
Epoch: 2
|
||||
Group: Applications/Internet
|
||||
License: GPLv2+
|
||||
@ -13,7 +13,7 @@ Source3: net-x%{name}.desktop
|
||||
Patch1: mtr-0.69-CVE-2002-0497.patch
|
||||
Patch2: mtr-0.69-format.patch
|
||||
Patch3: mtr-0.71-underflow.patch
|
||||
BuildRequires: ncurses-devel gtk2-devel desktop-file-utils
|
||||
BuildRequires: ncurses-devel gtk2-devel desktop-file-utils gtk+-devel
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -40,8 +40,10 @@ diagnostic tool.
|
||||
%patch3 -p1 -b .underflow
|
||||
|
||||
%build
|
||||
# mtr-0.73 has an error in ./configure, we need to create new one
|
||||
autoreconf
|
||||
%configure --enable-gtk2
|
||||
make && mv mtr xmtr && make distclean
|
||||
make %{?_smp_mflags} && mv mtr xmtr && make distclean
|
||||
%configure --without-gtk
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -88,6 +90,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/pixmaps/mtr_icon.xpm
|
||||
|
||||
%changelog
|
||||
* Wed May 21 2008 Zdenek Prikryl <zprikryl@redhat.com> - 2:0.73
|
||||
- Updated to 0.73
|
||||
- Fixed mtr-0.69-CVE-2002-0497.patch
|
||||
- Added build requirement for GTK+
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2:0.72-4
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user