Rebase to 0.92

Resolves: #1458265
This commit is contained in:
Michal Sekletar 2017-08-27 10:34:17 +02:00
parent 70d195ab8f
commit 743d0796a9
4 changed files with 57 additions and 83 deletions

12
.gitignore vendored
View File

@ -1,11 +1 @@
mtr-0.79.tar.gz
/mtr-0.80.tar.gz
/mtr-0.81.tar.gz
/mtr-0.82.tar.gz
/mtr-0.83.tar.gz
/mtr-0.84.tar.gz
/mtr-0.85.tar.gz
/mtr-0.85.tar.xz
/generate-tarball.sh
/mtr-0.86.tar.gz
/mtr-0.87.tar.gz
/mtr-*.tar.gz

View File

@ -1,30 +0,0 @@
From 119a0e33ee6a023f32b256b8bafa5f972ecc480f Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Tue, 28 Feb 2017 12:29:55 +0100
Subject: [PATCH] Don't copy Makefile.dist to Makefile in distclean
Note that make doesn't wait for this background task to finish. During
rpm build we are building mtr twice. After first build we call
distclean. If second invocation of configure script runs in less than 3
seconds then the Makefile generated by configure will be overwritten by
background copy. We don't want that and since we are calling configure
explicitly we don't really need this "feature" at all.
---
Makefile.am | 1 -
1 file changed, 1 deletion(-)
diff --git a/Makefile.am b/Makefile.am
index fa9a2dd..adf43c0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,7 +44,6 @@ version.h: version.h.tmp Makefile $(mtr_SOURCES)
EXTRA_DIST = SECURITY mtr.8 Makefile Makefile.dist
distclean-local:
- (sleep 3; cp Makefile.dist Makefile) &
rm -f *.orig
DISTCLEANFILES = *~
--
2.9.3

View File

@ -1,14 +1,14 @@
%global _hardened_build 1
Summary: A network diagnostic tool
Summary: Network diagnostic tool combining 'traceroute' and 'ping'
Name: mtr
Version: 0.87
Release: 6%{?dist}
Version: 0.92
Release: 1%{?dist}
Epoch: 2
Group: Applications/Internet
License: GPLv2+
URL: http://www.BitWizard.nl/mtr
Source: https://github.com/traviscross/mtr/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
License: GPLv2
URL: https://www.bitwizard.nl/mtr/
Source0: https://github.com/traviscross/mtr/archive/v%{version}/%{name}-%{version}.tar.gz
Source1: net-x%{name}.desktop
Source2: mtr-gtk-pkexec-wrapper.sh
Source3: org.fedoraproject.mtr.policy
@ -16,71 +16,85 @@ Source3: org.fedoraproject.mtr.policy
BuildRequires: ncurses-devel gtk2-devel desktop-file-utils
BuildRequires: autoconf automake libtool git
Patch1: 0001-Don-t-copy-Makefile.dist-to-Makefile-in-distclean.patch
%description
Mtr is a network diagnostic tool that combines ping and traceroute
into one program. Mtr provides two interfaces: an ncurses interface,
useful for using Mtr from a telnet session; and a GTK+ interface for X
(provided in the mtr-gtk package).
MTR combines the functionality of the 'traceroute' and 'ping' programs
in a single network diagnostic tool.
When MTR is started, it investigates the network connection between the
host MTR runs on and the user-specified destination host. Afterwards it
determines the address of each network hop between the machines and sends
a sequence of ICMP echo requests to each one to determine the quality of
the link to each machine. While doing this, it prints running statistics
about each machine.
MTR provides two user interfaces: an ncurses interface, useful for the
command line, e.g. for SSH sessions; and a GTK+ interface for X (provided
in the mtr-gtk package).
%package gtk
Summary: The GTK+ interface for mtr
Summary: GTK+ interface for MTR
Group: Applications/Internet
Requires: mtr = %{epoch}:%{version}-%{release}
Requires: %{name} = %{epoch}:%{version}-%{release}
%description gtk
The mtr-gtk package provides the GTK+ interface for the mtr network
diagnostic tool.
MTR combines the functionality of the 'traceroute' and 'ping' programs
in a single network diagnostic tool. The mtr-gtk package provides the
GTK+ interface for MTR.
When MTR is started, it investigates the network connection between the
host MTR runs on and the user-specified destination host. Afterwards it
determines the address of each network hop between the machines and sends
a sequence of ICMP echo requests to each one to determine the quality of
the link to each machine. While doing this, it prints running statistics
about each machine.
%prep
%setup -q
%autopatch
%build
export CFLAGS="%{optflags} -fPIE"
export LDFLAGS="-z now -pie"
# Upstream forgot to ship .tarball-version
echo "%{version}" > .tarball-version
./bootstrap.sh
%configure --enable-gtk2
make %{?_smp_mflags} && mv mtr xmtr.bin && make distclean
%configure --with-gtk
%make_build && mv -f mtr xmtr.bin && make distclean
%configure --without-gtk
make %{?_smp_mflags}
%make_build
%install
install -D -p -m 0755 mtr %{buildroot}/%{_sbindir}/mtr
install -D -p -m 0755 xmtr.bin %{buildroot}/%{_bindir}/xmtr.bin
install -D -p -m 0755 %{SOURCE2} %{buildroot}/%{_bindir}/xmtr
install -D -p -m 644 %{SOURCE3} %{buildroot}/%{_datadir}/polkit-1/actions/org.fedoraproject.mtr.policy
install -D -p -m 644 img/mtr_icon.xpm %{buildroot}/%{_datadir}/pixmaps/mtr_icon.xpm
make DESTDIR=%{buildroot} install
desktop-file-install \
%if 0%{?fedora} && 0%{?fedora} < 19
--vendor="fedora"\
%endif
--dir=%{buildroot}/%{_datadir}/applications\
%{SOURCE1}
install -D -p -m 0755 mtr %{buildroot}%{_sbindir}/mtr
install -D -p -m 0755 xmtr.bin %{buildroot}%{_bindir}/xmtr.bin
install -D -p -m 0755 %{SOURCE2} %{buildroot}%{_bindir}/xmtr
install -D -p -m 0644 %{SOURCE3} %{buildroot}%{_datadir}/polkit-1/actions/org.fedoraproject.mtr.policy
install -D -p -m 0644 img/mtr_icon.xpm %{buildroot}%{_datadir}/pixmaps/mtr_icon.xpm
%make_install
desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE1}
%files
%defattr(-,root,root,-)
%doc AUTHORS COPYING FORMATS NEWS README SECURITY
%caps(cap_net_raw=pe) %{_sbindir}/mtr
%{!?_licensedir:%global license %%doc}
%license COPYING
%doc AUTHORS FORMATS NEWS README SECURITY
%{_sbindir}/%{name}
%caps(cap_net_raw=pe) %{_sbindir}/%{name}-packet
%{_mandir}/man8/*
%dir %{_datadir}/bash-completion/
%dir %{_datadir}/bash-completion/completions/
%{_datadir}/bash-completion/completions/%{name}
%files gtk
%defattr(-,root,root,-)
%{_bindir}/xmtr
%{_bindir}/xmtr.bin
%{_datadir}/pixmaps/mtr_icon.xpm
%{_datadir}/polkit-1/actions/org.fedoraproject.mtr.policy
%if 0%{?fedora} && 0%{?fedora} < 19
%{_datadir}/applications/fedora-net-x%{name}.desktop
%else
%{_datadir}/applications/net-x%{name}.desktop
%endif
%changelog
* Sat Aug 26 2017 Robert Scheck <robert@fedoraproject.org> - 2:0.92-1
- Rebase to 0.92 (#1458265)
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2:0.87-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (mtr-0.87.tar.gz) = 05cbe3928fef348e9c0794ad5b20e3c33c9319155d7c15eb16dc247e26812a1d16ff2fe2631f463fa15ee632f1e8ca4045866ff5ea7e6bbb8bb1e1e6a604b98c
SHA512 (mtr-0.92.tar.gz) = 576da5717f0abf849f5583bdd09790fb14a3b7538289192ac0d41bfa2a1c8e5bc9ec11bff87c5b348e85b5fe6f70f046d1d897e506e597b6f00d56bc918c0450