- /* impossible? if( totusec < 0 ) totusec = 0 */;
- /* sometimes < 0 */ totusec = abs(totusec);
This commit is contained in:
parent
2ac1af437f
commit
22da837052
14
mtr-0.71-underflow.patch
Normal file
14
mtr-0.71-underflow.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
--- mtr-0.71/net.c.fix 2006-03-24 07:37:17.000000000 +0100
|
||||||
|
+++ mtr-0.71/net.c 2006-05-30 08:52:50.000000000 +0200
|
||||||
|
@@ -354,8 +354,9 @@
|
||||||
|
|
||||||
|
totusec = (now.tv_sec - sequence[seq].time.tv_sec ) * 1000000 +
|
||||||
|
(now.tv_usec - sequence[seq].time.tv_usec);
|
||||||
|
- /* impossible? if( totusec < 0 ) totusec = 0 */;
|
||||||
|
-
|
||||||
|
+ /* sometimes < 0 */
|
||||||
|
+ totusec = abs(totusec);
|
||||||
|
+
|
||||||
|
if ( addrcmp( (void *) &(host[index].addr),
|
||||||
|
(void *) &unspec_addr, af ) == 0 ) {
|
||||||
|
// should be out of if as addr can change
|
7
mtr.spec
7
mtr.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A network diagnostic tool.
|
Summary: A network diagnostic tool.
|
||||||
Name: mtr
|
Name: mtr
|
||||||
Version: 0.71
|
Version: 0.71
|
||||||
Release: 1
|
Release: 2
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
License: GPL
|
License: GPL
|
||||||
@ -11,6 +11,7 @@ Source1: xmtr.consolehelper
|
|||||||
Source2: xmtr.pam
|
Source2: xmtr.pam
|
||||||
Patch1: mtr-0.69-CVE-2002-0497.patch
|
Patch1: mtr-0.69-CVE-2002-0497.patch
|
||||||
Patch2: mtr-0.69-format.patch
|
Patch2: mtr-0.69-format.patch
|
||||||
|
Patch3: mtr-0.71-underflow.patch
|
||||||
BuildRequires: ncurses-devel gtk2-devel
|
BuildRequires: ncurses-devel gtk2-devel
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||||
@ -35,6 +36,7 @@ diagnostic tool.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .CVE-2002-0497
|
%patch1 -p1 -b .CVE-2002-0497
|
||||||
%patch2 -p1 -b .format
|
%patch2 -p1 -b .format
|
||||||
|
%patch3 -p1 -b .underflow
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --enable-gtk2
|
%configure --enable-gtk2
|
||||||
@ -91,6 +93,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/pixmaps/mtr_icon.xpm
|
%{_datadir}/pixmaps/mtr_icon.xpm
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 30 2006 Marcela Maslanova <mmaslano@redhat.com> - 2:0.71-2
|
||||||
|
- underflow solved
|
||||||
|
|
||||||
* Fri Mar 24 2006 Miroslav Lichvar <mlichvar@redhat.com> - 2:0.71-1
|
* Fri Mar 24 2006 Miroslav Lichvar <mlichvar@redhat.com> - 2:0.71-1
|
||||||
- update to mtr-0.71
|
- update to mtr-0.71
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user