--- mtr-0.71/dns.c.mar 2006-07-03 07:53:28.000000000 +0200
mtr-0.71/dns.c 2006-07-03 07:52:26.000000000 +0200 @@ -1357,7 +1357,7 @@ #ifdef ENABLE_IPV6 /* Returns an ip6.arpa character string. */ void addr2ip6arpa( ip_t * ip, char * buf ) { - char * p = (char *) ip; unsigned char * p = (unsigned char *) ip; char * b = buf; int i;
This commit is contained in:
parent
22da837052
commit
1e86198c1b
11
mtr-0.71-ipv6-resolvehostname.patch
Normal file
11
mtr-0.71-ipv6-resolvehostname.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- mtr-0.71/dns.c.mar 2006-07-03 07:53:28.000000000 +0200
|
||||||
|
+++ mtr-0.71/dns.c 2006-07-03 07:52:26.000000000 +0200
|
||||||
|
@@ -1357,7 +1357,7 @@
|
||||||
|
#ifdef ENABLE_IPV6
|
||||||
|
/* Returns an ip6.arpa character string. */
|
||||||
|
void addr2ip6arpa( ip_t * ip, char * buf ) {
|
||||||
|
- char * p = (char *) ip;
|
||||||
|
+ unsigned char * p = (unsigned char *) ip;
|
||||||
|
char * b = buf;
|
||||||
|
int i;
|
||||||
|
|
7
mtr.spec
7
mtr.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A network diagnostic tool.
|
Summary: A network diagnostic tool.
|
||||||
Name: mtr
|
Name: mtr
|
||||||
Version: 0.71
|
Version: 0.71
|
||||||
Release: 2
|
Release: 3
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
License: GPL
|
License: GPL
|
||||||
@ -12,6 +12,7 @@ Source2: xmtr.pam
|
|||||||
Patch1: mtr-0.69-CVE-2002-0497.patch
|
Patch1: mtr-0.69-CVE-2002-0497.patch
|
||||||
Patch2: mtr-0.69-format.patch
|
Patch2: mtr-0.69-format.patch
|
||||||
Patch3: mtr-0.71-underflow.patch
|
Patch3: mtr-0.71-underflow.patch
|
||||||
|
Patch4: mtr-0.71-ipv6-resolvehostname.patch
|
||||||
BuildRequires: ncurses-devel gtk2-devel
|
BuildRequires: ncurses-devel gtk2-devel
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||||
@ -37,6 +38,7 @@ diagnostic tool.
|
|||||||
%patch1 -p1 -b .CVE-2002-0497
|
%patch1 -p1 -b .CVE-2002-0497
|
||||||
%patch2 -p1 -b .format
|
%patch2 -p1 -b .format
|
||||||
%patch3 -p1 -b .underflow
|
%patch3 -p1 -b .underflow
|
||||||
|
%patch4 -p1 -b .resolvehostname
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --enable-gtk2
|
%configure --enable-gtk2
|
||||||
@ -93,6 +95,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/pixmaps/mtr_icon.xpm
|
%{_datadir}/pixmaps/mtr_icon.xpm
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 3 2006 Marcela Maslanova <mmaslano@redhat.com> - 2:0.71-3
|
||||||
|
- bugzilla #195458 – reverse-map bug in mtr and patch - resolving ipv6 hostname correctly
|
||||||
|
|
||||||
* Tue May 30 2006 Marcela Maslanova <mmaslano@redhat.com> - 2:0.71-2
|
* Tue May 30 2006 Marcela Maslanova <mmaslano@redhat.com> - 2:0.71-2
|
||||||
- underflow solved
|
- underflow solved
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user