updated to 3.9.11
This commit is contained in:
parent
48d00b2bc6
commit
92cf55d0a7
@ -1,2 +1 @@
|
||||
mtools-3.9.9.tar.bz2
|
||||
mtools-3.9.10.tar.bz2
|
||||
mtools-3.9.11.tar.bz2
|
||||
|
90
amuFormat.sh
90
amuFormat.sh
@ -1,90 +0,0 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
# amuFormat.sh Formats various types and sizes of PC-Cards, according to the
|
||||
# AMU-specification
|
||||
#
|
||||
# parameters: $1: Card Type: The Card Type is written as disk/volume-label
|
||||
# to the boot-record
|
||||
# The string should have a length of max. 11 characters.
|
||||
#
|
||||
# $2: Drive character (b:, c:)
|
||||
#
|
||||
# 10-12-2003 lct created
|
||||
#
|
||||
vers=1.4
|
||||
|
||||
#echo "debug: $0,$1,$2,$3,$4"
|
||||
|
||||
#
|
||||
# main()
|
||||
#
|
||||
if [ $# != 2 ] ; then
|
||||
cat <<-EOF
|
||||
|
||||
Usage: amuFormat.sh <Card Type> <drive>
|
||||
<Card Type> has to be defined in amuFormat.sh itself
|
||||
<drive> has to be defined in mtools.conf
|
||||
EOF
|
||||
exit 0
|
||||
fi
|
||||
|
||||
echo "amuFormat $vers started..."
|
||||
|
||||
drive=$2
|
||||
|
||||
case $1 in
|
||||
8MBCARD-FW)
|
||||
## using the f: or g: drive for fat12 formatting...
|
||||
## see mtools.conf file...
|
||||
case $2 in
|
||||
[bB]:) drive="f:" ;;
|
||||
[cC]:) drive="g:" ;;
|
||||
*) echo "Drive $2 not supported."; exit 1 ;;
|
||||
esac
|
||||
cylinders=245 heads=2 cluster_size=8
|
||||
;;
|
||||
32MBCARD-FW)
|
||||
#from amu_toolkit_0_6:
|
||||
#mformat -t489 -h4 -c4 -n32 -H32 -r32 -vPC-CARD -M512 -N0000 c:
|
||||
cylinders=489 heads=4 cluster_size=4
|
||||
;;
|
||||
64MBCARD-FW)
|
||||
echo "***** WARNING: untested on AvHMU, exiting *****"
|
||||
exit 1
|
||||
cylinders=245 heads=2 cluster_size=8
|
||||
;;
|
||||
1GBCARD-FW)
|
||||
# from amu_toolkit_0_6:
|
||||
#mformat -t2327 -h16 -c64 -n63 -H63 -r32 -v AMU-CARD -M512 -N 0000 c:
|
||||
echo "***** WARNING: untested on AvHMU *****"
|
||||
cylinders=2327 heads=16 cluster_size=64
|
||||
;;
|
||||
64MBCARDSAN)
|
||||
# from amu_toolkit_0_6:
|
||||
#mformat -t489 -h8 -c4 -n32 -H32 -r32 -v AMU-CARD -M512 -N 0000 c:
|
||||
cylinders=489 heads=8 cluster_size=4
|
||||
;;
|
||||
#
|
||||
# insert new cards here...
|
||||
#
|
||||
*)
|
||||
echo "Card not supported."
|
||||
exit 1
|
||||
;;
|
||||
esac
|
||||
|
||||
echo "Formatting card in slot $2 as $1"
|
||||
|
||||
## initialise partition table
|
||||
mpartition -I $drive
|
||||
|
||||
# write a partition table
|
||||
mpartition -c -t$cylinders -h$heads -s32 -b32 $drive
|
||||
|
||||
## write boot-record, two FATs and a root-directory
|
||||
mformat -c$cluster_size -v "$1" $drive
|
||||
|
||||
minfo $2
|
||||
mdir $2
|
||||
|
||||
echo "done."
|
@ -1,22 +0,0 @@
|
||||
--- mtools-3.9.9/mainloop.c.badc 2004-01-08 10:00:40.329589474 +0000
|
||||
+++ mtools-3.9.9/mainloop.c 2004-01-08 10:01:18.862998275 +0000
|
||||
@@ -328,7 +328,7 @@
|
||||
return ERROR_ONE;
|
||||
if(got_signal)
|
||||
return ret | ERROR_ONE;
|
||||
- if(doing_mcwd & !have_one)
|
||||
+ if(doing_mcwd && !have_one)
|
||||
return NO_CWD;
|
||||
return ret;
|
||||
}
|
||||
--- mtools-3.9.9/mpartition.c.badc 2004-12-10 17:02:04.252330515 +0000
|
||||
+++ mtools-3.9.9/mpartition.c 2004-12-10 17:04:27.784874153 +0000
|
||||
@@ -249,7 +249,7 @@
|
||||
fprintf(stderr,
|
||||
"Mtools version %s, dated %s\n", mversion, mdate);
|
||||
fprintf(stderr,
|
||||
- "Usage: %s [-pradcv] [-I [-B bootsect-template] [-s sectors] "
|
||||
+ "Usage: %s [-pradcv] [-I] [-B bootsect-template] [-s sectors] "
|
||||
"[-t cylinders] "
|
||||
"[-h heads] [-T type] [-b begin] [-l length] "
|
||||
"drive\n", progname);
|
@ -1,15 +0,0 @@
|
||||
--- mtools-3.9.9/stream.h.gcc4 2005-03-15 11:27:15.000000000 +0000
|
||||
+++ mtools-3.9.9/stream.h 2005-03-15 11:27:37.000000000 +0000
|
||||
@@ -25,10 +25,10 @@
|
||||
} Class_t;
|
||||
|
||||
#define READS(stream, buf, address, size) \
|
||||
-(stream)->Class->read( (stream), (char *) (buf), (address), (size) )
|
||||
+((stream)->Class->read)( (stream), (char *) (buf), (address), (size) )
|
||||
|
||||
#define WRITES(stream, buf, address, size) \
|
||||
-(stream)->Class->write( (stream), (char *) (buf), (address), (size) )
|
||||
+((stream)->Class->write)( (stream), (char *) (buf), (address), (size) )
|
||||
|
||||
#define SET_GEOM(stream, dev, orig_dev, media, boot) \
|
||||
(stream)->Class->set_geom( (stream), (dev), (orig_dev), (media), (boot) )
|
@ -1,13 +0,0 @@
|
||||
--- mtools-3.9.9/fat.c.memset 2005-03-21 11:23:10.000000000 +0000
|
||||
+++ mtools-3.9.9/fat.c 2005-03-21 11:23:36.000000000 +0000
|
||||
@@ -437,8 +437,8 @@
|
||||
InfoSector_t *infoSector;
|
||||
infoSector = (InfoSector_t *) safe_malloc(This->sector_size);
|
||||
set_dword(infoSector->signature1, INFOSECT_SIGNATURE1);
|
||||
- memset(infoSector->filler1, sizeof(infoSector->filler1),0);
|
||||
- memset(infoSector->filler2, sizeof(infoSector->filler2),0);
|
||||
+ memset(infoSector->filler1, 0, sizeof(infoSector->filler1));
|
||||
+ memset(infoSector->filler2, 0, sizeof(infoSector->filler2));
|
||||
set_dword(infoSector->signature2, INFOSECT_SIGNATURE2);
|
||||
set_dword(infoSector->pos, This->last);
|
||||
set_dword(infoSector->count, This->freeSpace);
|
16
mtools.spec
16
mtools.spec
@ -1,20 +1,16 @@
|
||||
Summary: Programs for accessing MS-DOS disks without mounting the disks
|
||||
Name: mtools
|
||||
Version: 3.9.10
|
||||
Release: 7%{?dist}
|
||||
Version: 3.9.11
|
||||
Release: 1%{?dist}
|
||||
License: GPL
|
||||
Group: Applications/System
|
||||
Source: http://mtools.linux.lu/mtools-%{version}.tar.bz2
|
||||
Source1: amuFormat.sh
|
||||
Url: http://mtools.linux.lu/
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Patch0: mtools-3.9.6-config.patch
|
||||
Patch1: mtools-3.9.6-paths.patch
|
||||
Patch2: mtools-gcc4.patch
|
||||
Patch3: mtools-3.9.7-bigdisk.patch
|
||||
Patch4: mtools-3.9.9-noargs.patch
|
||||
Patch5: mtools-3.9.9-badc.patch
|
||||
Patch6: mtools-memset.patch
|
||||
Requires: info
|
||||
|
||||
BuildRequires: texinfo
|
||||
@ -31,15 +27,10 @@ Mtools should be installed if you need to use MS-DOS disks
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1 -b .gcc4
|
||||
%patch3 -p1 -b .big
|
||||
%patch4 -p1 -b .noargs
|
||||
%patch5 -p1 -b .badc
|
||||
%patch6 -p1 -b .memset
|
||||
|
||||
%build
|
||||
cp -f %{SOURCE1} scripts/
|
||||
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -73,6 +64,9 @@ fi
|
||||
%{_infodir}/*
|
||||
|
||||
%changelog
|
||||
* Wed May 31 2007 Adam Tkac <atkac redhat com> 3.9.11-1.fc8
|
||||
- updated to latest upstream (3.9.11)
|
||||
|
||||
* Fri May 11 2007 Adam Tkac <atkac redhat com> 3.9.10-7.fc7
|
||||
- in the end script has been completely rewriten by <skasal@redhat.com>
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user