import mt-st-1.1-24.el8

This commit is contained in:
CentOS Sources 2019-05-07 02:48:14 -04:00 committed by Andrew Lukoshko
commit be64c78542
13 changed files with 781 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/mt-st-1.1.tar.gz

1
.mt-st.metadata Normal file
View File

@ -0,0 +1 @@
e42d7fb0f57ccbd5c791e3b968e0a4573e7f9857 SOURCES/mt-st-1.1.tar.gz

View File

@ -0,0 +1,172 @@
--- mt-st-0.8/stinit.def.examples.configfiles 2002-09-23 19:02:21.000000000 +0200
+++ mt-st-0.8/stinit.def.examples 2005-04-07 08:21:01.732633520 +0200
@@ -56,3 +56,169 @@
mode3 blocksize=0 density=1 # 800 bpi
}
+# DLT2000 / 2000XT
+manufacturer="QUANTUM" model = "DLT2000" {
+scsi2logical=1
+can-bsr
+auto-lock=0
+two-fms=0
+drive-buffering=1
+buffer-writes
+read-ahead=1
+async-writes=1
+can-partitions=0
+fast-mteom=1
+#
+# If your stinit supports the timeouts:
+timeout=3600 # 1 hour
+long-timeout=14400 # 4 hours
+#
+mode1 blocksize=0 density=0x81 # 10GB + compression on DLTtape III, 15+ with DLTtape IIIXT in 2000XT
+mode2 blocksize=0 density=0x80 # 10GB, no compression on DLTtape III, 15 with DLTtape IIIXT in 2000XT
+mode3 blocksize=0 density=0x18 # 6GB, compression not available, on DLTtape III
+mode4 blocksize=0 density=0x17 #2.6GB, compression not available, on DLTtape III
+}
+
+# DLT4000
+manufacturer="QUANTUM" model = "DLT4000" {
+scsi2logical=1
+can-bsr
+auto-lock=0
+two-fms=0
+drive-buffering=1
+buffer-writes
+read-ahead=1
+async-writes=1
+can-partitions=0
+fast-mteom=1
+#
+# If your stinit supports the timeouts:
+timeout=3600 # 1 hour
+long-timeout=14400 # 4 hours
+#
+# Drive is backwards compatible, use older modes (e.g. from above) as required
+mode1 blocksize=0 density=0x83 # 20GB + compression
+mode2 blocksize=0 density=0x82 # 20GB, no compression
+mode3 blocksize=0 density=0x81 # 10GB + compression (DLT2000 mode) with DLTtape III, 15+ with DLTtape IIIXT in 2000XT
+mode4 blocksize=0 density=0x80 # 10GB, no compression (DLT2000 mode) with DLTtape III, 15 with DLTtape IIIXT in 2000XT
+}
+
+# DLT7000
+manufacturer="QUANTUM" model = "DLT7000" {
+scsi2logical=1
+can-bsr
+auto-lock=0
+two-fms=0
+drive-buffering=1
+buffer-writes
+read-ahead=1
+async-writes=1
+can-partitions=0
+fast-mteom=1
+#
+# If your stinit supports the timeouts:
+timeout=3600 # 1 hour
+long-timeout=14400 # 4 hours
+#
+# Drive is backwards compatible, use older modes (e.g. from above) as required.
+mode1 blocksize=0 density=0x85 # 35GB + compression
+mode2 blocksize=0 density=0x84 # 35GB, no compression
+mode3 blocksize=0 density=0x83 # 20GB + compression (DLT4000 mode)
+mode4 blocksize=0 density=0x82 # 20GB, no compression (DLT4000 mode)
+}
+
+# DLT8000
+manufacturer="QUANTUM" model = "DLT8000" {
+scsi2logical=1
+can-bsr=1
+auto-lock=0
+two-fms=0
+drive-buffering=1
+buffer-writes
+read-ahead=1
+async-writes=1
+can-partitions=0
+fast-mteom=1
+#
+# If your stinit supports the timeouts:
+timeout=3600 # 1 hour
+long-timeout=14400 # 4 hours
+#
+# Drive is backwards compatible to DLT7000, use older modes (e.g. from above) as required. Modes <10GB (<0x19) not supported!
+mode1 blocksize=0 density=0x89 # 40GB + compression
+mode2 blocksize=0 density=0x88 # 40GB, no compression
+mode3 blocksize=0 density=0x85 # 35GB + compression (DLT7000 mode)
+mode4 blocksize=0 density=0x84 # 35GB, no compression (DLT7000 mode)
+}
+
+
+# SDLT220
+manufacturer="QUANTUM" model = "SuperDLT1" {
+scsi2logical=1
+can-bsr=1
+auto-lock=0
+two-fms=0
+drive-buffering=1
+buffer-writes
+read-ahead=1
+async-writes=1
+can-partitions=0
+fast-mteom=1
+#
+# If your stinit supports the timeouts:
+timeout=3600 # 1 hour
+long-timeout=14400 # 4 hours
+#
+# Drive is backwards read compatible to DLT4000/7000/8000. Mode settings are only required for writing, so no need to define any other modes here.
+mode1 blocksize=0 density=0x48 compression=1 # 110 GB + compression
+mode2 blocksize=0 density=0x48 compression=0 # 110 GB, no ompression
+}
+
+# SDLT320
+manufacturer="QUANTUM" model = "SDLT320" {
+scsi2logical=1
+can-bsr=1
+auto-lock=0
+two-fms=0
+drive-buffering=1
+buffer-writes
+read-ahead=1
+async-writes=1
+can-partitions=0
+fast-mteom=1
+#
+# If your stinit supports the timeouts:
+timeout=3600 # 1 hour
+long-timeout=14400 # 4 hours
+#
+# Drive is backwards write compatible to SDLT220 and read compatible to DLT4000/7000/8000. Mode settings are only required for writing, so we need only the SDL220/320 modes here
+mode1 blocksize=0 density=0x49 compression=1 # 160 GB + compression
+mode2 blocksize=0 density=0x49 compression=0 # 160 GB, no ompression
+mode3 blocksize=0 density=0x48 compression=1 # 110 GB + compression
+mode4 blocksize=0 density=0x48 compression=0 # 110 GB, no ompression
+}
+
+# SDLT600
+manufacturer="QUANTUM" model = "SDLT600" {
+scsi2logical=1
+can-bsr=1
+auto-lock=0
+two-fms=0
+drive-buffering=1
+buffer-writes
+read-ahead=1
+async-writes=1
+can-partitions=0
+fast-mteom=1
+#
+# If your stinit supports the timeouts:
+timeout=3600 # 1 hour
+long-timeout=14400 # 4 hours
+#
+# Drive is backwards read compatible to SDLT220/320 and VS160. Mode settings are only required for writing, so we need only the native SDLT600 mode here.
+mode1 blocksize=0 density=0x4a compression=1 # 300 GB + compression
+mode2 blocksize=0 density=0x4a compression=0 # 300 GB, no ompression
+mode3 blocksize=0 density=0x4a compression=1 # 300 GB + compression
+mode4 blocksize=0 density=0x4a compression=0 # 300 GB, no ompression
+}
+

View File

@ -0,0 +1,31 @@
--- mt-st-0.9b/mt.1.manfix 2005-08-21 20:53:50.000000000 +0200
+++ mt-st-0.9b/mt.1 2005-10-25 12:13:43.000000000 +0200
@@ -48,20 +48,22 @@
files.
The tape is positioned on the first block of the next file.
.IP fsfm
-Forward space
+Forward space past
.I count
-files.
-The tape is positioned on the last block of the previous file.
+file marks, then backward space one file record.
+This leaves the tape positioned on the last block of the file that is count-1
+files past the current file.
.IP bsf
Backward space
.I count
files.
The tape is positioned on the last block of the previous file.
.IP bsfm
-Backward space
+Backward space past
.I count
-files.
-The tape is positioned on the first block of the next file.
+file marks, then forward space one file record.
+This leaves the tape positioned on the first block of the file that is count-1
+files before the current file.
.IP asf
The tape is positioned at the beginning of the
.I count

View File

@ -0,0 +1,11 @@
--- mt-st-1.1/mt.c.sdlt 2008-04-27 18:49:00.000000000 +0200
+++ mt-st-1.1/mt.c 2008-08-04 08:21:54.000000000 +0200
@@ -225,6 +225,8 @@
{0x45, "QIC-3095-MC (TR-4)"},
{0x46, "LTO-4"},
{0x47, "DDS-5 or TR-5"},
+ {0x48, "Quantum SDLT220"},
+ {0x49, "Quantum SDLT320"},
{0x51, "IBM 3592 J1A"},
{0x52, "IBM 3592 E05"},
{0x80, "DLT 15GB uncomp. or Ecrix"},

View File

@ -0,0 +1,117 @@
diff -Nur mt-st-1.1_old/debugfiles.list mt-st-1.1/debugfiles.list
--- mt-st-1.1_old/debugfiles.list 1970-01-01 08:00:00.000000000 +0800
+++ mt-st-1.1/debugfiles.list 2018-09-14 05:51:39.368918861 +0800
@@ -0,0 +1,8 @@
+%dir /usr/lib/debug
+%dir /usr/lib/debug/usr
+%dir /usr/lib/debug/usr/bin
+%dir /usr/lib/debug/usr/sbin
+%dir /usr/lib/debug/.dwz
+/usr/lib/debug/usr/bin/mt-1.1-22.fc28.x86_64.debug
+/usr/lib/debug/usr/sbin/stinit-1.1-22.fc28.x86_64.debug
+/usr/lib/debug/.dwz/mt-st-1.1-22.fc28.x86_64
diff -Nur mt-st-1.1_old/debugsourcefiles.list mt-st-1.1/debugsourcefiles.list
--- mt-st-1.1_old/debugsourcefiles.list 1970-01-01 08:00:00.000000000 +0800
+++ mt-st-1.1/debugsourcefiles.list 2018-09-14 05:51:39.371085528 +0800
@@ -0,0 +1 @@
+/usr/src/debug/mt-st-1.1-22.fc28.x86_64
Binary files mt-st-1.1_old/debugsources.list and mt-st-1.1/debugsources.list differ
diff -Nur mt-st-1.1_old/elfbins.list mt-st-1.1/elfbins.list
--- mt-st-1.1_old/elfbins.list 1970-01-01 08:00:00.000000000 +0800
+++ mt-st-1.1/elfbins.list 2018-09-14 05:51:39.341835530 +0800
@@ -0,0 +1,2 @@
+.//usr/bin/mt
+.//usr/sbin/stinit
diff -Nur mt-st-1.1_old/mt.c mt-st-1.1/mt.c
--- mt-st-1.1_old/mt.c 2018-09-13 12:19:35.156610050 +0800
+++ mt-st-1.1/mt.c 2018-09-14 05:52:08.509500057 +0800
@@ -280,7 +280,7 @@
int
main(int argc, char **argv)
{
- int mtfd, cmd_code, i, argn, len, oflags;
+ int mtfd, i, argn, len, oflags;
char *cmdstr;
cmdef_tr *comp, *comp2;
@@ -351,7 +351,6 @@
comp->cmd_name);
exit(1);
}
- cmd_code = comp->cmd_code;
if (comp->cmd_fdtype != NO_FD) {
oflags = comp->cmd_fdtype == FD_RDONLY ? O_RDONLY : O_RDWR;
@@ -390,23 +389,23 @@
usage(int explain)
{
int ind;
- char line[100];
+ int counter = 0;
fprintf(stderr, "usage: mt [-v] [--version] [-h] [ -f device ] command [ count ]\n");
if (explain) {
for (ind=0; cmds[ind].cmd_name != NULL; ) {
if (ind == 0)
- strcpy(line, "commands: ");
+ counter = fprintf(stderr, "commands: ");
else
- strcpy(line, " ");
+ counter = fprintf(stderr, " ");
for ( ; cmds[ind].cmd_name != NULL; ind++) {
- strcat(line, cmds[ind].cmd_name);
+ counter += fprintf(stderr, "%s", cmds[ind].cmd_name);
if (cmds[ind+1].cmd_name != NULL)
- strcat(line, ", ");
+ counter += fprintf(stderr, ", ");
else
- strcat(line, ".");
- if (strlen(line) >= 70 || cmds[ind+1].cmd_name == NULL) {
- fprintf(stderr, "%s\n", line);
+ counter += fprintf(stderr, ".");
+ if (counter >= 70 || cmds[ind+1].cmd_name == NULL) {
+ fprintf(stderr, "\n");
ind++;
break;
}
@@ -736,6 +735,8 @@
if ((fd = open(fname, O_RDONLY)) < 0 ||
read(fd, buf, 20) < 0) {
fprintf(stderr, "Can't read the sysfs file '%s'.\n", fname);
+ if (fd >= 0)
+ close(fd);
return 2;
}
close(fd);
diff -Nur mt-st-1.1_old/stinit.c mt-st-1.1/stinit.c
--- mt-st-1.1_old/stinit.c 2018-09-13 12:19:35.151610044 +0800
+++ mt-st-1.1/stinit.c 2018-09-14 05:51:38.644168915 +0800
@@ -148,7 +148,7 @@
else
for (cp2=cp+1; isalnum(*cp2) || *cp2 == '-'; cp2++)
;
- if (cp2 == '\0')
+ if (*cp2 == '\0')
return NULL;
have_arg = TRUE;
argp = cp;
@@ -349,8 +349,7 @@
continue;
}
- strcpy(defstr, comptr);
- strcat(defstr, cp);
+ snprintf(defstr, sizeof(defstr)/sizeof(char), "%s%s", comptr, cp);
*nextdef = c;
if (verbose > 1)
@@ -451,9 +450,6 @@
static int sg_io_errcheck(struct sg_io_hdr *hdp)
{
- int status;
-
- status = hdp->status & 0x7e;
if ((hdp->status & 0x7e) == 0 || hdp->host_status == 0 ||
hdp->driver_status == 0)
return 0;

View File

@ -0,0 +1,63 @@
From 78c0868407b59bbfdd1301fe5c1b57831b53c26e Mon Sep 17 00:00:00 2001
From: Jan Chaloupka <jchaloup@redhat.com>
Date: Thu, 21 Aug 2014 12:46:44 +0200
Subject: [PATCH] mt missing options section
---
mt.1 | 33 ++++++++++++++++++---------------
1 file changed, 18 insertions(+), 15 deletions(-)
diff --git a/mt.1 b/mt.1
index 8ff5b63..7dccdee 100644
--- a/mt.1
+++ b/mt.1
@@ -13,21 +13,7 @@ performs the given
which must be one of the tape operations listed below, on a tape
drive. The commands can also be listed by running the program with the
.I \-h
-option. The version of mt is printed with the
-.I \-v
-or
-.I \-\-version
-option. The path of the tape device on which to operate can be given with
-the
-.I \-f
-or
-.I \-t
-option. If neither of those options is given, and the environment
-variable
-.B TAPE
-is set, it is used. Otherwise, a default device defined in the file
-.I /usr/include/sys/mtio.h
-is used.
+option.
.PP
Some operations optionally take an argument or repeat count, which can be given
after the operation name and defaults to 1. The postfix
@@ -275,6 +261,23 @@ set the cleaning request interpretation parameters.
exits with a status of 0 if the operation succeeded, 1 if the
operation or device name given was invalid, or 2 if the operation
failed.
+.SH OPTIONS
+.TP
+.B \-h, \-\-help
+Print a usage message on standard output and exit successfully.
+.TP
+.B \-v, \-\-version
+Print version of mt.
+.TP
+.B \-f, \-t
+The path of the tape device on which to operate.
+If neither of those options is given,
+and the environment variable
+.B TAPE
+is set, it is used.
+Otherwise, a default device defined in the file
+.I /usr/include/sys/mtio.h
+is used.
.SH AUTHOR
The program is written by Kai Makisara <Kai.Makisara@kolumbus.fi>.
.SH COPYRIGHT
--
1.9.3

View File

@ -0,0 +1,22 @@
--- mt-st-1.1/mt.c.mtio 2008-08-04 08:24:45.000000000 +0200
+++ mt-st-1.1/mt.c 2008-08-04 08:24:45.000000000 +0200
@@ -23,7 +23,7 @@
#include <sys/stat.h>
#include <sys/utsname.h>
-#include "mtio.h"
+#include <linux/mtio.h>
#ifndef DEFTAPE
#define DEFTAPE "/dev/tape" /* default tape device */
--- mt-st-1.1/stinit.c.mtio 2008-04-27 13:24:16.000000000 +0200
+++ mt-st-1.1/stinit.c 2008-08-04 08:24:45.000000000 +0200
@@ -22,7 +22,7 @@
#include <linux/major.h>
#include <scsi/sg.h>
-#include "mtio.h"
+#include <linux/mtio.h>
#ifndef FALSE
#define TRUE 1

View File

@ -0,0 +1,12 @@
diff -up mt-st-1.1/stinit.c.options mt-st-1.1/stinit.c
--- mt-st-1.1/stinit.c.options 2013-07-23 11:55:33.000000000 +0200
+++ mt-st-1.1/stinit.c 2013-07-23 11:56:09.000000000 +0200
@@ -889,7 +889,7 @@ define_tape(int tapeno, FILE *dbf, devde
usage(int retval)
{
fprintf(stderr,
- "Usage: stinit [-h] [-v] [-f dbname] [-p] [drivename_or_number ...]\n");
+ "Usage: stinit [-h] [-v] [--version] [-f dbname] [-p] [-r] [drivename_or_number ...]\n");
exit(retval);
}

View File

@ -0,0 +1,32 @@
--- mt-st-1.1/Makefile.redhat 2008-03-01 11:50:12.000000000 +0100
+++ mt-st-1.1/Makefile 2008-08-04 08:20:01.000000000 +0200
@@ -1,8 +1,9 @@
-CFLAGS= -Wall -O2
-SBINDIR= /sbin
-BINDIR= /bin
-USRBINDIR= /usr/bin
-MANDIR= /usr/share/man
+CFLAGS= $(RPM_OPT_FLAGS)
+SBINDIR= $(RPM_BUILD_ROOT)/usr/sbin
+BINDIR= $(RPM_BUILD_ROOT)/usr/bin
+USRBINDIR= $(RPM_BUILD_ROOT)/usr/bin
+MANDIR= $(RPM_BUILD_ROOT)/usr/share/man
+CC=gcc
MTDIR=$(BINDIR)
@@ -15,11 +16,12 @@
$(CC) $(CFLAGS) -o stinit stinit.c
install: mt stinit
- install -s mt $(MTDIR)
+ mkdir -p $(BINDIR) $(SBINDIR) $(MANDIR)/man1 $(MANDIR)/man8
+ install -m 755 mt $(BINDIR)
install -c -m 444 mt.1 $(MANDIR)/man1
(if [ -f $(MANDIR)/man1/mt.1.gz ] ; then \
rm -f $(MANDIR)/man1/mt.1.gz; gzip $(MANDIR)/man1/mt.1; fi)
- install -s stinit $(SBINDIR)
+ install -m 755 stinit $(SBINDIR)
install -c -m 444 stinit.8 $(MANDIR)/man8
(if [ -f $(MANDIR)/man8/stinit.8.gz ] ; then \
rm -f $(MANDIR)/man8/stinit.8.gz; gzip $(MANDIR)/man8/stinit.8; fi)

View File

@ -0,0 +1,11 @@
diff -Nur mt-st-1.1_old/mt.c mt-st-1.1/mt.c
--- mt-st-1.1_old/mt.c 2018-08-09 12:47:25.997552769 -0400
+++ mt-st-1.1/mt.c 2018-08-09 12:49:02.764150055 -0400
@@ -19,6 +19,7 @@
#include <errno.h>
#include <fcntl.h>
#include <sys/types.h>
+#include <sys/sysmacros.h>
#include <sys/ioctl.h>
#include <sys/stat.h>
#include <sys/utsname.h>

10
SOURCES/stinit.service Normal file
View File

@ -0,0 +1,10 @@
[Unit]
Description=Initialize SCSI Tape Drives
[Service]
Type=oneshot
RemainAfterExit=yes
ExecStart=/sbin/stinit -f /etc/stinit.def
[Install]
WantedBy=multi-user.target

298
SPECS/mt-st.spec Normal file
View File

@ -0,0 +1,298 @@
Summary: Tool for controlling tape drives
Name: mt-st
Version: 1.1
Release: 24%{?dist}
License: GPL+
Group: Applications/System
URL: ftp://ftp.ibiblio.org/pub/linux/system/backup
Source0: ftp://metalab.unc.edu/pub/Linux/system/backup/mt-st-%{version}.tar.gz
Source1: stinit.service
Patch0: mt-st-1.1-redhat.patch
Patch1: mt-st-1.1-SDLT.patch
Patch2: mt-st-0.7-config-files.patch
Patch3: mt-st-0.9b-manfix.patch
Patch4: mt-st-1.1-mtio.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=948457
Patch5: mt-st-1.1-options.patch
Patch6: mt-st-1.1-man.patch
Patch7: mt-st-1.1-sysmacros.patch
Patch8: mt-st-1.1-covscan.patch
BuildRequires: systemd
Requires(post): systemd
Requires(preun): systemd
Requires(postun): systemd
%description
The mt-st package contains the mt and st tape drive management
programs. Mt (for magnetic tape drives) and st (for SCSI tape devices)
can control rewinding, ejecting, skipping files and blocks and more.
Install mt-st if you need a tool to manage tape drives.
%prep
%setup -q
%patch0 -p1 -b .redhat
%patch1 -p1 -b .sdlt
%patch2 -p1 -b .configfiles
%patch3 -p1 -b .manfix
%patch4 -p1 -b .mtio
%patch5 -p1 -b .options
%patch6 -p1 -b .man
%patch7 -p1 -b .sysmacros
%patch8 -p1 -b .covscan
# fix encoding
f=README.stinit
iconv -f ISO8859-1 -t UTF-8 -o $f.new $f
touch -r $f $f.new
mv $f.new $f
%build
RPM_OPT_FLAGS="$RPM_OPT_FLAGS -pie -Wl,-z,now" make
%install
make install
install -D -p -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_unitdir}/stinit.service
%post
%systemd_post stinit.service
%preun
%systemd_preun stinit.service
%postun
%systemd_postun_with_restart stinit.service
%files
%doc COPYING README README.stinit mt-st-1.1.lsm stinit.def.examples
%{_bindir}/mt
%{_sbindir}/stinit
%{_mandir}/man[18]/*
%{_unitdir}/stinit.service
%changelog
* Wed Oct 10 2018 Gris Ge <fge@redhat.com> - 1.1-24
- Fix annocheck distro failure of '-Wl,-z,now'. (RHBZ#1624146)
* Fri Sep 14 2018 Gris Ge <fge@redhat.com> - 1.1-23
- Fix covscan. (RHBZ#1628439)
* Thu Sep 06 2018 Gris Ge <fge@redhat.com> - 1.1-22
- Fix annocheck distro flag failure of 'stack protection'. (RHBZ#1624146)
* Fri Aug 10 2018 Gris Ge <fge@redhat.com> 1.1-21
- Fix build failure of missing defination of `minor()`.
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1-20
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1-18
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.1-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-16
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Fri Aug 22 2014 Dan Horák <dan[at]danny.cz> - 1.1-15
- update man page (#948457)
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Tue Jul 23 2013 Dan Horák <dan[at]danny.cz> - 1.1-11
- print all options in stinit's help (#948457)
- switch to systemd scriptlet macros
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Tue Nov 20 2012 Dan Horák <dan[at]danny.cz> - 1.1-9
- spec cleanup
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Thu Apr 19 2012 Jon Ciesla <limburgher@gmail.com> - 1.1-7
- Migrate to systemd, BZ 789926.
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Thu Nov 26 2009 Dan Horák <dan[at]danny.cz> - 1.1-4
- stinit initscript updated (#541592)
- fixed License
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Mon Aug 4 2008 Dan Horak <dan[at]danny.cz> - 1.1-1
- update to upstream version 1.1
- rebase patches
* Mon May 26 2008 Radek Brich <rbrich@redhat.com> - 0.9b-6
- add init script to call /sbin/stinit (#249665)
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9b-5
- Autorebuild for GCC 4.3
* Thu Aug 23 2007 Jindrich Novy <jnovy@redhat.com> - 0.9b-4
- update License
- rebuild for BuildID
* Wed Feb 7 2007 Jindrich Novy <jnovy@redhat.com> - 0.9b-3
- spec fixes
- use mtio.h from kernel-headers instead of the mt-st one
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.9b-2.2.2
- rebuild
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9b-2.2.1
- bump again for double-long bug on ppc(64)
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9b-2.2
- rebuilt for new gcc4.1 snapshot and glibc changes
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- rebuilt
* Tue Oct 25 2005 Jindrich Novy <jnovy@redhat.com> 0.9b-2
- fix misleading description of "fsfm" and "bsfm" commands (#171340)
* Thu Sep 22 2005 Jindrich Novy <jnovy@redhat.com> 0.9b-1
- update to mt-st 0.9b
* Thu Apr 7 2005 Jindrich Novy <jnovy@redhat.com> 0.8-5
- add SDLT600 entry to stinit.def.examples,
suggested by Ralf-Peter Rohbeck (#153305)
* Fri Mar 4 2005 Jindrich Novy <jnovy@redhat.com> 0.8-4
- rebuilt with gcc4
* Thu Feb 10 2005 Jindrich Novy <jnovy@redhat.com> 0.8-3
- remove -D_FORTIFY_SOURCE=2 from CFLAGS, present in RPM_OPT_FLAGS
* Wed Feb 9 2005 Jindrich Novy <jnovy@redhat.com> 0.8-2
- rebuilt with -D_FORTIFY_SOURCE=2
* Mon Aug 09 2004 Jindrich Novy <jnovy@redhat.com> 0.8-1
- updated to 0.8
- updated .redhat patch
- license fixup to GPL
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Mon May 26 2003 Than Ngo <than@redhat.com> 0.7-11.1
- add config file for Quantum DLT drive bug #91550
* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Sat Feb 22 2003 Than Ngo <than@redhat.com> 0.7-9
- add density code for Quantum SDLT320 from tibbs@math.uh.edu (#84843)
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
- rebuilt
* Wed Dec 11 2002 Tim Powers <timp@redhat.com> 0.7-7
- rebuild on all arches
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
- automated rebuild
* Wed Jun 19 2002 Than Ngo <than@redhat.com> 0.7-5
- don't forcibly strip binaries
- clean up a patch file
* Thu May 23 2002 Tim Powers <timp@redhat.com>
- automated rebuild
* Tue Feb 26 2002 Than Ngo <than@redhat.com> 0.7-3
- rebuild
* Wed Feb 20 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.7-2
- Add density code 0x48 for Quantum SDLT220 tape drive (#59442)
* Tue Feb 19 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.7-1
- Update to 0.7
* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
- automated rebuild
* Tue Apr 24 2001 Than Ngo <than@redhat.com>
- update to 0.6, supports all ioctls up to kernel 2.4.0
* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
- summaries from specspo.
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
- automatic rebuild
* Wed Jun 14 2000 Jeff Johnson <jbj@redhat.com>
- FHS packaging.
* Sat Apr 15 2000 Jeff Johnson <jbj@redhat.com>
- permit leading whitespace in config file.
- cortrect spelling error.
* Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
- handle compressed manpages
* Fri Jan 14 2000 Jeff Johnson <jbj@redhat.com>
- rebuild for Red Hat 6.2.
* Sun Sep 5 1999 Jeff Johnson <jbj@redhat.com>
- enable "datcompression" command (#3654).
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
- auto rebuild in the new build environment (release 3)
* Wed Feb 10 1999 Preston Brown <pbrown@redhat.com>
- upgrade to .5b, which fixes some cmd. line arg issues (bugzilla #18)
* Thu Jul 23 1998 Jeff Johnson <jbj@redhat.com>
- package for 5.2.
* Sun Jul 19 1998 Andrea Borgia <borgia@cs.unibo.it>
- updated to version 0.5
- removed the touch to force the build: no binaries are included!
- added to the docs: README.stinit, stinit.def.examples
- made buildroot capable
* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
- translations modified for de, fr, tr
* Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
- spec file cleanups
* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
- built against glibc