- Update to latest tagged release.
- Drop support for GCJ ahead of time compilation. - Fix RHBZ #627688, RHBZ #631076 - This project now builds with maven instead of ant. - The new build in this release aggregates javadocs, so now we have one javadoc package that obsoletes the many javadoc packages we had before. - Use new jar names that upstream use, provide the old names. - Misc other changes for guideline compliance.
This commit is contained in:
parent
034253f995
commit
da8646c271
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
msv-20050722.tar.gz
|
||||
/msv-2009.1.tar.gz
|
||||
|
@ -1,32 +0,0 @@
|
||||
/*
|
||||
* @(#)$Id: msv-20060821-Datatype.java,v 1.1 2007/03/12 14:54:43 mwringe Exp $
|
||||
*
|
||||
* Copyright 2001 Sun Microsystems, Inc. All Rights Reserved.
|
||||
*
|
||||
* This software is the proprietary information of Sun Microsystems, Inc.
|
||||
* Use is subject to license terms.
|
||||
*
|
||||
*/
|
||||
package com.sun.msv.datatype.xsd;
|
||||
|
||||
|
||||
/**
|
||||
* "date" type.
|
||||
*
|
||||
* type of the value object is {@link com.sun.msv.datatype.xsd.datetime.IDateTimeValueType}.
|
||||
* See http://www.w3.org/TR/xmlschema-2/#dateTime for the spec
|
||||
*
|
||||
* @author <a href="mailto:kohsuke.kawaguchi@eng.sun.com">Kohsuke KAWAGUCHI</a>
|
||||
*/
|
||||
public class DateType extends DateTimeBaseType {
|
||||
|
||||
public static final DateType theInstance = new DateType();
|
||||
private DateType() { super("date"); }
|
||||
|
||||
protected final String getFormat() {
|
||||
return "%Y-%M-%D%z";
|
||||
}
|
||||
|
||||
// serialization support
|
||||
private static final long serialVersionUID = 1;
|
||||
}
|
@ -1,23 +1,44 @@
|
||||
--- ./relames/src/com/sun/msv/schematron/verifier/RelmesVerifier.java.orig 2007-02-14 15:38:34.000000000 -0500
|
||||
+++ ./relames/src/com/sun/msv/schematron/verifier/RelmesVerifier.java 2007-02-14 15:39:44.000000000 -0500
|
||||
@@ -94,13 +94,13 @@
|
||||
--- relames/pom.xml.orig 2009-03-14 16:03:30.000000000 +0000
|
||||
+++ relames/pom.xml 2010-09-18 13:55:25.927247417 +0100
|
||||
@@ -3,12 +3,12 @@
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
<groupId>net.java.dev.msv</groupId>
|
||||
<artifactId>msv-relames</artifactId>
|
||||
- <version>2009.1-SNAPSHOT</version>
|
||||
+ <version>2009.1</version>
|
||||
<name>MSV Schematron Plugin</name>
|
||||
<parent>
|
||||
<groupId>net.java.dev.msv</groupId>
|
||||
<artifactId>msv-parent</artifactId>
|
||||
- <version>2009.1-SNAPSHOT</version>
|
||||
+ <version>2009.1</version>
|
||||
<relativePath>../parent/pom.xml</relativePath>
|
||||
</parent>
|
||||
|
||||
@@ -88,10 +88,6 @@
|
||||
<artifactId>isorelax</artifactId>
|
||||
</dependency>
|
||||
<dependency>
|
||||
- <groupId>crimson</groupId>
|
||||
- <artifactId>crimson</artifactId>
|
||||
- </dependency>
|
||||
- <dependency>
|
||||
<groupId>relaxngDatatype</groupId>
|
||||
<artifactId>relaxngDatatype</artifactId>
|
||||
</dependency>
|
||||
--- relames/src/com/sun/msv/schematron/verifier/RelmesVerifier.java.orig 2010-09-18 14:01:07.461250681 +0100
|
||||
+++ relames/src/com/sun/msv/schematron/verifier/RelmesVerifier.java 2010-09-18 14:01:18.194245268 +0100
|
||||
@@ -88,13 +88,6 @@
|
||||
} catch( Throwable t ) {
|
||||
; // ignore any error. it wasn't Xerces.
|
||||
// ignore any error. it wasn't Xerces.
|
||||
}
|
||||
- try {
|
||||
- // Crimson?
|
||||
- ((org.apache.crimson.tree.ElementNode2)super.parent)
|
||||
- .setIdAttributeName(atts.getQName(i));
|
||||
- } catch( Throwable t ) {
|
||||
- ; // ignore any error. it wasn't Crimson.
|
||||
- // ignore any error. it wasn't Crimson.
|
||||
- }
|
||||
+// try {
|
||||
+// // Crimson?
|
||||
+// ((org.apache.crimson.tree.ElementNode2)super.parent)
|
||||
+// .setIdAttributeName(atts.getQName(i));
|
||||
+// } catch( Throwable t ) {
|
||||
+// ; // ignore any error. it wasn't Crimson.
|
||||
+// }
|
||||
}
|
||||
}
|
||||
}
|
||||
|
24
msv-disable-maven-wagon-svn.patch
Normal file
24
msv-disable-maven-wagon-svn.patch
Normal file
@ -0,0 +1,24 @@
|
||||
--- pom.xml.orig 2009-06-10 19:33:50.000000000 +0100
|
||||
+++ pom.xml 2010-09-18 13:16:55.901247026 +0100
|
||||
@@ -62,6 +62,7 @@
|
||||
<module>msv</module>
|
||||
<module>generator</module>
|
||||
<module>rngconverter</module>
|
||||
+ <module>relames</module>
|
||||
</modules>
|
||||
|
||||
<profiles>
|
||||
@@ -188,13 +189,6 @@
|
||||
</plugin>
|
||||
</plugins>
|
||||
</pluginManagement>
|
||||
- <extensions>
|
||||
- <extension>
|
||||
- <groupId>org.jvnet.wagon-svn</groupId>
|
||||
- <artifactId>wagon-svn</artifactId>
|
||||
- <version>1.8</version>
|
||||
- </extension>
|
||||
- </extensions>
|
||||
</build>
|
||||
<reporting>
|
||||
<plugins>
|
@ -1,26 +0,0 @@
|
||||
diff -ur generator/MANIFEST.MF generator/MANIFEST.MF
|
||||
--- generator/MANIFEST.MF 2007-02-16 11:25:22.000000000 -0500
|
||||
+++ generator/MANIFEST.MF 2007-02-16 11:26:31.000000000 -0500
|
||||
@@ -1,5 +1,2 @@
|
||||
Manifest-Version: 1.0
|
||||
Main-Class: com.sun.msv.generator.Driver
|
||||
-Created-By: 1.2.2 (Sun Microsystems Inc.)
|
||||
-Class-Path: msv.jar xsdlib.jar relaxngDatatype.jar isorelax.jar xercesImpl.jar xmlParserAPIs.jar
|
||||
-
|
||||
diff -ur msv/MANIFEST.MF msv/MANIFEST.MF
|
||||
--- msv/MANIFEST.MF 2007-02-16 11:27:27.000000000 -0500
|
||||
+++ msv/MANIFEST.MF 2007-02-16 11:26:20.000000000 -0500
|
||||
@@ -1,4 +1,2 @@
|
||||
Manifest-Version: 1.0
|
||||
Main-Class: com.sun.msv.driver.textui.Driver
|
||||
-Created-By: 1.2.2 (Sun Microsystems Inc.)
|
||||
-Class-Path: xercesImpl.jar isorelax.jar relaxngDatatype.jar xsdlib.jar xmlParserAPIs.jar resolver.jar
|
||||
diff -ur rngconverter/MANIFEST.MF rngconverter/MANIFEST.MF
|
||||
--- rngconverter/MANIFEST.MF 2007-02-16 11:26:55.000000000 -0500
|
||||
+++ rngconverter/MANIFEST.MF 2007-02-16 11:27:05.000000000 -0500
|
||||
@@ -1,5 +1,2 @@
|
||||
Manifest-Version: 1.0
|
||||
Main-Class: com.sun.msv.writer.relaxng.Driver
|
||||
-Created-By: 1.2.2 (Sun Microsystems Inc.)
|
||||
-Class-Path: msv.jar xerces.jar
|
||||
-
|
564
msv.spec
564
msv.spec
@ -1,145 +1,79 @@
|
||||
# Copyright (c) 2000-2007, JPackage Project
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use in source and binary forms, with or without
|
||||
# modification, are permitted provided that the following conditions
|
||||
# are met:
|
||||
#
|
||||
# 1. Redistributions of source code must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
# 2. Redistributions in binary form must reproduce the above copyright
|
||||
# notice, this list of conditions and the following disclaimer in the
|
||||
# documentation and/or other materials provided with the
|
||||
# distribution.
|
||||
# 3. Neither the name of the JPackage Project nor the names of its
|
||||
# contributors may be used to endorse or promote products derived
|
||||
# from this software without specific prior written permission.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
||||
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
||||
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
|
||||
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
|
||||
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
||||
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
|
||||
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
|
||||
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
||||
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
|
||||
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
#
|
||||
|
||||
%define gcj_support 1
|
||||
|
||||
%define bootstrap %{?_with_bootstrap:1}%{!?_with_bootstrap:%{?_without_bootstrap:0}%{!?_without_bootstrap:%{?_bootstrap:%{_bootstrap}}%{!?_bootstrap:0}}}
|
||||
|
||||
%define cvsdate 20050722
|
||||
|
||||
Summary: Multischema Validator
|
||||
Name: msv
|
||||
Version: 1.2
|
||||
Release: 0.4.%{cvsdate}.3.4%{?dist}.1
|
||||
Epoch: 1
|
||||
License: BSD
|
||||
URL: http://msv.dev.java.net
|
||||
Version: 2009.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Multi-Schema Validator
|
||||
Group: Development/Libraries
|
||||
# cvs -d :pserver:guest@cvs.dev.java.net:/cvs export -r msv-20050722 msv ; mv msv msv-20050722 tar zcf msv-20050722.tar.gz msv-*
|
||||
Source0: %{name}-%{cvsdate}.tar.gz
|
||||
# cvs -d :pserver:guest@cvs.dev.java.net:/cvs co -r msv-20060821 msv/xsdlib/src/com/sun/msv/datatype/xsd/DateType.java
|
||||
# This is needed for the package to build
|
||||
Source1: %{name}-20060821-Datatype.java
|
||||
Patch0: %{name}-build_xmls.patch
|
||||
# There is a build time dependency on crimson which needs to be stripped
|
||||
Patch1: %{name}-disable-crimson.patch
|
||||
# Class-Path
|
||||
Patch2: %{name}-noclasspathsinmanifests.patch
|
||||
BuildRequires: ant >= 0:1.6, jpackage-utils >= 0:1.6
|
||||
BuildRequires: javacc
|
||||
BuildRequires: junit
|
||||
%if ! %{bootstrap}
|
||||
BuildRequires: jdom
|
||||
BuildRequires: saxon
|
||||
%endif
|
||||
License: BSD
|
||||
URL: https://msv.dev.java.net/
|
||||
|
||||
# To generate tarball from upstream source control:
|
||||
# $ svn export https://msv.dev.java.net/svn/msv/tags/msv-2009.1/ --username guest
|
||||
# $ tar zcf msv-2009.1.tar.gz msv-2009.1
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
|
||||
# The "maven-wagon-svn" plug-in is not in Fedora
|
||||
Patch0: %{name}-disable-maven-wagon-svn.patch
|
||||
|
||||
# There is a build time dependency on crimson which needs to be stripped
|
||||
# (We're using xerces-j2 instead)
|
||||
Patch1: %{name}-disable-crimson.patch
|
||||
|
||||
BuildRequires: java-devel
|
||||
BuildRequires: java-javadoc
|
||||
BuildRequires: jpackage-utils
|
||||
BuildRequires: maven-compiler-plugin
|
||||
BuildRequires: maven-install-plugin
|
||||
BuildRequires: maven-jar-plugin
|
||||
BuildRequires: maven-javadoc-plugin
|
||||
BuildRequires: maven-resources-plugin
|
||||
BuildRequires: maven-site-plugin
|
||||
BuildRequires: maven-surefire-maven-plugin
|
||||
BuildRequires: maven-surefire-provider-junit4
|
||||
BuildRequires: maven-plugin-build-helper
|
||||
BuildRequires: isorelax
|
||||
BuildRequires: relaxngDatatype
|
||||
BuildRequires: servlet
|
||||
BuildRequires: xalan-j2
|
||||
BuildRequires: xerces-j2
|
||||
BuildRequires: xml-commons-apis
|
||||
BuildRequires: xml-commons-resolver
|
||||
BuildRequires: ant-trax
|
||||
BuildRequires: java-javadoc
|
||||
BuildRequires: xerces-j2-javadoc-impl
|
||||
BuildRequires: xerces-j2-javadoc-xni
|
||||
BuildRequires: xerces-j2-javadoc-apis
|
||||
BuildRequires: isorelax-javadoc
|
||||
BuildRequires: relaxngDatatype-javadoc
|
||||
Requires: jpackage-utils >= 0:1.6
|
||||
Requires(postun): jpackage-utils >= 0:1.6
|
||||
|
||||
%if ! %{gcj_support}
|
||||
#BuildRequires: xerces-j2-javadoc-impl
|
||||
#BuildRequires: xerces-j2-javadoc-xni
|
||||
#BuildRequires: xerces-j2-javadoc-apis
|
||||
#BuildRequires: isorelax-javadoc
|
||||
#BuildRequires: relaxngDatatype-javadoc
|
||||
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
%if %{gcj_support}
|
||||
# Don't need this since java-gcj-compat-devel seems to fill these needs
|
||||
#BuildRequires: gnu-crypto
|
||||
BuildRequires: java-gcj-compat-devel
|
||||
Requires(post): java-gcj-compat
|
||||
Requires(postun): java-gcj-compat
|
||||
%endif
|
||||
|
||||
%description
|
||||
The Sun Multi-Schema XML Validator (MSV) is a Java
|
||||
technology tool to validate XML documents against
|
||||
several kinds of XML schemata. It supports RELAX NG,
|
||||
RELAX Namespace, RELAX Core, TREX, XML DTDs, and a
|
||||
subset of XML Schema Part 1. This latest (version 1.2)
|
||||
release includes several bug fixes and adds better
|
||||
conformance to RELAX NG/W3C XML standards and JAXP
|
||||
masquerading.
|
||||
The Sun Multi-Schema XML Validator (MSV) is a Java technology tool to validate
|
||||
XML documents against several kinds of XML schemata. It supports RELAX NG,
|
||||
RELAX Namespace, RELAX Core, TREX, XML DTDs, and a subset of XML Schema Part 1.
|
||||
This latest (version 1.2) release includes several bug fixes and adds better
|
||||
conformance to RELAX NG/W3C XML standards and JAXP masquerading.
|
||||
|
||||
%package msv
|
||||
Summary: MSV proper
|
||||
Summary: Multi-Schema Validator Core
|
||||
Group: Development/Libraries
|
||||
Requires: jpackage-utils
|
||||
Requires: java
|
||||
Requires: isorelax
|
||||
Requires: relaxngDatatype
|
||||
Requires: servlet
|
||||
Requires: xerces-j2
|
||||
Requires: xml-commons-apis
|
||||
Requires: xml-commons-resolver
|
||||
Requires: msv-xsdlib
|
||||
Requires: jpackage-utils >= 0:1.6
|
||||
Provides: msv-strict <= %{version}-%{release}
|
||||
Obsoletes: msv-strict <= %{version}-%{release}
|
||||
|
||||
%description msv
|
||||
%{summary}.
|
||||
|
||||
%package msv-javadoc
|
||||
Summary: Javadoc for MSV proper
|
||||
Group: Documentation
|
||||
Requires: jpackage-utils >= 0:1.6
|
||||
Provides: msv-strict-javadoc <= %{version}-%{release}
|
||||
Obsoletes: msv-strict-javadoc <= %{version}-%{release}
|
||||
|
||||
%description msv-javadoc
|
||||
%{summary}.
|
||||
|
||||
%package demo
|
||||
Summary: Samples for %{name}
|
||||
Group: Documentation
|
||||
Requires: msv-msv
|
||||
Requires: msv-xsdlib
|
||||
Requires: jpackage-utils >= 0:1.6
|
||||
|
||||
%description demo
|
||||
%{summary}.
|
||||
|
||||
%package relames
|
||||
Summary: Relames
|
||||
Summary: Multi-Schema Validator Schematron Plugin
|
||||
Group: Development/Libraries
|
||||
Requires: jpackage-utils
|
||||
Requires: java
|
||||
Requires: isorelax
|
||||
Requires: relaxngDatatype
|
||||
Requires: xalan-j2
|
||||
@ -148,342 +82,250 @@ Requires: xml-commons-apis
|
||||
Requires: xml-commons-resolver
|
||||
Requires: msv-msv
|
||||
Requires: msv-xsdlib
|
||||
Requires: jpackage-utils >= 0:1.6
|
||||
|
||||
%description relames
|
||||
%{summary}.
|
||||
|
||||
%package relames-javadoc
|
||||
Summary: Javadoc for relames
|
||||
Group: Documentation
|
||||
Requires: jpackage-utils >= 0:1.6
|
||||
|
||||
%description relames-javadoc
|
||||
%{summary}.
|
||||
|
||||
%package rngconv
|
||||
Summary: Rngconv
|
||||
Summary: Multi-Schema Validator RNG Converter
|
||||
Group: Development/Libraries
|
||||
Requires: jpackage-utils
|
||||
Requires: java
|
||||
Requires: isorelax
|
||||
Requires: relaxngDatatype
|
||||
Requires: xerces-j2
|
||||
Requires: xml-commons-apis
|
||||
Requires: xml-commons-resolver
|
||||
Requires: msv-msv
|
||||
Requires: msv-xsdlib
|
||||
Requires: jpackage-utils >= 0:1.6
|
||||
|
||||
%description rngconv
|
||||
%{summary}.
|
||||
|
||||
%package xmlgen
|
||||
Summary: XmlGen
|
||||
Summary: Multi-Schema Validator Generator
|
||||
Group: Development/Libraries
|
||||
Requires: jpackage-utils
|
||||
Requires: java
|
||||
Requires: isorelax
|
||||
Requires: relaxngDatatype
|
||||
Requires: xml-commons-apis
|
||||
Requires: xerces-j2
|
||||
Requires: xml-commons-apis
|
||||
Requires: xml-commons-resolver
|
||||
Requires: msv-msv
|
||||
Requires: msv-xsdlib
|
||||
Requires: jpackage-utils >= 0:1.6
|
||||
|
||||
%description xmlgen
|
||||
%{summary}.
|
||||
|
||||
%package xmlgen-javadoc
|
||||
Summary: Javadoc for xmlgen
|
||||
Group: Documentation
|
||||
Requires: jpackage-utils >= 0:1.6
|
||||
|
||||
%description xmlgen-javadoc
|
||||
%{summary}.
|
||||
|
||||
%package xsdlib
|
||||
Summary: Xsdlib
|
||||
Summary: Multi-Schema Validator XML Schema Library
|
||||
Group: Development/Libraries
|
||||
Requires: jpackage-utils
|
||||
Requires: java
|
||||
Requires: isorelax
|
||||
Requires: relaxngDatatype
|
||||
Provides: xsdlib <= %{version}-%{release}
|
||||
Obsoletes: xsdlib <= %{version}-%{release}
|
||||
Requires: jpackage-utils >= 0:1.6
|
||||
Requires: xerces-j2
|
||||
|
||||
# Can remove these obsoletes at Fedora 17 time
|
||||
Obsoletes: xsdlib < %{version}-%{release}
|
||||
|
||||
%description xsdlib
|
||||
%{summary}.
|
||||
|
||||
%package xsdlib-javadoc
|
||||
Summary: Javadoc for xsdlib
|
||||
%package javadoc
|
||||
Summary: API documentation for Multi-Schema Validator
|
||||
Group: Documentation
|
||||
Provides: xsdlib-javadoc <= %{version}-%{release}
|
||||
Obsoletes: xsdlib-javadoc <= %{version}-%{release}
|
||||
Requires: jpackage-utils >= 0:1.6
|
||||
Requires: java-javadoc
|
||||
Requires: jpackage-utils
|
||||
|
||||
%description xsdlib-javadoc
|
||||
# Can remove these obsoletes at Fedora 17 time
|
||||
Obsoletes: msv-msv-javadoc < %{version}-%{release}
|
||||
Obsoletes: msv-relames-javadoc < %{version}-%{release}
|
||||
Obsoletes: msv-xmlgen-javadoc < %{version}-%{release}
|
||||
Obsoletes: msv-xsdlib-javadoc < %{version}-%{release}
|
||||
Obsoletes: xsdlib-javadoc < %{version}-%{release}
|
||||
|
||||
%description javadoc
|
||||
%{summary}.
|
||||
|
||||
%package manual
|
||||
Summary: Documents for %{name}
|
||||
Summary: Manual for Multi-Schema Validator
|
||||
Group: Documentation
|
||||
Requires: jpackage-utils >= 0:1.6
|
||||
|
||||
%description manual
|
||||
%{summary}.
|
||||
|
||||
%package demo
|
||||
Summary: Samples for Multi-Schema Validator
|
||||
Group: Documentation
|
||||
Requires: msv-msv
|
||||
Requires: msv-xsdlib
|
||||
Requires: jpackage-utils
|
||||
|
||||
%description demo
|
||||
%{summary}.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{cvsdate}
|
||||
cp %{SOURCE1} xsdlib/src/com/sun/msv/datatype/xsd/DateType.java
|
||||
# remove all binary libs
|
||||
find . -name "*.jar" -exec rm -f {} \;
|
||||
# delete Class-Path: from manifests
|
||||
for m in $(find . -name MANIFEST.MF); do
|
||||
sed -e '/^Class-path:/d' $m > tempf
|
||||
cp tempf $m
|
||||
%setup -q
|
||||
|
||||
# Delete anything pre-compiled
|
||||
find -name '*.class' -exec rm -f '{}' \;
|
||||
find -name '*.jar' -exec rm -f '{}' \;
|
||||
find -name '*.zip' -exec rm -f '{}' \;
|
||||
|
||||
# Delete class-path entries from manifests
|
||||
for m in $(find . -name MANIFEST.MF) ; do
|
||||
sed --in-place -e '/^[Cc]lass-[Pp]ath:/d' $m
|
||||
done
|
||||
rm tempf
|
||||
|
||||
#change encoding of non utf-8 files
|
||||
iconv msv/doc/copyright.txt -f iso-8859-1 -t utf-8 -o msv/doc/copyright.txt.utf8
|
||||
mv msv/doc/copyright.txt.utf8 msv/doc/copyright.txt
|
||||
iconv relames/doc/copyright.txt -f iso-8859-1 -t utf-8 -o relames/doc/copyright.txt.utf8
|
||||
mv relames/doc/copyright.txt.utf8 relames/doc/copyright.txt
|
||||
iconv rngconverter/doc/copyright.txt -f iso-8859-1 -t utf-8 -o rngconverter/doc/copyright.txt.utf8
|
||||
mv rngconverter/doc/copyright.txt.utf8 rngconverter/doc/copyright.txt
|
||||
iconv generator/doc/copyright.txt -f iso-8859-1 -t utf-8 -o generator/doc/copyright.txt.utf8
|
||||
mv generator/doc/copyright.txt.utf8 generator/doc/copyright.txt
|
||||
iconv xsdlib/doc/copyright.txt -f iso-8859-1 -t utf-8 -o xsdlib/doc/copyright.txt.utf8
|
||||
mv xsdlib/doc/copyright.txt.utf8 xsdlib/doc/copyright.txt
|
||||
# Apply patches
|
||||
%patch0 -p0 -b .orig
|
||||
%patch1 -p0 -b .orig
|
||||
|
||||
|
||||
|
||||
%patch0 -b .sav
|
||||
%patch1 -b .sav2
|
||||
%patch2
|
||||
# Change encoding of non utf-8 files
|
||||
for m in $(find . -name copyright.txt) ; do
|
||||
iconv -f iso-8859-1 -t utf-8 < $m > $m.utf8
|
||||
mv $m.utf8 $m
|
||||
done
|
||||
|
||||
%build
|
||||
pushd shared/lib
|
||||
ln -sf $(build-classpath ant) ant.jar
|
||||
#ln -sf $(build-classpath crimson) crimson.jar
|
||||
#ln -sf $(build-classpath dom4j) dom4j.jar
|
||||
ln -sf $(build-classpath isorelax) isorelax.jar
|
||||
ln -sf $(build-classpath junit) junit.jar
|
||||
ln -sf $(build-classpath relaxngDatatype) relaxngDatatype.jar
|
||||
ln -sf $(build-classpath xml-commons-resolver) resolver.jar
|
||||
%if ! %{bootstrap}
|
||||
ln -sf $(build-classpath jdom) jdom.jar
|
||||
ln -sf $(build-classpath saxon) saxon.jar
|
||||
%endif
|
||||
ln -sf $(build-classpath servlet) servlet.jar
|
||||
ln -sf $(build-classpath xalan-j2) xalan.jar
|
||||
ln -sf $(build-classpath xerces-j2) xercesImpl.jar
|
||||
ln -sf $(build-classpath xml-commons-apis) xmlParserAPIs.jar
|
||||
popd
|
||||
export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
|
||||
mkdir -p $MAVEN_REPO_LOCAL
|
||||
|
||||
export ANT_OPTS=" -Dant.build.javac.source=1.4 -Dant.build.javac.target=1.4 "
|
||||
ant release
|
||||
|
||||
pushd msv/dist/examples
|
||||
# remove all prebuild classes
|
||||
find . -name "*.class" -exec rm -f {} \;
|
||||
popd
|
||||
|
||||
pushd xsdlib/dist/examples
|
||||
# remove all prebuild classes
|
||||
find . -name "*.class" -exec rm -f {} \;
|
||||
popd
|
||||
mvn-jpp -Dmaven.repo.local=$MAVEN_REPO_LOCAL \
|
||||
install javadoc:aggregate
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
rm -rf %{buildroot}
|
||||
|
||||
# jars
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
|
||||
# Jars
|
||||
install -pD -T msv/target/%{name}-core-%{version}.jar \
|
||||
%{buildroot}%{_javadir}/%{name}-core-%{version}.jar
|
||||
install -pD -T relames/target/%{name}-relames-%{version}.jar \
|
||||
%{buildroot}%{_javadir}/%{name}-relames-%{version}.jar
|
||||
install -pD -T rngconverter/target/%{name}-rngconverter-%{version}.jar \
|
||||
%{buildroot}%{_javadir}/%{name}-rngconverter-%{version}.jar
|
||||
install -pD -T generator/target/%{name}-generator-%{version}.jar \
|
||||
%{buildroot}%{_javadir}/%{name}-generator-%{version}.jar
|
||||
install -pD -T xsdlib/target/xsdlib-%{version}.jar \
|
||||
%{buildroot}%{_javadir}/xsdlib-%{version}.jar
|
||||
|
||||
install -m 644 package/msv.jar \
|
||||
$RPM_BUILD_ROOT%{_javadir}/%{name}-msv-%{version}.jar
|
||||
install -m 644 package/relames.jar \
|
||||
$RPM_BUILD_ROOT%{_javadir}/%{name}-relames-%{version}.jar
|
||||
install -m 644 package/rngconv.jar \
|
||||
$RPM_BUILD_ROOT%{_javadir}/%{name}-rngconv-%{version}.jar
|
||||
install -m 644 package/xmlgen.jar \
|
||||
$RPM_BUILD_ROOT%{_javadir}/%{name}-xmlgen-%{version}.jar
|
||||
install -m 644 package/xsdlib.jar \
|
||||
$RPM_BUILD_ROOT%{_javadir}/%{name}-xsdlib-%{version}.jar
|
||||
(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}.jar; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
|
||||
(cd $RPM_BUILD_ROOT%{_javadir}
|
||||
ln -sf msv-msv.jar msv-strict.jar
|
||||
ln -sf msv-xsdlib.jar xsdlib.jar
|
||||
)
|
||||
# Alternate jar names
|
||||
ln -s %{name}-core-%{version}.jar \
|
||||
%{buildroot}%{_javadir}/%{name}-msv-%{version}.jar
|
||||
ln -s %{name}-rngconverter-%{version}.jar \
|
||||
%{buildroot}%{_javadir}/%{name}-rngconv-%{version}.jar
|
||||
ln -s %{name}-generator-%{version}.jar \
|
||||
%{buildroot}%{_javadir}/%{name}-xmlgen-%{version}.jar
|
||||
ln -s xsdlib-%{version}.jar \
|
||||
%{buildroot}%{_javadir}/%{name}-xsdlib-%{version}.jar
|
||||
|
||||
# javadoc
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}/msv
|
||||
cp -pr msv/dist/javadoc/* \
|
||||
$RPM_BUILD_ROOT%{_javadocdir}/%{name}/msv
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}/relames
|
||||
cp -pr relames/dist/javadoc/* \
|
||||
$RPM_BUILD_ROOT%{_javadocdir}/%{name}/relames
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}/xmlgen
|
||||
cp -pr generator/dist/javadoc/* \
|
||||
$RPM_BUILD_ROOT%{_javadocdir}/%{name}/xmlgen
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}/xsdlib
|
||||
cp -pr xsdlib/dist/javadoc/* \
|
||||
$RPM_BUILD_ROOT%{_javadocdir}/%{name}/xsdlib
|
||||
# Versionless jar names
|
||||
(cd %{buildroot}%{_javadir} &&
|
||||
for jar in *-%{version}.jar ; do
|
||||
ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
|
||||
done)
|
||||
|
||||
# docs
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_docdir}/%{name}
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_docdir}/%{name}/msv
|
||||
install -m 644 msv/doc/* \
|
||||
$RPM_BUILD_ROOT%{_docdir}/%{name}/msv
|
||||
rm $RPM_BUILD_ROOT%{_docdir}/%{name}/msv/Apache-LICENSE-1.1.txt
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_docdir}/%{name}/relames
|
||||
install -m 644 relames/doc/* \
|
||||
$RPM_BUILD_ROOT%{_docdir}/%{name}/relames
|
||||
rm $RPM_BUILD_ROOT%{_docdir}/%{name}/relames/Apache-LICENSE-1.1.txt
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_docdir}/%{name}/rngconv
|
||||
install -m 644 rngconverter/doc/* \
|
||||
$RPM_BUILD_ROOT%{_docdir}/%{name}/rngconv
|
||||
rm $RPM_BUILD_ROOT%{_docdir}/%{name}/rngconv/Apache-LICENSE-1.1.txt
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_docdir}/%{name}/xmlgen
|
||||
install -m 644 generator/doc/* \
|
||||
$RPM_BUILD_ROOT%{_docdir}/%{name}/xmlgen
|
||||
rm $RPM_BUILD_ROOT%{_docdir}/%{name}/xmlgen/Apache-LICENSE-1.1.txt
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_docdir}/%{name}/xsdlib
|
||||
install -m 644 xsdlib/doc/* \
|
||||
$RPM_BUILD_ROOT%{_docdir}/%{name}/xsdlib
|
||||
rm $RPM_BUILD_ROOT%{_docdir}/%{name}/xsdlib/Apache-LICENSE-1.1.txt
|
||||
# Javadocs
|
||||
install -d -m 755 %{buildroot}%{_javadocdir}/%{name}-%{version}
|
||||
cp -pr target/site/apidocs/* %{buildroot}%{_javadocdir}/%{name}-%{version}
|
||||
ln -s %{name}-%{version} %{buildroot}%{_javadocdir}/%{name}
|
||||
|
||||
#examples
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}-%{version}/msv
|
||||
cp -pr msv/dist/examples/* $RPM_BUILD_ROOT%{_datadir}/%{name}-%{version}/msv
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}-%{version}/xsdlib
|
||||
cp -pr xsdlib/dist/examples/* $RPM_BUILD_ROOT%{_datadir}/%{name}-%{version}/xsdlib
|
||||
# Manuals
|
||||
install -d -m 755 %{buildroot}%{_docdir}/%{name}-%{version}/msv
|
||||
install -m 644 msv/doc/*.html %{buildroot}%{_docdir}/%{name}-%{version}/msv
|
||||
install -m 644 msv/doc/*.gif %{buildroot}%{_docdir}/%{name}-%{version}/msv
|
||||
install -m 644 msv/doc/README.txt %{buildroot}%{_docdir}/%{name}-%{version}/msv
|
||||
|
||||
%if %{gcj_support}
|
||||
#export CLASSPATH=$(build-classpath gnu-crypto)
|
||||
%{_bindir}/aot-compile-rpm
|
||||
%endif
|
||||
install -d -m 755 %{buildroot}%{_docdir}/%{name}-%{version}/relames
|
||||
install -m 644 relames/doc/README.txt %{buildroot}%{_docdir}/%{name}-%{version}/relames
|
||||
|
||||
install -d -m 755 %{buildroot}%{_docdir}/%{name}-%{version}/rngconverter
|
||||
install -m 644 rngconverter/doc/README.txt %{buildroot}%{_docdir}/%{name}-%{version}/rngconverter
|
||||
|
||||
install -d -m 755 %{buildroot}%{_docdir}/%{name}-%{version}/generator
|
||||
install -m 644 generator/doc/*.html %{buildroot}%{_docdir}/%{name}-%{version}/generator
|
||||
install -m 644 generator/doc/README.txt %{buildroot}%{_docdir}/%{name}-%{version}/generator
|
||||
|
||||
install -d -m 755 %{buildroot}%{_docdir}/%{name}-%{version}/xsdlib
|
||||
install -m 644 xsdlib/doc/*.html %{buildroot}%{_docdir}/%{name}-%{version}/xsdlib
|
||||
install -m 644 xsdlib/doc/README.txt %{buildroot}%{_docdir}/%{name}-%{version}/xsdlib
|
||||
|
||||
# Examples
|
||||
install -d -m 755 %{buildroot}%{_datadir}/%{name}-%{version}/msv
|
||||
cp -pr msv/examples/* %{buildroot}%{_datadir}/%{name}-%{version}/msv
|
||||
install -d -m 755 %{buildroot}%{_datadir}/%{name}-%{version}/xsdlib
|
||||
cp -pr xsdlib/examples/* %{buildroot}%{_datadir}/%{name}-%{version}/xsdlib
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%if %{gcj_support}
|
||||
%post
|
||||
if [ -x %{_bindir}/rebuild-gcj-db ]
|
||||
then
|
||||
%{_bindir}/rebuild-gcj-db
|
||||
fi
|
||||
%endif
|
||||
|
||||
%if %{gcj_support}
|
||||
%postun
|
||||
if [ -x %{_bindir}/rebuild-gcj-db ]
|
||||
then
|
||||
%{_bindir}/rebuild-gcj-db
|
||||
fi
|
||||
%endif
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%files msv
|
||||
%defattr(0644,root,root,0755)
|
||||
%defattr(-,root,root,-)
|
||||
%{_javadir}/%{name}-core-%{version}.jar
|
||||
%{_javadir}/%{name}-core.jar
|
||||
%{_javadir}/%{name}-msv-%{version}.jar
|
||||
%{_javadir}/%{name}-msv.jar
|
||||
%{_javadir}/msv-strict.jar
|
||||
%dir %doc %{_docdir}/%{name}
|
||||
%dir %doc %{_docdir}/%{name}/msv
|
||||
%doc %{_docdir}/%{name}/msv/license.txt
|
||||
%doc %{_docdir}/%{name}/msv/copyright.txt
|
||||
%if %{gcj_support}
|
||||
%dir %attr(-,root,root) %{_libdir}/gcj/%{name}
|
||||
%attr(-,root,root) %{_libdir}/gcj/%{name}/%{name}-msv*
|
||||
%endif
|
||||
|
||||
%files msv-javadoc
|
||||
%defattr(0644,root,root,0755)
|
||||
%dir %doc %{_javadocdir}/%{name}
|
||||
%doc %{_javadocdir}/%{name}/msv
|
||||
|
||||
%files demo
|
||||
%defattr(0644,root,root,0755)
|
||||
%dir %{_datadir}/%{name}-%{version}
|
||||
%{_datadir}/%{name}-%{version}/msv
|
||||
%{_datadir}/%{name}-%{version}/xsdlib
|
||||
%doc msv/doc/license.txt
|
||||
|
||||
%files relames
|
||||
%defattr(0644,root,root,0755)
|
||||
%defattr(-,root,root,-)
|
||||
%{_javadir}/%{name}-relames-%{version}.jar
|
||||
%{_javadir}/%{name}-relames.jar
|
||||
##%{_docdir}/%{name}/relames/license.txt
|
||||
%dir %doc %{_docdir}/%{name}/relames
|
||||
%doc %{_docdir}/%{name}/relames/copyright.txt
|
||||
%if %{gcj_support}
|
||||
%attr(-,root,root) %{_libdir}/gcj/%{name}/%{name}-relames*
|
||||
%endif
|
||||
|
||||
%files relames-javadoc
|
||||
%defattr(0644,root,root,0755)
|
||||
%dir %doc %{_javadocdir}/%{name}
|
||||
%doc %{_javadocdir}/%{name}/relames
|
||||
%doc relames/doc/copyright.txt
|
||||
|
||||
%files rngconv
|
||||
%defattr(0644,root,root,0755)
|
||||
%defattr(-,root,root,-)
|
||||
%{_javadir}/%{name}-rngconverter-%{version}.jar
|
||||
%{_javadir}/%{name}-rngconverter.jar
|
||||
%{_javadir}/%{name}-rngconv-%{version}.jar
|
||||
%{_javadir}/%{name}-rngconv.jar
|
||||
%dir %doc %{_docdir}/%{name}/rngconv
|
||||
%doc %{_docdir}/%{name}/rngconv/license.txt
|
||||
%doc %{_docdir}/%{name}/rngconv/copyright.txt
|
||||
%if %{gcj_support}
|
||||
%attr(-,root,root) %{_libdir}/gcj/%{name}/%{name}-rngconv*
|
||||
%endif
|
||||
%doc rngconverter/doc/license.txt
|
||||
%doc rngconverter/doc/copyright.txt
|
||||
|
||||
%files xmlgen
|
||||
%defattr(0644,root,root,0755)
|
||||
%defattr(-,root,root,-)
|
||||
%{_javadir}/%{name}-generator-%{version}.jar
|
||||
%{_javadir}/%{name}-generator.jar
|
||||
%{_javadir}/%{name}-xmlgen-%{version}.jar
|
||||
%{_javadir}/%{name}-xmlgen.jar
|
||||
%dir %doc %{_docdir}/%{name}/xmlgen
|
||||
%doc %{_docdir}/%{name}/xmlgen/license.txt
|
||||
%doc %{_docdir}/%{name}/xmlgen/copyright.txt
|
||||
%if %{gcj_support}
|
||||
%attr(-,root,root) %{_libdir}/gcj/%{name}/%{name}-xmlgen*
|
||||
%endif
|
||||
|
||||
%files xmlgen-javadoc
|
||||
%defattr(0644,root,root,0755)
|
||||
%dir %doc %{_javadocdir}/%{name}
|
||||
%doc %{_javadocdir}/%{name}/xmlgen
|
||||
%doc generator/doc/license.txt
|
||||
%doc generator/doc/copyright.txt
|
||||
|
||||
%files xsdlib
|
||||
%defattr(0644,root,root,0755)
|
||||
%defattr(-,root,root,-)
|
||||
%{_javadir}/xsdlib-%{version}.jar
|
||||
%{_javadir}/xsdlib.jar
|
||||
%{_javadir}/%{name}-xsdlib-%{version}.jar
|
||||
%{_javadir}/%{name}-xsdlib.jar
|
||||
%{_javadir}/xsdlib.jar
|
||||
%dir %doc %{_docdir}/%{name}/xsdlib
|
||||
%doc %{_docdir}/%{name}/xsdlib/license.txt
|
||||
%doc %{_docdir}/%{name}/xsdlib/copyright.txt
|
||||
%if %{gcj_support}
|
||||
%attr(-,root,root) %{_libdir}/gcj/%{name}/%{name}-xsdlib*
|
||||
%endif
|
||||
%doc xsdlib/doc/license.txt
|
||||
%doc xsdlib/doc/copyright.txt
|
||||
|
||||
%files xsdlib-javadoc
|
||||
%defattr(0644,root,root,0755)
|
||||
%dir %doc %{_javadocdir}/%{name}
|
||||
%doc %{_javadocdir}/%{name}/xsdlib
|
||||
%files javadoc
|
||||
%defattr(-,root,root,-)
|
||||
%{_javadocdir}/%{name}-%{version}
|
||||
%{_javadocdir}/%{name}
|
||||
|
||||
%files manual
|
||||
%defattr(0644,root,root,0755)
|
||||
%dir %doc %{_docdir}/%{name}
|
||||
%dir %doc %{_docdir}/%{name}/msv
|
||||
%doc %{_docdir}/%{name}/msv/ChangeLog.txt
|
||||
%doc %{_docdir}/%{name}/msv/*.html
|
||||
%doc %{_docdir}/%{name}/msv/*.gif
|
||||
%doc %{_docdir}/%{name}/msv/README.txt
|
||||
%dir %doc %{_docdir}/%{name}/relames
|
||||
%doc %{_docdir}/%{name}/relames/README.txt
|
||||
%dir %doc %{_docdir}/%{name}/rngconv
|
||||
%doc %{_docdir}/%{name}/rngconv/README.txt
|
||||
%dir %doc %{_docdir}/%{name}/xmlgen
|
||||
%doc %{_docdir}/%{name}/xmlgen/*.html
|
||||
%doc %{_docdir}/%{name}/xmlgen/README.txt
|
||||
%dir %doc %{_docdir}/%{name}/xsdlib
|
||||
%doc %{_docdir}/%{name}/xsdlib/*.html
|
||||
%doc %{_docdir}/%{name}/xsdlib/README.txt
|
||||
%defattr(-,root,root,-)
|
||||
%doc %{_docdir}/%{name}-%{version}
|
||||
|
||||
%files demo
|
||||
%defattr(-,root,root,-)
|
||||
%{_datadir}/%{name}-%{version}
|
||||
|
||||
%changelog
|
||||
* Thu Sep 16 2010 Mat Booth <fedora@matbooth.co.uk> - 1:2009.1-1
|
||||
- Update to latest tagged release.
|
||||
- Drop support for GCJ ahead of time compilation.
|
||||
- Fix RHBZ #627688, RHBZ #631076
|
||||
- This project now builds with maven instead of ant.
|
||||
- The new build in this release aggregates javadocs, so now we have one javadoc
|
||||
package that obsoletes the many javadoc packages we had before.
|
||||
- Use new jar names that upstream use, provide the old names.
|
||||
- Misc other changes for guideline compliance.
|
||||
|
||||
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.2-0.4.20050722.3.4.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user