Fix license tag for msv subpackage
- Remove unneeded patches
This commit is contained in:
parent
ab6091fa11
commit
8216c2ad5a
@ -1,24 +0,0 @@
|
|||||||
--- pom.xml.orig 2009-06-10 19:33:50.000000000 +0100
|
|
||||||
+++ pom.xml 2010-09-18 13:16:55.901247026 +0100
|
|
||||||
@@ -62,6 +62,7 @@
|
|
||||||
<module>msv</module>
|
|
||||||
<module>generator</module>
|
|
||||||
<module>rngconverter</module>
|
|
||||||
+ <module>relames</module>
|
|
||||||
</modules>
|
|
||||||
|
|
||||||
<profiles>
|
|
||||||
@@ -188,13 +189,6 @@
|
|
||||||
</plugin>
|
|
||||||
</plugins>
|
|
||||||
</pluginManagement>
|
|
||||||
- <extensions>
|
|
||||||
- <extension>
|
|
||||||
- <groupId>org.jvnet.wagon-svn</groupId>
|
|
||||||
- <artifactId>wagon-svn</artifactId>
|
|
||||||
- <version>1.8</version>
|
|
||||||
- </extension>
|
|
||||||
- </extensions>
|
|
||||||
</build>
|
|
||||||
<reporting>
|
|
||||||
<plugins>
|
|
@ -1,14 +0,0 @@
|
|||||||
--- pom.xml.orig2 2010-09-19 17:34:07.530248002 +0100
|
|
||||||
+++ pom.xml 2010-09-19 17:41:12.377247570 +0100
|
|
||||||
@@ -139,6 +139,11 @@
|
|
||||||
<bottom>MSV</bottom>
|
|
||||||
<javadocVersion>1.5</javadocVersion>
|
|
||||||
<encoding>UTF-8</encoding>
|
|
||||||
+ <links>
|
|
||||||
+ <link>/usr/share/javadoc/java/</link>
|
|
||||||
+ <link>/usr/share/javadoc/isorelax/</link>
|
|
||||||
+ <link>/usr/share/javadoc/relaxngDatatype/</link>
|
|
||||||
+ </links>
|
|
||||||
</configuration>
|
|
||||||
</plugin>
|
|
||||||
<plugin>
|
|
14
msv.spec
14
msv.spec
@ -1,7 +1,7 @@
|
|||||||
Name: msv
|
Name: msv
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2013.2.3
|
Version: 2013.2.3
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Multi-Schema Validator
|
Summary: Multi-Schema Validator
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
License: BSD and ASL 1.1
|
License: BSD and ASL 1.1
|
||||||
@ -15,6 +15,8 @@ Source0: %{name}-%{version}.tar.gz
|
|||||||
# Parent POM is no longer in svn, get it from Maven central repository
|
# Parent POM is no longer in svn, get it from Maven central repository
|
||||||
Source1: http://repo1.maven.org/maven2/net/java/dev/%{name}/%{name}-parent/2009.1/%{name}-parent-2009.1.pom
|
Source1: http://repo1.maven.org/maven2/net/java/dev/%{name}/%{name}-parent/2009.1/%{name}-parent-2009.1.pom
|
||||||
|
|
||||||
|
Source2: http://www.apache.org/licenses/LICENSE-2.0.txt
|
||||||
|
|
||||||
# There is a build time dependency on crimson which needs to be stripped
|
# There is a build time dependency on crimson which needs to be stripped
|
||||||
# (We're using xerces-j2 instead)
|
# (We're using xerces-j2 instead)
|
||||||
Patch0: %{name}-Disable-crimson.patch
|
Patch0: %{name}-Disable-crimson.patch
|
||||||
@ -57,6 +59,8 @@ conformance to RELAX NG/W3C XML standards and JAXP masquerading.
|
|||||||
%package msv
|
%package msv
|
||||||
Summary: Multi-Schema Validator Core
|
Summary: Multi-Schema Validator Core
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
|
# src/com/sun/msv/reader/xmlschema/DOMLSInputImpl.java is under ASL 2.0
|
||||||
|
License: BSD and ASL 1.1 and ASL 2.0
|
||||||
Requires: jpackage-utils
|
Requires: jpackage-utils
|
||||||
Requires: java
|
Requires: java
|
||||||
Requires: isorelax
|
Requires: isorelax
|
||||||
@ -174,6 +178,9 @@ Requires: jpackage-utils
|
|||||||
|
|
||||||
cp %{SOURCE1} parent-pom.xml
|
cp %{SOURCE1} parent-pom.xml
|
||||||
|
|
||||||
|
# ASL 2.0 license text
|
||||||
|
cp %{SOURCE2} Apache-LICENSE-2.0.txt
|
||||||
|
|
||||||
# Delete anything pre-compiled
|
# Delete anything pre-compiled
|
||||||
find -name '*.class' -exec rm -f '{}' \;
|
find -name '*.class' -exec rm -f '{}' \;
|
||||||
find -name '*.jar' -exec rm -f '{}' \;
|
find -name '*.jar' -exec rm -f '{}' \;
|
||||||
@ -287,6 +294,7 @@ cp -pr xsdlib/examples/* %{buildroot}%{_datadir}/%{name}-%{version}/xsdlib
|
|||||||
%{_javadir}/%{name}-testharness*
|
%{_javadir}/%{name}-testharness*
|
||||||
%doc msv/doc/license.txt
|
%doc msv/doc/license.txt
|
||||||
%doc msv/doc/Apache-LICENSE-1.1.txt
|
%doc msv/doc/Apache-LICENSE-1.1.txt
|
||||||
|
%doc Apache-LICENSE-2.0.txt
|
||||||
|
|
||||||
%files relames
|
%files relames
|
||||||
%{_bindir}/relames
|
%{_bindir}/relames
|
||||||
@ -335,6 +343,10 @@ cp -pr xsdlib/examples/* %{buildroot}%{_datadir}/%{name}-%{version}/xsdlib
|
|||||||
%{_datadir}/%{name}-%{version}
|
%{_datadir}/%{name}-%{version}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 12 2013 Michal Srb <msrb@redhat.com> - 1:2013.2.3-2
|
||||||
|
- Fix license tag for msv subpackage
|
||||||
|
- Remove unneeded patches
|
||||||
|
|
||||||
* Thu Apr 11 2013 Michal Srb <msrb@redhat.com> - 1:2013.2.3-1
|
* Thu Apr 11 2013 Michal Srb <msrb@redhat.com> - 1:2013.2.3-1
|
||||||
- Update to upstream version 2013.2.3
|
- Update to upstream version 2013.2.3
|
||||||
- Resolves: rhbz#876845
|
- Resolves: rhbz#876845
|
||||||
|
Loading…
Reference in New Issue
Block a user