Do not build module with unclear licensing (relames)
- Replace %add_to_maven_depmap with %add_maven_depmap
This commit is contained in:
parent
0955ef5b58
commit
7c5c080e1d
@ -14,7 +14,7 @@ svn co https://svn.java.net/svn/${NAME}~svn/tags/${NAME}-${VERSION}/ ${NAME}-${V
|
||||
# Remove things that we don't need
|
||||
(
|
||||
cd ${NAME}-${VERSION}
|
||||
rm -Rf www/ relames/doc/ relames/schemas
|
||||
rm -Rf www/ relames/ .svn/
|
||||
rm -Rf schmit/ shared/ tahiti/
|
||||
)
|
||||
|
||||
|
@ -1,61 +0,0 @@
|
||||
From 7473c0343eaaf0f9593ff26f29887f2ba7e10971 Mon Sep 17 00:00:00 2001
|
||||
From: Michal Srb <msrb@redhat.com>
|
||||
Date: Fri, 12 Apr 2013 08:34:07 +0200
|
||||
Subject: [PATCH] Disable crimson
|
||||
|
||||
---
|
||||
relames/pom.xml | 8 ++------
|
||||
relames/src/com/sun/msv/schematron/verifier/RelmesVerifier.java | 7 -------
|
||||
2 files changed, 2 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/relames/pom.xml b/relames/pom.xml
|
||||
index 69d8d91..0ef18ae 100644
|
||||
--- a/relames/pom.xml
|
||||
+++ b/relames/pom.xml
|
||||
@@ -3,12 +3,12 @@
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
<groupId>net.java.dev.msv</groupId>
|
||||
<artifactId>msv-relames</artifactId>
|
||||
- <version>2009.1-SNAPSHOT</version>
|
||||
+ <version>2009.1</version>
|
||||
<name>MSV Schematron Plugin</name>
|
||||
<parent>
|
||||
<groupId>net.java.dev.msv</groupId>
|
||||
<artifactId>msv-parent</artifactId>
|
||||
- <version>2009.1-SNAPSHOT</version>
|
||||
+ <version>2009.1</version>
|
||||
<relativePath>../parent/pom.xml</relativePath>
|
||||
</parent>
|
||||
|
||||
@@ -71,10 +71,6 @@
|
||||
<artifactId>isorelax</artifactId>
|
||||
</dependency>
|
||||
<dependency>
|
||||
- <groupId>crimson</groupId>
|
||||
- <artifactId>crimson</artifactId>
|
||||
- </dependency>
|
||||
- <dependency>
|
||||
<groupId>relaxngDatatype</groupId>
|
||||
<artifactId>relaxngDatatype</artifactId>
|
||||
</dependency>
|
||||
diff --git a/relames/src/com/sun/msv/schematron/verifier/RelmesVerifier.java b/relames/src/com/sun/msv/schematron/verifier/RelmesVerifier.java
|
||||
index cbc898c..8327180 100644
|
||||
--- a/relames/src/com/sun/msv/schematron/verifier/RelmesVerifier.java
|
||||
+++ b/relames/src/com/sun/msv/schematron/verifier/RelmesVerifier.java
|
||||
@@ -88,13 +88,6 @@ public class RelmesVerifier implements IVerifier {
|
||||
} catch( Throwable t ) {
|
||||
// ignore any error. it wasn't Xerces.
|
||||
}
|
||||
- try {
|
||||
- // Crimson?
|
||||
- ((org.apache.crimson.tree.ElementNode2)super.parent)
|
||||
- .setIdAttributeName(atts.getQName(i));
|
||||
- } catch( Throwable t ) {
|
||||
- // ignore any error. it wasn't Crimson.
|
||||
- }
|
||||
}
|
||||
}
|
||||
}
|
||||
--
|
||||
1.8.1.4
|
||||
|
60
msv.spec
60
msv.spec
@ -1,7 +1,7 @@
|
||||
Name: msv
|
||||
Epoch: 1
|
||||
Version: 2013.5.1
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Multi-Schema Validator
|
||||
Group: Development/Libraries
|
||||
License: BSD and ASL 1.1
|
||||
@ -16,10 +16,6 @@ Source1: http://repo1.maven.org/maven2/net/java/dev/%{name}/%{name}-parent
|
||||
|
||||
Source2: http://www.apache.org/licenses/LICENSE-2.0.txt
|
||||
|
||||
# There is a build time dependency on crimson which needs to be stripped
|
||||
# (We're using xerces-j2 instead)
|
||||
Patch0: %{name}-Disable-crimson.patch
|
||||
|
||||
# Use CatalogResolver from xml-commons-resolver package
|
||||
Patch1: %{name}-Use-CatalogResolver-class-from-xml-commons-resolver.patch
|
||||
|
||||
@ -49,6 +45,8 @@ BuildRequires: isorelax
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
Obsoletes: %{name}-relames < %{version}-%{release}
|
||||
|
||||
%description
|
||||
The Sun Multi-Schema XML Validator (MSV) is a Java technology tool to validate
|
||||
XML documents against several kinds of XML schemata. It supports RELAX NG,
|
||||
@ -71,21 +69,6 @@ Requires: msv-xsdlib
|
||||
%description msv
|
||||
%{summary}.
|
||||
|
||||
%package relames
|
||||
Summary: Multi-Schema Validator Schematron Plugin
|
||||
Group: Development/Libraries
|
||||
Requires: jpackage-utils
|
||||
Requires: java
|
||||
Requires: isorelax
|
||||
Requires: relaxngDatatype
|
||||
Requires: xalan-j2
|
||||
Requires: xerces-j2
|
||||
Requires: msv-msv
|
||||
Requires: msv-xsdlib
|
||||
|
||||
%description relames
|
||||
%{summary}.
|
||||
|
||||
%package rngconv
|
||||
Summary: Multi-Schema Validator RNG Converter
|
||||
Group: Development/Libraries
|
||||
@ -166,9 +149,6 @@ Requires: jpackage-utils
|
||||
# Needed becuase of patch3
|
||||
%pom_add_dep xml-resolver:xml-resolver
|
||||
|
||||
# Enable relames module
|
||||
%pom_xpath_inject "pom:modules" "<module>relames</module>"
|
||||
|
||||
cp %{SOURCE1} parent-pom.xml
|
||||
|
||||
# ASL 2.0 license text
|
||||
@ -185,14 +165,12 @@ for m in $(find . -name MANIFEST.MF) ; do
|
||||
done
|
||||
|
||||
# Apply patches
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
# Fix isorelax groupId
|
||||
%pom_xpath_replace "pom:dependency[pom:groupId[text()='com.sun.xml.bind.jaxb']]/pom:groupId" "<groupId>isorelax</groupId>"
|
||||
%pom_xpath_replace "pom:dependency[pom:groupId[text()='com.sun.xml.bind.jaxb']]/pom:groupId" "<groupId>isorelax</groupId>" generator
|
||||
%pom_xpath_replace "pom:dependency[pom:groupId[text()='com.sun.xml.bind.jaxb']]/pom:groupId" "<groupId>isorelax</groupId>" msv
|
||||
%pom_xpath_replace "pom:dependency[pom:groupId[text()='com.sun.xml.bind.jaxb']]/pom:groupId" "<groupId>isorelax</groupId>" relames
|
||||
%pom_xpath_replace "pom:dependency[pom:groupId[text()='com.sun.xml.bind.jaxb']]/pom:groupId" "<groupId>isorelax</groupId>" rngconverter
|
||||
%pom_xpath_replace "pom:dependency[pom:groupId[text()='com.sun.xml.bind.jaxb']]/pom:groupId" "<groupId>isorelax</groupId>" xsdlib
|
||||
|
||||
@ -209,8 +187,6 @@ mvn-rpmbuild install javadoc:aggregate
|
||||
# Jars
|
||||
install -pD -T msv/target/%{name}-core-%{version}.jar \
|
||||
%{buildroot}%{_javadir}/%{name}-core.jar
|
||||
install -pD -T relames/target/%{name}-relames-2009.1.jar \
|
||||
%{buildroot}%{_javadir}/%{name}-relames.jar
|
||||
install -pD -T rngconverter/target/%{name}-rngconverter-%{version}.jar \
|
||||
%{buildroot}%{_javadir}/%{name}-rngconverter.jar
|
||||
install -pD -T generator/target/%{name}-generator-%{version}.jar \
|
||||
@ -234,21 +210,17 @@ ln -s xsdlib.jar \
|
||||
install -pD -T -m 644 pom.xml %{buildroot}%{_mavenpomdir}/JPP-msv.pom
|
||||
install -pD -T -m 644 parent-pom.xml %{buildroot}%{_mavenpomdir}/JPP-msv-parent.pom
|
||||
install -pD -T -m 644 msv/pom.xml %{buildroot}%{_mavenpomdir}/JPP-msv-core.pom
|
||||
install -pD -T -m 644 relames/pom.xml %{buildroot}%{_mavenpomdir}/JPP-msv-relames.pom
|
||||
install -pD -T -m 644 rngconverter/pom.xml %{buildroot}%{_mavenpomdir}/JPP-msv-rngconverter.pom
|
||||
install -pD -T -m 644 generator/pom.xml %{buildroot}%{_mavenpomdir}/JPP-msv-generator.pom
|
||||
install -pD -T -m 644 testharness/pom.xml %{buildroot}%{_mavenpomdir}/JPP-msv-testharness.pom
|
||||
install -pD -T -m 644 xsdlib/pom.xml %{buildroot}%{_mavenpomdir}/JPP-xsdlib.pom
|
||||
%add_to_maven_depmap net.java.dev.msv msv %{version} JPP msv
|
||||
%add_to_maven_depmap net.java.dev.msv msv-parent %{version} JPP msv-parent
|
||||
%add_to_maven_depmap net.java.dev.msv msv-core %{version} JPP msv-core
|
||||
%add_to_maven_depmap net.java.dev.msv msv-relames %{version} JPP msv-relames
|
||||
%add_to_maven_depmap net.java.dev.msv msv-rngconverter %{version} JPP msv-rngconverter
|
||||
%add_to_maven_depmap net.java.dev.msv msv-generator %{version} JPP msv-generator
|
||||
%add_to_maven_depmap net.java.dev.msv msv-testharness %{version} JPP msv-testharness
|
||||
%add_to_maven_depmap net.java.dev.msv xsdlib %{version} JPP xsdlib
|
||||
%add_to_maven_depmap msv msv %{version} JPP msv-core
|
||||
%add_to_maven_depmap com.sun.msv.datatype.xsd xsdlib %{version} JPP xsdlib
|
||||
%add_maven_depmap JPP-%{name}.pom %{name}.jar
|
||||
%add_maven_depmap JPP-%{name}-parent.pom
|
||||
%add_maven_depmap JPP-%{name}-core.pom %{name}-core.jar -a "msv:msv"
|
||||
%add_maven_depmap JPP-%{name}-rngconverter.pom %{name}-rngconverter.jar
|
||||
%add_maven_depmap JPP-%{name}-generator.pom %{name}-generator.jar
|
||||
%add_maven_depmap JPP-%{name}-testharness.pom %{name}-testharness.jar
|
||||
%add_maven_depmap JPP-xsdlib.pom xsdlib.jar -a "com.sun.msv.datatype.xsd:xsdlib"
|
||||
|
||||
# Javadocs
|
||||
install -d -m 755 %{buildroot}%{_javadocdir}/%{name}
|
||||
@ -280,7 +252,6 @@ cp -pr xsdlib/examples/* %{buildroot}%{_datadir}/%{name}-%{version}/xsdlib
|
||||
# Scripts
|
||||
%jpackage_script com.sun.msv.driver.textui.Driver "" "" msv-msv:msv-xsdlib:relaxngDatatype:isorelax msv true
|
||||
%jpackage_script com.sun.msv.generator.Driver "" "" msv-xmlgen:msv-msv:msv-xsdlib:relaxngDatatype:isorelax:xerces-j2 xmlgen true
|
||||
%jpackage_script com.sun.msv.schematron.Driver "" "" msv-relames:msv-msv:msv-xsdlib:relaxngDatatype:isorelax:xalan-j2 relames true
|
||||
%jpackage_script com.sun.msv.writer.relaxng.Driver "" "" msv-rngconv:msv-msv:msv-xsdlib:relaxngDatatype:isorelax:xerces-j2 rngconv true
|
||||
|
||||
%files msv
|
||||
@ -294,13 +265,6 @@ cp -pr xsdlib/examples/* %{buildroot}%{_datadir}/%{name}-%{version}/xsdlib
|
||||
%doc msv/doc/Apache-LICENSE-1.1.txt
|
||||
%doc Apache-LICENSE-2.0.txt
|
||||
|
||||
%files relames
|
||||
%{_bindir}/relames
|
||||
%{_mavenpomdir}/JPP-%{name}-relames.pom
|
||||
%{_javadir}/%{name}-relames.jar
|
||||
%doc msv/doc/Apache-LICENSE-1.1.txt
|
||||
%doc License.txt
|
||||
|
||||
%files rngconv
|
||||
%{_bindir}/rngconv
|
||||
%{_mavenpomdir}/JPP-%{name}-rngconverter.pom
|
||||
@ -344,6 +308,10 @@ cp -pr xsdlib/examples/* %{buildroot}%{_datadir}/%{name}-%{version}/xsdlib
|
||||
%{_datadir}/%{name}-%{version}
|
||||
|
||||
%changelog
|
||||
* Wed Jul 31 2013 Michal Srb <msrb@redhat.com> - 1:2013.5.1-2
|
||||
- Do not build module with unclear licensing (relames)
|
||||
- Replace %%add_to_maven_depmap with %%add_maven_depmap
|
||||
|
||||
* Fri Jun 07 2013 Michal Srb <msrb@redhat.com> - 1:2013.5.1-1
|
||||
- Update to latest upstream version 2013.5.1
|
||||
- Clean up tarball
|
||||
|
Loading…
Reference in New Issue
Block a user