Package unretired
Update to upstream version 2022.7
This commit is contained in:
parent
51d897134d
commit
680fd4fab5
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@ msv-20050722.tar.gz
|
||||
/LICENSE-2.0.txt
|
||||
/msv-2013.5.1-clean.tar.gz
|
||||
/msv-2013.6.1-clean.tar.gz
|
||||
/msv-2022.7.tar.gz
|
||||
|
24
0001-Disable-Apache-XercesImpl.patch
Normal file
24
0001-Disable-Apache-XercesImpl.patch
Normal file
@ -0,0 +1,24 @@
|
||||
From a580f124197fcc2a62875e43100cd35b1fc4329e Mon Sep 17 00:00:00 2001
|
||||
From: Marian Koncek <mkoncek@redhat.com>
|
||||
Date: Thu, 17 Aug 2023 09:30:08 +0200
|
||||
Subject: [PATCH] Disable Apache XercesImpl
|
||||
|
||||
---
|
||||
.../main/java/com/sun/msv/datatype/xsd/regex/RegExpFactory.java | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/xsdlib/src/main/java/com/sun/msv/datatype/xsd/regex/RegExpFactory.java b/xsdlib/src/main/java/com/sun/msv/datatype/xsd/regex/RegExpFactory.java
|
||||
index 4a4c4be..cdeab93 100644
|
||||
--- a/xsdlib/src/main/java/com/sun/msv/datatype/xsd/regex/RegExpFactory.java
|
||||
+++ b/xsdlib/src/main/java/com/sun/msv/datatype/xsd/regex/RegExpFactory.java
|
||||
@@ -42,7 +42,6 @@ public abstract class RegExpFactory {
|
||||
public static RegExpFactory createFactory() {
|
||||
String[] classList = new String[] {
|
||||
"com.sun.msv.datatype.regexp.InternalImpl",
|
||||
- "com.sun.msv.datatype.xsd.regex.XercesImpl",
|
||||
"com.sun.msv.datatype.xsd.regex.JDKImpl"
|
||||
};
|
||||
|
||||
--
|
||||
2.41.0
|
||||
|
@ -1,22 +0,0 @@
|
||||
#!/bin/bash
|
||||
|
||||
if [ $# -ne 1 ]; then
|
||||
echo "Usage: ./create-tarball VERSION"
|
||||
exit 1
|
||||
fi
|
||||
|
||||
VERSION=${1}
|
||||
NAME="msv"
|
||||
|
||||
# Generate tarball from upstream source control:
|
||||
svn co https://svn.java.net/svn/${NAME}~svn/tags/${NAME}-${VERSION}/ ${NAME}-${VERSION}
|
||||
|
||||
# Remove things that we don't need
|
||||
(
|
||||
cd ${NAME}-${VERSION}
|
||||
rm -Rf www/ relames/ .svn/
|
||||
rm -Rf schmit/ shared/ tahiti/
|
||||
)
|
||||
|
||||
tar zcf ${NAME}-${VERSION}-clean.tar.gz ${NAME}-${VERSION}
|
||||
|
29
generate-tarball.sh
Executable file
29
generate-tarball.sh
Executable file
@ -0,0 +1,29 @@
|
||||
#!/bin/bash
|
||||
set -e
|
||||
|
||||
name=msv
|
||||
version="$(sed -n 's/Version:\s*//p' ./*.spec)"
|
||||
|
||||
# RETRIEVE
|
||||
wget "https://github.com/xmlark/msv/archive/${name}-${version}/${name}-${version}.tar.gz" -O "${name}-${version}.orig.tar.gz"
|
||||
|
||||
rm -rf tarball-tmp
|
||||
mkdir tarball-tmp
|
||||
pushd tarball-tmp
|
||||
tar -xf "../${name}-${version}.orig.tar.gz"
|
||||
mv "msv-msv-${version}" "${name}-${version}"
|
||||
|
||||
pushd "${name}-${version}"
|
||||
mv docs/xsdlib/Apache-LICENSE-1.1.txt .
|
||||
mv docs/xsdlib/license.txt .
|
||||
mv docs/xsdlib/README.md README-xsdlib.md
|
||||
|
||||
# CLEAN TARBALL
|
||||
find . -mindepth 1 -maxdepth 1 -type d ! -name 'xsdlib' -exec rm -rf {} +
|
||||
rm -rf xsdlib/src/test
|
||||
|
||||
popd
|
||||
|
||||
tar -czf "../${name}-${version}.tar.gz" ./*
|
||||
popd
|
||||
rm -r tarball-tmp "${name}-${version}.orig.tar.gz"
|
@ -1,67 +0,0 @@
|
||||
From 4b691adecd92c09689b0d23b7b17cc50f4b5bee9 Mon Sep 17 00:00:00 2001
|
||||
From: Michal Srb <msrb@redhat.com>
|
||||
Date: Thu, 11 Apr 2013 16:26:09 +0200
|
||||
Subject: [PATCH] Use CatalogResolver class from xml-commons-resolver
|
||||
|
||||
---
|
||||
msv/examples/schemaLookup/Main.java | 2 +-
|
||||
msv/src/com/sun/msv/driver/textui/Driver.java | 2 +-
|
||||
msv/test/batch/BatchTester.java | 2 +-
|
||||
msv/test/batch/driver/AbstractValidatorExImpl.java | 2 +-
|
||||
4 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/msv/examples/schemaLookup/Main.java b/msv/examples/schemaLookup/Main.java
|
||||
index 426051d..5bcbaa3 100644
|
||||
--- a/msv/examples/schemaLookup/Main.java
|
||||
+++ b/msv/examples/schemaLookup/Main.java
|
||||
@@ -36,7 +36,7 @@ import java.io.IOException;
|
||||
|
||||
import javax.xml.parsers.DocumentBuilderFactory;
|
||||
|
||||
-import com.sun.org.apache.xml.internal.resolver.tools.CatalogResolver;
|
||||
+import org.apache.xml.resolver.tools.CatalogResolver;
|
||||
import org.iso_relax.verifier.Schema;
|
||||
import org.iso_relax.verifier.Verifier;
|
||||
import org.w3c.dom.Document;
|
||||
diff --git a/msv/src/com/sun/msv/driver/textui/Driver.java b/msv/src/com/sun/msv/driver/textui/Driver.java
|
||||
index f659b5f..63a5794 100644
|
||||
--- a/msv/src/com/sun/msv/driver/textui/Driver.java
|
||||
+++ b/msv/src/com/sun/msv/driver/textui/Driver.java
|
||||
@@ -39,7 +39,7 @@ import java.util.Locale;
|
||||
|
||||
import javax.xml.parsers.SAXParserFactory;
|
||||
|
||||
-import com.sun.org.apache.xml.internal.resolver.tools.CatalogResolver;
|
||||
+import org.apache.xml.resolver.tools.CatalogResolver;
|
||||
import org.iso_relax.dispatcher.Dispatcher;
|
||||
import org.iso_relax.dispatcher.SchemaProvider;
|
||||
import org.iso_relax.dispatcher.impl.DispatcherImpl;
|
||||
diff --git a/msv/test/batch/BatchTester.java b/msv/test/batch/BatchTester.java
|
||||
index 7fd8b88..b7bba01 100644
|
||||
--- a/msv/test/batch/BatchTester.java
|
||||
+++ b/msv/test/batch/BatchTester.java
|
||||
@@ -40,7 +40,7 @@ import javax.xml.parsers.SAXParserFactory;
|
||||
import junit.framework.Test;
|
||||
import junit.framework.TestSuite;
|
||||
|
||||
-import com.sun.org.apache.xml.internal.resolver.tools.CatalogResolver;
|
||||
+import org.apache.xml.resolver.tools.CatalogResolver;
|
||||
|
||||
import batch.driver.DTDValidator;
|
||||
import batch.driver.GenericValidator;
|
||||
diff --git a/msv/test/batch/driver/AbstractValidatorExImpl.java b/msv/test/batch/driver/AbstractValidatorExImpl.java
|
||||
index dd85d93..33121f0 100644
|
||||
--- a/msv/test/batch/driver/AbstractValidatorExImpl.java
|
||||
+++ b/msv/test/batch/driver/AbstractValidatorExImpl.java
|
||||
@@ -36,7 +36,7 @@ import java.io.InputStream;
|
||||
|
||||
import javax.xml.parsers.SAXParserFactory;
|
||||
|
||||
-import com.sun.org.apache.xml.internal.resolver.tools.CatalogResolver;
|
||||
+import org.apache.xml.resolver.tools.CatalogResolver;
|
||||
import org.xml.sax.InputSource;
|
||||
import org.xml.sax.XMLReader;
|
||||
|
||||
--
|
||||
1.8.1.4
|
||||
|
456
msv.spec
456
msv.spec
@ -1,430 +1,92 @@
|
||||
Name: msv
|
||||
Epoch: 1
|
||||
Version: 2013.6.1
|
||||
Release: 21%{?dist}
|
||||
Summary: Multi-Schema Validator
|
||||
License: BSD and ASL 1.1
|
||||
URL: http://msv.java.net/
|
||||
Name: msv
|
||||
Version: 2022.7
|
||||
Release: 1%{?dist}
|
||||
Summary: Multi-Schema Validator Toolkit
|
||||
# License breakdown
|
||||
# Apache-1.1
|
||||
# * xsdlib/src/main/java/com/sun/msv/datatype/regexp - All files except for InternalImpl.java
|
||||
# BSD-3-Clause-Sun
|
||||
# * pom.xml
|
||||
# * xsdlib/src/main/java/com/sun/msv/datatype/regexp/InternalImpl.java
|
||||
# BSD-3-Clause-Sun implied by docs/xsdlib/license.txt of the original tarball
|
||||
# * xsdlib/src/main/java/com/sun/msv/datatype/xsd/CommandLineTester.java
|
||||
# * xsdlib/src/main/resources/com/sun/msv/datatype/xsd/Messages.properties
|
||||
# * xsdlib/src/main/resources/com/sun/msv/datatype/xsd/Messages_ja.properties
|
||||
# BSD-3-Clause - All other .java files
|
||||
License: Apache-1.1 AND BSD-3-Clause AND BSD-3-Clause-Sun
|
||||
URL: https://xmlark.github.io/msv/
|
||||
BuildArch: noarch
|
||||
ExclusiveArch: %{java_arches} noarch
|
||||
|
||||
# To generate tarball from upstream source control:
|
||||
# $ ./create-tarball
|
||||
Source0: %{name}-%{version}-clean.tar.gz
|
||||
# ./generate-tarball.sh
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
|
||||
Source2: http://www.apache.org/licenses/LICENSE-2.0.txt
|
||||
Source3: create-tarball.sh
|
||||
Source1: generate-tarball.sh
|
||||
|
||||
# Use CatalogResolver from xml-commons-resolver package
|
||||
Patch1: %{name}-Use-CatalogResolver-class-from-xml-commons-resolver.patch
|
||||
Patch1: 0001-Disable-Apache-XercesImpl.patch
|
||||
|
||||
BuildRequires: maven-local
|
||||
BuildRequires: mvn(isorelax:isorelax)
|
||||
BuildRequires: mvn(jdom:jdom)
|
||||
BuildRequires: mvn(junit:junit)
|
||||
BuildRequires: mvn(net.java:jvnet-parent:pom:)
|
||||
BuildRequires: mvn(org.apache.ant:ant)
|
||||
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
|
||||
BuildRequires: mvn(org.apache.maven.plugins:maven-enforcer-plugin)
|
||||
BuildRequires: mvn(org.apache.maven.plugins:maven-source-plugin)
|
||||
BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
|
||||
BuildRequires: mvn(org.apache.maven.plugins:maven-assembly-plugin)
|
||||
BuildRequires: mvn(org.jdom:jdom2)
|
||||
BuildRequires: mvn(relaxngDatatype:relaxngDatatype)
|
||||
BuildRequires: mvn(xerces:xercesImpl)
|
||||
BuildRequires: mvn(xml-resolver:xml-resolver)
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
Obsoletes: %{name}-relames < %{version}-%{release}
|
||||
|
||||
%description
|
||||
The Sun Multi-Schema XML Validator (MSV) is a Java technology tool to validate
|
||||
XML documents against several kinds of XML schemata. It supports RELAX NG,
|
||||
RELAX Namespace, RELAX Core, TREX, XML DTDs, and a subset of XML Schema Part 1.
|
||||
This latest (version 1.2) release includes several bug fixes and adds better
|
||||
conformance to RELAX NG/W3C XML standards and JAXP masquerading.
|
||||
The Multi Schema Validation toolkit is a Java based toolkit consisting of 8
|
||||
different submodules. The core module is the Multi-Schema XML Validator (MSV)
|
||||
for the validation of XML documents against several kinds of XML schemata The
|
||||
core supports RELAX NG, RELAX Namespace, RELAX Core, TREX, XML DTDs, and a
|
||||
subset of XML Schema Part 1.
|
||||
|
||||
%package msv
|
||||
Summary: Multi-Schema Validator Core
|
||||
# src/com/sun/msv/reader/xmlschema/DOMLSInputImpl.java is under ASL 2.0
|
||||
# msv/src/com/sun/msv/writer/ContentHandlerAdaptor.java is partially under Public Domain
|
||||
License: BSD and ASL 1.1 and ASL 2.0 and Public Domain
|
||||
# Explicit javapackages-tools requires since scripts use
|
||||
# /usr/share/java-utils/java-functions
|
||||
Requires: javapackages-tools
|
||||
%package javadoc
|
||||
Summary: API documentation for %{name}
|
||||
|
||||
%description msv
|
||||
%{summary}.
|
||||
%description javadoc
|
||||
This package provides %{summary}.
|
||||
|
||||
%package rngconv
|
||||
Summary: Multi-Schema Validator RNG Converter
|
||||
# Explicit javapackages-tools requires since scripts use
|
||||
# /usr/share/java-utils/java-functions
|
||||
Requires: javapackages-tools
|
||||
%package xsdlib
|
||||
Summary: Java implementation of W3C’s XML Schema Part 2
|
||||
|
||||
%description rngconv
|
||||
%{summary}.
|
||||
|
||||
%package xmlgen
|
||||
Summary: Multi-Schema Validator Generator
|
||||
# Explicit javapackages-tools requires since scripts use
|
||||
# /usr/share/java-utils/java-functions
|
||||
Requires: javapackages-tools
|
||||
|
||||
%description xmlgen
|
||||
%{summary}.
|
||||
|
||||
%package xsdlib
|
||||
Summary: Multi-Schema Validator XML Schema Library
|
||||
|
||||
%description xsdlib
|
||||
%{summary}.
|
||||
|
||||
%package javadoc
|
||||
Summary: API documentation for Multi-Schema Validator
|
||||
License: BSD and ASL 1.1 and ASL 2.0 and Public Domain
|
||||
|
||||
%description javadoc
|
||||
%{summary}.
|
||||
|
||||
%package manual
|
||||
Summary: Manual for Multi-Schema Validator
|
||||
License: BSD
|
||||
|
||||
%description manual
|
||||
%{summary}.
|
||||
|
||||
%package demo
|
||||
Summary: Samples for Multi-Schema Validator
|
||||
License: BSD
|
||||
Requires: msv-msv
|
||||
Requires: msv-xsdlib
|
||||
|
||||
%description demo
|
||||
%{summary}.
|
||||
%description xsdlib
|
||||
MSV XML Datatypes Library, Java implementation of W3C’s XML Schema Part 2, is
|
||||
intended for use with applications that incorporate XML Schema Part 2.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
# We don't have this plugin
|
||||
%pom_remove_plugin :buildnumber-maven-plugin
|
||||
# Disable runtime dependency on Apache Xerces
|
||||
%patch 1 -p1
|
||||
rm xsdlib/src/main/java/com/sun/msv/datatype/xsd/regex/XercesImpl.java
|
||||
|
||||
# javadoc generation fails due to strict doclint in JDK 8
|
||||
%pom_remove_plugin :maven-javadoc-plugin
|
||||
%pom_xpath_remove 'pom:project/pom:modules'
|
||||
%pom_xpath_inject 'pom:project' '<modules><module>xsdlib</module></modules>'
|
||||
|
||||
# Needed becuase of patch3
|
||||
%pom_add_dep xml-resolver:xml-resolver
|
||||
%pom_xpath_remove 'pom:build/pom:extensions'
|
||||
|
||||
# ASL 2.0 license text
|
||||
cp %{SOURCE2} Apache-LICENSE-2.0.txt
|
||||
%pom_remove_dep org.apache.maven.scm:maven-scm-provider-gitexe
|
||||
%pom_remove_dep xerces:xercesImpl xsdlib
|
||||
|
||||
# Delete anything pre-compiled
|
||||
find -name '*.class' -exec rm -f '{}' \;
|
||||
find -name '*.jar' -exec rm -f '{}' \;
|
||||
find -name '*.zip' -exec rm -f '{}' \;
|
||||
%pom_remove_plugin org.codehaus.mojo:flatten-maven-plugin
|
||||
%pom_remove_plugin -r :maven-javadoc-plugin
|
||||
|
||||
# Test sources in default package break BND
|
||||
rm -f testharness/src/*.java
|
||||
|
||||
# Delete class-path entries from manifests
|
||||
for m in $(find . -name MANIFEST.MF) ; do
|
||||
sed --in-place -e '/^[Cc]lass-[Pp]ath:/d' $m
|
||||
done
|
||||
|
||||
# Apply patches
|
||||
%patch1 -p1
|
||||
|
||||
# Fix isorelax groupId
|
||||
%pom_xpath_replace "pom:dependency[pom:groupId[text()='com.sun.xml.bind.jaxb']]/pom:groupId" "<groupId>isorelax</groupId>"
|
||||
%pom_xpath_replace "pom:dependency[pom:groupId[text()='com.sun.xml.bind.jaxb']]/pom:groupId" "<groupId>isorelax</groupId>" msv
|
||||
|
||||
# remove maven-compiler-plugin configuration that is broken with Java 11
|
||||
%pom_xpath_remove 'pom:plugin[pom:artifactId="maven-compiler-plugin"]/pom:configuration/pom:source'
|
||||
%pom_xpath_remove 'pom:plugin[pom:artifactId="maven-compiler-plugin"]/pom:configuration/pom:target'
|
||||
|
||||
# Change encoding of non utf-8 files
|
||||
for m in $(find . -name copyright.txt) ; do
|
||||
iconv -f iso-8859-1 -t utf-8 < $m > $m.utf8
|
||||
mv $m.utf8 $m
|
||||
done
|
||||
|
||||
%mvn_file ":%{name}-core" %{name}-core %{name}-%{name}
|
||||
%mvn_file ":%{name}-rngconverter" %{name}-rngconverter %{name}-rngconv
|
||||
%mvn_file ":%{name}-generator" %{name}-generator %{name}-xmlgen
|
||||
%mvn_file ":xsdlib" xsdlib %{name}-xsdlib
|
||||
|
||||
%mvn_alias ":xsdlib" "com.sun.msv.datatype.xsd:xsdlib"
|
||||
|
||||
%mvn_package ":*::{tests,javadoc,sources}:" __noinstall
|
||||
%mvn_package ":%{name}{,-testharness}::{}:" __noinstall
|
||||
%mvn_package ":%{name}{,-core}::{}:" %{name}-msv
|
||||
# We only build xsdlib
|
||||
%mvn_package net.java.dev.msv:msv __noinstall
|
||||
|
||||
%build
|
||||
%mvn_build -s -- -Dmaven.compiler.source=1.8 -Dmaven.compiler.target=1.8
|
||||
%mvn_build -s
|
||||
|
||||
%install
|
||||
%mvn_install
|
||||
|
||||
# Manuals
|
||||
install -d -m 755 %{buildroot}%{_docdir}/%{name}/msv
|
||||
install -m 644 msv/doc/*.html %{buildroot}%{_docdir}/%{name}/msv
|
||||
install -m 644 msv/doc/*.gif %{buildroot}%{_docdir}/%{name}/msv
|
||||
install -m 644 msv/doc/README.txt %{buildroot}%{_docdir}/%{name}/msv
|
||||
|
||||
install -d -m 755 %{buildroot}%{_docdir}/%{name}/rngconverter
|
||||
install -m 644 rngconverter/README.txt %{buildroot}%{_docdir}/%{name}/rngconverter
|
||||
|
||||
install -d -m 755 %{buildroot}%{_docdir}/%{name}/generator
|
||||
install -m 644 generator/*.html %{buildroot}%{_docdir}/%{name}/generator
|
||||
install -m 644 generator/README.txt %{buildroot}%{_docdir}/%{name}/generator
|
||||
|
||||
install -d -m 755 %{buildroot}%{_docdir}/%{name}/xsdlib
|
||||
install -m 644 xsdlib/*.html %{buildroot}%{_docdir}/%{name}/xsdlib
|
||||
install -m 644 xsdlib/README.txt %{buildroot}%{_docdir}/%{name}/xsdlib
|
||||
|
||||
# Examples
|
||||
install -d -m 755 %{buildroot}%{_datadir}/%{name}/msv
|
||||
cp -pr msv/examples/* %{buildroot}%{_datadir}/%{name}/msv
|
||||
install -d -m 755 %{buildroot}%{_datadir}/%{name}/xsdlib
|
||||
cp -pr xsdlib/examples/* %{buildroot}%{_datadir}/%{name}/xsdlib
|
||||
|
||||
# Scripts
|
||||
%jpackage_script com.sun.msv.driver.textui.Driver "" "" msv-msv:msv-xsdlib:relaxngDatatype:isorelax msv true
|
||||
%jpackage_script com.sun.msv.generator.Driver "" "" msv-xmlgen:msv-msv:msv-xsdlib:relaxngDatatype:isorelax:xerces-j2 xmlgen true
|
||||
%jpackage_script com.sun.msv.writer.relaxng.Driver "" "" msv-rngconv:msv-msv:msv-xsdlib:relaxngDatatype:isorelax:xerces-j2 rngconv true
|
||||
|
||||
%files msv -f .mfiles-msv-msv
|
||||
%{_bindir}/msv
|
||||
%doc License.txt
|
||||
%doc msv/doc/Apache-LICENSE-1.1.txt
|
||||
%doc Apache-LICENSE-2.0.txt
|
||||
|
||||
%files rngconv -f .mfiles-msv-rngconverter
|
||||
%{_bindir}/rngconv
|
||||
%doc msv/doc/Apache-LICENSE-1.1.txt
|
||||
%doc License.txt
|
||||
|
||||
%files xmlgen -f .mfiles-msv-generator
|
||||
%{_bindir}/xmlgen
|
||||
%doc msv/doc/Apache-LICENSE-1.1.txt
|
||||
%doc License.txt
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
%license Apache-LICENSE-1.1.txt license.txt
|
||||
|
||||
%files xsdlib -f .mfiles-xsdlib
|
||||
%doc msv/doc/Apache-LICENSE-1.1.txt
|
||||
%doc License.txt
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
%doc License.txt
|
||||
%doc msv/doc/Apache-LICENSE-1.1.txt
|
||||
%doc Apache-LICENSE-2.0.txt
|
||||
|
||||
%files manual
|
||||
%doc %{_docdir}/%{name}
|
||||
%doc License.txt
|
||||
|
||||
%files demo
|
||||
%{_datadir}/%{name}
|
||||
%doc README.md README-xsdlib.md
|
||||
%license Apache-LICENSE-1.1.txt license.txt
|
||||
|
||||
%changelog
|
||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1:2013.6.1-21
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1:2013.6.1-20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1:2013.6.1-19
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Sat Jul 18 2020 Fabio Valentini <decathorpe@gmail.com> - 1:2013.6.1-18
|
||||
- Set javac source and target to 1.8 to fix Java 11 builds.
|
||||
|
||||
* Sat Jul 11 2020 Jiri Vanek <jvanek@redhat.com> - 1:2013.6.1-17
|
||||
- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1:2013.6.1-16
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:2013.6.1-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:2013.6.1-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Jul 31 2018 Severin Gehwolf <sgehwolf@redhat.com> - 1:2013.6.1-13
|
||||
- Add explicit javapackages-tools requirement since scripts use
|
||||
java-functions.
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:2013.6.1-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:2013.6.1-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:2013.6.1-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:2013.6.1-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1:2013.6.1-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Sep 23 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 1:2013.6.1-7
|
||||
- Remove testharness sources from default package
|
||||
- Resolves: rhbz#1263628
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2013.6.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Thu May 14 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 1:2013.6.1-5
|
||||
- Remove maven-javadoc-plugin execution
|
||||
|
||||
* Sun Sep 14 2014 Gerard Ryan <galileo@fedoraproject.org> - 1:2013.6.1-4
|
||||
- Don't install testharness jar: pulls in ant
|
||||
- Fix changelog bogus date warning
|
||||
|
||||
* Mon Aug 4 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 1:2013.6.1-3
|
||||
- Remove unneeded build-requires
|
||||
- Fix build-requires on jvnet-parent
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2013.6.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Sep 23 2013 Michal Srb <msrb@redhat.com> - 1:2013.6.1-1
|
||||
- Update to upstream version 2013.6.1
|
||||
|
||||
* Mon Sep 23 2013 Michal Srb <msrb@redhat.com> - 1:2013.5.1-7
|
||||
- Adapt to current guidelines
|
||||
|
||||
* Wed Aug 07 2013 Michal Srb <msrb@redhat.com> - 1:2013.5.1-6
|
||||
- Unversioned doc dir (Resolves: #993980)
|
||||
- See: http://fedoraproject.org/wiki/Changes/UnversionedDocdirs
|
||||
|
||||
* Tue Aug 06 2013 Michal Srb <msrb@redhat.com> - 1:2013.5.1-5
|
||||
- Provide net.java.dev.msv:msv (Resolves: #993872)
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2013.5.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Thu Aug 01 2013 Michal Srb <msrb@redhat.com> - 1:2013.5.1-3
|
||||
- Fix license tag (+Public Domain)
|
||||
- Add create-tarball.sh to SRPM
|
||||
|
||||
* Wed Jul 31 2013 Michal Srb <msrb@redhat.com> - 1:2013.5.1-2
|
||||
- Do not build module with unclear licensing (relames)
|
||||
- Replace %%add_to_maven_depmap with %%add_maven_depmap
|
||||
|
||||
* Fri Jun 07 2013 Michal Srb <msrb@redhat.com> - 1:2013.5.1-1
|
||||
- Update to latest upstream version 2013.5.1
|
||||
- Clean up tarball
|
||||
- Fix BR/R
|
||||
|
||||
* Fri Apr 12 2013 Michal Srb <msrb@redhat.com> - 1:2013.2.3-3
|
||||
- Fix license tags in javadoc, manual, demo subpackages
|
||||
|
||||
* Fri Apr 12 2013 Michal Srb <msrb@redhat.com> - 1:2013.2.3-2
|
||||
- Fix license tag for msv subpackage
|
||||
- Remove unneeded patches
|
||||
|
||||
* Thu Apr 11 2013 Michal Srb <msrb@redhat.com> - 1:2013.2.3-1
|
||||
- Update to upstream version 2013.2.3
|
||||
- Resolves: rhbz#876845
|
||||
- Fix URL and license tag
|
||||
|
||||
* Mon Feb 25 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 1:2009.1-14
|
||||
- Add missing BR: maven-local
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2009.1-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2009.1-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Apr 6 2012 Alexander Kurtakov <akurtako@redhat.com> 1:2009.1-11
|
||||
- Drop unneeded BR/R.
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2009.1-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Tue Nov 29 2011 Alexander Kurtakov <akurtako@redhat.com> 1:2009.1-9
|
||||
- Build with maven 3.
|
||||
- Adapt to current guidelines.
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2009.1-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Tue Nov 2 2010 Ville Skyttä <ville.skytta@iki.fi> - 1:2009.1-7
|
||||
- Add msv, relames, xmlgen, and rngconv command line scripts.
|
||||
|
||||
* Thu Oct 28 2010 Alexander Kurtakov <akurtako@redhat.com> 1:2009.1-6
|
||||
- BR junit4.
|
||||
|
||||
* Thu Oct 28 2010 Alexander Kurtakov <akurtako@redhat.com> 1:2009.1-5
|
||||
- Fix depmaps and install jars required by msv.pom.
|
||||
|
||||
* Fri Sep 24 2010 Mat Booth <fedora@matbooth.co.uk> - 1:2009.1-4
|
||||
- Really require a version of xml-commons-resolver that provides the necessary
|
||||
maven pom and depmap.
|
||||
|
||||
* Sun Sep 19 2010 Mat Booth <fedora@matbooth.co.uk> - 1:2009.1-3
|
||||
- Require a version of xml-commons-resolver that provides the necessary maven
|
||||
pom and depmap.
|
||||
|
||||
* Sun Sep 19 2010 Mat Booth <fedora@matbooth.co.uk> - 1:2009.1-2
|
||||
- Re-patch build to link to local javadocs.
|
||||
- Install maven poms/depmap.
|
||||
|
||||
* Thu Sep 16 2010 Mat Booth <fedora@matbooth.co.uk> - 1:2009.1-1
|
||||
- Update to latest tagged release.
|
||||
- Drop support for GCJ ahead of time compilation.
|
||||
- Fix RHBZ #627688, RHBZ #631076
|
||||
- This project now builds with maven instead of ant.
|
||||
- The new build in this release aggregates javadocs, so now we have one javadoc
|
||||
package that obsoletes the many javadoc packages we had before.
|
||||
- Use new jar names that upstream use, provide the old names.
|
||||
- Misc other changes for guideline compliance.
|
||||
|
||||
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.2-0.4.20050722.3.4.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Fri May 08 2009 Karsten Hopp <karsten@redhat.com> 1.2-0.3.20050722.3.4.1
|
||||
- Specify source and target as 1.4 to make it build
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.2-0.3.20050722.3.4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Wed Jul 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1:1.2-0.2.20050722.3.4
|
||||
- drop repotag
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:1.2-0.2.20050722.3jpp.3
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Wed Sep 12 2007 Matt Wringe <mwringe@redhat.com> 0:1,2-0.1.20050722.3jpp.3
|
||||
- Make package build with new gcj. Remove .class files from demo package and
|
||||
remove demo exclude from aot-compile-rpm
|
||||
|
||||
* Tue Sep 11 2007 Matt Wringe <mwringe@redhat.com> 0:1.2-0.1.20050722.3jpp.2
|
||||
- Fix unowned directories
|
||||
- Change copyright files to utf-8 format
|
||||
- Change license field to BSD (from BSD-Style)
|
||||
|
||||
* Fri Feb 16 2007 Andrew Overholt <overholt@redhat.com> 0:1.2-0.1.20050722.3jpp.1
|
||||
- Remove postun Requires on jpackage-utils
|
||||
- Set gcj_support to 1
|
||||
- Fix groups to shut up rpmlint
|
||||
- Add versions to the Provides and Obsoletes
|
||||
- Add patch to take out Class-Path in MANIFEST.MF
|
||||
|
||||
* Thu Feb 15 2007 Matt Wringe <mwringe at redhat.com> - 0:1.2-0.1.20050722.3jpp.1.fc7
|
||||
- Extract sources from a fresh CVS export of the given tag and add extra source
|
||||
required to build the package not present in the 20050722 tag anymore
|
||||
- Add a patch to remove compile time dependency on crimson
|
||||
- Add a patch to enable compression of jar files
|
||||
- Add jpackage-utils as a requires for the packages/subpackages
|
||||
|
||||
* Mon Feb 12 2007 Ralph Apel <r.apel at r-apel.de> - 0:1.2-0.20050722.3jpp
|
||||
- Add bootstrap option to build without saxon nor jdom
|
||||
- Add gcj_support option
|
||||
|
||||
* Fri Feb 17 2006 Fernando Nasser <fnasser@redhat.com> - 0:1.2-0.20050722.2jpp
|
||||
- First JPP 1.7 build
|
||||
|
||||
* Wed Aug 17 2005 Ralph Apel <r.apel at r-apel.de> - 0:1.2-0.20050722.1jpp
|
||||
- First JPP from this code base
|
||||
* Mon Aug 07 2023 Marian Koncek <mkoncek@redhat.com> - 2022.7-1
|
||||
- Package unretired
|
||||
- Update to upstream version 2022.7
|
||||
|
Loading…
Reference in New Issue
Block a user