bf5ba95e07
Resolves: RHEL-886 Signed-off-by: Kamal Heib <kheib@redhat.com>
69 lines
2.7 KiB
Diff
69 lines
2.7 KiB
Diff
From 0bf822388a194c01c82beb6b6529b49255a4bd39 Mon Sep 17 00:00:00 2001
|
|
From: Kamal Heib <kheib@redhat.com>
|
|
Date: Tue, 17 Oct 2023 14:19:52 -0400
|
|
Subject: [PATCH] Add default link flags for shared libraries
|
|
|
|
Signed-off-by: Kamal Heib <kheib@redhat.com>
|
|
---
|
|
cmdif/Makefile.am | 2 +-
|
|
dev_mgt/Makefile.am | 2 +-
|
|
mtcr_py/Makefile.am | 2 +-
|
|
reg_access/Makefile.am | 2 +-
|
|
4 files changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/cmdif/Makefile.am b/cmdif/Makefile.am
|
|
index b6c43d59c8b5..0e03839459f2 100644
|
|
--- a/cmdif/Makefile.am
|
|
+++ b/cmdif/Makefile.am
|
|
@@ -51,7 +51,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h
|
|
cmdif_pylibdir = $(libdir)/mstflint/python_tools/
|
|
cmdif_pylib_DATA = ${CCMDIF_SO} cmdif.py
|
|
${CCMDIF_SO}: libcmdif.a
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${CCMDIF_SO} \
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${CCMDIF_SO} \
|
|
-L$(USER_DIR)/tools_layouts -ltools_layouts -L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
|
|
|
|
CLEANFILES = ${CCMDIF_SO}
|
|
diff --git a/dev_mgt/Makefile.am b/dev_mgt/Makefile.am
|
|
index 2283c2d1c763..ab8910dfc435 100644
|
|
--- a/dev_mgt/Makefile.am
|
|
+++ b/dev_mgt/Makefile.am
|
|
@@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py
|
|
dist_dev_mgt_pylib_DATA = dev_mgt.py
|
|
|
|
c_dev_mgt.so: libdev_mgt.a
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} tools_dev_types.o -o c_dev_mgt.so \
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} tools_dev_types.o -o c_dev_mgt.so \
|
|
-L$(USER_DIR)/reg_access -lreg_access \
|
|
-L$(USER_DIR)/tools_layouts -ltools_layouts \
|
|
-L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
|
|
diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am
|
|
index 934b8030a229..c8af0c2d5dac 100644
|
|
--- a/mtcr_py/Makefile.am
|
|
+++ b/mtcr_py/Makefile.am
|
|
@@ -40,7 +40,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR}
|
|
mtcr_pylib_DATA = cmtcr.so mtcr.py
|
|
dist_mtcr_pylib_DATA = mtcr.py
|
|
cmtcr.so:
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK)
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK)
|
|
|
|
CLEANFILES = cmtcr.so
|
|
|
|
diff --git a/reg_access/Makefile.am b/reg_access/Makefile.am
|
|
index c33bac653620..a231a6cd57e1 100644
|
|
--- a/reg_access/Makefile.am
|
|
+++ b/reg_access/Makefile.am
|
|
@@ -56,7 +56,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO} regaccess.py regaccess_structs.py
|
|
dist_reg_access_pylib_DATA = regaccess.py regaccess_structs.py
|
|
|
|
${RREG_ACCESS_SO}: libreg_access.a
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${RREG_ACCESS_SO} \
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${RREG_ACCESS_SO} \
|
|
-L$(USER_DIR)/tools_layouts -ltools_layouts -lmlxconfig_4th_gen_layouts -L$(MTCR_DIR) -lmtcr_ul
|
|
|
|
CLEANFILES = ${RREG_ACCESS_SO}
|
|
--
|
|
2.41.0
|
|
|