180 lines
6.7 KiB
Diff
180 lines
6.7 KiB
Diff
diff --git a/cmdif/Makefile.am b/cmdif/Makefile.am
|
|
index 0d8f53b..d800302 100644
|
|
--- a/cmdif/Makefile.am
|
|
+++ b/cmdif/Makefile.am
|
|
@@ -50,7 +50,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h
|
|
cmdif_pylibdir = $(libdir)/mstflint/python_tools/
|
|
cmdif_pylib_DATA = ${CCMDIF_SO} cmdif.py
|
|
${CCMDIF_SO}: libcmdif.a
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${CCMDIF_SO} \
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${CCMDIF_SO} \
|
|
-L$(USER_DIR)/tools_layouts -ltools_layouts -L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
|
|
|
|
CLEANFILES = ${CCMDIF_SO}
|
|
diff --git a/dev_mgt/Makefile.am b/dev_mgt/Makefile.am
|
|
index 3118b85..e708ad8 100644
|
|
--- a/dev_mgt/Makefile.am
|
|
+++ b/dev_mgt/Makefile.am
|
|
@@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py
|
|
dist_dev_mgt_pylib_DATA = dev_mgt.py
|
|
|
|
c_dev_mgt.so: libdev_mgt.a
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} tools_dev_types.o -o c_dev_mgt.so \
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} tools_dev_types.o -o c_dev_mgt.so \
|
|
-L$(USER_DIR)/reg_access -lreg_access \
|
|
-L$(USER_DIR)/tools_layouts -ltools_layouts \
|
|
-L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
|
|
diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am
|
|
index 5f5677d..566a870 100644
|
|
--- a/mtcr_py/Makefile.am
|
|
+++ b/mtcr_py/Makefile.am
|
|
@@ -39,7 +39,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR}
|
|
mtcr_pylib_DATA = cmtcr.so mtcr.py
|
|
dist_mtcr_pylib_DATA = mtcr.py
|
|
cmtcr.so:
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so
|
|
|
|
CLEANFILES = cmtcr.so
|
|
|
|
diff --git a/mvpd/Makefile.am b/mvpd/Makefile.am
|
|
index e9fa5c6..fab1599 100755
|
|
--- a/mvpd/Makefile.am
|
|
+++ b/mvpd/Makefile.am
|
|
@@ -1,61 +1,61 @@
|
|
-#--
|
|
-# Copyright (c) 2004-2010 Mellanox Technologies LTD. All rights reserved.
|
|
-#
|
|
-# This software is available to you under a choice of one of two
|
|
-# licenses. You may choose to be licensed under the terms of the GNU
|
|
-# General Public License (GPL) Version 2, available from the file
|
|
-# COPYING in the main directory of this source tree, or the
|
|
-# OpenIB.org BSD license below:
|
|
-#
|
|
-# Redistribution and use in source and binary forms, with or
|
|
-# without modification, are permitted provided that the following
|
|
-# conditions are met:
|
|
-#
|
|
-# - Redistributions of source code must retain the above
|
|
-# copyright notice, this list of conditions and the following
|
|
-# disclaimer.
|
|
-#
|
|
-# - Redistributions in binary form must reproduce the above
|
|
-# copyright notice, this list of conditions and the following
|
|
-# disclaimer in the documentation and/or other materials
|
|
-# provided with the distribution.
|
|
-#
|
|
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
-# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
|
|
-# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
-# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
|
|
-# BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
|
|
-# ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
|
|
-# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
|
|
-# SOFTWARE.
|
|
-#--
|
|
-
|
|
-# Makefile.am -- Process this file with automake to produce Makefile.in
|
|
-MTCR_DIR = $(top_srcdir)/${MTCR_CONF_DIR}
|
|
-COMMON_DIR = $(top_srcdir)/common
|
|
-LAYOUTS_DIR = $(top_srcdir)/tools_layouts
|
|
-USER_DIR = $(top_srcdir)
|
|
-
|
|
-AM_CPPFLAGS = -I. -I$(USER_DIR) -I$(srcdir) -I$(LAYOUTS_DIR) -I$(USER_DIR)/include/mtcr_ul
|
|
-AM_CFLAGS = -W -Wall -g -MP -MD $(COMPILER_FPIC)
|
|
-
|
|
-noinst_LTLIBRARIES = libmvpd.a
|
|
-
|
|
-libmvpd_a_SOURCES = mvpd.c mvpd.h
|
|
-
|
|
-libmvpd_a_DEPENDENCIES = $(MTCR_DIR)/libmtcr_ul.a
|
|
-libmvpd_a_LIBADD = $(libmvpd_a_DEPENDENCIES)
|
|
-
|
|
-RMVPD_SO = rmvpd.so
|
|
-
|
|
-
|
|
-LDADD= ../${MTCR_CONF_DIR}/libmtcr_ul.a ${LDL}
|
|
-
|
|
-
|
|
-noinst_HEADERS = mvpd.h
|
|
-
|
|
-${RMVPD_SO}: libmvpd.a
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${RMVPD_SO} \
|
|
- -L$(MTCR_DIR) -lmtcr_ul
|
|
-
|
|
-CLEANFILES = ${RMVPD_SO}
|
|
+#--
|
|
+# Copyright (c) 2004-2010 Mellanox Technologies LTD. All rights reserved.
|
|
+#
|
|
+# This software is available to you under a choice of one of two
|
|
+# licenses. You may choose to be licensed under the terms of the GNU
|
|
+# General Public License (GPL) Version 2, available from the file
|
|
+# COPYING in the main directory of this source tree, or the
|
|
+# OpenIB.org BSD license below:
|
|
+#
|
|
+# Redistribution and use in source and binary forms, with or
|
|
+# without modification, are permitted provided that the following
|
|
+# conditions are met:
|
|
+#
|
|
+# - Redistributions of source code must retain the above
|
|
+# copyright notice, this list of conditions and the following
|
|
+# disclaimer.
|
|
+#
|
|
+# - Redistributions in binary form must reproduce the above
|
|
+# copyright notice, this list of conditions and the following
|
|
+# disclaimer in the documentation and/or other materials
|
|
+# provided with the distribution.
|
|
+#
|
|
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
|
|
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
|
|
+# BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
|
|
+# ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
|
|
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
|
|
+# SOFTWARE.
|
|
+#--
|
|
+
|
|
+# Makefile.am -- Process this file with automake to produce Makefile.in
|
|
+MTCR_DIR = $(top_srcdir)/${MTCR_CONF_DIR}
|
|
+COMMON_DIR = $(top_srcdir)/common
|
|
+LAYOUTS_DIR = $(top_srcdir)/tools_layouts
|
|
+USER_DIR = $(top_srcdir)
|
|
+
|
|
+AM_CPPFLAGS = -I. -I$(USER_DIR) -I$(srcdir) -I$(LAYOUTS_DIR) -I$(USER_DIR)/include/mtcr_ul
|
|
+AM_CFLAGS = -W -Wall -g -MP -MD $(COMPILER_FPIC)
|
|
+
|
|
+noinst_LTLIBRARIES = libmvpd.a
|
|
+
|
|
+libmvpd_a_SOURCES = mvpd.c mvpd.h
|
|
+
|
|
+libmvpd_a_DEPENDENCIES = $(MTCR_DIR)/libmtcr_ul.a
|
|
+libmvpd_a_LIBADD = $(libmvpd_a_DEPENDENCIES)
|
|
+
|
|
+RMVPD_SO = rmvpd.so
|
|
+
|
|
+
|
|
+LDADD= ../${MTCR_CONF_DIR}/libmtcr_ul.a ${LDL}
|
|
+
|
|
+
|
|
+noinst_HEADERS = mvpd.h
|
|
+
|
|
+${RMVPD_SO}: libmvpd.a
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${RMVPD_SO} \
|
|
+ -L$(MTCR_DIR) -lmtcr_ul
|
|
+
|
|
+CLEANFILES = ${RMVPD_SO}
|
|
diff --git a/reg_access/Makefile.am b/reg_access/Makefile.am
|
|
index f28290e..a141704 100644
|
|
--- a/reg_access/Makefile.am
|
|
+++ b/reg_access/Makefile.am
|
|
@@ -53,7 +53,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO} regaccess.py
|
|
dist_reg_access_pylib_DATA = regaccess.py
|
|
|
|
${RREG_ACCESS_SO}: libreg_access.a
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${RREG_ACCESS_SO} \
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${RREG_ACCESS_SO} \
|
|
-L$(USER_DIR)/tools_layouts -ltools_layouts -L$(MTCR_DIR) -lmtcr_ul
|
|
|
|
CLEANFILES = ${RREG_ACCESS_SO}
|