8b8ea71ac7
Resolves: RHEL-24470 Signed-off-by: Kamal Heib <kheib@redhat.com>
68 lines
2.9 KiB
Diff
68 lines
2.9 KiB
Diff
From a91f8252d007aa0d8b2d211ea0061a60ad003c73 Mon Sep 17 00:00:00 2001
|
|
From: Kamal Heib <kheib@redhat.com>
|
|
Date: Tue, 17 Oct 2023 14:19:52 -0400
|
|
Subject: [PATCH] Add default link flags for shared libraries
|
|
|
|
Signed-off-by: Kamal Heib <kheib@redhat.com>
|
|
---
|
|
cmdif/Makefile.am | 2 +-
|
|
dev_mgt/Makefile.am | 2 +-
|
|
mtcr_py/Makefile.am | 2 +-
|
|
reg_access/Makefile.am | 2 +-
|
|
4 files changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/cmdif/Makefile.am b/cmdif/Makefile.am
|
|
index 7bb332aada48..3ffdf7d6653e 100644
|
|
--- a/cmdif/Makefile.am
|
|
+++ b/cmdif/Makefile.am
|
|
@@ -53,7 +53,7 @@ libcmdif_la_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.
|
|
cmdif_pylibdir = $(libdir)/mstflint/python_tools/
|
|
cmdif_pylib_DATA = ${CCMDIF_SO} cmdif.py
|
|
${CCMDIF_SO}: libcmdif.la
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${CCMDIF_SO} \
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${CCMDIF_SO} \
|
|
$(top_builddir)/tools_layouts/.libs/libtools_layouts.a $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a
|
|
|
|
CLEANFILES = ${CCMDIF_SO}
|
|
diff --git a/dev_mgt/Makefile.am b/dev_mgt/Makefile.am
|
|
index a5f66e9fd935..0d1417daa647 100644
|
|
--- a/dev_mgt/Makefile.am
|
|
+++ b/dev_mgt/Makefile.am
|
|
@@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so
|
|
dist_dev_mgt_pylib_DATA = dev_mgt.py
|
|
|
|
c_dev_mgt.so: libdev_mgt.la
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} tools_dev_types.o -o c_dev_mgt.so \
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} tools_dev_types.o -o c_dev_mgt.so \
|
|
$(top_builddir)/reg_access/.libs/libreg_access.a \
|
|
$(top_builddir)/tools_layouts/.libs/libtools_layouts.a \
|
|
$(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a
|
|
diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am
|
|
index 46fa4e60916d..2f431156a45e 100644
|
|
--- a/mtcr_py/Makefile.am
|
|
+++ b/mtcr_py/Makefile.am
|
|
@@ -35,6 +35,6 @@ mtcr_pylibdir = $(libdir)/mstflint/python_tools/
|
|
mtcr_pylib_DATA = cmtcr.so
|
|
dist_mtcr_pylib_DATA = mtcr.py
|
|
cmtcr.so:
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} -o cmtcr.so -Wl,--whole-archive $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a -Wl,--no-whole-archive
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} -o cmtcr.so -Wl,--whole-archive $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a -Wl,--no-whole-archive
|
|
|
|
CLEANFILES = cmtcr.so
|
|
diff --git a/reg_access/Makefile.am b/reg_access/Makefile.am
|
|
index 8e38c473cc9c..6228b45af312 100644
|
|
--- a/reg_access/Makefile.am
|
|
+++ b/reg_access/Makefile.am
|
|
@@ -57,7 +57,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO}
|
|
dist_reg_access_pylib_DATA = regaccess.py regaccess_hca_ext_structs.py regaccess_switch_ext_structs.py
|
|
|
|
${RREG_ACCESS_SO}: libreg_access.la
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${RREG_ACCESS_SO} \
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${RREG_ACCESS_SO} \
|
|
$(top_builddir)/tools_layouts/.libs/libtools_layouts.a $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a
|
|
|
|
CLEANFILES = ${RREG_ACCESS_SO}
|
|
--
|
|
2.44.0
|
|
|