53 lines
2.2 KiB
Diff
53 lines
2.2 KiB
Diff
diff --git a/cmdif/Makefile.am b/cmdif/Makefile.am
|
|
index 9807603..b23bcb9 100644
|
|
--- a/cmdif/Makefile.am
|
|
+++ b/cmdif/Makefile.am
|
|
@@ -51,7 +51,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h
|
|
cmdif_pylibdir = $(libdir)/mstflint/python_tools/
|
|
cmdif_pylib_DATA = ${CCMDIF_SO} cmdif.py
|
|
${CCMDIF_SO}: libcmdif.a
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${CCMDIF_SO} \
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${CCMDIF_SO} \
|
|
-L$(USER_DIR)/tools_layouts -ltools_layouts -L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
|
|
|
|
CLEANFILES = ${CCMDIF_SO}
|
|
diff --git a/dev_mgt/Makefile.am b/dev_mgt/Makefile.am
|
|
index 1fbd142..df5b14a 100644
|
|
--- a/dev_mgt/Makefile.am
|
|
+++ b/dev_mgt/Makefile.am
|
|
@@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py
|
|
dist_dev_mgt_pylib_DATA = dev_mgt.py
|
|
|
|
c_dev_mgt.so: libdev_mgt.a
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} tools_dev_types.o -o c_dev_mgt.so \
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} tools_dev_types.o -o c_dev_mgt.so \
|
|
-L$(USER_DIR)/reg_access -lreg_access \
|
|
-L$(USER_DIR)/tools_layouts -ltools_layouts \
|
|
-L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
|
|
diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am
|
|
index 934b803..c8af0c2 100644
|
|
--- a/mtcr_py/Makefile.am
|
|
+++ b/mtcr_py/Makefile.am
|
|
@@ -40,7 +40,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR}
|
|
mtcr_pylib_DATA = cmtcr.so mtcr.py
|
|
dist_mtcr_pylib_DATA = mtcr.py
|
|
cmtcr.so:
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK)
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK)
|
|
|
|
CLEANFILES = cmtcr.so
|
|
|
|
diff --git a/reg_access/Makefile.am b/reg_access/Makefile.am
|
|
index 26f6a5a..9a42c37 100644
|
|
--- a/reg_access/Makefile.am
|
|
+++ b/reg_access/Makefile.am
|
|
@@ -53,7 +53,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO} regaccess.py
|
|
dist_reg_access_pylib_DATA = regaccess.py
|
|
|
|
${RREG_ACCESS_SO}: libreg_access.a
|
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${RREG_ACCESS_SO} \
|
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${RREG_ACCESS_SO} \
|
|
-L$(USER_DIR)/tools_layouts -ltools_layouts -L$(MTCR_DIR) -lmtcr_ul
|
|
|
|
CLEANFILES = ${RREG_ACCESS_SO}
|