import RHEL 10 Beta mstflint-4.26.0-5.el10
This commit is contained in:
parent
c4aace486f
commit
f8c0c0b93d
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/mstflint-4.25.0-1.tar.gz
|
||||
mstflint-4.26.0-1.tar.gz
|
||||
|
26
0001-Fix-bind-now-test.patch
Normal file
26
0001-Fix-bind-now-test.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From f9c2ffd7935fb799a084d74ee432e21c3f45b6f1 Mon Sep 17 00:00:00 2001
|
||||
From: Kamal Heib <kheib@redhat.com>
|
||||
Date: Fri, 24 May 2024 21:15:47 -0400
|
||||
Subject: [PATCH] Fix bind-now test
|
||||
|
||||
Signed-off-by: Kamal Heib <kheib@redhat.com>
|
||||
---
|
||||
resourcetools/resourcedump_lib/src/sdk/Makefile.am | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/resourcetools/resourcedump_lib/src/sdk/Makefile.am b/resourcetools/resourcedump_lib/src/sdk/Makefile.am
|
||||
index aefc88a4f849..de9577b27379 100644
|
||||
--- a/resourcetools/resourcedump_lib/src/sdk/Makefile.am
|
||||
+++ b/resourcetools/resourcedump_lib/src/sdk/Makefile.am
|
||||
@@ -86,7 +86,7 @@ resource_dump_sdk_so_DEPS = \
|
||||
|
||||
# if !WIN_BUILD
|
||||
libresource_dump_sdk.so: libresource_dump_sdk.la
|
||||
- $(CC) -Wall -pthread -shared ${CFLAGS} $(COMPILER_FPIC) libresource_dump_sdk_la-resource_dump_sdk.o \
|
||||
+ $(CC) -Wall -pthread -shared -Wl,-z,now -Wl,${CFLAGS} $(COMPILER_FPIC) libresource_dump_sdk_la-resource_dump_sdk.o \
|
||||
-o libresource_dump_sdk.so ${AM_LDFLAGS} $(resource_dump_sdk_so_DEPS)
|
||||
# else
|
||||
# libresource_dump_sdk.dll: libresource_dump_sdk.la
|
||||
--
|
||||
2.45.0
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 0bf822388a194c01c82beb6b6529b49255a4bd39 Mon Sep 17 00:00:00 2001
|
||||
From a91f8252d007aa0d8b2d211ea0061a60ad003c73 Mon Sep 17 00:00:00 2001
|
||||
From: Kamal Heib <kheib@redhat.com>
|
||||
Date: Tue, 17 Oct 2023 14:19:52 -0400
|
||||
Subject: [PATCH] Add default link flags for shared libraries
|
||||
@ -12,57 +12,56 @@ Signed-off-by: Kamal Heib <kheib@redhat.com>
|
||||
4 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/cmdif/Makefile.am b/cmdif/Makefile.am
|
||||
index b6c43d59c8b5..0e03839459f2 100644
|
||||
index 7bb332aada48..3ffdf7d6653e 100644
|
||||
--- a/cmdif/Makefile.am
|
||||
+++ b/cmdif/Makefile.am
|
||||
@@ -51,7 +51,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h
|
||||
@@ -53,7 +53,7 @@ libcmdif_la_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.
|
||||
cmdif_pylibdir = $(libdir)/mstflint/python_tools/
|
||||
cmdif_pylib_DATA = ${CCMDIF_SO} cmdif.py
|
||||
${CCMDIF_SO}: libcmdif.a
|
||||
${CCMDIF_SO}: libcmdif.la
|
||||
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${CCMDIF_SO} \
|
||||
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${CCMDIF_SO} \
|
||||
-L$(USER_DIR)/tools_layouts -ltools_layouts -L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
|
||||
$(top_builddir)/tools_layouts/.libs/libtools_layouts.a $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a
|
||||
|
||||
CLEANFILES = ${CCMDIF_SO}
|
||||
diff --git a/dev_mgt/Makefile.am b/dev_mgt/Makefile.am
|
||||
index 2283c2d1c763..ab8910dfc435 100644
|
||||
index a5f66e9fd935..0d1417daa647 100644
|
||||
--- a/dev_mgt/Makefile.am
|
||||
+++ b/dev_mgt/Makefile.am
|
||||
@@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py
|
||||
@@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so
|
||||
dist_dev_mgt_pylib_DATA = dev_mgt.py
|
||||
|
||||
c_dev_mgt.so: libdev_mgt.a
|
||||
c_dev_mgt.so: libdev_mgt.la
|
||||
- $(CC) -g -Wall -pthread -shared ${CFLAGS} tools_dev_types.o -o c_dev_mgt.so \
|
||||
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} tools_dev_types.o -o c_dev_mgt.so \
|
||||
-L$(USER_DIR)/reg_access -lreg_access \
|
||||
-L$(USER_DIR)/tools_layouts -ltools_layouts \
|
||||
-L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
|
||||
$(top_builddir)/reg_access/.libs/libreg_access.a \
|
||||
$(top_builddir)/tools_layouts/.libs/libtools_layouts.a \
|
||||
$(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a
|
||||
diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am
|
||||
index 934b8030a229..c8af0c2d5dac 100644
|
||||
index 46fa4e60916d..2f431156a45e 100644
|
||||
--- a/mtcr_py/Makefile.am
|
||||
+++ b/mtcr_py/Makefile.am
|
||||
@@ -40,7 +40,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR}
|
||||
mtcr_pylib_DATA = cmtcr.so mtcr.py
|
||||
@@ -35,6 +35,6 @@ mtcr_pylibdir = $(libdir)/mstflint/python_tools/
|
||||
mtcr_pylib_DATA = cmtcr.so
|
||||
dist_mtcr_pylib_DATA = mtcr.py
|
||||
cmtcr.so:
|
||||
- $(CC) -g -Wall -pthread -shared ${CFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK)
|
||||
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK)
|
||||
- $(CC) -g -Wall -pthread -shared ${CFLAGS} -o cmtcr.so -Wl,--whole-archive $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a -Wl,--no-whole-archive
|
||||
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} -o cmtcr.so -Wl,--whole-archive $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a -Wl,--no-whole-archive
|
||||
|
||||
CLEANFILES = cmtcr.so
|
||||
|
||||
diff --git a/reg_access/Makefile.am b/reg_access/Makefile.am
|
||||
index c33bac653620..a231a6cd57e1 100644
|
||||
index 8e38c473cc9c..6228b45af312 100644
|
||||
--- a/reg_access/Makefile.am
|
||||
+++ b/reg_access/Makefile.am
|
||||
@@ -56,7 +56,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO} regaccess.py regaccess_structs.py
|
||||
dist_reg_access_pylib_DATA = regaccess.py regaccess_structs.py
|
||||
@@ -57,7 +57,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO}
|
||||
dist_reg_access_pylib_DATA = regaccess.py regaccess_hca_ext_structs.py regaccess_switch_ext_structs.py
|
||||
|
||||
${RREG_ACCESS_SO}: libreg_access.a
|
||||
${RREG_ACCESS_SO}: libreg_access.la
|
||||
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${RREG_ACCESS_SO} \
|
||||
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${RREG_ACCESS_SO} \
|
||||
-L$(USER_DIR)/tools_layouts -ltools_layouts -lmlxconfig_4th_gen_layouts -L$(MTCR_DIR) -lmtcr_ul
|
||||
$(top_builddir)/tools_layouts/.libs/libtools_layouts.a $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a
|
||||
|
||||
CLEANFILES = ${RREG_ACCESS_SO}
|
||||
--
|
||||
2.41.0
|
||||
2.44.0
|
||||
|
@ -1,20 +1,36 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.6.1)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 5;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
%global __remake_config 1
|
||||
|
||||
Name: mstflint
|
||||
Summary: Mellanox firmware burning tool
|
||||
Version: 4.25.0
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ or BSD
|
||||
Version: 4.26.0
|
||||
Release: %autorelease
|
||||
# COPYING says the license is your choice of OpenIB.org BSD or GPLv2.
|
||||
# kernel/Makefile has the 3-clause BSD.
|
||||
# ext_libs/{iniParser,json,muparser}/ have MIT.
|
||||
# ext_libs/sqlite/ has the SQLite blessing.
|
||||
License: (GPL-2.0-only OR Linux-OpenIB) AND BSD-3-Clause AND MIT AND blessing
|
||||
Url: https://github.com/Mellanox/%{name}
|
||||
Source0: https://github.com/Mellanox/%{name}/releases/download/v%{version}-1/%{name}-%{version}-1.tar.gz
|
||||
Group: Applications/System
|
||||
|
||||
Patch4: add-default-link-flags-for-shared-libraries.patch
|
||||
Patch1: 0001-Fix-bind-now-test.patch
|
||||
Patch4: add-default-link-flags-for-shared-libraries.patch
|
||||
Patch6: replace-mlxfwreset-with-mstfwreset-in-mstflint-message.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: libstdc++-devel, zlib-devel, libibmad-devel, gcc-c++, gcc
|
||||
BuildRequires: libcurl-devel, boost-devel, libxml2-devel, openssl-devel
|
||||
BuildRequires: expat-devel
|
||||
%if %{__remake_config}
|
||||
BuildRequires: libtool, autoconf, automake
|
||||
%endif
|
||||
@ -29,6 +45,7 @@ for network adapters based on Mellanox Technologies chips.
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
|
||||
%patch1 -p1
|
||||
%patch4 -p1
|
||||
%patch6 -p1
|
||||
|
||||
@ -39,7 +56,7 @@ find . -type f -iname '*.cpp' -exec chmod a-x '{}' ';'
|
||||
%if %{__remake_config}
|
||||
./autogen.sh
|
||||
%endif
|
||||
%configure --enable-fw-mgr
|
||||
%configure --enable-adb-generic-tools --disable-openssl
|
||||
%make_build
|
||||
|
||||
%install
|
||||
@ -52,78 +69,169 @@ find %{buildroot} -type f -name '*.a' -delete
|
||||
# Mark these shared libs executable for find-debuginfo.sh to find them.
|
||||
# https://docs.fedoraproject.org/en-US/packaging-guidelines/Debuginfo/
|
||||
chmod +x %{buildroot}/%{_libdir}/mstflint/python_tools/*.so
|
||||
chmod +x %{buildroot}/%{_libdir}/mstflint/sdk/*.so
|
||||
|
||||
%files
|
||||
%doc README
|
||||
%_bindir/*
|
||||
%{_sysconfdir}/mstflint
|
||||
%{_libdir}/mstflint
|
||||
|
||||
%{_datadir}/mstflint
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Tue Oct 24 2023 Kamal Heib <kheib@redhat.com> - 4.25.0-1
|
||||
- Update to upstream release 4.25.0
|
||||
- Resolves: RHEL-931
|
||||
## START: Generated by rpmautospec
|
||||
* Sat May 25 2024 Kamal Heib <kheib@redhat.com> - 4.26.0-5
|
||||
- Fix annocheck failure
|
||||
|
||||
* Fri Jun 02 2023 Kamal Heib <kheib@redhat.com> - 4.24.0-1
|
||||
- Update to upstream release 4.24.0
|
||||
* Fri May 24 2024 Kamal Heib <kheib@redhat.com> - 4.26.0-4
|
||||
- Disable openssl
|
||||
|
||||
* Tue Apr 30 2024 Kamal Heib <kheib@redhat.com> - 4.26.0-3
|
||||
- Fix debuginfo
|
||||
|
||||
* Tue Apr 30 2024 Kamal Heib <kheib@redhat.com> - 4.26.0-2
|
||||
- Add gating tests
|
||||
- Resolves: rhbz#2170069
|
||||
|
||||
* Wed Feb 08 2023 Michal Schmidt <mschmidt@redhat.com> - 4.23.0-2
|
||||
* Fri Apr 26 2024 Kamal Heib <kheib@redhat.com> - 4.26.0-1
|
||||
- Update to upstream release 4.26.0
|
||||
|
||||
* Wed Feb 07 2024 Michal Schmidt <mschmidt@redhat.com> - 4.25.0-5
|
||||
- migrated to SPDX license
|
||||
|
||||
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 4.25.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 4.25.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Thu Jan 18 2024 Jonathan Wakely <jwakely@redhat.com> - 4.25.0-2
|
||||
- Rebuilt for Boost 1.83
|
||||
|
||||
* Tue Oct 17 2023 Kamal Heib <kheib@redhat.com> - 4.25.0-1
|
||||
- Update to upstream release 4.25.0
|
||||
|
||||
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 4.24.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Thu Jun 08 2023 Davide Cavalca <dcavalca@fedoraproject.org> - 4.24.0-2
|
||||
- Build the mstreg and mstlink tools; Fixes: RHBZ#2213620
|
||||
|
||||
* Thu Jun 01 2023 Kamal Heib <kheib@redhat.com> - 4.24.0-1
|
||||
- Update to upstream release 4.24.0
|
||||
|
||||
* Sun Apr 23 2023 Florian Weimer <fweimer@redhat.com> - 4.23.0-4
|
||||
- Port to C99
|
||||
|
||||
* Fri Feb 03 2023 Michal Schmidt <mschmidt@redhat.com> - 4.23.0-3
|
||||
- fix debuginfo generation for python_tools/*.so
|
||||
|
||||
* Thu Feb 02 2023 Kamal Heib <kheib@redhat.com> - 4.23.0-1
|
||||
- Update to upstream release 4.23.0
|
||||
- Resolves: rhbz#2112936
|
||||
|
||||
* Wed Aug 17 2022 Michal Schmidt <mschmidt@redhat.com> - 4.21.0-1
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 4.21.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Wed Aug 03 2022 Michal Schmidt <mschmidt@redhat.com> - 4.21.0-1
|
||||
- Update to upstream release 4.21.0
|
||||
- Resolves: rhbz#2049525
|
||||
|
||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 4.20.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Tue Jun 28 2022 Michal Schmidt <mschmidt@redhat.com> - 4.20.1-1
|
||||
- Update to upstream release 4.20.1
|
||||
|
||||
* Wed May 25 2022 Izabela Bakollari <izabela.bakollari@gmail.com> - 4.20.0-1
|
||||
- Update to upstream release 4.20.0
|
||||
|
||||
* Mon Mar 28 2022 Michal Schmidt <mschmidt@redhat.com> - 4.19.0-0.3
|
||||
- Rebase to the almost released 4.19.0
|
||||
- Resolves: rhbz#2045017
|
||||
|
||||
* Sun Dec 05 2021 Honggang Li <honli@redhat.com> - 4.18.0-1
|
||||
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 4.18.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Dec 03 2021 Honggang Li <honli@redhat.com> - 4.18.0-1
|
||||
- Rebase mstflint to latest upstream release v4.18.0-1
|
||||
- Resolves: rhbz#1982202
|
||||
|
||||
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 4.17.0-3
|
||||
- Rebuilt with OpenSSL 3.0.0
|
||||
|
||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 4.17.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Thu Jul 01 2021 Honggang Li <honli@redhat.com> - 4.17.0-1
|
||||
- Rebase mstflint to latest upstream release v4.17.0-1
|
||||
- Resolves: bz1915313
|
||||
|
||||
* Thu Nov 05 2020 Honggang Li <honli@redhat.com> - 4.15.0-1
|
||||
- Rebase to latest upstream release v4.15.0-1
|
||||
- Resolves: bz1851723
|
||||
* Wed Apr 07 2021 Honggang Li <honli@redhat.com> - 4.16.0-2
|
||||
- Rebase mstflint to latest upstream release v4.16.0-2
|
||||
|
||||
* Thu Apr 16 2020 Honggang Li <honli@redhat.com> - 4.14.0-1
|
||||
- Rebase to latest upstream release v4.14.0-1
|
||||
- Resolves: bz1789386
|
||||
* Sun Jan 31 2021 Honggang Li <honli@redhat.com> - 4.16.0-1
|
||||
- Rebase mstflint to latest upstream release v4.16.0-1
|
||||
|
||||
* Thu Jan 16 2020 Honggang Li <honli@redhat.com> - 4.13.3-2
|
||||
- Rebase to latest upstream release v4.13.3-2
|
||||
- Resolves: bz1788927
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 4.15.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Oct 30 2019 Honggang Li <honli@redhat.com> - 4.13.1-1
|
||||
- Rebase to latest upstream release v4.13.1-1
|
||||
- Resolves: bz1722258
|
||||
* Wed Sep 16 2020 Honggang Li <honli@redhat.com> - 4.15.0-1
|
||||
- Rebase mstflint to latest upstream release v4.15.0-1
|
||||
|
||||
* Thu Jun 13 2019 Honggang Li <honli@redhat.com> - 4.12.0-1
|
||||
- Rebase to latest upstream release v4.12.0-1
|
||||
- Resolves: bz1683083
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 4.14.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jul 13 2020 Tom Stellard <tstellar@redhat.com> - 4.14.0-4
|
||||
- Use make macros
|
||||
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
||||
|
||||
* Mon Jun 22 2020 Honggang Li <honli@redhat.com> - 4.14.0-3
|
||||
- Rebase mstflint to latest upstream release v4.14.0-3
|
||||
|
||||
* Sat May 30 2020 Jonathan Wakely <jwakely@redhat.com> - 4.14.0-2
|
||||
- Rebuilt for Boost 1.73
|
||||
|
||||
* Tue Mar 31 2020 Honggang Li <honli@redhat.com> - 4.14.0-1
|
||||
- Rebase mstflint to latest upstream release v4.14.0-1
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 4.13.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Tue Jan 07 2020 Honggang Li <honli@redhat.com> - 4.13.3-2
|
||||
- Rebase mstflint to latest upstream release v4.13.3-2
|
||||
|
||||
* Sun Jan 05 2020 Honggang Li <honli@redhat.com> - 4.13.3-1
|
||||
- Rebase mstflint to latest upstream release v4.13.3-1
|
||||
|
||||
* Thu Oct 17 2019 Honggang Li <honli@redhat.com> - 4.13.1-1
|
||||
- Rebase mstflint to latest upstream release v4.13.1-1
|
||||
|
||||
* Wed Oct 02 2019 Honggang Li <honli@redhat.com> - 4.13.0-1
|
||||
- Rebase mstflint to latest upstream release v4.13.0-1
|
||||
- Resolves: bz1758011
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.11.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Mon Apr 15 2019 Honggang Li <honli@redhat.com> - 4.11.0-5
|
||||
- Rebase mstflint to latest upstream release v4.11.0-4
|
||||
|
||||
* Fri Feb 22 2019 Honggang Li <honli@redhat.com> - 4.11.0-4
|
||||
- Fix mstflint segment fault issue for ConnectX-5 HCA
|
||||
- Resolves: 1679844
|
||||
|
||||
* Tue Feb 12 2019 Honggang Li <honli@redhat.com> - 4.11.0-3
|
||||
- Rebase mstflint to latest upstream release v4.11.0-3
|
||||
- Resolves: 1676338
|
||||
|
||||
* Fri Feb 1 2019 Honggang Li <honli@redhat.com> - 4.11.0-2
|
||||
- Rebase to latest upstream release v4.11.0-2
|
||||
- Resolves: bz1634777
|
||||
- Rebase mstflint to latest upstream release v4.11.0-2
|
||||
- Resolves: bz1671710
|
||||
|
||||
* Thu Sep 27 2018 Honggang Li <honli@redhat.com> - 4.10.0.3
|
||||
- Fix annocheck issues
|
||||
- Resolves: bz1630599
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.10.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Sun Aug 12 2018 Honggang Li <honli@redhat.com> - 4.10.0.2
|
||||
- Rebase to latest upstream release v4.10.0-2
|
||||
- Fix license issue of mtcr_ul.c
|
||||
- Resolves: bz1541741
|
||||
* Fri Jan 25 2019 Jonathan Wakely <jwakely@redhat.com> - 4.10.0-3
|
||||
- Rebuilt for Boost 1.69
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.10.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Tue Jul 10 2018 Honggang Li <honli@redhat.com> - 4.10.0-1
|
||||
- Rebase to latest upstream release v4.10.0-1
|
||||
@ -249,3 +357,5 @@ chmod +x %{buildroot}/%{_libdir}/mstflint/python_tools/*.so
|
||||
|
||||
* Thu Jul 19 2007 - Vladimir Sokolovsky vlad@mellanox.co.il
|
||||
- Initial Package, Version 1.2
|
||||
|
||||
## END: Generated by rpmautospec
|
Loading…
Reference in New Issue
Block a user