Import from AlmaLinux stable repository
This commit is contained in:
parent
a544bc5ee1
commit
c717fbed6f
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/mstflint-4.23.0-1.tar.gz
|
||||
SOURCES/mstflint-4.25.0-1.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
6e84aa3237c48a1208dcef3d46a258d1c6cff626 SOURCES/mstflint-4.23.0-1.tar.gz
|
||||
e8fe8035cc019b896290b74d550fd477f80b8ced SOURCES/mstflint-4.25.0-1.tar.gz
|
||||
|
@ -1,5 +1,18 @@
|
||||
From 0bf822388a194c01c82beb6b6529b49255a4bd39 Mon Sep 17 00:00:00 2001
|
||||
From: Kamal Heib <kheib@redhat.com>
|
||||
Date: Tue, 17 Oct 2023 14:19:52 -0400
|
||||
Subject: [PATCH] Add default link flags for shared libraries
|
||||
|
||||
Signed-off-by: Kamal Heib <kheib@redhat.com>
|
||||
---
|
||||
cmdif/Makefile.am | 2 +-
|
||||
dev_mgt/Makefile.am | 2 +-
|
||||
mtcr_py/Makefile.am | 2 +-
|
||||
reg_access/Makefile.am | 2 +-
|
||||
4 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/cmdif/Makefile.am b/cmdif/Makefile.am
|
||||
index 9807603..b23bcb9 100644
|
||||
index b6c43d59c8b5..0e03839459f2 100644
|
||||
--- a/cmdif/Makefile.am
|
||||
+++ b/cmdif/Makefile.am
|
||||
@@ -51,7 +51,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h
|
||||
@ -12,7 +25,7 @@ index 9807603..b23bcb9 100644
|
||||
|
||||
CLEANFILES = ${CCMDIF_SO}
|
||||
diff --git a/dev_mgt/Makefile.am b/dev_mgt/Makefile.am
|
||||
index 1fbd142..df5b14a 100644
|
||||
index 2283c2d1c763..ab8910dfc435 100644
|
||||
--- a/dev_mgt/Makefile.am
|
||||
+++ b/dev_mgt/Makefile.am
|
||||
@@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py
|
||||
@ -25,7 +38,7 @@ index 1fbd142..df5b14a 100644
|
||||
-L$(USER_DIR)/tools_layouts -ltools_layouts \
|
||||
-L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
|
||||
diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am
|
||||
index 934b803..c8af0c2 100644
|
||||
index 934b8030a229..c8af0c2d5dac 100644
|
||||
--- a/mtcr_py/Makefile.am
|
||||
+++ b/mtcr_py/Makefile.am
|
||||
@@ -40,7 +40,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR}
|
||||
@ -38,15 +51,18 @@ index 934b803..c8af0c2 100644
|
||||
CLEANFILES = cmtcr.so
|
||||
|
||||
diff --git a/reg_access/Makefile.am b/reg_access/Makefile.am
|
||||
index 26f6a5a..9a42c37 100644
|
||||
index c33bac653620..a231a6cd57e1 100644
|
||||
--- a/reg_access/Makefile.am
|
||||
+++ b/reg_access/Makefile.am
|
||||
@@ -53,7 +53,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO} regaccess.py
|
||||
dist_reg_access_pylib_DATA = regaccess.py
|
||||
@@ -56,7 +56,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO} regaccess.py regaccess_structs.py
|
||||
dist_reg_access_pylib_DATA = regaccess.py regaccess_structs.py
|
||||
|
||||
${RREG_ACCESS_SO}: libreg_access.a
|
||||
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${RREG_ACCESS_SO} \
|
||||
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${RREG_ACCESS_SO} \
|
||||
-L$(USER_DIR)/tools_layouts -ltools_layouts -lmlxconfig_4th_gen_layouts -L$(MTCR_DIR) -lmtcr_ul
|
||||
-L$(USER_DIR)/tools_layouts -ltools_layouts -lmlxconfig_4th_gen_layouts -L$(MTCR_DIR) -lmtcr_ul
|
||||
|
||||
CLEANFILES = ${RREG_ACCESS_SO}
|
||||
--
|
||||
2.41.0
|
||||
|
||||
|
@ -2,8 +2,8 @@
|
||||
|
||||
Name: mstflint
|
||||
Summary: Mellanox firmware burning tool
|
||||
Version: 4.23.0
|
||||
Release: 2%{?dist}
|
||||
Version: 4.25.0
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ or BSD
|
||||
Url: https://github.com/Mellanox/%{name}
|
||||
Source0: https://github.com/Mellanox/%{name}/releases/download/v%{version}-1/%{name}-%{version}-1.tar.gz
|
||||
@ -15,6 +15,7 @@ Patch6: replace-mlxfwreset-with-mstfwreset-in-mstflint-message.patch
|
||||
BuildRequires: make
|
||||
BuildRequires: libstdc++-devel, zlib-devel, libibmad-devel, gcc-c++, gcc
|
||||
BuildRequires: libcurl-devel, boost-devel, libxml2-devel, openssl-devel
|
||||
BuildRequires: expat-devel
|
||||
%if %{__remake_config}
|
||||
BuildRequires: libtool, autoconf, automake
|
||||
%endif
|
||||
@ -39,7 +40,7 @@ find . -type f -iname '*.cpp' -exec chmod a-x '{}' ';'
|
||||
%if %{__remake_config}
|
||||
./autogen.sh
|
||||
%endif
|
||||
%configure --enable-fw-mgr
|
||||
%configure --enable-fw-mgr --enable-adb-generic-tools
|
||||
%make_build
|
||||
|
||||
%install
|
||||
@ -63,6 +64,18 @@ chmod +x %{buildroot}/%{_libdir}/mstflint/python_tools/*.so
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Thu Oct 19 2023 Kamal Heib <kheib@redhat.com> - 4.25.0-1
|
||||
- Update to upstream release 4.25.0
|
||||
- Resolves: RHEL-886
|
||||
|
||||
* Thu Jun 08 2023 Davide Cavalca <dcavalca@centosproject.org> - 4.24.0-2
|
||||
- Build the mstreg and mstlink tools
|
||||
- Resolves: rhbz#2213647
|
||||
|
||||
* Fri Jun 02 2023 Kamal Heib <kheib@redhat.com> - 4.24.0-1
|
||||
- Update to upstream release 4.24.0
|
||||
- Resolves: rhbz#2170368
|
||||
|
||||
* Fri Feb 03 2023 Michal Schmidt <mschmidt@redhat.com> - 4.23.0-2
|
||||
- Fix debuginfo generation.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user